iPod shuffle

Dieses Thema im Forum "Laufwerke / Speichermedien" wurde erstellt von Wizard, 07.01.2007.

  1. Wizard

    Wizard Tripel-As

    Dabei seit:
    21.01.2003
    Beiträge:
    234
    Zustimmungen:
    0
    Ich habe einen iPod shuffle, den ich unter LInux benutzen möchte.
    Es handelt sich dabei um ein Gerät der zweiten Generation (A1204). Mein Linux-System ist SuSE 9.3 (Kernel 2.6.11.4-21.2-default).

    Problem: Der iPod lässt sich nicht mounten.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Andrea

    Andrea Routinier

    Dabei seit:
    01.12.2003
    Beiträge:
    418
    Zustimmungen:
    0
    Ort:
    Bielefeld
    Wie hast du es denn versucht?

    Mein Ipod Nano funktioniert mit dieser Zeile in der /etc/fstab
    /dev/sda2 /Ipod vfat defaults,users 0 0

    Andrea
     
  4. Wizard

    Wizard Tripel-As

    Dabei seit:
    21.01.2003
    Beiträge:
    234
    Zustimmungen:
    0
    Dieselben Einstellungen habe ich auch verwendet. Dabei bekomme ich aber die Fehlermeldung: "/dev/sda2 ist kein gültiges blockorientiertes Gerät".
     
  5. dizzgo

    dizzgo Lernbereite Riesenratte

    Dabei seit:
    04.08.2005
    Beiträge:
    573
    Zustimmungen:
    0
    Ort:
    /ch/sg///
    Mach mal 'fdisk -l' als Root wenn du deinen iPod an gesteckt hast und poste das Ergebnis.

    Gruss
    d22
     
  6. Wizard

    Wizard Tripel-As

    Dabei seit:
    21.01.2003
    Beiträge:
    234
    Zustimmungen:
    0
    linux:/home/tilman # fdisk -l

    Platte /dev/hda: 15.3 GByte, 15377080320 Byte
    255 Köpfe, 63 Sektoren/Spuren, 1869 Zylinder
    Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes

    Gerät boot. Anfang Ende Blöcke Id System
    /dev/hda1 * 1 764 6136798+ 83 Linux
    /dev/hda2 765 1869 8875912+ 5 Erweiterte
    /dev/hda5 765 827 506016 82 Linux Swap / Solaris
    /dev/hda6 828 1869 8369833+ 83 Linux
     
  7. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Hast Du nach dem Einstecken ein paar Sekunden gewartet?
    Post doch auch mal die letzten paar Zeilen von 'dmesg', ebenfalls ein paar Sekunden nach dem Einstecken.
     
  8. Wizard

    Wizard Tripel-As

    Dabei seit:
    21.01.2003
    Beiträge:
    234
    Zustimmungen:
    0
    Nach dem Einstecken habe ich einige Zeit gewartet. Die letzten Zeilen von dmesg sehen so aus:

    usb 4-3: new high speed USB device using ehci_hcd and address 8
    usb 4-3: device descriptor read/64, error -71
    usb 4-3: device not accepting address 8, error -71
    usb 4-3: new high speed USB device using ehci_hcd and address 9
    usb 4-3: device descriptor read/8, error -71
    usb 4-3: device descriptor read/8, error -71
    usb 4-3: new high speed USB device using ehci_hcd and address 10
    usb 4-3: device not accepting address 10, error -71
    hdc: status error: status=0x58 { DriveReady SeekComplete DataRequest }
    ide: failed opcode was: unknown
    hdc: drive not ready for command
     
  9. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Das sieht sehr nach einem beschaedigten iPod aus, siehe z.B. die google-Treffer mit 'usb linux "error -71"'.
     
  10. #9 Wizard, 10.01.2007
    Zuletzt bearbeitet: 10.01.2007
    Wizard

    Wizard Tripel-As

    Dabei seit:
    21.01.2003
    Beiträge:
    234
    Zustimmungen:
    0
    Das gerät wird aber unter Windows problemlos als Laufwerk erkannt und arbeitet an sich einwandfrei.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Ich habe nun noch einmal Google befragt und fand zwei Lösungsmöglichkeiten:

    Zum einen schrieb jemand, dass er seine USB-Karte auf USB 2.0 upgegraded hätte und das Gerät danach einsatzbereit war:
    http://www.linuxquestions.org/questions/showthread.php?t=311840

    Wie kann ich sehen, ob mein Rechner USB 2.0 unterstützt (ich habe eine zusätzlich eingebaute USB-Karte).

    Eine andere Möglichkeit sei, /dev/sda auf /media/ipod zu mounten. Da ich darin noch nicht ganz firm bin, kann mir jemand den genauen Mount-Befehl posten, den ich in xterm eingeben muss?
    Hier noch der entsprechende Forums-Beitrag: http://www.linuxforums.org/forum/ubuntu-help/80336-2nd-generation-ipod-shuffle.html)
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Nachtrag:
    Ich habe mein System eben auf Open SuSE 10.1 upgegraded. Hat überhaupt nichts an der Situation geändert (abgesehen davon, dass der Rechner jetzt eine halbe Ewigkeit zum Booten braucht).

    Ich weiß auch nicht, wie ich /dev/sda überhaupt einbinden soll; es erscheint erst im Systembaum, wenn ich z.B. meinen USB-Stick anschließe, der problemlos erkannt wird.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Ich habe noch ein USB-Manual für Gentoo-Linux gefunden:

    http://www.gentoo.org/doc/de/usb-guide.xml

    Wenn ich wie dort beschrieben meine USB-Ports mit dmesg auflisten lasse, erfahre ich, dass ich nur USB 1.0 habe.

    Dann werde ich mir wohl eine neue USB-Karte zulegen müssen, die USB 2.0 unterstützt.
     
  11. #10 Wizard, 11.01.2007
    Zuletzt bearbeitet: 11.01.2007
    Wizard

    Wizard Tripel-As

    Dabei seit:
    21.01.2003
    Beiträge:
    234
    Zustimmungen:
    0
    ES HAT GEFUNZT!!! TSCHAKKA!!!!!

    Also Leute, ich habe mir nun eine neue USB-Karte besorgt (Belkin USB 2.0 Hi-Speed PCI Card, Modell F5U220). Wurde anstandslos ins System integriert und nun der Hammer: Ich musste nichts weiter tun als den iPod einzustöpseln. Genial.

    Danke für Eure Hilfe,
    Wizard
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Nun gab es neue Probleme:

    1) Nach dem Systemupgrade kann ich keine MP3s mehr aus meinem Rachner abspielen

    2) gtkPod macht Probleme: Ich habe versucht, einige MP3s von meinem Rechner auf den iPod zu übertragen. Die neuen Dateien werden in der Wiedergabeliste von gtkPod angezeigt. Dann habe ich die Dateien abgeglichen. Beim Beenden des Programms kommt Die Fehlermeldung "Dateien noch nicht gespeichert". Ich finde aber keinerlei Speicherfunktion. Beim Einschalten des iPod meke ich dann, dass die Dateien nicht übertragen wurden.
     
  12. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Bei SuSE gibt es irgendein Extrapaket, das man installieren muss, um mp3s abspielen zu koennen, aus lizenzrechtlichen Gruenden, wenn ich mich nicht irre. Irgendwas mit multimedia im Namen. Wenn Du hier im Board suchst, muesstest Du schnell eine Antwort finden.
     
  13. Wizard

    Wizard Tripel-As

    Dabei seit:
    21.01.2003
    Beiträge:
    234
    Zustimmungen:
    0
    @rikola: danke, das entsprechende Thema habe ich mittlerweile gefunden.

    Ich habe auch herausgefunden, dass das Frontend gtkpod den neuen Shuffle noch nicht unterstützt:
    http://www.linux-fuer-alle.de/doc_show.php?docid=248&catid=17

    Ich werde wohl vorerst mit gnupod mittels Konsole mein Glück versuchen müssen...
     
  14. Wizard

    Wizard Tripel-As

    Dabei seit:
    21.01.2003
    Beiträge:
    234
    Zustimmungen:
    0
    mp3s kann ich mittlerweile wieder abspielen.

    Ich habe auch entdeckt, dass man mit Amarok Dateien auf den iPod laden kann. Hat jemand Erfahrung damit?
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Wizard, 14.01.2007
    Zuletzt bearbeitet: 14.01.2007
    Wizard

    Wizard Tripel-As

    Dabei seit:
    21.01.2003
    Beiträge:
    234
    Zustimmungen:
    0
    Also, dann mache ich amarok auch mal startklar für mp3s.

    Eine unmissverständliche Anleitung wie das geht gibt es direkt auf der Seite des Amarok-Projektes:
    http://amarok.kde.org/wiki/MP3
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    !!! WARNUNG !!!

    Leute, lasst es bloß sein! Linux ist noch nicht reif für den iPod shuffle der zweiten Generation. Ich habe mir soeben die Firmware gehimmelt und werde demnächst die Grundeinstellungen wiederherstellen müssen - mit itunes und dem Rechner eines Freundes.
     
  17. Wizard

    Wizard Tripel-As

    Dabei seit:
    21.01.2003
    Beiträge:
    234
    Zustimmungen:
    0
Thema:

iPod shuffle

Die Seite wird geladen...

iPod shuffle - Ähnliche Themen

  1. Probleme mit Ipod unter Ubuntu 9.04

    Probleme mit Ipod unter Ubuntu 9.04: Hallo, nach dem ich länger einen Mac benutzt hab, hab ich nun wieder ein Laptop mit Linux - und bin leicht genervt... Ich hab meinen Ipod...
  2. iPod nano + Linux

    iPod nano + Linux: Hi! Ich hab diesen Thread mal in "Anwendungen" angelegt, da es wohl ein distributionsübergreifendes Problem ist. Ich spiele mit dem Gedanken, mir...
  3. Amarok 1.4.10, iPod 4G und die Cover?!

    Amarok 1.4.10, iPod 4G und die Cover?!: Hi, Hab mir heute nen iPod Shuffle gegönnt (nachdem ich meiner Freundin einen zu ihren Geburtstag geschenkt hab, Sie benutzt Windows!)....
  4. über Ubunutu den iPod ansprechen

    über Ubunutu den iPod ansprechen: Gibt es eigendlich iTunes für Linux? Ich hab es bisher über auf der offiziellen Appel-Seite nicht gefunden.
  5. gtkpod(linux) und itunes(mac) mit ipod shuffe (3.gen)

    gtkpod(linux) und itunes(mac) mit ipod shuffe (3.gen): Hallo Zusammen, ich habe ein Problem mit dem Laden von Lieder auf den Ipod Shuffle(Werbegeschenk). Das Gute: Ich kann den Ipod mit Itunes...