Intel 3945 Wireless mit WPA2

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von hannes90, 23.12.2007.

  1. #1 hannes90, 23.12.2007
    hannes90

    hannes90 nerd

    Dabei seit:
    26.01.2007
    Beiträge:
    22
    Zustimmungen:
    0
    Hallo,
    Ich habe folgendes Problem:
    In meinem Dell XPS M1530 ist eine Intell 3945 Netzwerkkarte installiert und ich würde die gerne benutzen. Das geht auch, allerdings kann ich kein WPA2 einschalten, nur WEP, WPA-PSK und das andere WPA, mir ist der name entfallen (Bin gerade in meiner Spaßbremse Vista).
    wpa_suppliant und iwp3945 sind installiert.
    Betriebssysthem ist opensuse10.3 mit Gnome, kernel 2.6.keine Ahnung (muss ich beim Nächsten mal nachschauen).
    Eine Ausgabe der iwconfig dürfte sich, aufgrund fehlender übertragungsmöglichkeiten, als schwierig erweisen.
    Hat jemand eine Idee/ Anleitung, die möglichst einfach ist.
    Kenne mich zwar mittlerweile etwas aus, aber bitte nicht alles als selbstverständlich vorraussetzen :)
    Vielen Dank schonmal,

    Hannes

    P.S.: Ich kann WPA nich abschalten, mein Vater verwaltet das Netzwerk uund ich habe keinen Zugriff.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 beomuex, 23.12.2007
    beomuex

    beomuex Routinier

    Dabei seit:
    11.03.2007
    Beiträge:
    354
    Zustimmungen:
    0
    Code:
    iwconfig >> iwconfig.txt
    Code:
    uname -r >> kernelinfo.txt
    Das ganz auf ein Stick/Diskette & hier posten.
    Alternativ ein Kabel anstecken.

    Gruß beomuex
     
  4. chb

    chb Steirer

    Dabei seit:
    01.06.2003
    Beiträge:
    2.359
    Zustimmungen:
    0
    Ort:
    ÖSTERREICH
    Alternativ noch /etc/wpa_supplicant.conf posten.
     
  5. #4 hermann4, 23.12.2007
    hermann4

    hermann4 Firmware v.3.1

    Dabei seit:
    29.09.2006
    Beiträge:
    522
    Zustimmungen:
    0
    Ort:
    Hamburg
    Welches Programm benutzt du für die Verbindung? Hast du den Networkmanager, WICD oder benutzt du nur wpa_supplicant
     
  6. #5 hannes90, 23.12.2007
    hannes90

    hannes90 nerd

    Dabei seit:
    26.01.2007
    Beiträge:
    22
    Zustimmungen:
    0
    Danke schonmal.
    Habe mich versucht an die Anleitung zuhalten:
    http://www.linux-stammtisch.at/index.php?PHPSESSID=057f5e26dcbd3ca98763cb2f3e68cf81&topic=796.0
    Bin bis dahin gekommen,
    Code:
    wpa_supplicant -ieth1 -Dwext -c /etc/wpa_supplicant.conf
    danach gings nicht weiter.
    Hier die Dateien:
    iwconfig:
    Code:
    lo        no wireless extensions.
    
    eth0      unassociated  ESSID:"JANOTTANETZ"  Nickname:"XtremePowerfulSysthem"
              Mode:Managed  Frequency=nan kHz  Access Point: Not-Associated   
              Bit Rate:0 kb/s   Tx-Power:16 dBm   
              Retry limit:15   RTS thr:off   Fragment thr:off
              Encryption key:84DA-D6F4-C4A4-1B1A-2579-6A20-0A   Security mode:open
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:48   Missed beacon:0
    
    wpa_supplicant:
    Code:
    ctrl_interface=/var/wpa_supplicant
    ctrl_interface_group=0
    eapol_version=1
    ap_scan=1
    fast_reauth=1
    
    
    network={
    		ssid="JANOTTANETZ"
    		scan_ssid=1
    		proto=WPA2
    		pairwise=TKIP CCMP
    		key_mgmt=WPA-PSK
    		psk="Schlüssel"
    	}
    Kernel ist:
    Code:
    2.6.22.5-31-default
    
    Schon mal danke,
    hannes

    P.S.: Der in Key, der in der wpa_supplicant.conf steht, ist bei mir richtig eingegeben.
    P.P.S.: Ich habe versucht, das ganze via YAST zu konfigurieren
    P.P.P.S.: Ich benötige eine Statische IP
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. #6 supersucker, 23.12.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    1.

    Oder auch die ext-Treiber von fs-driver.org nutzen, die laufen sehr gut.


    2.

    Wie meinen? Es gibt nur WPA (1) und WPA2.

    3.

    Poste mal die Fehler-Meldungen wenn du die Karte auf WPA2 schaltest, sprich vorher ein

    Code:
    dmesg  | tail
    mitlaufen lassen und die Ausgabe hier posten.

    4.

    Steht natürlich auch noch diese Frage im Raum:

     
  9. #7 hannes90, 23.12.2007
    Zuletzt bearbeitet: 23.12.2007
    hannes90

    hannes90 nerd

    Dabei seit:
    26.01.2007
    Beiträge:
    22
    Zustimmungen:
    0
    Code:
    dmesg | tail
    ata1.00: cmd 61/08:10:0d:f8:f6/00:00:0f:00:00/40 tag 2 cdb 0x0 data 4096 out
             res 40/00:10:0d:f8:f6/00:00:0f:00:00/40 Emask 0x2 (HSM violation)
    ata1: soft resetting link
    ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
    ata1.00: configured for UDMA/133
    ata1: EH complete
    sd 0:0:0:0: [sda] 312581808 512-byte hardware sectors (160042 MB)
    sd 0:0:0:0: [sda] Write Protect is off
    sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
    sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    Welchen WPA soll ich in Yast wählen:
    WPA-EAP oder
    WPA-PSK?
    Habe es hald nach der oben genannten Anleitung versucht.
    allerdings bekomme ich da immer bei dem Befehl
    Code:
    dhclient3 eth0
    eine Meldung, dass der Befehl nicht gefunden werden konnte.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Habe es gelöst:
    Einfach mal im YAST die Einstellung von konfigurieren mit auf Networkmanager gestellt, anschliesend im Panel auf das Monitoricon gecklickt, das Netzwerk ausgewählt, Schlüssel eingegeben und voila: Es geht!
    Vielen Dank für eure Hilfe!

    hannes90
     
Thema:

Intel 3945 Wireless mit WPA2

Die Seite wird geladen...

Intel 3945 Wireless mit WPA2 - Ähnliche Themen

  1. OpenBSD Intel 3945ABG WLAN

    OpenBSD Intel 3945ABG WLAN: Guten Tag, Mein erstes mal WLAN unter OpenBSD, und ich habe keine Ahnung ;'(. Details: ---------- Name des Funknetzes (SSID): meinrouter...
  2. Suse 10.3 und IntelPro 3945

    Suse 10.3 und IntelPro 3945: Hi Board, Habe mal wieder nen Problem und hoffe auf eure Hilfe. Verwende zur zeit Suse 10.3 Läuft soweit auch super bis auf ein Kleines...
  3. intel pro wireless 3945 AGB

    intel pro wireless 3945 AGB: GUTEN tag zusammen suse linux 10.1.. im yast wird die intel pro wireless 3945 AGB angezeigt, aber wenn ich den kwifi starte erkennt er keine...
  4. OpenSuse - Intel(R) PRO/Wireless 3945ABG - funkt nicht

    OpenSuse - Intel(R) PRO/Wireless 3945ABG - funkt nicht: Vorerst mal eine Entschuldigung, falls das Problem schon mal gelöst wurde - ich hab's über die Suchfunktion nicht gefunden. Ich hab ein BenqR55...
  5. Wlan unter Debian 4.0 (Intel Pro/Wireless 3945ABG)

    Wlan unter Debian 4.0 (Intel Pro/Wireless 3945ABG): Hallo. Ich habe seit ca. einer Woche Debian 4.0 bin aber noch ein richtiger Noob in Sachen Linux. Mein Problem ist folgendes: Ich habe eine Intel...