INIT Script startet nicht automatisch

Dieses Thema im Forum "Shell-Skripte" wurde erstellt von illtiss, 21.09.2007.

  1. #1 illtiss, 21.09.2007
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    Hallo,


    ich habe ein init script geschrieben, welches sich auch super
    manuell starten lässt. Leider startet es nicht selbständig beim Boot

    Das script liegt ausführbar in /etc/init.d/ in rc3.d liegt ein link S11Postgrey auf

    /etc/init.d/postgrey das gleiche natürlich auch ein link mit K11Postgrey.

    Leider startet das script nicht.

    Vielleicht weiss jemand Rat. Das Script poste ich noch, aber wie gesagt, manuell
    geht es ohne Probleme.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. mcas

    mcas Routinier

    Dabei seit:
    29.12.2005
    Beiträge:
    398
    Zustimmungen:
    0
    Welche Optionen verarbeitet das Skript? Stimmen evtl. irgendwelche Umgebungsvariablen nicht.
     
  4. #3 b3ll3roph0n, 21.09.2007
    b3ll3roph0n

    b3ll3roph0n Tripel-As

    Dabei seit:
    13.07.2007
    Beiträge:
    160
    Zustimmungen:
    0
    Welche Distribution?
    Wie wurde das Script eingebunden?
     
  5. #4 Schlaubi_fi.de, 21.09.2007
    Schlaubi_fi.de

    Schlaubi_fi.de Mac OS X User

    Dabei seit:
    22.12.2004
    Beiträge:
    304
    Zustimmungen:
    0
    Skript ist ausführbar?
     
  6. #5 illtiss, 21.09.2007
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    Distribution ist SuSe auf einem ESX Server.

    Das Skript lässt sich manuell, also per /etc/init.d/postgrey start/stop/status
    bestens starten/stoppen/statuieren

    Das Skript ist einfach aufgebaut, komme momentan nicht an den Mailserver,

    das skript soll vor postfix gestartet werden.

    es ruft den postgrey befehl mit einigen Parametern auf, mehr nicht.

    Ich versuche Euch das Skript mal zu posten
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. #6 b3ll3roph0n, 21.09.2007
    b3ll3roph0n

    b3ll3roph0n Tripel-As

    Dabei seit:
    13.07.2007
    Beiträge:
    160
    Zustimmungen:
    0
    Hat das Script einen LSB-kompatiblen Header?
     
  9. #7 illtiss, 21.09.2007
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    LSB?

    Du meinst das Zeug, mit der Description usw.?
     
Thema:

INIT Script startet nicht automatisch

Die Seite wird geladen...

INIT Script startet nicht automatisch - Ähnliche Themen

  1. fedora 17 problem mit init script

    fedora 17 problem mit init script: Hallo an alle Möchte gerne samba4 (von Quellen kompiliert) mit dem auf der samba-Homepage geposteten init script automatisch zur boot Zeit...
  2. Startscript in init.d scheitert an - " -

    Startscript in init.d scheitert an - " -: Hallo ich schon wieder ;) Ich starte in Debian lenny auf der Console den mjpg_streamer problemlos: /usr/bin/mjpg_streamer -b -i "input_uvc.so -d...
  3. Glassfish Initscript

    Glassfish Initscript: Hi Ich versuche mir gerade ein Initscript zu basteln was mir den Glassfish starten soll. Problem ist ich starte als Daemon ein Script und bekomme...
  4. wpa_supplicant: Fehler bei Initialisierung mit Bootscripts /etc/init.d/net.ath0 start

    wpa_supplicant: Fehler bei Initialisierung mit Bootscripts /etc/init.d/net.ath0 start: Hallo zusammen, ich bin gerade dabei, unter Gentoo mein WLAN einzurichten. Ich habe eine Ubiquiti SRC mit Atheros Chipsatz. Die madwifi-Treiber...
  5. HLDS init script?

    HLDS init script?: Hallo, ich möchte meinen HLDS unter Debian in durch ein init script starten... das klappt auch schon relativ gut nur leider haut es mit den...