[HILFE] X startet nicht mehr mit Nvidia

Dieses Thema im Forum "Grafik / Video" wurde erstellt von SurferX, 22.12.2004.

  1. #1 SurferX, 22.12.2004
    SurferX

    SurferX Jungspund

    Dabei seit:
    12.08.2003
    Beiträge:
    16
    Zustimmungen:
    0
    Hi @ all!

    Habe da ein Problem und bin echt ratlos. Ich bin eher ein Linuxanfänger, das vorweg.

    Hatte bis vor kurzem Mandrake 10.0 auf meinem Rechner laufen. Dort habe ich auch meine Geforce4 Karte korrekt zum laufen gebracht, dafür nutzte ich diese Anleitung: http://www.linuxforen.de/forums/showthread.php?t=111187&highlight=nvidia

    So, nun habe ich mir Mandrake 10.1 aufgespielt (Kernel 2.6.8-10) und wollte meine Graka wieder installieren, bin wieder genau nach der Anleitung vorgegangen. Habe mir den neuesten Treiber besorgt, die richtige Kernel Source hatte ich auch drauf. Installation lief ohne Probleme . Danach aus init 3 wieder in init 5, siehe da die Karte läuft mit 3d Unterstützung.

    Nun schaltete ich meinen Rechner heute wieder an, und was ist? Das System startet nur in der Konsole... Daraufhin habe ich die alte XF86Config wieder eingebunden, und konnte wieder X starten allerdings ohne 3D Unterstützung. Wieso läuft das nach der Installation gut, und nach dem ersten Reboot nicht mehr?

    Ich habe gelesen das man eine Log mit hier ins Forum einbinden soll, weiss aber nicht welche... :(

    Hier mal die XF86Config von der Nvidia Installation:

    Ich hoffe und bitte das mir jemand helfen kann. Danke im voraus.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. khs

    khs Routinier

    Dabei seit:
    19.08.2004
    Beiträge:
    408
    Zustimmungen:
    0
    Die Config war schonmal gut. An der haette zumindest ich als X-Server nix auszusetzen. ;) Was er jetzt bei dir genau meckert, kannst du unter /var/log/XFree86.log nachlesen.
    Das ist vermutlich auch die, von der du gelesen hast... ;)

    -khs
     
  4. #3 Factory, 22.12.2004
    Factory

    Factory Routinier

    Dabei seit:
    21.12.2004
    Beiträge:
    445
    Zustimmungen:
    0
    Ort:
    Bochum - NRW
    Hi hatte ein ähnliches prob. !

    Habe mir einfach denn treiber neu installiert + Kernel u.-Kernel-source, schon lief alles wie gewollt !

    Teste das am besten mal aus !

    MfG : Linux-Debian
     
  5. #4 Goodspeed, 23.12.2004
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Äh ... vielleicht solltest Du das nvidia-Modul bei Start mit laden lassen ... nur so'n Tip.

    Könnte wetten, dass es noch dem Reboot bei "lsmod" nicht mit angezeigt wird.
     
  6. #5 SurferX, 23.12.2004
    SurferX

    SurferX Jungspund

    Dabei seit:
    12.08.2003
    Beiträge:
    16
    Zustimmungen:
    0
    Wo und wie stelle ich ein das das Modul mit geladen wird? Beim starten sieht es so aus, als wenn er kurz in den Grafikmodus wechselt, dann das aber nicht schafft und die Konsole geladen wird...
     
  7. #6 Goodspeed, 23.12.2004
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Hast Du mal geschaut, was "lsmod" sagt?
    Keine Ahnung, wo bzw. wie Mandrake Module verwaltet ... gibts modconf?
     
  8. khs

    khs Routinier

    Dabei seit:
    19.08.2004
    Beiträge:
    408
    Zustimmungen:
    0
    Trag mal in /etc/modprobe.conf
    Code:
    alias char-major-195 nvidia
    alias /dev/nvidiactl char-major-195
    
    ein. Damit muesste er es automatisch laden, wenn es gebraucht wird.

    -khs
     
  9. #8 SurferX, 23.12.2004
    Zuletzt bearbeitet: 24.12.2004
    SurferX

    SurferX Jungspund

    Dabei seit:
    12.08.2003
    Beiträge:
    16
    Zustimmungen:
    0
    Habe mal die Xorg.0.log mit angehängt.

    Folgender Auszug ist mir aufgefallen:

    Gut, er kann das NVIDIA Kernel Modul nicht laden, und kein Screen hat eine brauchbare Konfiguration... UND NUN? ;)
     

    Anhänge:

  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 Goodspeed, 24.12.2004
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Versuch mal als root "depmod" und danach "modprobe nvidia" ...
     
  12. #10 SurferX, 24.12.2004
    Zuletzt bearbeitet: 24.12.2004
    SurferX

    SurferX Jungspund

    Dabei seit:
    12.08.2003
    Beiträge:
    16
    Zustimmungen:
    0
    Hat jetzt geklappt! Hatte wohl was falsch mit "modprobe" gemacht...

    VIELEN DANK EUCH ALLEN, und noch ein frohes Fest!
     
Thema:

[HILFE] X startet nicht mehr mit Nvidia

Die Seite wird geladen...

[HILFE] X startet nicht mehr mit Nvidia - Ähnliche Themen

  1. Homeserver auf OpenSolaris Basis im Aufbau [Hilfe]

    Homeserver auf OpenSolaris Basis im Aufbau [Hilfe]: Hallo Leute! Ich bin ein ziemlicher Anfänger in der UNIX-Welt. Ich bin gerade dabei, mit dieser Anleitung...
  2. Remote Desktop für SUSE 10 - alternativen [Hilfe]

    Remote Desktop für SUSE 10 - alternativen [Hilfe]: Hallo, ich bin hier ziemlich neu jedoch wirft sich eine Frage ständig vor mir her, und zwar gibt es was vergleichbares wie Radmin für windows.....
  3. [Hilfe] Ip-Aliasing und Einrichtung vhosts unter Mandrake

    [Hilfe] Ip-Aliasing und Einrichtung vhosts unter Mandrake: Hallo, (hoffe dies ist das richtige Forum) ich betreue als Tutor einen Uniwebserver auf dem ein CMS läuft. Nun sollen zwei weitere Seiten...
  4. [Hilfe] cyrus-imap einrichten auf Suse root-Server

    [Hilfe] cyrus-imap einrichten auf Suse root-Server: Nabend, ich habe da ein Problem, ich habe schon viel bei google gesucht und versucht auch von den englischen How-to's was zu verstehen, da man...
  5. LEDE: Fork von OpenWRT gestartet

    LEDE: Fork von OpenWRT gestartet: Unter dem Namen LEDE haben einzelne OpenWRT-Entwickler ein neues Projekt gestartet. Ziel des neuen Projektes ist es, eine gemeinschaftszentrierte...