HILFE,¦Extrem¦verzweifelung

Dieses Thema im Forum "Gentoo" wurde erstellt von MTS, 08.05.2003.

  1. #1 MTS, 08.05.2003
    Zuletzt bearbeitet: 08.05.2003
    MTS

    MTS Kaiser

    Dabei seit:
    09.11.2002
    Beiträge:
    1.242
    Zustimmungen:
    0
    Ort:
    NRW, Bochum
    Hi!
    also ich wollte gestern mein Linux (Gentoo)auf den neuesten Stand bringen....also im konkreten xfree updaten und den neuen Kernel installieren.
    Aber es ging natürlich mal wieder alles schief:
    Das erste Problem ist das folgende: Nachdem ich den neuen Kernel 2.4.20 installiert habe kann ich mich nicht mehr als user einloggen, und zwar sagt er mir nach Eingabe des logins / passwd ..... gar nichts.
    es kommt einfach wieder das login viech, er gibt nichts aus!! Su klappt auch net. Erst dachte ich mir dass das ganze an der GrSecurity geschichte liegt, weil das das einzige war was ich gegenüber dem anderen kernel geändert habe.... In der Doku zu der option standt was von der identd service muss auf gid 10 laufen, aber da ich dummerweise nicht weiss wie ich das hinkriege ..... da habe ich den kernel noch einmal OHNE die grsec kompiliert. Aber das ändert gar nichts.
    Nun gut ... also dachte ich mir schauste mal im internet nach ... und siehe da ... xfree geht plÝtzlich mit dem neuen Kernel nicht mehr (unresolved symbol .....)
    Aber -- ich wollts ja eh updaten, mache ich es halt neu. alse Xfree unmerged und die neueste Version emerged. Das kompilieren geht ja auch. aber wenn er sein make install macht ... dann kommt plözlich nen make Fehler.
    Soweit ich das sehe is das Problem bei der Xft Geschichte die bei xfree dabei is ... und zwar gibt er mir nen Fehler bei FCHintstyle ...
    aber die genaue Fehlermeldung sage ich euch nochmal ... ich kompiliere das gerade nochmal ... vielleicht wars ja nur pech *g*.

    Wär nett wenn ihr mir wenigstens bei einer sache helfen könntet ;)
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. MTS

    MTS Kaiser

    Dabei seit:
    09.11.2002
    Beiträge:
    1.242
    Zustimmungen:
    0
    Ort:
    NRW, Bochum
    here it comes:
    xftdpy.c: In function '_XftDefaultInit'
    xftdpy.c:380 'FC_Hint_Style' undeclared

    [...]

    Leaving directory '/var/tmp/portage/xfree-4.3.0-r2/work/xc/lib/Xft
     
  4. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    na ich warte mal ab obs geht ... denn deine Fehler sind mir im moment nicht reproduzierbar !

    *zu lang gewartet*


    Naja XFT Fehler ... auch welchem Stand bist du denn ? 1.4rc4 ?

    Ansonsten solltest du mal dein System mit emerge -UpD world (emerge -UD world) updaten !
     
  5. MTS

    MTS Kaiser

    Dabei seit:
    09.11.2002
    Beiträge:
    1.242
    Zustimmungen:
    0
    Ort:
    NRW, Bochum
    ne ...
    1.4.rc4 .. das passt.
    aber ich kanns ja trotzdem mal machen....
     
  6. MTS

    MTS Kaiser

    Dabei seit:
    09.11.2002
    Beiträge:
    1.242
    Zustimmungen:
    0
    Ort:
    NRW, Bochum
    grmph ... jetzt mal ne dumme frage ;)

    bei dieserr emerge -UD world geschichte steht xfree mit ganz oben .. das will ich dann aber erst später machen ....

    nen
    USE="-X" emerge -UD world

    bringt es irgendwie nicht .. wie krieg ich das da raus ?`??
     
  7. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    probier mal ein emerge -eUp world (emerge -eU world)
    schauts da besser aus ?

    Notfalls probier dochmal deine CFLAGS abzuändern ... geht dann XFREE zu emergen ?
     
  8. MTS

    MTS Kaiser

    Dabei seit:
    09.11.2002
    Beiträge:
    1.242
    Zustimmungen:
    0
    Ort:
    NRW, Bochum
    also das mit den CFLAGS hab ich jetzt nicht probiert ...
    aber ob ich dazu lust habe .... immerhin ist gentoo ja für die optimierung da, und das wäre recht bescheiden wenn das nur daran liegen würde...

    diese emerge eUp geschichte lass ich auch bleiben ... da will der ungefähr 20 milliarden neue pakete installieren ... ;)
     
  9. #8 hopfe, 08.05.2003
    Zuletzt bearbeitet: 08.05.2003
    hopfe

    hopfe Haudegen

    Dabei seit:
    01.04.2003
    Beiträge:
    733
    Zustimmungen:
    0
    Ort:
    Aachen
    Die Reihenfolge der Pakete wird teilweise auch die Abhängigkeiten definiert, daher kann es sein das ein anders Paket die Sourcen von xfree benötigt.

    mach mal ein emerge -Upv world das 'v' zeigt dir dabei an welche USE Flags von welchen Paket verwendet werden. Ich würde dir empfehlen das "-X" nicht in die USE Variable aufzunehmen.

    Add: Kannst dir ja mit hilfe von env mal den Unterschied ansehen. (env USE="-X" emerge -Upv world)

    Hopfe
     
  10. MTS

    MTS Kaiser

    Dabei seit:
    09.11.2002
    Beiträge:
    1.242
    Zustimmungen:
    0
    Ort:
    NRW, Bochum
    jo , gute idee ,
    áber wie kriege ich denn dann die ganzen X11 sachen erstmal raus ...
    der soll zuerst den rest des systems updaten ... danach das Xsystem.
     
  11. #10 hopfe, 08.05.2003
    Zuletzt bearbeitet: 08.05.2003
    hopfe

    hopfe Haudegen

    Dabei seit:
    01.04.2003
    Beiträge:
    733
    Zustimmungen:
    0
    Ort:
    Aachen
    Das 'e' beim emerge brauchst du ja auch nur machen wennst alle Pakete neu übersetzen willst. Würde auch nur bei der Änderung deiner CFLAGS sinnmachen, für ein normales Update reicht ein emerge -U world.

    add: ich würde die Reihenfolge einfach einhalten, natürlich kannst immer noch von Hand Pakete einspielen zBemerge -U gentoo-sources.
     
  12. MTS

    MTS Kaiser

    Dabei seit:
    09.11.2002
    Beiträge:
    1.242
    Zustimmungen:
    0
    Ort:
    NRW, Bochum
    ja sicher ... aber dsa problem is ja
    das xfree nicht kompiliert, b zw es diesen Xft fehler gibt...

    ich dachte nur das das ja vielleicht an irgendnem anderem Paket liegen könnte, dass nicht aktuell genug is oder so ...

    im gentoo forum gibt es auch nichts nützliches (older ich habs net gefunden), aber viele leute haben sich da auch beschwert dass emerge xfree nicht geht.

    ich find das ganze langsam recht bescheiden
     
  13. hopfe

    hopfe Haudegen

    Dabei seit:
    01.04.2003
    Beiträge:
    733
    Zustimmungen:
    0
    Ort:
    Aachen
    Versuche mal erst das alte xft zu deinstalliern, die Libary kommt dann mit xfree neu mit.
     
  14. MTS

    MTS Kaiser

    Dabei seit:
    09.11.2002
    Beiträge:
    1.242
    Zustimmungen:
    0
    Ort:
    NRW, Bochum
    ;)
    ey .. ich bin nicht dumm *g*

    ich hatte sogar alles runtergeschmissen gehabt was mit xfree zu tun hat ...
    (ausser KDE natürlich)
    aber nichts is..
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. hopfe

    hopfe Haudegen

    Dabei seit:
    01.04.2003
    Beiträge:
    733
    Zustimmungen:
    0
    Ort:
    Aachen
    Welche Pakete will er bei dir eigentlich genau neuinstallieren?
     
  17. MTS

    MTS Kaiser

    Dabei seit:
    09.11.2002
    Beiträge:
    1.242
    Zustimmungen:
    0
    Ort:
    NRW, Bochum
    öhm ... wo meinst du jetzt`???

    bei emerge -eU world???



    das sind wirklich ne ganze reihe ... aus allen möglichen bereichen
     
Thema:

HILFE,¦Extrem¦verzweifelung