Hilfe bei Mandriva!

Dieses Thema im Forum "Mandriva" wurde erstellt von ruecki1971, 02.05.2006.

  1. #1 ruecki1971, 02.05.2006
    ruecki1971

    ruecki1971 Mitglied

    Dabei seit:
    02.05.2006
    Beiträge:
    27
    Zustimmungen:
    0
    Hallo Freunde :) ,
    ich hab Mandriva 2006 auf meinem Maxdata 8100 Notebook installiert und es läuft auch
    ganz rund! Aber wenn ich eine externe USB HDD unter dem Standard-Benutzer anschließe,
    dann verweigert das System den Zugriff! In der Konsole angemeldet als Root komme ich
    ohne Probleme auf die Platte! Wie bringe ich es dem Benutzer bei die Platte automatisch zu mounten. Hab schon in den Benutzerrechten herumgetüftelt aber es klappt einfach nicht!

    Gruß
    Rücki
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 hoernchen, 02.05.2006
    hoernchen

    hoernchen UBERgarstiges nagetier

    Dabei seit:
    17.02.2005
    Beiträge:
    1.081
    Zustimmungen:
    0
    poste mal deine fsatb, dort liegt vermutlich der hund begraben und wir koennen ausbuddeln.
     
  4. #3 DennisM, 02.05.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Bitte nach Mandriva verschieben.

    MFG

    Dennis
     
  5. #4 slasher, 02.05.2006
    slasher

    slasher König

    Dabei seit:
    22.03.2006
    Beiträge:
    827
    Zustimmungen:
    0
    a bissel genauer:

    cat /etc/fstab

    Die Ausgabe hier posten :)...

    @dennism: schau mal links, das kleine Warndreieck :)...nutz es!
     
  6. #5 ruecki1971, 02.05.2006
    ruecki1971

    ruecki1971 Mitglied

    Dabei seit:
    02.05.2006
    Beiträge:
    27
    Zustimmungen:
    0
    Hier mal meine fstab:

    # This file is edited by fstab-sync - see 'man fstab-sync' for details
    /dev/hda1 / ext3 noatime 1 1
    /dev/hda6 /home ext3 noatime 1 2
    /dev/hdc /mnt/cdrom auto umask=0022,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
    none /proc proc defaults 0 0
    /dev/hda5 swap swap defaults 0 0
    /dev/sdb1 /mnt/usbhdd ntfs pamconsole,exec,noauto,utf8,iocharset=iso8859-15,managed 0 0

    Gruß
    Rücki :)
     
  7. #6 hoernchen, 02.05.2006
    hoernchen

    hoernchen UBERgarstiges nagetier

    Dabei seit:
    17.02.2005
    Beiträge:
    1.081
    Zustimmungen:
    0
    /dev/sdb1 /mnt/usbhdd ntfs pamconsole,exec,noauto,users,utf8,iocharset=iso8859-15,managed 0 0

    und gut ist. :-)

    users muß hinzugefuegt werden, damit eben auch andere als root die mounten koennen. und die zugriffsrechte von /mn/usbhdd sollten auch angepasst werden, zb. chmod 777.
     
  8. #7 DennisM, 02.05.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Hab ich noch nie gesehen ;)

    Alles schon erledigt ;)

    MFG

    Dennis
     
  9. #8 ruecki1971, 02.05.2006
    ruecki1971

    ruecki1971 Mitglied

    Dabei seit:
    02.05.2006
    Beiträge:
    27
    Zustimmungen:
    0
    Also ich hab die fstab abgeändert versucht auch die Rechte anzupassen! Aber irgendwie klappt es noch nicht! Wie ist es genau mit chmod 777? Ich hab jetzt mal dem User alles an Gruppen hinzugefügt! Normal benötigt man doch nur User, oder?!? :think:

    Gruß
    Rücki
     
  10. Gebath

    Gebath Guest

    es besteht ein Unterschied zwischen user und users, users sind nämlich alle Benutzer. Bei chmod ist es glaub ich so dass die Zugriffsrechte standardmäßig eine bestimmte Zahl beträgt (die ich jetzt aber nicht weiß sry). Von dieser Zahl wird die angegebene Zahl subtrahiert also abgezogen.
     
  11. #10 hoernchen, 03.05.2006
    hoernchen

    hoernchen UBERgarstiges nagetier

    Dabei seit:
    17.02.2005
    Beiträge:
    1.081
    Zustimmungen:
    0
    Was ich meinte :

    Mach mal "ls -l mnt/usbhdd"

    Dann siehst du, wem es gehoert bzw. welcher Gruppe.

    zB.: drwxr-xr-x 1 root root 785 1. April 12:56 /etc/fstab
    Das heißt : root darf lesen, schreiben und ausfuehren (in dem Fall den Ordner oeffnen), alle anderen duerfen nur lesen und ausfuehren.
    Da du aber vermutlich als User auch in dem Ordner rumgurken willst, waere folgendes praktisch und anratenswert :
    als root : chown username.gruppe /mnt/usbhdd, zB.:chown hoernchen.hoernchenhorde /mnt/usbhdd.
    Dann gehoert der Ordner dem User hoernchen und der Gruppe hoernchenhorde.
    Als User machst du dann : chown 700 /mnt/usbhdd.
    Damit darfst dann nur du (und root) auf den Ordner und somit auch die USB-HD zugreifen.
    Die Faulsackmethode waere als root einfach chmod 777 /mnt/usbhdd. Dann darf allerdings jeder alles auf deiner Festplatte.
     
  12. #11 ruecki1971, 03.05.2006
    ruecki1971

    ruecki1971 Mitglied

    Dabei seit:
    02.05.2006
    Beiträge:
    27
    Zustimmungen:
    0
    Hallo Hoernchen!

    Ich bekomme bei der Eingabe des "Faulsackmethode" immer folgende Fehlermeldung:
    [root@localhost ruecki]# chmod 777 /mnt/usbhdd
    chmod: Beim Setzen der Zugriffsrechte für ,,/mnt/usbhdd": Das Dateisystem ist nur lesbar

    Wollte es nur mal auf die Schnelle probieren! Klappt aber auch nicht so! :think:

    Gruß
    Ruecki
     
  13. #12 hoernchen, 04.05.2006
    hoernchen

    hoernchen UBERgarstiges nagetier

    Dabei seit:
    17.02.2005
    Beiträge:
    1.081
    Zustimmungen:
    0
    das liegt dann daran, daß du ntfs nur lesen kannst, aber nicht beschreiben. formatier die platte mit fat und es funkt.
     
  14. #13 DennisM, 04.05.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Captive-ntfs.

    MFG

    Dennis
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 ruecki1971, 05.05.2006
    ruecki1971

    ruecki1971 Mitglied

    Dabei seit:
    02.05.2006
    Beiträge:
    27
    Zustimmungen:
    0
    Hallo Freunde, :hilfe2:

    bin total am Ende! Irgendwie klappt es nicht. Ich erkläre mal wie ich es jetzt gemacht habe.
    Also ich hab mich als root in der Konsole angemeldet. Dann hab ich mit dem MC die fstab
    editiert und users hinzugefügt, so wie beschrieben. hab den MC verlassen und chmod 777 /mnt/USB-HDD eingegeben. Es erscheint dann halt die Meldung:

    [root@localhost etc]# chmod 777 /mnt/USB-HDD
    chmod: Beim Setzen der Zugriffsrechte für ,,/mnt/USB-HDD": Das Dateisystem ist n ur lesbar

    Alles schön und gut, aber wenn ich dann auf dem Desktop auf Geräte klicke und dann auf die
    entsprechende Festplatte USB-HDD, dann kommt immer eine Fehlermeldung vom Konqueror und zwar lautet diese: Ordner /mnt/USB-HDD kann nicht geöffnet werden. Kann nur noch OK anklicken und mehr nicht! Was ist denn da nun noch falsch? Kann mir jemand helfen?

    Gruß Rücki ?(
     
  17. #15 hoernchen, 06.05.2006
    hoernchen

    hoernchen UBERgarstiges nagetier

    Dabei seit:
    17.02.2005
    Beiträge:
    1.081
    Zustimmungen:
    0
    das und die fehlermeldung vom konqueror bedeutet daß er das ntfs-dateisystem auf der usb-platte nicht beschreiben kann . entweder du formatierst sie neu (mit ext3, reiserfs oder vfat damit du daten mit windows austauschen kannst), oder du installierst dir, wie schon vorgeschlagen, captive ntfs.
     
Thema:

Hilfe bei Mandriva!

Die Seite wird geladen...

Hilfe bei Mandriva! - Ähnliche Themen

  1. mandriva 2007 und ipod nano?!?! (HILFE)

    mandriva 2007 und ipod nano?!?! (HILFE): guten tag erst einmal, die suchfunktion hat mir kein vorhandenes thema aufgetischt, und so sehe ich mich gezwungen eines aufzumachen. vor einer...
  2. Hilfe.

    Hilfe.: Hallo ich habe centos 7.2.15.11 Ich habe die .rpm Dateien von Epson direkt installiert, aber sonst nichts. Nachdem ich im Terminal...
  3. Bräuchte Hilfe bei Backupscript mittels Bash und cronjob

    Bräuchte Hilfe bei Backupscript mittels Bash und cronjob: Es soll für bestimmte Ordner Archivierung aller Dateien(Logfiles), die älter als 30 Tage sind machen. Am besten einmal täglich nachts irgendwann....
  4. [Gelöst] Suchen und ersetzen mit Hilfe mehrerer Parameter

    [Gelöst] Suchen und ersetzen mit Hilfe mehrerer Parameter: Hallo zusammen, ich bin an einem Punkt angekommen, wo ich nicht mehr weiter komme und hoffe ihr könnt mir weiter helfen. Anbei ein Ausschnitt aus...
  5. Benötige Hilfe- Dateien vergleichen

    Benötige Hilfe- Dateien vergleichen: Hallo, für eine Arbeit an der Uni muss ich einige viele Bilder miteinander vergleichen, was ich gerne durch eine Automatisierung etwas...