GUbutnu 14.04 LTS DualMonitor-Mode: Ubuntu merkt sich die Bildschirmpositionen nicht

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von hazelnoot, 06.06.2014.

  1. #1 hazelnoot, 06.06.2014
    hazelnoot

    hazelnoot www.mywm.dl.am

    Dabei seit:
    13.10.2005
    Beiträge:
    377
    Zustimmungen:
    0
    Ort:
    in Geiersberg
    Liebe Community,

    ich habe vor kurzem GUbuntu 14.04 LTS aufgesetzt. Es funktioniert soweit auch wunderbar, nur habe ich das Problem, dass es sich die Bildschirmposition nicht merkt.

    Mit Bildschirmposition meine ich, dass der Bildschirm DVI-0 links von dem Bildschirm HDMI-0 sein soll.

    Der Befehl:
    xrandr --output DVI-0 --auto --left-of HDMI-0
    funktioniert wunderbar nur weiß ich nicht wann ich diesen während des Startvorgangs ausführen soll damit er meinen Gnome-Desktop nicht zerfetzt (näheres dazu Später)

    Was ich schon alles versucht habe:
    1. Einstellen der Position über die GUI:
      Bildschirmfoto vom 2014-06-06 09:08:16.png
      schlug fehl, da nachdem man auf Anwenden klickt, der Bildschirm zwar auf die richtige Seite kommt nur nach dem nächsten Login ist der Bildschirm wieder auf der falschen Seite.
    2. Ich habe die Datei /etc/X11/Xsession.d/45x11-custom_xrandr-settings angelegt und dort folgende Konfiguration Eingetragen:
      Code:
      vergrößern
      #Erweiterter Desktop beim Start des XServers
      
      # Hier die Bezeichner der Bildschirme eintragen
      INTERNAL_OUTPUT="HDMI-0"
      EXTERNAL_OUTPUT="DVI-0"
      # EXTERNAL_LOCATION kann sein: left, right, above, oder below
      EXTERNAL_LOCATION="left"
       
      case "$EXTERNAL_LOCATION" in
             left|LEFT)
                     EXTERNAL_LOCATION="--left-of $INTERNAL_OUTPUT"
                     ;;
             right|RIGHT)
                     EXTERNAL_LOCATION="--right-of $INTERNAL_OUTPUT"
                     ;;
             top|TOP|above|ABOVE)
                     EXTERNAL_LOCATION="--above $INTERNAL_OUTPUT"
                     ;;
             bottom|BOTTOM|below|BELOW)
                     EXTERNAL_LOCATION="--below $INTERNAL_OUTPUT"
                     ;;
             *)
                     EXTERNAL_LOCATION="--left-of $INTERNAL_OUTPUT"
                     ;;
      esac
       
      xrandr |grep $EXTERNAL_OUTPUT | grep " connected "
      if [ $? -eq 0 ]; then
          xrandr --output $INTERNAL_OUTPUT --auto --output $EXTERNAL_OUTPUT --auto $EXTERNAL_LOCATION
      else
          xrandr --output $INTERNAL_OUTPUT --auto --output $EXTERNAL_OUTPUT --off
      fi
      Diese Datei wird einfach ignoriert vom System!
    3. Selben Inhalt wie /etc/X11/Xsession.d/45x11-custom_xrandr-settings habe ich im Heimatverzeichnis in die Datei .xprofile geschrieben. Selber Effekt wie bei Punkt 2.
    4. Wenn ich den Befehl xrandr --output DVI-0 --auto --left-of HDMI-0 in die Liste der zu startenden Befehle in Ubuntu gebe, Funktioniert es zwar, die Bildschirme sind an der richtigen Position, nur der Desktophintergrund beim Hauptbildschirm bleibt schwarz und wird auch nicht mehr refresht. D.h: Wenn man ein Fenster in diesem Desktop hin und her schiebt, "zieht" das Fenster schlieren. Das Fenster wird beim Bewegen von Position X auf Y an der Position X nicht mehr gelöscht.

    Ich bin mit meinem Latein am Ende!

    Vielleicht könnt Ihr mir helfen!

    Danke!
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 skull-y, 07.06.2014
    skull-y

    skull-y Guest

    Berichtige bitte den Namen deiner verwendeten Distri, ein GUbuntu gibt es nicht.

    Das Problem mit dem Hintergrund habe ich, wenn ich mich richtig erinnere gelöst, in dem ich ein bash script verwendet habe, statt nur den Befehl in den Autostart zu legen. Im Script muss glaube ich

    Code:
     sleep 5 && [FONT=Courier New]xrandr --output DVI-0 --auto --left-of HDMI-0[/FONT]
    Damit sollte der BEfehl mit einer Verzögerung von 5 Sekunden aufgerufen werden. Mit der Zeitangabe wirst du vermutlich etwas herumprobieren müssen.
     
Thema:

GUbutnu 14.04 LTS DualMonitor-Mode: Ubuntu merkt sich die Bildschirmpositionen nicht