Glibc_2.4

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von killer04, 08.12.2007.

  1. #1 killer04, 08.12.2007
    killer04

    killer04 Eroberer

    Dabei seit:
    03.08.2006
    Beiträge:
    66
    Zustimmungen:
    0
    Hi,
    Ich habe mir für C++ die boost library heruntergeladen und wollte dies mit dem Programm bjam "builden" jedoch will er beim ausführen das ich eine GLIBC_2.4 installiere. Wenn ich nun aber in der Paketverwaltung nachschaue finde ich dort keine GLIBC 2.4 die clib 6 ist installiert!

    MFG killer04
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Keruskerfürst, 08.12.2007
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Aktuell ist Glibc 2.6 oder 2.7.
     
  4. #3 Hello World, 08.12.2007
    Hello World

    Hello World Routinier

    Dabei seit:
    22.11.2006
    Beiträge:
    324
    Zustimmungen:
    0
    Das ist hier völlig ohne Belang. Es wäre eine gigantische Dummheit, nicht die libc zu verwenden, die beim Betriebssystem mitgeliefert wird.

    Was das Thema angeht: Debian und dessen Derivate enthalten boost-Pakete, die man mit apt-get install libboost-dev installieren kann, das selber bauen ist also unnötig und auch nicht zu empfehlen.

    Unter Debian heißt das glibc-Paket übrigens traditionell libc6 und liegt derzeit in Version 2.3.6 vor.
     
  5. #4 Keruskerfürst, 08.12.2007
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Kein Kommentar.
     
  6. #5 killer04, 08.12.2007
    killer04

    killer04 Eroberer

    Dabei seit:
    03.08.2006
    Beiträge:
    66
    Zustimmungen:
    0
    Hi,
    Danke für eure Antworten.
    Ich hab da folgendes Problem:
    Wenn ich libboost in der Synaptic Paketverwaltung suche findet er es nicht.
    wenn ich es per apt mache kommt folgender Fehler:
    Code:
    E: Konnte Lock /var/lib/dpkg/lock nicht bekommen - open (11 Die Ressource ist zur Zeit nicht verfügbar)
    E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
    
    Ich muss noch dazu sagen das dies mein erstes selbstinstalliertes Debian ist.
    In der Paketverwaltung hab ich folgende resourcen eingetragen:
    2x den Freenet server (Binary & Source);
    Debian 3.1 Sarge;
    debian.org (Binary).

    MFG killer04
     
  7. #6 Goodspeed, 08.12.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
  8. #7 Hello World, 08.12.2007
    Zuletzt bearbeitet: 08.12.2007
    Hello World

    Hello World Routinier

    Dabei seit:
    22.11.2006
    Beiträge:
    324
    Zustimmungen:
    0
    Bist Du root, und hast Du wirklich nur eine Instanz von dpkg oder apt laufen? Wenn Du Dich davon überzeugt hast, das letzteres der Fall ist, kannst Du /var/lib/dpkg/lock auch einfach löschen.
    Und dass er Sarge verwendet ist eigentlich nicht wichtig, denn auch dafür gibt es boost-Pakete, und es wird ja auch noch unterstützt.
     
  9. #8 killer04, 08.12.2007
    killer04

    killer04 Eroberer

    Dabei seit:
    03.08.2006
    Beiträge:
    66
    Zustimmungen:
    0
    Hi,
    Habe das so weit hinbekommen, nur ne dumme Frage noch.
    Wo sind die libs und includes von boost.
    In /usr/local/lib/ sind sie nicht!

    MFG killer04
     
  10. #9 Hello World, 08.12.2007
    Hello World

    Hello World Routinier

    Dabei seit:
    22.11.2006
    Beiträge:
    324
    Zustimmungen:
    0
    Wenn Du die Debian-Pakete verwendet hast, in /usr/include. Wenn Du selbst kompiliert hast, würde ich auf /usr/local/include tippen.
     
  11. #10 killer04, 08.12.2007
    killer04

    killer04 Eroberer

    Dabei seit:
    03.08.2006
    Beiträge:
    66
    Zustimmungen:
    0
    HI,
    Ja das sind die header files aber wo sind die librarys für threads etc.?

    Schöne Nacht noch.
    MFG killer04
     
  12. #11 Goodspeed, 09.12.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Äh ... unter /usr/lib/ ... wie alle Libraries ...
     
  13. #12 killer04, 09.12.2007
    killer04

    killer04 Eroberer

    Dabei seit:
    03.08.2006
    Beiträge:
    66
    Zustimmungen:
    0
    HI,
    In dem Ordner hab ich schon nachgeschaut ich finde die libs dadrinn nicht.
    Normalerweiße müssten sie ja libboost.a heißen oder?

    MFG killer04
     
  14. #13 Goodspeed, 09.12.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Naja ... könnt halt darauf an, welche der libboost*-Pakete Du installiert hast ...
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 killer04, 09.12.2007
    killer04

    killer04 Eroberer

    Dabei seit:
    03.08.2006
    Beiträge:
    66
    Zustimmungen:
    0
    Hi,
    Oben wurde ja geschrieben das ich libboost-dev installieren sollte. Dies hab ich getan, muss ich noch mehr installieren?
    Mir sind eigentlich nur die Thread Sachen von boost wichtig!

    Schöner Sonntag noch.
    MFG killer04
     
  17. #15 Goodspeed, 09.12.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Wie wär's mit "libboost-thread1.33.1"?
    Enthält "/usr/lib/libboost_thread-gcc-mt-1_33_1.so.1.33.1" ...
     
Thema:

Glibc_2.4