Gentoo Kernel Problem

Dieses Thema im Forum "Gentoo" wurde erstellt von illtiss, 25.05.2006.

  1. #1 illtiss, 25.05.2006
    Zuletzt bearbeitet: 25.05.2006
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    Um was es geht: Ich will meinem Bruder helfen ein Gentoo x86 2006 zu
    installieren. Routine habe ich genug.

    Das Problem: Ich habe die aktuellen Kernel-sources 2.6.18 von Kernel.org
    gezogen. Menuconfig gemacht wie immer (ist mein alter
    Rechner. Kernel installiert und einen REboot gemacht. Der Kernel boot nur bis kurz nach dem einlesen des physischen Speichers, meist ist die letzte Zeile irgentwas mit ACPIC. Kein Kernel Panic oder Fehlermeldung, er rödelt noch 30 Sekunden, dann ist es totenstill. Gut dachte ich mir neuer Versuch alles mit neuen Source usw. Wieder das selbe, diesmal war die letzte Zeile eine andere, also wahrlos. Das ganze Spiel habe ich jetzt 7 mal wiederholt, immer das gleiche Problem. Also muss der Genkernel drann glauben dachte ich mir. Genkernel installiert, und siehe da es geht. Da dachte ich mir ok, mach das Spiel nochmal, und modifiziere die /usr/share/genkernel/x86/kernel-config-2.6 damit wir auch eine Firewall mit Hilfe von IPtables aufsetzten können. Also habe ich die kernel-config-2.6 ins /usr/src/linux als .config mit menuconfig bearbeitet, wirklich nur die Netfilter sonst rein gar nix. dann wieder zurück kopiert als kernel-config-2.6 in /usr/share/genkernel/x86/ mit genkernel all compiliert und installiert. Neustart gemacht, und zu meinem Erstaunen habe ich festgestellt dass auch dieser Kernel nicht bootet, er blieb wieder an der fast selben Stelle hängen wie die anderen auch.

    Nun bin ich langsam am Verzweifeln, ich hatte das Problem schon öffter, seit den sagen wir Kernels ab Version 2.14.XX. Ich kann das Problem auch nicht eingrenzen, da keine Fehler meldung ausgegeben wird die mir weiterhelfen könnte. Ich bin sämliche configs des Kernels durch gegangen ohne und mit ACPIC mit CPU als 486èr usw. Erwähnenswert ist auch das ich das selbe Problem habe wnn ich die x86_64 Arch von Gentoo nehme. Ich wollte auch mal wissen ob die lokalen make.conf Einträge Einfluss auf das compilieren des Kernels haben, wenn ja findet sich vielleicht dort der Fehler. Ich dachte auch ein einen defekten Speicher oder gar CPU aber da ist Windows für gewöhnlich das erste das sich mit dem Blue Screen meldet. Aber ich bin mit dem Latein am Ende. Ich hoffe einer von Euch hat einen Tip für mich.

    Hardware:

    AMD 64 BIT 3400+
    ASUS K8V SE Deluxe
    2048 MB DDR 400Mhz RAM
    Geforce 6600 GT
    Gentoo x86 2006 und x86_64X
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 DennisM, 25.05.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Welche Fehlermeldung kommt denn genau?

    MFG

    Dennis
     
  4. #3 illtiss, 25.05.2006
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    Eben gar keine. Er bleibt einfach stehen. Er arbeitet laut HDD LED noch ca. 30 Sekunden, dann rüht Sie sich nicht mehr. Auch langes warten von 10 15 Minuten bringt keine Änderung. Wie gesagt keine Fehlermeldung, es steht jeweils nur die letzte Zeile da, die aber nicht ungewöhlich ist, und auf keinen Fall eine Fehlermeldung.
     
  5. #4 Keruskerfürst, 25.05.2006
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Was steht denn in der letzten Zeile?
     
  6. #5 illtiss, 25.05.2006
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    Wechselt, mal hält er nach dem Zeug mit dem Low and High Mem, dann mal wieder nach ACPI meist aber nach dem ACPI, wobei das keinen Fehler gibt
     
  7. #6 Keruskerfürst, 25.05.2006
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Dann mal mit ACPI=OFF (als Kernelparameter) versuchen.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. #7 illtiss, 25.05.2006
    Zuletzt bearbeitet: 25.05.2006
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    Habe ich getestet, vielleicht nicht richtig, muss ich die Kernelbefehltszeile im Grub Menü (glaube e war das ) editieren und dann einfach drannhängen?

    Nope, es geht nicht er bleibt bei folgendem stehen:

    1151MB HIGHMEM available.
    896 MB LOWMEM available.
    found SMP MP table at 000ff780


    Das kam auch schon öffter, wenn ich kein ACPI Support im Kernel hatte.
     
  10. #8 illtiss, 01.08.2006
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    So das Problem hat sich von selbst gelöst. Seit dem Kernel 2.6.17 geht das booten ohne Probleme. Danke nochmal an alle für Eure Hilfe.. :D
     
Thema:

Gentoo Kernel Problem

Die Seite wird geladen...

Gentoo Kernel Problem - Ähnliche Themen

  1. kernel panic nach gentoo-installation

    kernel panic nach gentoo-installation: moin :) ich installierte gestern nacht von einem existierenden arch linux aus gentoo. das ist nicht das erste mal, dass ich gentoo installiere....
  2. [Gentoo] - NIDSwrapper -> Internet (Can't find kernel build files in...)

    [Gentoo] - NIDSwrapper -> Internet (Can't find kernel build files in...): Hi zu allen, ich möchte jetzt gern von Debian u. Ubuntu nach Gentoo umsteigen. Um mir das ganze leichter zu machen habe ich Gentoo von der LiveCD...
  3. KERNEL PANIC nach gentoo installation mit yaboot

    KERNEL PANIC nach gentoo installation mit yaboot: hallo community :) ich habe soeben eine gentoo 2007.0 stage3 installation auf einem apple g5 (ppc64) fertiggestellt. leider bootet er nicht....
  4. Alsasound probleme seit Kernel-2.6.15-gentoo-r1

    Alsasound probleme seit Kernel-2.6.15-gentoo-r1: Moin Moin Ich hab seit Kernel-2.6.15-gentoo-r1 Probleme mit Alsa. Nach jedem Neustart, oder aus- und wieder einloggen eines Users, bleiben...
  5. Kernel Panic nach Gentoo installation

    Kernel Panic nach Gentoo installation: Hi Leute ich hab mich endlich auch an die Installation von Gentoo gewagt. Hab alles strikt nach der Anleitung bei www.Gentoo.org gemacht. Nach dem...