Gentoo bootet nicht

Dieses Thema im Forum "Gentoo" wurde erstellt von honkey, 01.04.2007.

  1. honkey

    honkey Grünschnabel

    Dabei seit:
    01.04.2007
    Beiträge:
    5
    Zustimmungen:
    0
    Ich habe Gentoo zum ersten Mal installiert. Wenn ich ehrlich bin, hab ich ja nicht daran geglaubt das alles gleich läuft, und siehe da: es bootet nicht. Vielleicht bin ich im Moment blind, aber ich habe das alles mehrmals durchgecheckt.

    "The root block device is unspecified or not detected", den Fehler spuckt Grub aus, nachdem ich Gentoo ausgewählt habe.

    Alle Auszüge aus dem Gentoo System sind mit einer Livecd eines anderen Linuxes gemacht, daher auch die anderen Pfade. Wenn irgendjemand von euch meinen Fehler sieht bin ich sehr dankbar :).

    greez honkey


    ls -l aus /boot:
    Code:
    :/mnt/sda1 # ls -l
    total 4939
    -rw-r--r-- 1 root root  856457 Mar 31 18:23 System.map-genkernel-x86-2.6.19-gentoo-r5
    lrwxrwxrwx 1 root root       1 Mar 31 17:27 boot -> .
    drwxr-xr-x 2 root root    1024 Mar 31 19:44 grub
    -rw-r--r-- 1 root root 2347120 Mar 31 18:38 initramfs-genkernel-x86-2.6.19-gentoo-r5
    -rw-r--r-- 1 root root 1815150 Mar 31 18:23 kernel-genkernel-x86-2.6.19-gentoo-r5
    drwx------ 2 root root   12288 Mar 31 17:13 lost+found
    
    /boot/grub/grub.conf:
    (geschrieben nach Anleitung; Ich hab genkernel verwendet.)
    Code:
    :/mnt/sda1 # cat grub/grub.conf
    default 0
    timeout 30
    splashimage=(hd0,0)/boot/grub/splash.xpm.gz
    
    title=Gentoo Linux 2.6.19-r5
    root (hd0,0)
    kernel /boot/kernel-genkernel-x86-2.6.19-gentoo-r5 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_boot=/dev/sda3 udev
    initrd /boot/initramfs-genkernel-x86-2.6.19-gentoo-r5
    
    /etc/fstab:
    Code:
    :/mnt/sda3 # cat etc/fstab
    
    # <fs>                  <mountpoint>    <type>          <opts>                  <dump/pass>
    
    # NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
    /dev/sda1               /boot           ext2            noauto,noatime          1 2
    /dev/sda3               /               ext3            noatime                 0 1
    /dev/sda2               none            swap            sw                      0 0
    #/dev/cdroms/cdrom0     /mnt/cdrom      iso9660         noauto,ro               0 0
    #/dev/fd0               /mnt/floppy     auto            noauto                  0 0
    
    # NOTE: The next line is critical for boot!
    proc                    /proc           proc            defaults                0 0
    
    # glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
    # POSIX shared memory (shm_open, shm_unlink).
    # (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
    #  use almost no memory if not populated with files)
    shm                     /dev/shm        tmpfs           nodev,nosuid,noexec     0 0
    
    /dev/cdrom              /mtn/cdrom      auto            noauto,user             0 0
    
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Keruskerfürst, 01.04.2007
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    1. Ich würde mich nicht strikt an das Gentoohandbuch halten.
    2. Den Kernel von Hand konfigurieren.
     
  4. #3 Stollentroll, 01.04.2007
    Stollentroll

    Stollentroll Schattenparasit

    Dabei seit:
    11.03.2006
    Beiträge:
    67
    Zustimmungen:
    0
    Bist du dir sicher, dass Grub diesen Fehler wirft, honkey?
    Denn sonst würde ich sagen, rufe genkernel mal mit der Option menuconfig auf und baue Unterstützung für deinenn SATA - Controller ein.
     
  5. #4 Floh1111, 01.04.2007
    Zuletzt bearbeitet: 01.04.2007
    Floh1111

    Floh1111 Realist

    Dabei seit:
    06.06.2006
    Beiträge:
    701
    Zustimmungen:
    0
    Ort:
    Oldenburg (Niedersachsen)
    Hi Honkey,

    Versuche deine grub.conf mal folgerndermaßen abzuändern:

    Code:
    :/mnt/sda1 # cat grub/grub.conf
    default 0
    timeout 30
    splashimage=(hd0,0)/grub/splash.xpm.gz
    
    title=Gentoo Linux 2.6.19-r5
    root (hd0,0)
    
    //Statt /boot gibts du grub direkt deine Bootpartition mit (hd0,0) an.
    kernel [COLOR="Red"](hd0,0)[/COLOR]/kernel-genkernel-x86-2.6.19-gentoo-r5 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_boot=/dev/sda3 udev

    Hier müsstest du zweierlei versuchen:
    Entweder statt /boot wieder die direkte Partition angeben oder aber das /boot oder (hd0,0) ganz weglassen so wie es bei mir ist.

    Code:
    initrd [COLOR="Red"]/initramfs-genkernel-x86-2.6.19-gentoo-r5[/COLOR]
    //ODER
    [COLOR="Red"](hd0,0)[/COLOR]/initramfs-genkernel-x86-2.6.19-gentoo-r5
    Da du dein /boot Verteichnis warscheinlich in eine eigene Partition gepackt hast, ist es am einfachsten grub durekt zu sagen wo sie sich befindet indem man ihm direkt die Partition angibt.
    Meines Wissens kann man das ganze auch umgehen indem man dort irgendwo einen Simlink setzt. Darüber weiss ich aber nichts genaueres.
    So ist es jedenfalls bei mir.

    Ansonsten einfach mal ein wenig damit experimentieren.
    Bei der angabe des frubsplahimmages hast du z.B. "(hd0,0)/boot/..." geschrieben. könnte man auch mal probieren.

    MFG
    Floh1111
     
  6. honkey

    honkey Grünschnabel

    Dabei seit:
    01.04.2007
    Beiträge:
    5
    Zustimmungen:
    0
    Ich hab den Kernel nun selbst kompiliert und bekomme jetzt folgende Meldung (grub funzt jetzt!):

    **Please append a correct "root=" boot option***********
    **Kernel panic: VFS: Unable to mount root fs

    Ich hab sata_qstor, sata_uli, sata_sis, sata_sx4, sata_nv, sata_via, sata_svw, sata_sil24, sata_sil, und sata_promise in den kernel kompiliert. Das sind alle Module, di mit sata zu tun haben und die lsmod ab der livecd ausspuckt. Nicht gefunden im menuconfig hab ich allerdings: sata_vsc und libata. Ich hab die Suche benutzt; sata_vsc wird gefunden, doch sehe ich es nicht in der liste :-S, libata findet er nicht.

    Ich scheine ein Problem mit SATA zu haben, hoffentlich gibt's da ne Lösung.

    Vielen Dank für bisherige und weitere Antworten ;-)

    greez honkey
     
  7. #6 dermoench, 01.04.2007
    dermoench

    dermoench Jungspund

    Dabei seit:
    11.04.2006
    Beiträge:
    10
    Zustimmungen:
    0
    lesen ist ne kunst, was hasten als fs laufen, denn daran haengt er ja, haste wohl nicht in den kernel mit reingehauen.
    Gruß DerMoench
     
  8. #7 Floh1111, 01.04.2007
    Zuletzt bearbeitet: 01.04.2007
    Floh1111

    Floh1111 Realist

    Dabei seit:
    06.06.2006
    Beiträge:
    701
    Zustimmungen:
    0
    Ort:
    Oldenburg (Niedersachsen)
    Mhh.... hoffe du hast die grub.conf dann auch für entsprechend für einen selbstkompilierten kernel geändert so wie es in der Anleitung steht.

    //EDIT: Den support für die Dateisysteme mit denen deine Platten laufen musst du natürlich mit einkompilieren wie mein Vorposter schon sagte. In diesem Fall warscheinlich support für ext2 und ext3. ;)

    Für Kerneloptionen und ihre Beschreibung hat mir das hier sehr geholfen!
    Es sind jeweils die Empfohlenen Optionen schon so markiert wie du sie einkompilieren solltest.

    Auch ansonsten ist das Gentoo Wiki natürlich sehr interessant.

    MFG
    Floh1111
     
  9. #8 Bloodsurfer, 01.04.2007
    Bloodsurfer

    Bloodsurfer Gentoo-User

    Dabei seit:
    15.10.2005
    Beiträge:
    243
    Zustimmungen:
    0
    Versuch es vielleicht mal so:

    Code:
    default 0
    timeout 30
    splashimage=(hd0,0)/grub/splash.xpm.gz
    
    title=Gentoo Linux 2.6.19-r5
    kernel (hd0,0)/kernel-genkernel-x86-2.6.19-gentoo-r5 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sda3 udev
    initrd (hd0,0)/initramfs-genkernel-x86-2.6.19-gentoo-r5
    
    Du hattest da noch einen Tippfehler (real_boot statt real_root).
     
  10. #9 honkey, 01.04.2007
    Zuletzt bearbeitet: 01.04.2007
    honkey

    honkey Grünschnabel

    Dabei seit:
    01.04.2007
    Beiträge:
    5
    Zustimmungen:
    0
    Das filesys der boot partition ist ext2, das der linux partition ext3, beide in den kernel kompiliert.
    @ floh: klar hab ich das geändert.
    @ bloodsurfer: real_boot statt real_root, das könnte vielleicht der ganze trick sein! muss ich dann gleich ausprobieren.

    Vielen Dank vorerst
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Es geht immernoch nicht, das mit dem real_boot gilt nicht mehr, da ich durch den selbst kompilierten kernel ein anderes grub.conf habe.

    Alles was mit SATA oder filesystemen zu tun hat aus der /usr/src/linux/.config:
    Code:
    #
    # Serial ATA (prod) and Parallel ATA (experimental) drivers
    #
    CONFIG_ATA=y
    # CONFIG_SATA_AHCI is not set
    CONFIG_SATA_SVW=y
    # CONFIG_ATA_PIIX is not set
    # CONFIG_SATA_MV is not set
    CONFIG_SATA_NV=y
    # CONFIG_PDC_ADMA is not set
    CONFIG_SATA_QSTOR=y
    CONFIG_SATA_PROMISE=y
    CONFIG_SATA_SX4=y
    CONFIG_SATA_SIL=y
    CONFIG_SATA_SIL24=y
    CONFIG_SATA_SIS=y
    CONFIG_SATA_ULI=y
    CONFIG_SATA_VIA=y
    # CONFIG_SATA_VITESSE is not set
    
    #
    # File systems
    #
    CONFIG_EXT2_FS=y
    CONFIG_EXT2_FS_XATTR=y
    CONFIG_EXT2_FS_POSIX_ACL=y
    CONFIG_EXT2_FS_SECURITY=y
    # CONFIG_EXT2_FS_XIP is not set
    CONFIG_EXT3_FS=y
    CONFIG_EXT3_FS_XATTR=y
    CONFIG_EXT3_FS_POSIX_ACL=y
    CONFIG_EXT3_FS_SECURITY=y
    
    die grub.conf:
    Code:
    default 0
    timeout 30
    splashimage=(hd0,0)/boot/grub/splash.xpm.gz
    
    title=Gentoo Linux 2.6.19-r5
    root (hd0,0)
    kernel /boot/kernel-2.6.19-gentoo-r5 root=(hd0,2)
    
    title=Gentoo Linux 2.6.19-r5 (Rescue)
    root (hd0,0)
    kernel /boot/kernel-2.6.19-gentoo-r5 root=/dev/sda3 init=/bin/bb
    
    Das root=(hd0,2) war ein Experiment, es geht jedoch weder der untere noch der obere Eintrag. Es kommt eben wieder die alte

    **Please append a correct "root=" boot option***********
    **Kernel panic: VFS: Unable to mount root fs

    Meldung.

    Was tun :hilfe2: ;( ?
     
  11. #10 Stollentroll, 01.04.2007
    Stollentroll

    Stollentroll Schattenparasit

    Dabei seit:
    11.03.2006
    Beiträge:
    67
    Zustimmungen:
    0
    Die root= Option ändern.
    Im rescue Eintrag ist sie im richtigen Format.
     
  12. honkey

    honkey Grünschnabel

    Dabei seit:
    01.04.2007
    Beiträge:
    5
    Zustimmungen:
    0
    Es funktionieren weder rescue noch der erste Eintrag. Hab zuvor beim ersten Eintrag das selbe root= gehabt wie bei rescue, auch nicht funktioniert.
     
  13. #12 Stollentroll, 01.04.2007
    Stollentroll

    Stollentroll Schattenparasit

    Dabei seit:
    11.03.2006
    Beiträge:
    67
    Zustimmungen:
    0
    Hast du die SATA - Treiber als Module oder fest im Kernel?
    Ansonsten könntest du mal versuchen, mit lspci rauszukriegen, was für einen SATA - Controller du überhaupt hast.
     
  14. #13 GendoIkari, 01.04.2007
    Zuletzt bearbeitet: 01.04.2007
    GendoIkari

    GendoIkari Routinier

    Dabei seit:
    04.12.2006
    Beiträge:
    336
    Zustimmungen:
    0
    Ort:
    Dort wo die Sonne aufgeht...
    Das Problem hatte ich auch mal mit grub da musst du in /boot/grub/ nach der Datei mit map kucken da steht dann sowas ähnliches wie
    /dev/hda (hd0)
    /dev/hdb (hd1)

    das muss du umtauschen

    /dev/hda (hd1)
    /dev/hdb (hd0)

    hatte damals auf der ersten also hda ein anderes System und auaf der zeiten hdb gentoo ,den boot loader hatte ich auch auf hdb trotzdem ,er hat gebootet und dann kam der gleiche fehler ,dann hab ich das umgestellt.
    dann geht's ,war jedenfalls bei mir so oder nim doch gleich lilo da geht's sofort

    nicht abschrecken lassen gentoo ist ein super system ;)
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. honkey

    honkey Grünschnabel

    Dabei seit:
    01.04.2007
    Beiträge:
    5
    Zustimmungen:
    0
    Danke für deine antwort GendoIkari, doch ich habe nur eine harddisk drin; hd0 bzw sda. Aber das mit lilo scheint mir noch ein Versuch wert.
     
  17. #15 Clownish, 06.04.2007
    Zuletzt bearbeitet: 06.04.2007
    Clownish

    Clownish none

    Dabei seit:
    22.05.2006
    Beiträge:
    62
    Zustimmungen:
    0
    Wie Stollentroll schon sagte ... Die Ausgabe von lspci wäre sinnvoll.
    SATA-Controller ist nicht immer gleich SATA-Controller, zb meldet sich meiner als
    00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA Storage Controller IDE (rev 02),
    Im Kernel brauchte es aber zb auch CONFIG_PATA_MPIIX=y ;)...
     
Thema:

Gentoo bootet nicht

Die Seite wird geladen...

Gentoo bootet nicht - Ähnliche Themen

  1. Gnome ohne Systemd bei Gentoo und Funtoo

    Gnome ohne Systemd bei Gentoo und Funtoo: Das GitHub-Projekt »GNOME Without Systemd« will für Gentoo und dessen Derivat Funtoo die Möglichkeit bieten, die Desktopumgebung Gnome ohne...
  2. Google bringt WLAN-Router mit Gentoo Linux auf den Markt

    Google bringt WLAN-Router mit Gentoo Linux auf den Markt: Google stellt einen Router vor, der mit Gentoo Linux läuft und dem ac-Standard entspricht. Der »OnHub« genannte Router wurde zusammen mit dem...
  3. gentoo-filemanager neue Dateiendung mit bestimmter SW öffnen lassen

    gentoo-filemanager neue Dateiendung mit bestimmter SW öffnen lassen: Hallo Kennt sich hier jemand mit dem filemanger gentoo aus ? Ich hab ejetzt geschlagene 1Std versucht, ihn zu überreden eine *.odt zu...
  4. Kein SSH/Ping über WLAN mit gentoo

    Kein SSH/Ping über WLAN mit gentoo: Hallo zusammen, ich habe ein folgendes Problem mit meinem WLAN- stick (LevelOne WNC-0305USB USB wlan stick). Ich bekomme kein Ping bzw. ich...
  5. gentoo installation über sabayon durchführen?

    gentoo installation über sabayon durchführen?: Hi ich möchte gerne Gentoo auf meinem PC installieren und als boot cd wollte ich Sabayon_Linux_14.01_amd64_KDE benutzen (da ich gerne auf der...