Geforce 6600 - Richtiger Treiber aber keine 3d-Beschleunigung

Dieses Thema im Forum "Grafik / Video" wurde erstellt von Jehova1, 15.02.2009.

  1. #1 Jehova1, 15.02.2009
    Zuletzt bearbeitet: 15.02.2009
    Jehova1

    Jehova1 Routinier

    Dabei seit:
    22.08.2006
    Beiträge:
    333
    Zustimmungen:
    0
    Ort:
    Wo die wilden Kerle wohnen
    Hejho -
    hab neulich auf Ubuntu 8.10 upgegraded.
    Seitdem scheine ich einen neuen Grafiktreiber zu haben - der funktioniert auch meistens einwandfrei, außer wenn ich auf aufwändige 3d-prozesse zugreifen will.
    Meine Graka: Nvidia Geforce 6600 GT
    Compiz tut seinen Dienst einwandfrei aber bei allen wine-apps bekomme ich Fehlermeldungen wie

    Code:
    3D-Ausgabe kann nicht initialisiert weden. Überprüft bitte, ob Ihr DirectX 8 und einen aktualisierten Grafiktreiber installiert habt.
    ( Guild Wars, gestartet mit "aoss env WINEPREFIX="/home/..." wine "C:\Programme\Guildwars\Gw.exe")

    eine Andere 3d-Anwendung, die ich auf dem pc hab (world of padman) ruckelt schon im startmenü unzumutbar...

    warcraft 3 sagt "fatal error, ... , ACCESS_VIOLATION ...

    Und das alles, obwohl ich den vom System vorgeschlagenen Treiber verwende
    (nvidia accelerated graphics driver (version 177).
    Hab auch schon die anderen 2 ausprobiert (173 und 96) aber keiner haut richtig hin...
    wenn jemand ne ahnung hat, woran es liegen könnte wär ich über antworten danbar.
    jehova
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 gropiuskalle, 15.02.2009
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Hast Du mal die 180er-Version von der NVidia-Seite ausprobiert? Deine Karte wird vom aktuellen Treiber noch unterstützt.
     
  4. #3 Jehova1, 15.02.2009
    Jehova1

    Jehova1 Routinier

    Dabei seit:
    22.08.2006
    Beiträge:
    333
    Zustimmungen:
    0
    Ort:
    Wo die wilden Kerle wohnen
    Jo, habs schon probiert aber da hatte es mir dann die ganze xorg.conf so zerschossen, dass grafikmäßig nichmehr viel (winzige auflösung) ging - da hat dann auch "nvidia-xconfig" nix geändert und ich hab den 180er wieder runtergeschmissen...
     
  5. #4 gropiuskalle, 15.02.2009
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Tatsächlich hat sich ja mit der 8.10 einiges hinsichtlich Xorg bzw. der xorg.conf gändert → klick.
     
  6. @->-

    @->- Guest

    Den neuen Treiber kannst du in die Tonne werfen. Ich habe genau das selbe Problem, zwar nicht mit Ubuntu sondern Suse, Debian und Arch. Der Treiber ist anscheinend nicht ganz sauber. Grafische Oberfläche geht, aber richtige Hardwarebeschleunigung gibt es nicht...

    Bei Ubuntu nimm aus dem Repo den nvidia-glx-new der läuft

    In diesem Sinne
     
  7. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    das sehe ich nicht so ... zumindest seit dem 180.29 er

    eventuel ist es ja genau das, mehr zu lesen hier:

    http://news.softpedia.com/news/New-...r-Linux-Bring-OpenGL-3-0-Support-104336.shtml

    seit dem treiber habe ich zumindest keinerlei probleme mehr mit meiner onboard karte.

    ohne xorg.conf und xorg.log jedenfalls der beste tip den ich geben kann ;)
     
  8. #7 gropiuskalle, 16.02.2009
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    *zustimm*
     
  9. @->-

    @->- Guest

    Glück :) Nein bei mir läuft ab diesem Treiber nichts mehr. Unter keiner Distri habe ich ihn dazu gebracht das zu tun was er soll, nämlich Grafikbeschleuniger spielen :)

    Jetzt habe ich bei Debian Lenny den 173.x im Einsatz und es gibt keine Probleme...

    In diesem Sinne
     
  10. #9 Jehova1, 16.02.2009
    Jehova1

    Jehova1 Routinier

    Dabei seit:
    22.08.2006
    Beiträge:
    333
    Zustimmungen:
    0
    Ort:
    Wo die wilden Kerle wohnen
    Schonmal danke für die ganzen antworten, bisher bin ich aber nur wenig weiter:

    Der von @->- vorgeschlagene "nvidia-glx-new" ist bei mir zwar in den repos drin, (restricted/misc) aber nur 1byte groß und anscheinend irgendwie kaputt/nur scheinbar da - wenn ich ihn installieren will kommt
    Code:
    Paket nvidia-glx-new ist nicht verfügbar, wird aber von einem anderen
    Paket referenziert. Das kann heißen, dass das Paket fehlt, dass es veraltet
    ist oder nur aus einer anderen Quelle verfügbar ist.
    Doch die folgenden Pakete ersetzen es:
      nvidia-glx-96 nvidia-glx-180 nvidia-glx-177 nvidia-glx-173 nvidia-glx-71
    
    Und das mit dem 180er hört sich ja eigentlich ganz gut an, würde es vllt nochmal versuchen den zu installieren, wenn ich wüsste, wie ich dann ne passable xorg.conf bekommen könnte...

    gruß jehova
     
  11. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    viel mehr als mehr als das sollte nicht nötig sein :

    Code:
    Section "Device"
    	Identifier	"Configured Video Device"
    	Driver		"nvidia"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    EndSection
    und ansonsten gibs noch:

    Code:
    nvidia-xconfig --help
    und das freundlich forum um die ecke, das sich deine xorg.log/conf ansieht wenns schiefgeht.
     
  12. @->-

    @->- Guest

  13. #12 Jehova1, 16.02.2009
    Jehova1

    Jehova1 Routinier

    Dabei seit:
    22.08.2006
    Beiträge:
    333
    Zustimmungen:
    0
    Ort:
    Wo die wilden Kerle wohnen
    also 180er installiert und: beim start nachricht:
    ubuntu is running in low-graph-mode blabla
    (EE) Faliled to load module "glx" (module does not exist,0)
    (EE) Faliled to load module "type1" (module does not exist,0)
    (EE) Faliled to load module "nvidia" (module does not exist,0)
    (EE) No drivers available...

    Meine xorg.conf:

    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildd@palmer)  Thu Jun 26 06:22:40 UTC 2008
    
    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    # commented out by update-manager, HAL is now used
    #Section "InputDevice"
    #	Identifier	"Generic Keyboard"
    #	Driver		"kbd"
    #	Option		"CoreKeyboard"
    #	Option		"XkbRules"	"xorg"
    #	Option		"XkbModel"	"pc105"
    #	Option		"XkbLayout"	"de"
    #	Option		"XkbOptions"	"lv3:ralt_switch"
    #EndSection
    # commented out by update-manager, HAL is now used
    #Section "InputDevice"
    #	Identifier	"Configured Mouse"
    #	Driver		"mouse"
    #	Option		"CorePointer"
    #	Option		"Device"	"/dev/input/mice"
    #	Option		"Protocol"	"ExplorerPS/2"
    #	Option		"Buttons"	"9"
    #	Option		"ZAxisMapping"	"4 5"
    #	Option		"Emulate3Buttons"	"true"
    #	Option		"Name"	"Razer Razer 1600dpi Mouse"
    #EndSection
    # commented out by update-manager, HAL is now used
    #Section "InputDevice"
    #	
    #	# /dev/input/event
    #	# for USB
    #	Identifier	"stylus"
    #	Driver		"wacom"
    #	Option		"Device"	"/dev/wacom"# Change to 
    #	Option		"Type"	"stylus"
    #	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    #EndSection
    # commented out by update-manager, HAL is now used
    #Section "InputDevice"
    #	
    #	# /dev/input/event
    #	# for USB
    #	Identifier	"eraser"
    #	Driver		"wacom"
    #	Option		"Device"	"/dev/wacom"# Change to 
    #	Option		"Type"	"eraser"
    #	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    #EndSection
    # commented out by update-manager, HAL is now used
    #Section "InputDevice"
    #	
    #	# /dev/input/event
    #	# for USB
    #	Identifier	"cursor"
    #	Driver		"wacom"
    #	Option		"Device"	"/dev/wacom"# Change to 
    #	Option		"Type"	"cursor"
    #	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    #EndSection
    
    Section "ServerLayout"
        Identifier     "Default Layout"
        Screen         "Default Screen" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
        FontPath        "/usr/share/X11/fonts/misc"
        FontPath        "/usr/share/X11/fonts/cyrillic"
        FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/Type1"
        FontPath        "/usr/share/X11/fonts/100dpi"
        FontPath        "/usr/share/X11/fonts/75dpi"
        FontPath        "/usr/share/fonts/X11/misc"
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection
    
    Section "Module"
        Load           "bitmap"
        Load           "ddc"
        Load           "extmod"
        Load           "freetype"
        Load           "glx"
        Load           "int10"
        Load           "type1"
        Load           "vbe"
    EndSection
    
    Section "InputDevice"
        Identifier     "Keyboard0"
        Driver         "keyboard"
    EndSection
    
    Section "InputDevice"
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "Monitor"
        Identifier     "Generic Monitor"
        HorizSync       30.0 - 65.0
        VertRefresh     50.0 - 75.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "NVIDIA GeForce 6600"
        Driver         "nvidia"
    EndSection
    
    Section "Screen"
        Identifier     "Default Screen"
        Device         "NVIDIA GeForce 6600"
        Monitor        "Generic Monitor"
        DefaultDepth    24
        Option         "TripleBuffer" "true"# meins
        Option         "AddARGBGLXVisuals" "true"# meins
        Option         "NoLogo" "True"
        SubSection     "Display"
            Depth       1
            Modes      "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       4
            Modes      "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       8
            Modes      "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       15
            Modes      "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       16
            Modes      "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       24
            Modes      "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
    EndSection
    
    danke schonmal für die hilfe :D
     
  14. #13 doc, 16.02.2009
    Zuletzt bearbeitet: 16.02.2009
    doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    joa da is der treiber wohl nicht richtig installiert ... hätte nicht gedacht das das unter ubnt so kompliziert ist ... haste den link von @->- gelesen ?

    ABER:

    Option "TripleBuffer" "true"# meins
    Option "AddARGBGLXVisuals" "true"# meins
    Option "NoLogo" "True"

    das sind optionen für deine graka die sollteste auch in die section device packen,
    hätteste du gleich deine xorg.conf gepostet, hätteste dir viel arbeit erspart ;)

    Code:
    Section "Device"
        Identifier     "NVIDIA GeForce 6600"
        Driver         "nvidia"
        Option         "TripleBuffer" "true"# meins
        Option         "AddARGBGLXVisuals" "true"# meins
        Option         "NoLogo" "True"
    EndSection
    also nimm einfach wieder deinen alten treiber und fix deine conf, dann denke ich läuft das.

    evtl noch nützliche optionen:

    Option "RenderAccel""true"
    Option "AllowGLXWithComposite""true"
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 gropiuskalle, 16.02.2009
    Zuletzt bearbeitet: 16.02.2009
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Sowie den hier noch:

    Code:
    Option         "DamageEvents" "True"
    Mit dem von doc erwähnten nvidia-xconfig sollte man nach einer (wie auch immer gearteten Treiber-Installation) so verfahren:

    Code:
    nvidia-xconfig --composite
    nvidia-xconfig --allow-glx-with-composite
    nvidia-xconfig --render-accel
    nvidia-xconfig --add-argb-glx-visuals -d 24
    nvidia-xconfig --damage-events
    Händisches Rumkritzeln in der xorg.conf ist, wie man hier im thread sieht, ja nicht immer die beste Lösung.

    Ich möchte zudem aber nochmal auf den von mir verlinkten Beitrag im ubuntuusers-Wiki aufmerksam machen:

     
  17. #15 Jehova1, 16.02.2009
    Jehova1

    Jehova1 Routinier

    Dabei seit:
    22.08.2006
    Beiträge:
    333
    Zustimmungen:
    0
    Ort:
    Wo die wilden Kerle wohnen
    Also... ich hab jetz erst die paar einträge von "section monitor" nach "sect device" verschoben und wie vorgeschlagen geändert, hat aber leider nichts bewirkt.
    Dann schließlich noch die zeile von kalle aus der wiki angehängt, aber außer dem keyboardlayout blieb auch da alles beim alten....
    hat einer noch ne idee?
    gruß jehova
     
Thema:

Geforce 6600 - Richtiger Treiber aber keine 3d-Beschleunigung

Die Seite wird geladen...

Geforce 6600 - Richtiger Treiber aber keine 3d-Beschleunigung - Ähnliche Themen

  1. Hilfe + NVidia GeForce 6600 GT und die Treiber

    Hilfe + NVidia GeForce 6600 GT und die Treiber: NAbend, langsam verzweifle ich...X( X( X( X( X( Also ich hab irgendwann mal den fehler gemacht und einen Grafikkartentreiber auf init ?...
  2. Linux Suse und Geforce 6600 ?? HILFE !!

    Linux Suse und Geforce 6600 ?? HILFE !!: hey bin ein Linux-Neuling !! und versuche seit 2 Tahen vergebens Linux auf meinem Computer zu installieren ! Also ich habe folgendes Problem :...
  3. vesafb und Geforce 6600

    vesafb und Geforce 6600: Hallo, wie bringe ich den vesa framebuffer für xvgatextmode unter Linux mit dieser Grafikkarte zum laufen? Urspünglich habe ich es so probiert:...
  4. Mandriva installation + GeForce 6600

    Mandriva installation + GeForce 6600: Servus! Mandriva unterstützt die Grafikkarte bei der installation nicht X( . Auf der Webpage von nivida kann man jedoch ein entsprechenden...
  5. MSI NVIDIA GeForce 8400GS Problemlos unter Linux?

    MSI NVIDIA GeForce 8400GS Problemlos unter Linux?: Hi, hat jemand Erfahrung mit (MSI) NVIDIA GeForce 8400GS GraKas? laufen die Out-Of-The-Box? oder steht da erst noch Treiberbastelei an? Danke !