Fusesmb

Dieses Thema im Forum "Samba" wurde erstellt von manni81, 27.06.2007.

  1. #1 manni81, 27.06.2007
    manni81

    manni81 Grünschnabel

    Dabei seit:
    27.06.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Hallo,

    bei der Konfiguration/Nutzung von FUSESMB habe ich einige Probleme:
    ich habe in meinem home Verzeichnis ein Verzeichnis "network" erstellt und dann mit "sudo fusesmb network -o allow_other" versucht das Netzwerk in das Verzeichnis network zu legen.
    Daraufhin bekam ich die erste Fehlermeldung:
    Could not find the required file fusesmb.cache.
    This file should either be in:
    -
    - $PATH
    - your current working directory
    (No such file or directory)
    fusesmb.cache liegt in /usr/bin/ und sollte daher eigentlich gefunden werden. Zu Testzwecken habe ich fusesmb.cache in mein aktuelles Arbeitsverzeichnis gelegt und damit kam ich dann ein Stückchen weiter.
    Beim Erneuten aufrufen von "sudo fusesmb network -o allow_other" meckerte das System, dass FUSE nicht in /etc/modules stehen würde. Beim Nachschauen stellte ich fest, dass /etc/modules gar nicht existiert. Mit "sudo modprobe fuse" lies sich das Problem dann allerdings auch (zumindest temporär lösen).
    Nun lies sich ein "sudo fusesmb network -o allow_other " eingeben ohne, dass eine erneute Fehlermeldung erschien, allerdings bleibt das Verzeichnis network trotzdem leer. ;(
    Da das alles so nichts brachte wollte ich das Netzwerk wieder unmounten. Also "sudo fusermount network" eingeben. Dabei erhielt ich die Fehlermeldung:
    fusermount: old style mounting not supported

    Und an dem Punkt bin ich jetzt. Ich benutze OpenSuSE 10.2 (also cifs anstelle von smbfs) .
    Unter Xubuntu hatte ich auch das Problem, dass das network Verzeichnis immer leer blieb. Was mache ich falsch?
    Unter Xubuntu hielt ich mich daher einfach an das Alternativprogramm smbnetfs und alles lief bestens, aber bei SuSE ist smbnetfs standardmäßig nicht mit drin und eigentlich muss es mit FUSE ja auch funktionieren.

    Weiß jemand Rat?

    Manni
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 manni81, 28.06.2007
    manni81

    manni81 Grünschnabel

    Dabei seit:
    27.06.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Ich habs wie folgt gelöst:
    1.) FUSE Kernelmodul standardmäßig laden lassen. Dazu Yast->System->etc/sysconfig Editor -> System -> Kernel editieren
    2.) Fusesmb funktioniert bei mir einfach nicht. Es funktionierte auch schon unter Ubuntu nicht und ich werde es jetzt einfach dran geben. Stattdessen:
    3.) smbnetfs installieren. Das gibts zwar nicht als rpm, aber configure make make install funktioniert schnell und unkompliziert.
    Anschließend nur smbnetfs <Zielverzeichnis> eingeben und wunschlos glücklich sein ;)
     
Thema:

Fusesmb

Die Seite wird geladen...

Fusesmb - Ähnliche Themen

  1. fusesmb - Netzwerkumgebung verschwindet irgendwann

    fusesmb - Netzwerkumgebung verschwindet irgendwann: Hallo, ich nutze fusesmb und bin auch mit der Funktion sehr zufrieden. Nur habe ich das Problem, das der Ordner, den ich als Mountpunkte benutze,...