fstab komisch und mounten geht nicht

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Gebath, 02.08.2006.

  1. Gebath

    Gebath Guest

    also ich habe heute Suse10.1 aus dem GameStar Sonderheft installiert und ich muss sagen es lief runder als bei jeder anderen Distri bis jetzt (bei der 10.0 kam ich noch nichtmal bis zum Bootprompt...) und hier habe ich sofort KDE am laufen was ich bis jetzt noch nie hatte :D

    so bin noch ziemlich unerfahren in der linux welt aber meine fstab verwirrt mich da ich eigentlihc wollte dass sie so ist dass ich folgendes habe:
    sda1 ntfs mit WindowsXP PRo und ~24 GB
    sda2 wird irgendwie immer ausgelassen :think:
    sda3 ext3 mit SuSe und 8,5 GB
    sda4 vfat 1GB zum Datenaustausch...
    sda5 ntfs 2. Winpartition für die Daten also ohne OS
    und eine swap partition war da auch noch bei der installation... (die sehe ich aber nicht am Arbeitsplatz aber ok)

    nun sieht meine fstab aber so aus:

    /dev/sda3 / ext3 acl,user_xattr 1 1
    /dev/sda6 swap swap defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0


    und da scheitere ich ganz gewaltig. ich will dass alle meine Partitionen beim start gemountet sind und die ext und die vfat mit schreibrechten auch für meinen normalen user, würde außerdem gerne alles mounten können :D ich weiß dass das ziemlich viel ist aber ich blick einfach nicht durch und da das doch etwas ist was stimmen sollte trau ich mich noch nicht wirklich drüber also bitte helft mir :hilfe2:
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Keruskerfürst, 02.08.2006
    Zuletzt bearbeitet: 02.08.2006
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Vorhandene fstab:
    /dev/sda3 / ext3 acl,user_xattr 1 1
    /dev/sda6 swap swap defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0

    Neue fstab:
    /dev/sda3 / ext3 noatime 1 1
    /dev/sda6 swap swap defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    /dev/sda1 /(Mountpunkt anlegen) ntfs ro, auto, users
    /dev/sda4 /(mountpunkt anlegen) vfat rw, auto, users
    /dev/sda5 /(Mountpunkt anlegen) ntfs ro, auto, users
    /dev/sda2 ??? <- Welches Filesystem wird verwendet?

    Mit dieser Fstab werden sda1, sda4 und sda5 automatisch gemountet.
    Swappartition ist in der fstab vorhanden und wird auch automatisch gemountet, man kann darauf allerdings (als normaler Anwender) nicht zugreifen.
     
  4. #3 Gebath, 02.08.2006
    Zuletzt von einem Moderator bearbeitet: 02.08.2006
    Gebath

    Gebath Guest

    danke für die schnelle antwort!
    das ist ja das komische dass ich keine partition mehr habe die sda2 sein könnte aber es wird immer ausgelassen bei jeder distri bis jetzt (ubuntu, knoppix, mandriva) und jetzt auch bei SuSe warum auch immer ist aber nicht weiter schlimm!

    wie muss ich die neuen mountpunkte jetzt erstellen? bis jetzt war meine einzige änderung in der fstab immer ein "users" :brav: bitte genauer erklären! ansonsten DANKE!!! echt große hilfe da gleich ne fertige fstab gepostet zu bekommen!

    Edit: anderes Thema:
    mir wird angezeigt dass 191softwareupdates verfügbar sind aber ich kann sie nicht downloaden weil ich einfahc nicht weiterkomme auch nach einer halben stunde steht da getting updated list... und es tut sich nix noch nicht ein Eintrag hab ich was verpasst einzustellen? (hab SuSe wie gesagt noch nie verwendet und Linux nur selten)
     
  5. #4 Keruskerfürst, 02.08.2006
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Die Mountpunkte muß man im Dateisystbaum anlegen, damit dann der Inhalt der Partition sichtbar wird und darauf zugegriffen werden kann.

    In diesem Fall:
    1. über die Konsole: mkdir /mnt/wina
    mkdir /mnt/winb
    mkdir /nmt/winc
    2. Mit dem Konqueror: einfach unter /mnt gleichnamige Ordner erstellen.

    3. Thema Softwareupdates: keine Ahnung, ich benutze Suse nicht mehr.
    Ein Umstieg auf eine andere Distribution wäre schon sinnvoll.
     
  6. Gebath

    Gebath Guest

    danke wunderbar ich habs geschafft kann sie jetzt mounten (geht zumindest mal händisch ich geh jetzt abendessen und morgen wird man dann beim starten sehen ob er es auch automatisch schafft ;) danke nochmals für deine Hilfe! das mit den Updates krieg ich schon noch hin mal n bissl probieren... (muss ich die vllt. als root machen :think: hatte bis jetzt ja noch nichtmal nen i-net zugang in linux zustande gebracht :D )
     
Thema:

fstab komisch und mounten geht nicht

Die Seite wird geladen...

fstab komisch und mounten geht nicht - Ähnliche Themen

  1. smbshare mounten per fstab, komisches verhalten

    smbshare mounten per fstab, komisches verhalten: Tach zusammen. Hier mein Problem: Ich will nen SMBshare per fstab mounten. Man sollte denken, dass dies eigentlich nicht so schwer ist. Also...
  2. fstab: Netzlaufwerk beim Booten einbinden verursacht Fehler

    fstab: Netzlaufwerk beim Booten einbinden verursacht Fehler: Ich benutze davfs2, um ein WebDAV-Verzeichnis einzubinden. Wenn ich folgenden Eintrag in meine fstab schreibe, kann ich das Verzeichnis wunderbar...
  3. fstab-Einstellungen für ext4

    fstab-Einstellungen für ext4: Hallo ich bin jetzt durch die Inet-recherche in Bezug auf fstab + ext4-Einstellungen etwas verwirrt. ich möchte auf einem System...
  4. Mounten ohne sudo/root/fstab

    Mounten ohne sudo/root/fstab: Hallo, vl übersehe ich nur was ganz offensichtliches oder so ... Nunja gibt es eine Möglichkeit einem normalen Nutzer das mounten von (meist...
  5. fstab oder mount problem

    fstab oder mount problem: fstab oder mount problem[geloest] Moin Moin, ein komisches Problem hat sich beim aufspielen eines Backup's aufgetan. Man schau sich es doch...