Frage! zu zurückgehaltene Pakete

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Emess, 26.01.2008.

  1. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Was genau hat es eigentlich immer mit den zurückgehaltenen Paketen beim Update auf sich?
    Code:
    Abhängigkeitsbaum wird aufgebaut
    Reading state information... Fertig
    Die folgenden Pakete sind zurückgehalten worden:
      cpp-4.2 dirmngr g++-4.2 gcc-4.2 gcc-4.2-base gcc-4.2-multilib gnupg lib64gcc1 lib64gomp1
      lib64stdc++6 libcurl3-gnutls libffi4 libgcc1 libgomp1 libmudflap0 libnfsidmap2 libsdl1.2debian
      libsdl1.2debian-alsa libstdc++6 libstdc++6-4.2-dev libxine1 libxine1-console libxine1-ffmpeg
      libxine1-misc-plugins libxine1-x mplayer
    Die folgenden Pakete werden aktualisiert:
      cron gpgv gtk2-engines-pixbuf icedove-dispmua installation-report libcairo2 libcairo2-dev
      libgstreamer0.10-0 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgtk2.0-dev libnautilus-extension1
      libpisock9 libxine1-doc libxml-libxml-common-perl manpages-de manpages-de-dev mencoder
      module-assistant sudo
    21 aktualisiert, 0 neu installiert, 0 zu entfernen und 26 nicht aktualisiert.
    Es müssen 21,4MB Archive geholt werden.
    Nach dem Auspacken werden 100kB Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren [J/n]?        
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Goodspeed, 26.01.2008
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Beim upgrade werden Pakete nur aktualisiert wenn deren neue Abhängigkeiten kein Löschen von anderen Paketen vorraussetzt.
    D.h. irgendeins der Pakete will wohl, dass möglicherweise eine alte lib weggeschmissen wird.

    Wenn Du statt upgrade dist-upgrade verwendest, wird auch versucht derartige "Konflikte" aufzulösen ...
    Aber man sollte da halt genau hinschauen, was gemacht wird ...
     
  4. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Solange ich keinen Eintrag unstable oder sid in der Source.list habe, wird ja wohl nicht auf sid geupdatet (was für ein hässliches Wort). Sehe ich das richtig?
     
  5. #4 Tomekk228, 26.01.2008
    Tomekk228

    Tomekk228 Lebende Foren Legende

    Dabei seit:
    14.08.2007
    Beiträge:
    2.417
    Zustimmungen:
    0
    Ort:
    /home/tomekk/
    Jup.

    Also: Wenn du "normal" updatest, dann updatet er alle Pakete, deren Abhängigkeiten nicht verlangen das man ältere Abhängigkeiten löscht.

    dist-upgrade hingegen updatet das ganze system incl Abhängigkeiten und deren Abhängigkeiten. Und bringt den komplett auf dem selben stand wie der von dir gewählten Repo.
     
  6. #5 GambaJo, 26.01.2008
    GambaJo

    GambaJo Maxi King alraaaight!!!

    Dabei seit:
    08.01.2008
    Beiträge:
    171
    Zustimmungen:
    0
    dist-upgrade hat bei mir wunderbar funktioniert. Zur Sicherheit mit -s aufrufen um zuerst zu simulieren.
     
  7. #6 Tomekk228, 26.01.2008
    Tomekk228

    Tomekk228 Lebende Foren Legende

    Dabei seit:
    14.08.2007
    Beiträge:
    2.417
    Zustimmungen:
    0
    Ort:
    /home/tomekk/
    Wikipedia, man pages und doku geben mehr infos :)

    @gambajo: Dein Titel "warum liegt da Stroh?" handelt, bzw deutet nicht zufällig zu den einem Video an, wo 2 personen im keller sind wegen dem Stromkasten? xD
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Hat auch bei mir funktioniert.
     
  10. #8 GambaJo, 26.01.2008
    GambaJo

    GambaJo Maxi King alraaaight!!!

    Dabei seit:
    08.01.2008
    Beiträge:
    171
    Zustimmungen:
    0
    @Tomekk228:
    Mir fiel gerde nichts interessantes ein, also habe ich etwas selten Blödes genommen. Ich verbuche das unter künstlerische Freiheit :D
     
Thema:

Frage! zu zurückgehaltene Pakete

Die Seite wird geladen...

Frage! zu zurückgehaltene Pakete - Ähnliche Themen

  1. Anfänger Frage: Welchen Standard wählen

    Anfänger Frage: Welchen Standard wählen: Hallo, früher wußte ich nie wie ich anfangen muß. Heute weiß ich einfach anfangen und mir alles selbst beibringen. Was ich mich aber noch...
  2. Sicherheitsfragen zu PHP-Anwendungen auf der Webseite

    Sicherheitsfragen zu PHP-Anwendungen auf der Webseite: Hallo miteinander, habe eine kleine Webseite (4 Jahre statisch, keine Sicherheitsprobleme bisher) und ich frage mich, wie sicher die Verwendung...
  3. Fragen zu find

    Fragen zu find: Hallo an alle, Ich bin ziemlich neu in der Linux Welt und habe paar frage Ich soll alle Datein im system finden die vor weniger als drei Tagen...
  4. Frage zu QNX - habe login nie gefunden

    Frage zu QNX - habe login nie gefunden: ′
  5. Kleine Frage (Solaris ein Cloud Betriebsystem?)

    Kleine Frage (Solaris ein Cloud Betriebsystem?): ′