Fieses Soundknacken beim Runterfahren

Dieses Thema im Forum "Gentoo" wurde erstellt von karloff, 12.03.2010.

  1. #1 karloff, 12.03.2010
    karloff

    karloff Routinier

    Dabei seit:
    09.07.2007
    Beiträge:
    317
    Zustimmungen:
    0
    Ort:
    ~/
    Moin,

    wollte mal nach Rat fragen,

    hab folgendes Problem: beim runterfahren kurz vor power off
    kommt nen sehr fieses knacken aus dem minisub.

    Hat jemand ne Idee wie man das Problem beheben kann, bin da ziemlich ratlos?

    Habs unter Fedora 12 mal angeschaut und da besteht das Prob. nicht.

    soundkarte
    Code:
    00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
    	Subsystem: Hewlett-Packard Company Device 365c
    	Flags: bus master, fast devsel, latency 0, IRQ 22
    	Memory at db100000 (64-bit, non-prefetchable) [size=16K]
    	Capabilities: [50] Power Management version 2
    	Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
    	Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
    	Capabilities: [100] Virtual Channel <?>
    	Capabilities: [130] Root Complex Link <?>
    	Kernel driver in use: HDA Intel
    	Kernel modules: snd-hda-intel
    
    
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. @->-

    @->- Guest

    Das liegt an einem "billigen" Soundchip. Beim herunterfahren wird die Soundkarte abgeschaltet und das verursacht bei billigen Chips das genannte Geräusch. Tritt auch gerne beim Bootvorgang auf. Schau mal bei Ubuntuusers.de dort wurde das Problem mal in einem Artikel behandelt. EInen Link habe ich leider nicht.

    In diesem Sinne
     
  4. #3 bitmuncher, 12.03.2010
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Es muss nicht zwingend am Soundchip liegen, sondern kann seine Ursache auch an unsauberen Steckverbindungen z.B. beim Boxenstecker haben. Wenn das Problem aber nur bei Gentoo auftritt, solltest du mal schauen, inwiefern sich der Treiber zu den Treibern von Fedora unterscheidet (gleiche Version, evtl. irgendwelche Patches bei Fedora dabei, ggf. Bootparameter für den Soundtreiber gesetzt etc.). Gerade beim hda-intel-Treiber hilft es zumeist, wenn man dem Kernel schon beim Laden des Moduls sagt, welches Model verbaut ist ('options snd-hda-intel model=...' in der modprobe-Konfiguration). Das vermeidet unnötige Probleme.
     
  5. #4 marcellus, 13.03.2010
    marcellus

    marcellus Kaiser

    Dabei seit:
    09.05.2007
    Beiträge:
    1.392
    Zustimmungen:
    0
    Was ist, wenn du
    Code:
    rc-config stop alsasound
    vorm herunterfahren?

    bzw, wenn du vorm herunterfahren alle kanäle mutest?
     
  6. #5 karloff, 16.03.2010
    Zuletzt bearbeitet: 16.03.2010
    karloff

    karloff Routinier

    Dabei seit:
    09.07.2007
    Beiträge:
    317
    Zustimmungen:
    0
    Ort:
    ~/
    Danke schon mal für die Tipps hoffe ich komme heute dazu das mal auszuprobieren dem kernel die Parameter mitzugeben.

    Also Alsa hat nix damit zu tun, hab den shutdown mal von hand gemacht, das syntom tritt immer nur in dem Moment auf in dem das system ausgeschaltet wird, fast so als würde das von ner restspannung verursacht, was das ganze nicht unbedingt einfacher macht.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    So wie's aussieht hab ichs gefixt bekommen.

    Allem Anschein nach liegt es an der suspend funktion der soundkarte.

    folgendes muss in die /etc/modprobe.d/alsa.conf
    Code:
    options snd-hda-intel model=hp-m4
    options snd_hda_intel power_save=1
    
     
Thema:

Fieses Soundknacken beim Runterfahren