Fetchmail Googlemail ssl Zertifikat

Dieses Thema im Forum "Anwendungen" wurde erstellt von Mitzekotze, 16.08.2007.

  1. #1 Mitzekotze, 16.08.2007
    Zuletzt bearbeitet: 16.08.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Servus zusammen,

    Beim Ausführen von Fetchmail, kommt bei meinem Googlemail Account immer die Meldungen:
    Code:
    fetchmail: Fehler bei Server-Zertifikat-Überprüfung: unable to get local issuer certificate
    fetchmail: Fehler bei Server-Zertifikat-Überprüfung: certificate not trusted
    fetchmail: Fehler bei Server-Zertifikat-Überprüfung: unable to verify the first certificate
    
    Durch ein wenig googlen bin ich auf diese Mailing Liste gestoßen *klick*, bei der empfohlen wurde sich das ssl Zertifikat von dem entsprechenden Server zu holen.

    Dies geschieht über den Befehl:
    Code:
    openssl s_client -showcerts -connect <serveradresse>:995
    Da sich das Problem auf der Mailing Liste aber auf einen anderen Server bezog, weiß ich nun nicht woher ich das Zertifikat für Googlemail herbekomme.

    Kennt jemand diese Server Adresse oder weiß einer noch einen anderen Rat, um dieses "kosmetische" Problem zu lösen?
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Keiner eine Idee?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 saeckereier, 16.08.2007
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Äh, wie holst du denn deine Mails ab wenn du nicht mal den Servernamen kennst??
     
  4. #3 nequiquam, 16.08.2007
    nequiquam

    nequiquam Tripel-As

    Dabei seit:
    11.01.2007
    Beiträge:
    169
    Zustimmungen:
    0
    Hi,

    auf dieser Seite habe ich unter Punkt 5.1 Google Gmail Certificates dies gefunden:
    Vielleicht hilft Dir das ja weiter.

    Liebe Grüße, Neq
     
  5. #4 Mitzekotze, 17.08.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Thx nequiquam das war der Server, ist ja eigentlich logisch *andenkopffass*.

    Nun besteht das Problem aber noch immer noch. Ich bin nach dem von nequiquam gefundenen Tutorial vorgegangen und habe die zwei Zertifikate welche im Tut genannt werden erstellt und in dem versteckten Ordner .certs abgespeichert. Fetchmail scheint diese Zertifikate aber nicht zu finden, obwohl ich folgende Optionen an die Daten meines Gmail Accounts in der .fetchmailrc angehängt habe:
    Code:
     ssl sslcertpath '/home/mitzekotze/.certs
    Weiß jemand Rat oder mach ich was vollkommen falsch?
     
  6. #5 nequiquam, 17.08.2007
    nequiquam

    nequiquam Tripel-As

    Dabei seit:
    11.01.2007
    Beiträge:
    169
    Zustimmungen:
    0
    Hi,

    denke ich habe es jetzt. Die Anleitung ist ja schon ein wenig älter, deswegen haben sich auch die Server geändert.

    Also erstmal mit
    Code:
    openssl s_client -connect pop.googlemail.com:995 -showcerts
    
    das Zertifikat von GoogleMail besorgen. Dabei wird auch folgendes angezeigt:
    also kommt das Zertifikat vom Thawte Premium Server. Und dieses Zertifikat finden wir auch in der, in deroben verlinkten, Anleitung aufgeführten cert.pem.
    (nach "Thawte Premium Server CA" suchen) Daraus dann das Zertifikat rausschneiden. Ich habe die Zertifikate auch in einem Ordner namens .certs innerhalb meines Homeverzeichnisses gespeichert. Da sind jetzt also die Dateien googlepop.pem und thawte.pem drin. Dann noch
    Code:
    andy@ubuntu:~$ c_rehash .certs
    ausführen und dann müsste es klappen. Mit diesen Einstellungen hatte es bei mir mit fetchmail geklappt, kann aber gut sein, das die ein oder andere Option überflüssig ist:
    Code:
    poll pop.googlemail.com with proto POP3 and options
    	user 'abc@googlemail.com' with pass 'def' is 'hugo' here options 
    sslproto SSL3
    ssl 
    sslcertpath /home/hugo/.certs
     sslcertck fetchall keep
    sslfingerprint "D3:B3:42:74:E5:1C:6F:30:6B:06:E4:CE:1C:8F:D6:45"
    
    Liebe Grüße, Neq
     
  7. #6 Mitzekotze, 17.08.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Tausend Dank Nequiquam jetzt funktioniert es ohne Probleme. Vielen Dank für die detaillierte Problemlösung.

    Ich habe bloß noch ein Problem mit meinem GMX Account :) . Und zwar
    Code:
    2 Nachrichten (1 gesehene) für mitzekotze@gmx.net bei pop.gmx.net (273625 Bytes).
    Nachricht ******@gmx.net@pop.gmx.net:1 wird ausgelassen nicht gelöscht
    fetchmail: Verbindung zu localhost:smtp [127.0.0.1/25] fehlgeschlagen: Verbindungsaufbau abgelehnt.
    fetchmail: SMTP-Verbindung zu localhost fehlgeschlagen
    fetchmail: SMTP-Transaktion-Fehler beim Abholen von 
    ********@gmx.net@pop.gmx.net und Auslieferung zum SMTP-Host localhost
    Nachricht *******@gmx.net@pop.gmx.net:2 von 2 wird gelesen (120257 Bytes)fetchmail: Abfragestatus=10 (SMTP)
    
    erscheint diese Fehlermeldung beim Aufruf von Fetchmail.

    Im meinem .cert Verzeichnis habe ich die Ausgabe von
    Code:
    openssl s_client -connect pop.gmx.net:995 -showcerts
    als die Datei gmxpop.pem hineinkopiert und auch in der .fetchmailrc Datei habe ich den selben Zertifikatenpfad wie bei Gmail angegeben.

    Weiß jemand woran es liegt?

    EDIT: Aber es scheint eher nicht am Zertifikat zu liegen oder?
     
  8. #7 nequiquam, 17.08.2007
    nequiquam

    nequiquam Tripel-As

    Dabei seit:
    11.01.2007
    Beiträge:
    169
    Zustimmungen:
    0
    Hi,

    hast Du auch nochmal
    Code:
    c_rehash .certs
    
    ausgeführt? Ist zwingend notwendig, sonst erkennt er die Zertifikate nicht. So eine Fehlermeldung hatte ich heute auch schon mal, weiß aber nicht mehr, was ich da falsch konfiguriert hatte. (habe kein SMTP konfiguriert) Habe die Einstellungen von Google übernommen und angepasst. Dann läuft es auch ohne Fehlermeldung bei mir durch.

    Liebe Grüße, Neq
     
  9. #8 Mitzekotze, 19.08.2007
    Zuletzt bearbeitet: 19.08.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Des Rätsels Lösung war dieser fehlende Eintrag von in der .fetchmailrc:
    Code:
    poll pop.googlemail.com with proto POP3 and options
    	user 'abc@googlemail.com' with pass 'def' is 'hugo' here options 
    [B]sslproto SSL3[/B]
    ssl 
    sslcertpath /home/hugo/.certs
     sslcertck fetchall keep
    sslfingerprint "D3:B3:42:74:E5:1C:6F:30:6B:06:E4:CE:1C:8F:D6:45"
    Vielen Dank Nequiquam, jetzt läuft fast alles so wie es soll. Das einzigste Problem was ich jetzt noch habe, ist das fetchmail die Nachrichten von meinem GMX Account nicht vom GMX Server löscht. Woran könnte das liegen?
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 nequiquam, 19.08.2007
    nequiquam

    nequiquam Tripel-As

    Dabei seit:
    11.01.2007
    Beiträge:
    169
    Zustimmungen:
    0
    Hi,

    nimm mal die Option keep raus. Dann lässt er die Mails nicht mehr auf dem Server. Hier sind auch nochmal die ganzen Parameter aufgeführt.

    Liebe Grüße, Neq
     
  12. #10 Mitzekotze, 02.09.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Die Option keep war gar nicht gesetzt. An den Einstellungen meines GMX Accounts kann es auch nicht liegen, da ich mit Thunderbird meine E-mails ohne Probleme abholen kann.

    Hat jemand eine Idee?
     
Thema:

Fetchmail Googlemail ssl Zertifikat

Die Seite wird geladen...

Fetchmail Googlemail ssl Zertifikat - Ähnliche Themen

  1. Domainproblem bei POP3-Abholung mit fetchmail

    Domainproblem bei POP3-Abholung mit fetchmail: Hallo Leute! Ich hab einen Webserver unter der Domain A . Hinter dieser Domain ist ein MX-Eintrag zu Webserver B. Die eMail-Adresse endet...
  2. Fetchmail - Account an zwei Email-Adressen weiterleiten

    Fetchmail - Account an zwei Email-Adressen weiterleiten: Hi, momentan sieht meine Konfiguration so aus: poll "pop.gmx.de" with proto pop3 user "meine@gmx.de" password "xxx" is "meine2@gmx.net"...
  3. fetchmail/procmail/postfix - berechtigungsproblem

    fetchmail/procmail/postfix - berechtigungsproblem: Hi, das berechtigungsproblem äußert sich dadurch, das die abgeholten mails im maildir immer root.mail gehören und nicht dem eigentlichen...
  4. Cygwin, fetchmail und W2K8-Server funzt nicht

    Cygwin, fetchmail und W2K8-Server funzt nicht: Hallo zusammen, ich bekomme fetchmail unter W2K8 nicht zum laufen. Wenn ich fetchmail von der Kommandozeile starte funktioniert es...
  5. debian lenny: fetchmail

    debian lenny: fetchmail: Hi, ich habe hier ein komisches phänomen benutze ich fetchmail als benutzer (über cron) funktioniert alles .. benutze ich es als daemon...