Festplatte und Standby

Dieses Thema im Forum "Linux OS" wurde erstellt von Lord_x, 23.12.2007.

  1. #1 Lord_x, 23.12.2007
    Zuletzt von einem Moderator bearbeitet: 27.12.2007
    Lord_x

    Lord_x Guest

    [gelöst] Festplatte und Standby

    Hallo zusammen :)

    Ich habe ein Problem mit meiner Festplatte und zwar wird sie im Akku Betrieb nach wenigen Sekunden ausgeschaltet. Immer wenn ich dann z.B. mit
    Firefox eine neue Seite öffne, schaltet sich die Festplatte wieder an um sich kurz darauf gleich wieder schlafen zu legen.
    Habe ich das Netzteil angeschlossen, passiert das nicht. Die HD schaltet sich hier nicht in den Standby Modus.

    Jetzt meine Frage: Kann ich das abschaltet oder besser gesagt, wie kann ich prüfen, warum meine HD wieder aufgeweckt wird?

    Eine andere Idee habe ich auch noch. Irgendwas muss auf der HD sein, weshalb sie wieder aufgeweckt wird. Könnte man das auf einen USB Stick auslagern?
    (/var oder /tmp ? )

    Hat mir jemand einen Tipp?
    Danke
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Athur Dent, 23.12.2007
    Athur Dent

    Athur Dent Handtuchhalter

    Dabei seit:
    08.12.2006
    Beiträge:
    662
    Zustimmungen:
    0
    Ort:
    Hannover
    So ganz verstehe ich Deinen Text nicht, deswegen kann das recht unnütz sein, was ich Dir hier schreibe.
    Aber über "Kpowersave" kann man die Energiesparfunktionen konfigurieren (KDE).

    Ahm - welches OS?
     
  4. #3 Bâshgob, 23.12.2007
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    Du solltest im BIOS fündig werden. Festplattenstandby macht unter LInux mit der Systemplatte normalerweise ohnehin keinen Sinn, wie du selbst schon bemerkt hast wird die Platte regelmäßig wieder erweckt, spätestens alle 20 Minuten wenn der syslogd einen Mark ins Syslog malt.
     
  5. #4 Lord_x, 23.12.2007
    Zuletzt von einem Moderator bearbeitet: 23.12.2007
    Lord_x

    Lord_x Guest

    Also OS ist Ubuntu 7.10 und es ist so, dass wenn der NB im Akku- Betrieb läuft meine Festplatte sich abschaltet. Wenn ich ein Netzteil angeschlossen habe, passiert das nicht.
    Wenn sich die Festplatte abgeschaltet hat, und ich klicke z.B. einen Link an, der eine neue Seite im Firefox öffnet, erwacht die Festplatte wieder...

    Ich möchte das abschalten oder eben auf einen USB Stick auslagern. Muss ja ein Zugriff sein, auf die HD. Was auch immer das ist, könnte man evtl. auf den USB Stick auslagern,
    damit meine HD nicht immer aufgeweckt wird...

    Lord_x
     
  6. #5 Bâshgob, 23.12.2007
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    Dann lager doch /var/log und /tmp entweder auf den Stick oder in den RAM aus.

    Google sollte für die Konfiguration unendlich viele Lösungen parat haben.
     
  7. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    habe zwar nich viel erfahrung mit laptops, aber soweit ich weiß, wird beim wechsel in den batterie modus ein anderer runlevel gestartet. Und da wird dann z.B festgelegt das deine platte in den standby modus wechselt.

    hdparm -S 0 /dev/DEINEPLADDE würde das ausschalten
    hdparm -S 120 /dev/DEINEPLADDE würde die pladde nach 10 minuten runterfahren

    aber ich habe keine ahnung von ubuntu, und ob das da nich vieleicht anders gelöst ist, ich kenne nur diese methode, und weiss von keiner anderen
     
  8. Lord_x

    Lord_x Guest

    Ich weiss aber nicht ob das alles ist bzw. man das so machen kann...
    Werde es mal versuchen...
     
  9. Yomm

    Yomm Foren As

    Dabei seit:
    12.08.2007
    Beiträge:
    79
    Zustimmungen:
    0
    Nun noch eine dumme Bermerkung von einem Unerfahrenen. Es scheint mir aber doch so, daß Du mal ins BIOS Deines Rechner gucken solltest. So wie Du es beschreibst, hat das offensichtlich nichts mit Linux sondern mit Deinem Rechner zu tun. Wenn Du Deinen Rechner startest, sehe mal genau hin, was Du zu drücken hast um ins Bios zu kommen. Sehe damal mal nach. Meistens steht "HIT DEL!" dann drücke beim starten Deines Rechners mal die Delte oder Entfernen -Taste. Mag sein Du findest dort etwas.
    Viel Erfolg
    Yomm
     
  10. #9 Lord_x, 27.12.2007
    Zuletzt von einem Moderator bearbeitet: 27.12.2007
    Lord_x

    Lord_x Guest

    Ich konnte es leider noch nicht versuchen aber es hat ganz sicher was mit GNU/Linux zu tun.
    Wie ich oben schon geschrieben habe, tritt dieses Verhalten nur auf, wenn ich den NB ohne Netzteil laufen habe. Das im Akkubetrieb ein andere Runlevel gestartet wird, könnte ich mir vorstellen. Ich muss das anschauen, um es genau sagen zu können. Ich melde mich sicher nochmal...
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Vielen Dank ich konnte das Problem mit hdparm lösen :)
     
  11. #10 Jabo, 27.12.2007
    Zuletzt bearbeitet: 27.12.2007
    Jabo

    Jabo Aufgabe ohne Minister

    Dabei seit:
    12.10.2006
    Beiträge:
    1.322
    Zustimmungen:
    0
    Ort:
    Hamburg
    Hm, trotzdem noch mal.... meint ihr wirklich, daß der Vorgang einen neuen Runlevel auslöst? Das bedeutet für mich "init n" wobei "n" die Nummer des Runlevels ist.

    Ist es nicht doch eher so, daß das Laptop "sieht", ob es Ladestrom hat und über ACPI diese Info weiter leitet? Und dann setzt das System den entsprechenden Befehl ab? Kann man das evtl. in einem Log beobachten? Ich hab gar kein Laptop, wenn ich bei mir den Stecker ziehe, geht der Rechner aus, das lasse ich mal bleiben.

    Aber es gibt ja bei Laptops noch mehr Schalter, die Powersave-Events auslösen können, oft z.B. "Deckel schließen" -> Hybernate und einschlafen. Ich hab zu wenig Hintergrundwissen zu ACPI-Events, aber an einen Wechsel des Runlevels dachte ich dabei noch nie...

    [Edit]
    So ähnlich hatte ich mir das gedacht...
     
  12. #11 Bâshgob, 28.12.2007
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    Das hat ganz sicher weder mit irgendeinem Runlevel noch mit Linux was zu tun. In 99,9% aller Fälle ist das eine BIOSEinstellung. Aber stocher du mal weiter im Nebel und ärgere dich über deine Festplatte, du bist dir einfach zu sicher um doch zumindest vielleicht einfach mal nachzusehen (das kostet auch nichts!).
     
  13. Lord_x

    Lord_x Guest

    Hast du mein letztes posting gelesen? :headup:
    Ich habe auf dem NB noch Debian und Windows inst. und da passiert das nicht.
    Mit "hdparm" konnte ich das Problem lösen...

    @Jabo
    Da ich denke du hast recht mit dem was du meinst.
     
  14. #13 Bâshgob, 28.12.2007
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    Ja, ich habe dein letztes Posting gelesen; Und ich bin davon überzeugt, das du mittels hdparm einfach nur vom BIOS übergebene Parameter überstimmst.

    Ich habe ein IBM T23, das hat solcherlei Einstellungen im BIOS, und ebendiese kann ich via Userlandtools überstimmen.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. Lord_x

    Lord_x Guest

    Kannst du mir die genaue Bezeichnung im BIOS verraten? :)
     
  17. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    nein nicht zwingend, wäre aber eine lösung

    ja, es gibt dann einen acpi event, sollte in /var/log/acpid stehen, woraufhin dann eine "action" gestartet wird z.B. ein neuer runlevel oder ein script, das diverse befehle ausführt unter anderem evntl. auch "hdparm -SXX /dev/hdX"

    wo und wie genau weiss ich aber nich ich tippe mal in /etc/acpi...
     
Thema:

Festplatte und Standby

Die Seite wird geladen...

Festplatte und Standby - Ähnliche Themen

  1. festplatte im standby beim herunterfahren beachten

    festplatte im standby beim herunterfahren beachten: hi! folgendes: ich versetze häufiger mal meine zwei zusätzlichen festplatten in den standbymodus, wenn ich weiß, dass lange zeit nicht darauf...
  2. Festplatte auf SD Karte umziehen

    Festplatte auf SD Karte umziehen: Hi zusammen, ich habe einen alten Laptop zum Server umfunktioniert. habe bei der Installation von CentOS bzw. der Partitionierung die...
  3. Western Digital widmet dem Raspberry Pi eine eigene Festplatte

    Western Digital widmet dem Raspberry Pi eine eigene Festplatte: Der Festplattenhersteller Western Digital (WD) gibt die Verfügbarkeit einer 314 GByte großen Festplatte für den Raspberry Pi bekannt. Weiterlesen...
  4. Festplatte wird nicht erkannt

    Festplatte wird nicht erkannt: Hallo, ich habe auf meinem HTPC (Mainboard IOM330-ITX von Zotac) XBMCbuntu installiert, das ist ein Lubuntu mit XBMC als HTPC-Oberfläche. Das...
  5. Indiegogo-Kampagne für Ubuntu-Tablet mit großer Festplatte

    Indiegogo-Kampagne für Ubuntu-Tablet mit großer Festplatte: Das UbuTab getaufte Gerät, für das seit einer Woche eine Finanzierungskampagne auf der Crowdfundingplattform Indiegogo läuft, soll eine 1 TB...