Fehler beim Starten des Samba Servers

Dieses Thema: "Fehler beim Starten des Samba Servers" im Forum "Samba" wurde erstellt von Linux88, 24.10.2005.

  1. #1 Linux88, 24.10.2005
    Linux88

    Linux88 Jungspund

    Dabei seit:
    23.10.2005
    Beiträge:
    20
    Zustimmungen:
    0
    Hallo,
    unter Suse kann oder will mir keiner antworten
    Ich habe unter Suse 9.2 die Fehlermeldung
    "Fehler beim Starten des Samba Servers (/etc/init.d/smb start && /etc/init.d/nmb start) fehlgeschlagen"
    wenn ich vom Webmin aus versuche Samba zu starten.
    Kann da einer helfen?
     
  2. Anzeige

    schau mal hier --> (hier klicken). Viele Antworten inkl. passender Shell-Befehle!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 damager, 24.10.2005
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    was passiert wenn du als root das (/etc/init.d/smb start) aus den console probierst?
    fehlermeldungen?
    /var/log/messages?
    wie sieht deine /etc/samba/smb.conf aus?
     
  4. #3 Linux88, 24.10.2005
    Linux88

    Linux88 Jungspund

    Dabei seit:
    23.10.2005
    Beiträge:
    20
    Zustimmungen:
    0
    Samba Startet nicht

    Hallo damager,
    danke für die schnelle Antwort.


    was passiert wenn du als root das (/etc/init.d/smb start) aus den console probierst?

    Dann kommt diese Fehlermeldung

    Starting Samba SMB daemon startproc: exit status of parent of /usr/sbin/smbd: 255
    failed

    /var/log/messages?

    sieht so aus (ich hoffe es der richtige teil)
    Oct 24 17:12:45 sonne nmbd[7377]: [2005/10/24 17:12:45, 0] nmbd/nmbd_logonnames.c:add_logon_names(163)
    Oct 24 17:12:45 sonne nmbd[7377]: add_domain_logon_names:
    Oct 24 17:12:45 sonne nmbd[7377]: Attempting to become logon server for workgroup OFFICE on subnet 192.168.123.131
    Oct 24 17:12:45 sonne nmbd[7377]: [2005/10/24 17:12:45, 0] nmbd/nmbd_become_dmb.c:become_domain_master_browser_bcast(282)
    Oct 24 17:12:45 sonne nmbd[7377]: become_domain_master_browser_bcast:
    Oct 24 17:12:45 sonne nmbd[7377]: Attempting to become domain master browser on workgroup OFFICE on subnet 192.168.123.131
    Oct 24 17:12:45 sonne nmbd[7377]: [2005/10/24 17:12:45, 0] nmbd/nmbd_become_dmb.c:become_domain_master_browser_bcast(295)
    Oct 24 17:12:45 sonne nmbd[7377]: become_domain_master_browser_bcast: querying subnet 192.168.123.131 for domain master browser on workgroup OFFICE
    Oct 24 17:12:45 sonne smbd[7399]: [2005/10/24 17:12:45, 0] passdb/pdb_interface.c:make_pdb_context_list(776)
    Oct 24 17:12:45 sonne smbd[7399]: ERROR: empty passdb backend list!
    Oct 24 17:12:49 sonne net: [2005/10/24 17:12:49, 0] passdb/pdb_interface.c:make_pdb_context_list(776)
    Oct 24 17:12:49 sonne net: ERROR: empty passdb backend list!
    Oct 24 17:12:49 sonne nmbd[7377]: [2005/10/24 17:12:49, 0] nmbd/nmbd_logonnames.c:become_logon_server_success(124)
    Oct 24 17:12:49 sonne nmbd[7377]: become_logon_server_success: Samba is now a logon server for workgroup OFFICE on subnet 192.168.123.131
    Oct 24 17:12:53 sonne nmbd[7377]: [2005/10/24 17:12:53, 0] nmbd/nmbd_become_dmb.c:become_domain_master_stage2(113)
    Oct 24 17:12:53 sonne nmbd[7377]: *****
    Oct 24 17:12:53 sonne nmbd[7377]:
    Oct 24 17:12:53 sonne nmbd[7377]: Samba server SONNE is now a domain master browser for workgroup OFFICE on subnet 192.168.123.131
    Oct 24 17:12:53 sonne nmbd[7377]:
    Oct 24 17:12:53 sonne nmbd[7377]: *****
    Oct 24 17:13:08 sonne nmbd[7377]: [2005/10/24 17:13:08, 0] nmbd/nmbd_become_lmb.c:become_local_master_stage2(396)
    Oct 24 17:13:08 sonne nmbd[7377]: *****
    Oct 24 17:13:08 sonne nmbd[7377]:
    Oct 24 17:13:08 sonne nmbd[7377]: Samba name server SONNE is now a local master browser for workgroup OFFICE on subnet 192.168.123.131
    Oct 24 17:13:08 sonne nmbd[7377]:
    Oct 24 17:13:08 sonne nmbd[7377]: *****
    Oct 24 17:14:14 sonne webmin[7414]: Successful login as root from 192.168.123.155
    Oct 24 17:14:36 sonne sshd[7454]: Accepted keyboard-interactive/pam for root from ::ffff:192.168.123.155 port 3125 ssh2
    Oct 24 17:17:03 sonne smbd[7515]: [2005/10/24 17:17:03, 0] passdb/pdb_interface.c:make_pdb_context_list(776)
    Oct 24 17:17:03 sonne smbd[7515]: ERROR: empty passdb backend list!
    Oct 24 17:31:27 sonne master[7652]: about to exec /usr/lib/cyrus/bin/ctl_cyrusdb
    Oct 24 17:31:27 sonne ctl_cyrusdb[7652]: checkpointing cyrus databases
    Oct 24 17:31:27 sonne ctl_cyrusdb[7652]: archiving database file: /var/lib/imap/annotations.db
    Oct 24 17:31:27 sonne ctl_cyrusdb[7652]: archiving log file: /var/lib/imap/db/log.0000000001
    Oct 24 17:31:27 sonne ctl_cyrusdb[7652]: archiving database file: /var/lib/imap/mailboxes.db
    Oct 24 17:31:27 sonne ctl_cyrusdb[7652]: archiving log file: /var/lib/imap/db/log.0000000001
    Oct 24 17:31:27 sonne ctl_cyrusdb[7652]: done checkpointing cyrus databases
    Oct 24 17:31:27 sonne master[5230]: process 7652 exited, status 0

    wie sieht deine /etc/samba/smb.conf aus?

    Damit es nicht zu lang wird habe ersteinmal nur die Global parameters
    aufgelistet.

    Samba config file created using SWAT
    # from 0.0.0.0 (0.0.0.0)
    # Date: 2005/10/24 17:41:25

    # Global parameters
    [global]
    workgroup = OFFICE
    server string = Samba Server
    interfaces = 192.168.123.131/255.255.255.0
    bind interfaces only = Yes
    map to guest = Bad User
    passdb backend =
    username map = /etc/samba/smbusers
    printcap cache time = 750
    add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
    logon path = \\%L\profiles\.msprofile
    logon drive = P:
    logon home = \\%L\%U\.9xprofile
    domain logons = Yes
    os level = 65
    ldap idmap suffix = ou=Idmap
    ldap machine suffix = ou=Computers
    ldap suffix = dc=example,dc=com
    ldap ssl = no
    printer admin = @ntadmin, root, administrator
    cups options = raw


    Ich hoffe das Du damit was anfagen kannst Vilen Dank schon einmal.
     
  5. #4 damager, 24.10.2005
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    hast du überhaupt irgedwelche samba-user?
    hast du eine /etc/samba/smbpasswd?
    wenn nicht dann probiere man smbpasswd -a username /etc/samba/smbpasswd aus und dann erneut einen start.
    es gab ne samba-version die abgesürzt ist bei eine leeren oder nicht vorhandenen smbpasswd.
    zitat samba-bug-db:
    Don't segfault on empty passdb backend list (bug #136).

    hoffe das hilft weiter....
     
  6. #5 Linux88, 25.10.2005
    Linux88

    Linux88 Jungspund

    Dabei seit:
    23.10.2005
    Beiträge:
    20
    Zustimmungen:
    0
    Samba Startet nicht

    Ersteinmal Danke für die Antwort.

    Samba User sind eingerichtet. Zur Info der Server lief schon über 2 Jahre ohne Probleme. Ich habe einfach "nur" die IPs von 192.168.99.11 auf 192.168.123.131 verändert. Dabei habe ich wohl was "zerschossen"

    hast du eine /etc/samba/smbpasswd?
    wenn nicht dann probiere man smbpasswd -a username /etc/samba/smbpasswd aus und dann erneut einen start.


    werde ich heute Abend testen und dann berichten.
     
  7. #6 Linux88, 25.10.2005
    Linux88

    Linux88 Jungspund

    Dabei seit:
    23.10.2005
    Beiträge:
    20
    Zustimmungen:
    0
    Samba Startet nicht

    hast du eine /etc/samba/smbpasswd?

    Ja smbpasswd gibt es als Datei. Es sind auch alle Benutzer aufgeführt und dahinter sehr "Kryptische" Werte. Root hat 0, die Benutzer sind von 500 bis 506 aufgeführt.
    Wenn ich unter Yast Samba konfiguriere, läßt sich alles einstellen und verändern. Nur beim Beenden mit Abspeichern, kommt die Abfrage "Für den Benutzer root ist noch kein Passwort angelegt". Dann kann man dort auch ein Passwort anlegen und bestätigen, aber mit der Fehlermeldung "Benutzer Root hat keine Recht ein Passwort anzulegen"!!! werden die Änderungen nicht angenommen. Der Balken geht noch auf 60% und als Abschluss kommt "Samba kann nicht starten"

    Ich werde jetzt einmal versuchen die smbpasswd umzubenen und dann Deinen Befehl auzuführen. Mal sehen was dann passiert.
     
  8. #7 Linux88, 25.10.2005
    Linux88

    Linux88 Jungspund

    Dabei seit:
    23.10.2005
    Beiträge:
    20
    Zustimmungen:
    0
    Samba startet nicht

    Ich werde jetzt einmal versuchen die smbpasswd umzubenen und dann Deinen Befehl auzuführen. Mal sehen was dann passiert.

    Beim restart vom smb kommt leider wieder nur die Fehlermeldung
    > /etc/init.d/smb start
    Starting Samba SMB daemon ..failed


    Die /var/log/messages? sieht wieder so aus

    Oct 25 23:11:25 sonne nmbd[8673]: *****
    Oct 25 23:11:25 sonne nmbd[8673]:
    Oct 25 23:11:25 sonne nmbd[8673]: Samba server SONNE is now a domain master browser for workgroup OFFICE on subnet 192.168.123.131
    Oct 25 23:11:25 sonne nmbd[8673]:
    Oct 25 23:11:25 sonne nmbd[8673]: *****
    Oct 25 23:11:40 sonne nmbd[8673]: [2005/10/25 23:11:40, 0] nmbd/nmbd_become_lmb.c:become_local_master_stage2(396)
    Oct 25 23:11:40 sonne nmbd[8673]: *****
    Oct 25 23:11:40 sonne nmbd[8673]:
    Oct 25 23:11:40 sonne nmbd[8673]: Samba name server SONNE is now a local master browser for workgroup OFFICE on subnet 192.168.123.131
    Oct 25 23:11:40 sonne nmbd[8673]:
    Oct 25 23:11:40 sonne nmbd[8673]: *****
    Oct 25 23:11:51 sonne smbd[8744]: [2005/10/25 23:11:51, 0] passdb/pdb_interface.c:make_pdb_context_list(776)
    Oct 25 23:11:51 sonne smbd[8744]: ERROR: empty passdb backend list!
    Oct 25 23:12:17 sonne net: [2005/10/25 23:12:17, 0] passdb/pdb_interface.c:make_pdb_context_list(776)
    Oct 25 23:12:17 sonne net: ERROR: empty passdb backend list!
    Oct 25 23:15:00 sonne smbd[8829]: [2005/10/25 23:15:00, 0] passdb/pdb_interface.c:make_pdb_context_list(776)
    Oct 25 23:15:00 sonne smbd[8829]: ERROR: empty passdb backend list!
    Oct 25 23:15:00 sonne startproc: startproc: exit status of parent of /usr/sbin/smbd: 255


    Das Windows Netzwerk wird jetzt auch so blockiert, das auf die Arbeitsgruppe nicht mehr zugreifen kann.
    Gibt es da noch Hoffnug?
     
  9. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Und wenn wir mal einen Blick auf die Zeile "passdb backend = " werfen... Was steht da? Nix! Und was sagt die Fehlermeldung? Empty passdb backend list! Muss ich dazu noch mehr sagen?

    .oO( nimm die Zeile raus oder korrigiere sie, aber ich vermute mal, dass dort das Problem liegt)
     
  10. #9 damager, 26.10.2005
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    klingt logisch was theton sagt...
    komisch ist nur, der server dürfte nie galaufen sein so wie er konfiguriert ist.

    also einfach mal auskommentieren oder benutzt du ldap oder so als user-backend?
     
  11. #10 Linux88, 26.10.2005
    Linux88

    Linux88 Jungspund

    Dabei seit:
    23.10.2005
    Beiträge:
    20
    Zustimmungen:
    0
    Samba startet nicht

    Hallo theton,

    vielen dank für die Anwort,

    sorry, aber ich bin ein echter Windoofer Linux-Neuling. Und das obwohl bei uns schon seit 6 Jahren Linuxserver laufen. Und da Sie nach der Einrichtung immer Problemlos liefen mußte ich ja auch bisher nichts wissen. Das ist der nachteil vom stabilen Linux. Aber das soll nun anders werden .

    Und wenn wir mal einen Blick auf die Zeile "passdb backend = " werfen... Was steht da? Nix! Und was sagt die Fehlermeldung? Empty passdb backend list! Muss ich dazu noch mehr sagen?

    rauslöschen ist sicher kein Problem (werde ich heute Abend teste)

    Wenn ich die Benutzer neu anlege mit Passwort werd die Zeile dann wieder neu angelegt?

    Was heißt oder ist .oO


    Hallo damager,

    auch nochmal danke, der sever lief wirklich 2 Jahre Problemlos, bis ich ran ging! mit 5 Clients mit 6 Platten (4 davon mit einem Hadware Raid 5).

    Was ist oder heißt ldap oder so als user-backend

    Wenn Ihr mal Probleme mit PDF Erstellung für den professionellen Offsetdruck habt, werden ich mich revanchieren.

    Ich hoffe heute abend läuft er wieder der Samba.
     
  12. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    LDAP steht fuer Leightweigth Directory Access Protocol und wird oft benutzt um Passwoerter in Netzwerken zentral zu verwalten.

    .oO(blabla) steht fuer eine Gedankenblase. :)
     
  13. #12 damager, 26.10.2005
    Zuletzt bearbeitet: 26.10.2005
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    Linux88:
    du musst die zeile nicht löschen. einfach eine - # - am anfang der zeile reicht aus. damit ist die zeile auskommentiert und wird bei parsen der konfig "überlesen" :]
    ldap hat dir ja theton schon erklärt.

    das problem bekommen wir schon irgendwie gefixt :-)
    sind evtl irgendwelche updates auf diesem server erfolgt?
     
  14. #13 Linux88, 26.10.2005
    Linux88

    Linux88 Jungspund

    Dabei seit:
    23.10.2005
    Beiträge:
    20
    Zustimmungen:
    0
    Samba startet wieder!!

    Hallo und Guten Abend damager und theton,

    Samba läuft wieder vielen Dank.
    Nach dem rausnehmen der Zeile "passdb backend = " lief Samba sofort.
    Der Server ist mit allen Laufwerken auf den Win2000 Rechnern wieder da.
    Nur kann sich leider kein Benutzer anmelden! (Ich suche noch und hoffe auf hilfe):think:
    Den Fehler habe ich, wenn auch unbemerkt, durch YAST (die "Text" Version) aus gelöst. Der Fehler läßt sich sogar reproduzieren!
    So wie ich in meiner aller ersten Anfrage Vorgehe

    Wenn ich unter Yast Samba konfiguriere, läßt sich alles einstellen und verändern. Nur beim Beenden mit Abspeichern, kommt die Abfrage "Für den Benutzer root ist noch kein Passwort angelegt". Dann kann man dort auch ein Passwort anlegen und bestätigen, aber mit der Fehlermeldung "Benutzer Root hat keine Recht ein Passwort anzulegen"!!! werden die Änderungen nicht angenommen. Der Balken geht noch auf 60% und als Abschluss kommt "Samba kann nicht starten"
    -Yast (die Textversion) wird dabei über Putty vom Windoof Rechner ausbedient

    Jetzt wird doch tatsächlich in die /etc/samba/smb.conf die Zeile "passdb backend = " geschrieben. Setzte ich ein # davor ist wieder alles OK. Führe ich den oben beschriebenen Vorgang unter YAST wieder aus wird das # automatisch entfernt!!

    sind evtl irgendwelche updates auf diesem server erfolgt? Nein

    So nun suche ich wo ich die Benutzer wieder Aktiviern kann.
    Hilft da das LDAP ?
     
  15. #14 Linux88, 26.10.2005
    Linux88

    Linux88 Jungspund

    Dabei seit:
    23.10.2005
    Beiträge:
    20
    Zustimmungen:
    0
    Samba ja aber kein Benutzer

    /etc/samba/smbpasswd ist jetzt leer, müßen da nicht die Benutzer und die Passwörter rein?
    In Webmin kann ich zwar Samba Benutzer und Passwörter bearbeiten bearbeiten (ist aber auch leer) nicht aber neue (und dann die alten) wieder anlegen?
     
  16. #15 Linux88, 26.10.2005
    Linux88

    Linux88 Jungspund

    Dabei seit:
    23.10.2005
    Beiträge:
    20
    Zustimmungen:
    0
    Bingo jetzt gehts

    Ja da soll einer mal daraufkommen???
    In Webmin unter Samba Freigabeverwaltung erst mit
    Unix Benutzer zu Samba Benutzern konvertieren die Benutzer Anlegen und dann mit Samba Benutzer und Passwörter bearbeiten die Passwörter bearbeiten!

    Jetzt habe ich nur noch ein Problem. Bei Booten kommt die Fehlemeldung INET Faild und Fehler auf RUNLEVEl 3 XINETD

    Das muß mit den Netzwerk Karten zu tunen haben. Nach dem Boot läst sich der Server noch nicht mal Anpingen. Gehe ich dann mit YAST auf Netzwerkkarten und dann auf die angeschlossene und wieder zurück, kommte antwort auf Ping und Jetzt (einfach toll) ist dann ja auch der Server durch Samba wieder sichtbar. Ich habe sicher auch dort (Netzwerkkarten) "rumgefuscht, auf der suche nach dem Samba Fehler. (Asche auf mein Haupt).
    Eingebaut im Rechner sind eine 3COM 100 (Wird benutzt) und eine ? Karte on Board 100/1000 wird nicht benutzt. Nun sind unter YAST aber auch eth0 bis eth3, wobei die eth1 scheinbar auch was mit der Aktiven karte etwas zutuen hat aber wie und was hier einzustellen ist, geht über mein kleines Windoof verständnis.
     
Thema:

Fehler beim Starten des Samba Servers

Die Seite wird geladen...

Fehler beim Starten des Samba Servers - Ähnliche Themen

  1. Ubuntu fehler beim instalieren

    Ubuntu fehler beim instalieren: Hallo Ich wollte auf meinem Pc Ubuntu neben Windows instalieren da ich hörte ist besser geignet für steam games. Ich habe mir deshalb auf einem...
  2. fstab: Netzlaufwerk beim Booten einbinden verursacht Fehler

    fstab: Netzlaufwerk beim Booten einbinden verursacht Fehler: Ich benutze davfs2, um ein WebDAV-Verzeichnis einzubinden. Wenn ich folgenden Eintrag in meine fstab schreibe, kann ich das Verzeichnis wunderbar...
  3. KSH: Problem beim Umleiten des Fehlerkanals

    KSH: Problem beim Umleiten des Fehlerkanals: Hallo, in einen KSH Skript führe ich folgende Befehle aus RESULT=""; ERROR=""; idsldapsearch -h localhost -p $PORT -D $USER -w $PW -s sub -b...
  4. Fehlermeldung beim SSH-Login / Server nicht mehr erreichbar

    Fehlermeldung beim SSH-Login / Server nicht mehr erreichbar: Hallo, nach einem Neustart ist mein Lenny (Root-Server bei Hetzner) leider nicht mehr so richtig aufgewacht. Die Symptome: - Websites sind...
  5. VirtualBox Fehler beim Installieren

    VirtualBox Fehler beim Installieren: Hallo zusammen Ich habe mir das Fedora 15 aufegspielt und wollte mir heute mal die Virtualbox installieren. Lerider bekomme ich immer ein Fehler...