fedora core 1 & radeon 9600XT

Dieses Thema: "fedora core 1 & radeon 9600XT" im Forum "Grafik / Video" wurde erstellt von baytor, 05.01.2004.

  1. baytor

    baytor Grünschnabel

    Dabei seit:
    05.01.2004
    Beiträge:
    2
    Zustimmungen:
    0
    hi..

    ich habe da ein problem mit fedora core 1 und meiner neu erstadenen Sapphire Radeon 9600XT und zwar: sie läuft nicht ordentlich unter fedora..
    ich habe mir den ati treiber für linux gezogen und ohne probleme installiert..
    schon bei der installation war ich bei den "advanced graphics" fragen langsam verwirrt..
    aber das habe ich noch richtig hinbekommen denke ich..
    das problem ist jetzt nur, dass weder der 2d noch der 3d support läuft.. wenn ich in dem graphischen control panel von ati nachschaue heißt es dort auch das wäre eine pci karte und desweiteren gibt er unter opengl irgendwas von wegen unbekannt an (kann es nicht genau hinschreiben, bin leider gezwungen momentan windows zu benutzen)..
    habe auch lsmod probiert aber da schreibt er mir immer dass er den befehl nicht finden kann.. also kurzgesagt wird der treiber installiert, konfiguriert läuft jedoch nicht richtig, da die karte nicht als agp karte läuft und da die opengl beschleunigung nicht läuft.. kann es irgendwie mit fedora oder der tatsache, dass ich vorher eine geforce 2mx drin hatte zusammenhängen? wenn ihr mehr infos benötigt um etwas dazu zu schreiben dann sagt mir wie ich die bekomme und ich poste es..
    wenn es irgendwie mit fedora zusammenhängt und ich es gar nicht beheben kann.. wie funktioniert die karte mit suse oder mandrake? wollte mandrake eh ma ausprobieren und letztes suse, welches ich hatte war 7.3...
    danke schonmal im voraus
     
  2. Anzeige

    Schau dir mal diesen Ratgeber an. Viele Antworten inkl. passender Shell-Befehle!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Zero

    Zero Keyboard-Ninja

    Dabei seit:
    12.11.2003
    Beiträge:
    598
    Zustimmungen:
    0
    Ort:
    echo $HOME
    hier steht, was du beim wechsle von einer nvidia zur ati karte
    beachten musst.
    http://www.g4l.de/cms/faq/showfaq.php?id=14

    auf www.gmpf.de gibts noch ein gutes ATI Howto,
    damit habe ich ne ATI Readon 9700 Pro einwandfrei zum laufen
    bekommen. Wenn du nach dem HowTo gehst, kann eigentlich nichts schief gehen.

    btw:
    mach bei deinem nächsten Post, bitte paar Absätze
    liest sich nämlich so echt unübersichtlich ;)
     
  4. #3 redlabour, 06.01.2004
    redlabour

    redlabour -

    Dabei seit:
    23.05.2003
    Beiträge:
    4.353
    Zustimmungen:
    0
    Ort:
    Wuppertal, NRW
  5. baytor

    baytor Grünschnabel

    Dabei seit:
    05.01.2004
    Beiträge:
    2
    Zustimmungen:
    0
    will immer noch nicht

    dankef für die schnelle Antwort!!
    aber ich komme immernoch nicht klar..

    habe versucht die nvidia zu ati schritte auszuführen, aber
    1) /usr/lib/libGL.so und /usr/lib/libGLcore.so existierten auch so schon nicht.. also gibt es nichts zu löschen
    2) das mit den verlinken hat auch nicht geklappt weil er /usr/lib/libGL.so nicht gefunden hat (was mir auch logisch erscheint, weil ich es ja vorher gelöscht haben soll)
    3) und /usr/lib/libGLcore.so konnte ich nicht löschen weil ich es ja nicht habe..

    wenn ich glxgears starte wird angezeigt:

    Xlib: extension "GLX" missing on display ":0.0".
    Error: couldn't get an RGB, Double-buffered visual

    ich habe auch wie im andren faq beschrieben mit lsmod nachgesehen ob fglrx geladen ist.. nachdem ich es mit modprobe fglrx nachgeladen habe hat er mir folgendes ausgegeben:

    "Warning: loading /lib/modules/2.4.22-1.2115.nptl/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologi es, Starnberg, GERMANY
    See http://www.tux.org/lkml/#export-tainted for information about tainted modu les
    Module fglrx loaded, with warnings"

    für

    lsmod | grep fglrx

    gibt er danach folgendes aus:

    fglrx 189416 0 (unused)

    das soweit..
    zusätzlich denke ich kann die ausgabe bei der treiber installation interessant sein.. die sieht wie folgt aus..

    [root@localhost rpms etc]# rpm -Uvh --force fglrx-glc22-4.3.0-3.7.0.i386.rpm
    Preparing... ########################################### [100%]
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    Warnung: user mtippett does not exist - using root
    Warnung: group mtippett does not exist - using root
    1:fglrx-glc22 ########################################### [100%]
    *** Trying to install a precompiled kernel module.
    *** WARNING ***
    Tailored kernel module for fglrx not present in your system.
    You must go to /lib/modules/fglrx/build_mod subdir
    and execute './make.sh' to build a fully customed kernel module.
    Afterwards go to /lib/modules/fglrx and run './make_install.sh'
    in order to install the module into your kernel's module repository.
    (see readme.txt for more details.)

    As of now you can still run your XServer in 2D, but hardware acclerated
    OpenGL will not work and 2D graphics will lack performance.

    failed.
    *** Found kernel module build environment, generating kernel module now.
    ATI module generator V 2.0
    ==========================
    initializing...
    cleaning...
    patching 'highmem.h'...
    skipping patch for 'drmP.h', not needed
    patching 'drm_os_linux.h'...
    probing for VMA API version...
    doing script based build for kernel 2.4.x and similar
    make.sh: line 1009: [: -ge: unary operator expected
    compiling './agpgart_be.c'...
    In file included from /lib/modules/2.4.22-1.2115.nptl/build/include/asm/semaphore.h:39,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/fs.h:202,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/capability.h:17,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/binfmts.h:4,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/sched.h:10,
    from agpgart_be.c:108:
    /lib/modules/2.4.22-1.2115.nptl/build/include/asm/system.h: In function `__set_64bit_var':
    /lib/modules/2.4.22-1.2115.nptl/build/include/asm/system.h:189: Warnung: dereferencing type-punned pointer will break strict-aliasing rules
    /lib/modules/2.4.22-1.2115.nptl/build/include/asm/system.h:189: Warnung: dereferencing type-punned pointer will break strict-aliasing rules
    compiling './agp3.c'...
    In file included from /lib/modules/2.4.22-1.2115.nptl/build/include/asm/semaphore.h:39,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/fs.h:202,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/capability.h:17,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/binfmts.h:4,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/sched.h:10,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/mm.h:4,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/slab.h:14,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/asm/pci.h:37,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/pci.h:658,
    from agp3.c:61:
    /lib/modules/2.4.22-1.2115.nptl/build/include/asm/system.h: In function `__set_64bit_var':
    /lib/modules/2.4.22-1.2115.nptl/build/include/asm/system.h:189: Warnung: dereferencing type-punned pointer will break strict-aliasing rules
    /lib/modules/2.4.22-1.2115.nptl/build/include/asm/system.h:189: Warnung: dereferencing type-punned pointer will break strict-aliasing rules
    compiling './i7505-agp.c'...
    In file included from /lib/modules/2.4.22-1.2115.nptl/build/include/asm/semaphore.h:39,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/fs.h:202,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/capability.h:17,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/binfmts.h:4,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/sched.h:10,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/mm.h:4,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/slab.h:14,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/asm/pci.h:37,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/pci.h:658,
    from i7505-agp.c:33:
    /lib/modules/2.4.22-1.2115.nptl/build/include/asm/system.h: In function `__set_64bit_var':
    /lib/modules/2.4.22-1.2115.nptl/build/include/asm/system.h:189: Warnung: dereferencing type-punned pointer will break strict-aliasing rules
    /lib/modules/2.4.22-1.2115.nptl/build/include/asm/system.h:189: Warnung: dereferencing type-punned pointer will break strict-aliasing rules
    compiling './nvidia-agp.c'...
    In file included from /lib/modules/2.4.22-1.2115.nptl/build/include/asm/semaphore.h:39,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/fs.h:202,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/capability.h:17,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/binfmts.h:4,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/sched.h:10,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/mm.h:4,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/slab.h:14,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/asm/pci.h:37,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/pci.h:658,
    from nvidia-agp.c:10:
    /lib/modules/2.4.22-1.2115.nptl/build/include/asm/system.h: In function `__set_64bit_var':
    /lib/modules/2.4.22-1.2115.nptl/build/include/asm/system.h:189: Warnung: dereferencing type-punned pointer will break strict-aliasing rules
    /lib/modules/2.4.22-1.2115.nptl/build/include/asm/system.h:189: Warnung: dereferencing type-punned pointer will break strict-aliasing rules
    compiling './firegl_public.c'...
    In file included from /lib/modules/2.4.22-1.2115.nptl/build/include/asm/semaphore.h:39,
    from /lib/modules/2.4.22-1.2115.nptl/build/include/linux/fs.h:202,
    from firegl_public.c:76:
    /lib/modules/2.4.22-1.2115.nptl/build/include/asm/system.h: In function `__set_64bit_var':
    /lib/modules/2.4.22-1.2115.nptl/build/include/asm/system.h:189: Warnung: dereferencing type-punned pointer will break strict-aliasing rules
    /lib/modules/2.4.22-1.2115.nptl/build/include/asm/system.h:189: Warnung: dereferencing type-punned pointer will break strict-aliasing rules
    linking of fglrx kernel module...
    duplicating results into driver repository...
    done.
    ==============================
    - creating symlink
    - recreating module dependency list
    - trying a sample load of the kernel module
    Warning: loading /lib/modules/2.4.22-1.2115.nptl/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY
    See http://www.tux.org/lkml/#export-tainted for information about tainted modules
    Module fglrx loaded, with warnings
    done.
    Installed: qt3 (gcc 3.2) based control panel application
    ===
    ATI display drivers successfully installed
    please run 'fglrxconfig' now
    ===
    [root@localhost rpms etc]#

    gibt es noch chancen für den patienten?
     
  6. dalex

    dalex Tripel-As

    Dabei seit:
    28.10.2003
    Beiträge:
    175
    Zustimmungen:
    0
    Ort:
    Augsburg
    Nun,
    ich habe heute eine Radeon das erste mal installiert und fast alles genauso angezeigt bekommen wie du. Jetzt mußt du eigentlich nur noch fglrxconfig im Textmodus ausführen. Alles gewissenhaft beantworten und X neu starten.

    Das wars. Läuft hier super

    Gruß dalex
     
Thema:

fedora core 1 & radeon 9600XT

Die Seite wird geladen...

fedora core 1 & radeon 9600XT - Ähnliche Themen

  1. Fedora Core 10 Beitritt W2k8-Domäne

    Fedora Core 10 Beitritt W2k8-Domäne: hi leutz, habe lieber ein neues Thread erstellt, da dies nicht mehr so ganz in meinen Samba-ACL-Thread passt. Wenn ich mit Fedora Core10...
  2. Backup unter fedora core / centos

    Backup unter fedora core / centos: hi leutz, es wird oft diskutiert wie samba-server, nis und nfs-server, etc. eingerichtet werden. Aber welche Dateien / Verzeichnisse müssen bei...
  3. samba mit acl unter fedora core 10

    samba mit acl unter fedora core 10: hi leutz, habe samba als domain-member in einer w2k8-domäne eingerichtet. Auf dem Samba-Server ist ein Share mit ext3 formatiert und mittels...
  4. Fedora Core9: Dynamische DNS-Updates über DHCP einrichten

    Fedora Core9: Dynamische DNS-Updates über DHCP einrichten: hi leutz, ich möchte unter Fedora Core 9 dynamische DNS-Updates über DHCP mittels einem Key DHCP_UPDATER einrichten. Den Key habe ich mittels...
  5. Unterschied zwischen "Fedora" und "Fedora Core"

    Unterschied zwischen "Fedora" und "Fedora Core": Hallo erstmal, Ich muss mich für diese dumme Frage entschuldigen, aber im Internet hab ich irgendwie nichts gefunden! Also, bitte mault mich...