FC 16 vs Win*7: Kein Zugriff auf den Inhalt der Shares

Dieses Thema im Forum "Samba" wurde erstellt von pkuehnle, 19.01.2012.

  1. #1 pkuehnle, 19.01.2012
    pkuehnle

    pkuehnle Grünschnabel

    Dabei seit:
    19.01.2012
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo Foristi,
    ich habe ein merkwürdiges Problem mit meiner neu installierten FC 16-Kiste und Win7. Bislang hatte ich eine Maschine laufen mit FC14, die mir Samba geliefert hat und mit meiner Win*7-Kiste gut gespielt hat. (Die Win*-Seite ist also erprobt und funktioniert schon länger reibungslos.)
    Wenn ich nach dem Wechsel der Linux-Kiste nun versuche, unter Win* auf meine Shares zuzugreifen, meldet mir Windows, dass etwa auf "Laufwerk Z:" "nicht zugegriffen werden" kann. Im Folgenden sehe ich dann zwar das icon für ein angeschlossenes Netzlaufwerk, samt der Angabe für den Speicherplatz, der auf dem Laufwerk frei bzw. vorhanden ist - aber ich kann auf keine Datei zugreifen. Das scheint mir ein Linux-seitiges Problem zu sein.
    Hat jemand aus der Hand eine Lösungsidee?
    Vielen Dank und schöne Grüße,
    Peter
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Remidemi, 19.01.2012
    Remidemi

    Remidemi Routinier

    Dabei seit:
    17.03.2008
    Beiträge:
    352
    Zustimmungen:
    0
    Ort:
    Südpfalz
    Hi

    Hat sich an der smb.conf was geändert?
    Ist das Share User/Passwort geschützt? Hast du das in Windows mit angegeben?
    Kommst du über \\linux-server\share auf die Freigabe?
     
  4. #3 pkuehnle, 19.01.2012
    pkuehnle

    pkuehnle Grünschnabel

    Dabei seit:
    19.01.2012
    Beiträge:
    6
    Zustimmungen:
    0
    Alles geguttenbergt

    Danke für die Antwort!

    Ich hab die smb.conf von der geretteten Festplatte rüberkopiert; an die Freigabe komme ich (z.B.) über \\192.168.2.100\html und versuche dann, mich über Login / Passwort anzumelden. Mit eben dem Erfolg: ich sehe die Freigabe, aber komm nicht rein...

    Mein SWAT gibt mir dann auch aus, dass ich als dieser User von dem Win-Rechner auf die Freigabe zugreife.

    Interessant: Win listet den Rechner nicht als zur Gruppe gehörig. Hat's aber auch beim alten FC 14 nicht...

    Schöne Grüße,
    Peter
     
  5. #4 illtiss, 20.01.2012
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    Mhhh,

    mach mal bitte einen Test, und zwar lege auf dem FC16 einen Benutzer an, also SMB User der genauso heißt wie der Benutzer unter dem Du an dem Windows 7 Rechner arbeitest und versuche Dich dann nochmal auf das Share zu connecten.
     
  6. #5 pkuehnle, 20.01.2012
    pkuehnle

    pkuehnle Grünschnabel

    Dabei seit:
    19.01.2012
    Beiträge:
    6
    Zustimmungen:
    0
    standard input is not a socket

    Moin illtiss,
    Danke für den Tipp: ich habe aber bereits identische Usernamen / Passwörter unter Linux, SMB und Win*.

    AAAABBBEEERRR: gerade gesehen: mein smb.log spuckt mir eine Warnung aus: standard input is not a socket, assuming -D option
    UND: no socket to connect to

    das klingt ja ungut... kannst Du / jemand anders damit was anfangen? Klingt ja nach Konfigurationsfehler...

    Schöne Grüße,
    Peter
     
  7. #6 illtiss, 20.01.2012
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    Kannst Du mir/uns mal die smb.conf posten. Bzw. schau mal bitte nach was Du in der smb.conf (unter Global) drinn hast, ist da was mit socket options?
     
  8. #7 pkuehnle, 20.01.2012
    pkuehnle

    pkuehnle Grünschnabel

    Dabei seit:
    19.01.2012
    Beiträge:
    6
    Zustimmungen:
    0
    smb.conf

    Du bist schnell... Danke ;)

    Hier ist die smb.conf... da ist nix mit socket options...

    ---(schnipp)---

    # Samba config file created using SWAT
    # from UNKNOWN (192.168.2.100)
    # Date: 2012/01/20 07:55:29

    [global]
    server string = Samba Server Version %v
    log file = /var/log/samba/log.%m
    max log size = 50
    os level = 65
    preferred master = Yes
    idmap config * : backend = tdb
    valid users = pkuehnle
    hosts allow = 192.168.2.100, 192.168.2.101, 127.0.0.1
    cups options = raw

    [homes]
    comment = Home Directories
    read only = No
    browseable = No

    [printers]
    comment = All Printers
    path = /var/spool/samba
    printable = Yes
    print ok = Yes
    browseable = No

    [pkuehnle]
    path = /home/pkuehnle
    read list = pkuehnle
    write list = pkuehnle
    read only = No

    HTML:
    	path = /var/www/html
    	read list = pkuehnle
    	write list = pkuehnle
    	read only = No
     
  9. #8 illtiss, 20.01.2012
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    Bin ich momentan etwas überfragt. Nehme der Thematik heute Abend nochmals an, falls noch niemand eine Lösung bis dahin findet. Was mir spontan einfallen würde ist, das kein Parameter mit Security Level existiert, sowas wie user oder share.
     
  10. #9 pkuehnle, 20.01.2012
    pkuehnle

    pkuehnle Grünschnabel

    Dabei seit:
    19.01.2012
    Beiträge:
    6
    Zustimmungen:
    0
    Klasse! Danke illtiss! Ich werd weiter experimentieren, und - falls sich was ergibt - Ergebnisse posten!
     
  11. #10 illtiss, 20.01.2012
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    Was Du selbst spontan mal machen kannst, schnapp Dir ne einfache smb.conf aus dem Netz, ne example Config. Änder die an den zwei drei stellen ab, Deinem Netzwerk betreffend, und restarte den Samba nochmal. Dann können wir evtl. schon sehen obs an der config liegt, oder an etwas anderem.
     
  12. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  13. #11 pkuehnle, 20.01.2012
    pkuehnle

    pkuehnle Grünschnabel

    Dabei seit:
    19.01.2012
    Beiträge:
    6
    Zustimmungen:
    0
    Oh Mann! Asche auf mein Haupt... Es LAG an was anderem! Und zwar an SELinux - ich hatte das irgendwann disabled, und nach einem Update war's nun *enabled* - das hat mir schlicht den Zugang geblockt. Wie peinlich!

    Also: Fehlermeldung "no socket" -> erstmal SELinux beschuldigen...

    Deshalb: Tausend Dank für die Gedanken und die Hilfe! Es funktioniert jetzt alles, wie's soll!

    Schönen Tach weiterhin: Peter
     
  14. #12 illtiss, 20.01.2012
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    Super :-)

    werd ich mir merken... Schönen Tag noch.
     
Thema:

FC 16 vs Win*7: Kein Zugriff auf den Inhalt der Shares

Die Seite wird geladen...

FC 16 vs Win*7: Kein Zugriff auf den Inhalt der Shares - Ähnliche Themen

  1. Keine Benachrichtigungen im Vollbild Modus

    Keine Benachrichtigungen im Vollbild Modus: Arch Linux Plasma 5.8 Weiss einer ob das gehen sollte, bzw kann mal einer testen ob es bei ihm geht, gerne auch mit anderen kde/plasma versionen....
  2. Torvalds: »Kein Porno unter Linux«

    Torvalds: »Kein Porno unter Linux«: Ohne eine größere Ankündigung hat Linus Torvalds im Zuge des aktuellen Merge-Fensters einen Patch der Gruppe »Gesellschaft gegen Porno« in den...
  3. BSI-Audit findet keine akuten Probleme in OpenSSL

    BSI-Audit findet keine akuten Probleme in OpenSSL: Das Bundesamt für Sicherheit in der Informationstechnik hat OpenSSL auf seine Sicherheit untersuchen lassen. Die Analyse zeigt vor allem, dass die...
  4. BSI-Audit findet keine akute Probleme in OpenSSL

    BSI-Audit findet keine akute Probleme in OpenSSL: Das Bundesamt für Sicherheit in der Informationstechnik hat OpenSSL auf seine Sicherheit untersuchen lassen. Die Analyse zeigt vor allem, dass die...
  5. RoboVM keine freie Software mehr

    RoboVM keine freie Software mehr: RoboVM, Hersteller der gleichnamigen Entwicklungsumgebung für Mobilsysteme, hat die Lizenz von der GPL in eine proprietäre Lizenz gewandelt. Nach...