Fat32 mounten: kein Schreibzugriff für user/root

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Stollentroll, 07.05.2006.

  1. #1 Stollentroll, 07.05.2006
    Stollentroll

    Stollentroll Schattenparasit

    Dabei seit:
    11.03.2006
    Beiträge:
    67
    Zustimmungen:
    0
    Nabend,
    wie der Titel schon sagt, ich kann weder als user noch als root auf meine Fat32 Partition schreiben. Der Eintrag in der fstab sieht so aus:
    Code:
    /dev/sda11      /mnt/gateway    vfat    defaults,uid=1000,gid=1000   0   0
    Laut Fehlermeldung habe ich nicht die nötigen Rechte um zu schreiben, obwohl ein Rechtsklick auf das Laufwerk-->Eigenschaften-->Zugriffsrechte mir sagt, dass ich der Besitzer des Laufwerks bin und dass der Besitzer Schreibrechte hat. Allerdings hat die Gruppe seltsamerweise keinen Schreibzugriff - müsste das gid=1000 nicht bewirken?
    auch ein umask=002 bzw umask=000 haben keine veränderung gebracht.

    Was ist falsch an meinem fstab - Eintrag?

    Auf Tipps hoffend
    Stollentroll
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Bâshgob, 07.05.2006
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    ~$ id

    und die gid/uid in der fstab entsprechend anpassen. uid dürfte sich bei ~500 bewegen, gid bei 100.

    HTH
     
  4. #3 Stollentroll, 07.05.2006
    Stollentroll

    Stollentroll Schattenparasit

    Dabei seit:
    11.03.2006
    Beiträge:
    67
    Zustimmungen:
    0
    ne, das ist schon 1000:
    (oder hab ich nen Knick in der Optik? - is spät)

    Code:
    christoph@RECHNER1:~$ id
    uid=1000(christoph) gid=1000(christoph) Gruppen=20(dialout),24(cdrom),25(floppy),29(audio),44(video),46(plugdev),1000(christoph)
    christoph@RECHNER1:~$
    
    
     
  5. #4 Bâshgob, 07.05.2006
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    die gültigen Optionen für die fstab findest du in man mount für vfat. Schau mal durch, ggf ist da was für dich dabei.

    Ich arbeite bei vfat immer ohne gid/uid. Klappt hier hervorragend.
     
  6. #5 Stollentroll, 08.05.2006
    Zuletzt bearbeitet: 08.05.2006
    Stollentroll

    Stollentroll Schattenparasit

    Dabei seit:
    11.03.2006
    Beiträge:
    67
    Zustimmungen:
    0
    Ich hab das mounten jetzt nur mit den Optionen defaults und umask versucht.
    Nachdem ich endlich verstanden habe wie sich umask zusammensetzt hab ich umask=027 angegeben.
    Siehe da, ich bekomme keinen Lesezugriff --> ergo bin ich nicht der Eigentümer dieses Laufwerks.
    Ich habe jetzt mit chown mich zum Besitzer des Ordners gemacht, in den das Laufwerk eingehängt werden soll und mit chmod die Rechte auf 027 gesetzt, da ich dachte dass sich die Rechte vllt auf eine übersinnliche Art auf das Laufwerk übertragen. Dem war nicht so, ich hätts wissen müssen, es ist nicht Vollmond ;)
    Ich habe also immer noch keinen Lesezugriff.
    Jetzt habe ich irgendwo aufgeschnappt, dass ich den Eigentümer der Gerätedatei auf mich setzen kann um Eigentümer des Laufwerks zu werden.
    Geht das? Wenn ja, geht das eleganter? Oder ist das schon elegant?

    EDIT: Einmal Wikipedia gelesen und schon verwirrt - habe ich das richtig verstanden: 0 bedeutet Nutzer darf alles, 1 Nutzer darf nicht ausführen, 2 Nutzer darf nicht schreiben, 4 Nutzer darf nicht lesen

    In der Wikipedia steht es genau andersrum, allerdings auch für Unix, wobei ich eigentlich davon ausgegangen war dass aufgrund der Verwandschaft zwischen Linux und Unix die Befehle gleich sind.

    EDIT2: Das kommt davon wenn man nicht richtig liest: chmod mit umask verwechselt
     
  7. #6 Bâshgob, 08.05.2006
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    Vermutlich fehlt dir lediglich ein rw fällt mir grade so auf.
     
  8. #7 Stollentroll, 08.05.2006
    Zuletzt bearbeitet: 08.05.2006
    Stollentroll

    Stollentroll Schattenparasit

    Dabei seit:
    11.03.2006
    Beiträge:
    67
    Zustimmungen:
    0
    Morgen,
    naja, rw steckt eigentlich in defaults mit drin.
    Ich habs jetzt nochmal neu versucht.
    mount -o defaults,umask=027 /dev/sda11 /mnt/gateway
    führt dazu dass ich keinen Lesezugriff habe, also bin ich kein Besitzer und nicht in der Gruppe.
    mount -o defaults,umask=027,uid=1000,gid=1000 /dev/sda11 /mnt/gateway
    Damit habe ich Lesezugriff, und ein Rechtsklick auf Dateien--> ...-->Zugriffsrechtesagt mir dass ich Schreibzugriff auf die Dateien habe, aber wenn ich sie Löschen will habe ich wieder nicht genug Rechte (Laut Fehlemeldung)
    Unter Zugriffsrechte stehe unter Besitzer ich, bei der Gruppe meine Gruppe und die Rechte stehen auf -rwxr-w---
    Kann es sein, dass es gar nicht an dem Eintrag liegt, sondern vllt an der Platte selbst?
    Wobei, löschen sollte ja immer gehn.
     
  9. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Wenn Du sagst, dass Du selbst als root nicht schreiben kannst, dann liegt es sicher am Einhaengen, da root an sich immer schreiben darf, es sei denn, ein Geraet ist ro eingehaengt.

    gibt doch mal nur 'mount' ein, dann siehst Du, welche Optionen fuer das Laufwerk gueltig sind.
    Dann haeng sie nochmal aus und als root von der Konsole aus wieder ein:
    'mount -tvfat -orw /dev/sda11 /mnt/gateway'
    und schau dann mit 'mount' nochmal nach, bzw, versuch, als root zu schreiben. Klappt's dann?
     
  10. #9 UllaUffz, 08.05.2006
    UllaUffz

    UllaUffz Eroberer

    Dabei seit:
    25.01.2006
    Beiträge:
    57
    Zustimmungen:
    0
    Ich weiss nicht ob es hilft, aber bei mir funkt. das einwandfrei und mein Eintrag in die /etc/fstab sieht fuer die Partition so aus:

    /dev/sda3 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0
     
  11. #10 Stollentroll, 08.05.2006
    Stollentroll

    Stollentroll Schattenparasit

    Dabei seit:
    11.03.2006
    Beiträge:
    67
    Zustimmungen:
    0
    @UllaUffz: ne, der (angepasste) Eintrag ändert leider nichts.

    So, ich hab mich jetzt mal an rikolas Anleitung gehalten.
    Mein Eintrag in der fstab:

    Code:
    /dev/sda11    /mnt/gateway   vfat  defaults,umask=027,uid=1000,gid=1000    0  0
    Ausgabe von mount für gateway:

    Code:
    /dev/sda11 on /mnt/gateway type vfat (rw,umask=027,uid=1000,gid=1000)
    unmounten, mit mount -tvfat -orw /dev/sda11 /mnt/gateway mounten, ausgabe von mount:

    Code:
    /dev/sda11 on /mnt/gateway type vfat (rw)
    jetzt kann ich als root schreiben
    Ich versteh zwar nicht wieso, aber das ist ja schon mal was.

    wie erweitere ich die Schreibrechte jetzt auf mich?
    Das Anhängen von uid=1000, gid=1000 und umask=027 hat nichts gebracht.


    Was mich jetzt doch ziemlich wundert: Wenn ich den (für root) erfolgreichen mount Befehl mit mit Leerzeichne fülle, (also -t vfat -o rw /dev/sda11 /mnt/gateway) hat root keinen Schreibzugriff mehr. Wo ein Blick in die man von mount mir doch sagt, dass dieses Leerzeichen gesetzt werden darf.
     
  12. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Lass doch einfach mal das rw weg. FAT32 wird doch eh als RW eingehaengt.
     
  13. #12 Stollentroll, 08.05.2006
    Stollentroll

    Stollentroll Schattenparasit

    Dabei seit:
    11.03.2006
    Beiträge:
    67
    Zustimmungen:
    0
    Stimmt, das Laufwerk wird, zumindest laut mount liste, als rw eingehängt, aber wenn ich die option -orw nicht angebe, kann ich auch als root nicht auf das Laufwerk schreiben.
     
  14. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Bei mir haengt 'ne FAT32 mit den Optionen rw,nosuid drin und funktioniert einwandfrei zumindest fuer root. Funkt dir da evtl. nen Automounter zwischen? Wie sieht der der Eintrag in der /etc/mtab fuer die Platte aus, wenn du sie eingehaengt hast? Stehen da wirklich nur die Optionen, die du angegeben hast?
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Stollentroll, 09.05.2006
    Stollentroll

    Stollentroll Schattenparasit

    Dabei seit:
    11.03.2006
    Beiträge:
    67
    Zustimmungen:
    0
    Aus Fehlern lernt man, oder?
    Ich hoffe es ja.
    Nachdem alle Versuche nichts gebracht bzw. mich komplett verwirrt haben, wollte ich die brutale Methode ausprobieren: Partition löschen und neu erstellen, und hoffen, dass ich sie über Debian richtig einstellen kann. Denn als ich die Festplatte während der Debian - Installation zum mounten eingestellt hatte, konnte ich als normaler Nutzer darauf schreiben. Da ich wie gesagt schon leicht verwirrt bzw. genervt war, habe ich, nach einem kurzen Reinschnuppern in qparted, dass beim Festplatten erkennen dauernd abschmierte, die Partition unter Windows gelöscht.
    Das war keine gute Idee.
    Nachdem ich grub von Knoppix aus wiederhergestellt und debian gebootet hatte, stellte ich fest, dass die Windows Aktion bleibende Schäden bei Debian hinterlassen hatte.

    Wie oft darf man als Anfänger sein Debian zerschießen? Ich habs bis jetzt 2 mal geschafft (In einem Monat)

    Jedenfalls kann ich jetzt, nachdem ich bei der Installation die Fat32 Platte neu erstellt und auf /mnt/gateway eingestellt habe, als root darauf schreiben.
    Ohne Probleme und seltsamerweise mit einer Einstellungen, die vorher nicht funktioniert hat. ?(

    Der einzige (für mich sichtbare) Unterschied: Die Partition wird auf meinem Desktop nicht mit ihrem Namen, sondern als 1,0GB Datenträger angezeigt. Wisst ihr wo man das ändern kann?
     
  17. bertB

    bertB Grünschnabel

    Dabei seit:
    08.06.2006
    Beiträge:
    5
    Zustimmungen:
    0
    gleiches problem

    hi,
    nachdem ich mein ubuntu von version 5.10 auf die neue 6.06 gebracht habe hab ich ein ähnliches problem. auf eine meiner fat partitionen kann ich nicht schreiben. obwohl sie in der fstab genau so eingehängt ist wie die anderen die sich auf der selben platte befinden.
    was auch sehr seltsam ist wenn ich den ordner im dateimanager geöffnet lasse
    das ganze dann unmounte und wieder einmounte dann kann ich mittels dem zurück butten wieder in den ordner gehen und dann dort schreiben.
    haber leider auch noch keine lösung dafür.
     
Thema:

Fat32 mounten: kein Schreibzugriff für user/root

Die Seite wird geladen...

Fat32 mounten: kein Schreibzugriff für user/root - Ähnliche Themen

  1. fat32 ordentlich mounten

    fat32 ordentlich mounten: Hallo, irgendwie will meine frisch angelegte fat32 Partition nicht gemountet werden, damit auch User auf sie Zugriff haben.Sorry, für die dumme...
  2. FAT32 Partition unter Suse 10.1 mounten

    FAT32 Partition unter Suse 10.1 mounten: Hallo Leute, ich weiß, es gib viel Artikel zu diesem Thema, aber ich komm einfach nicht zurecht. Mein Problem: Ich möchte ein unter Suse bei der...
  3. Fat32 Mounten wie unter Windows

    Fat32 Mounten wie unter Windows: Hallo, hab eine Partion mit Fat formatiert und gemountet. Wenn ich jetzt ein Tool über eine Datei laufen lassen, was mir eine Checksumme...
  4. Mounten von FAT32 und NTFS

    Mounten von FAT32 und NTFS: hey leutzz, also ich bin debian-anfänger...ich habe mir gestern mal das Ubuntu angeguckt und installiert, bin echt zufrieden damit :D nur,...
  5. Fedora Core 3 und NTFS und FAT32 mounten !

    Fedora Core 3 und NTFS und FAT32 mounten !: Hi, ich verzweifle gerade schier. Da Fedora ja leider nicht imstande ist NTFS und FAT32 Laufwerke auf Wunsch direkt zu verknüpfen wie...