ext3 mounten nicht möglich

Dieses Thema im Forum "Linux OS" wurde erstellt von Wojtek, 17.09.2004.

  1. Wojtek

    Wojtek Grünschnabel

    Dabei seit:
    11.08.2004
    Beiträge:
    7
    Zustimmungen:
    0
    Hallöle liebe Gemeinde,
    nachdem mir letztes mal so wunderbar geholfen wurde, melde ich mich mit dem nächsten Problem.

    Ich nutze Fedora Core 2 auf einem Abit NF-7 mit 2 S-ATA Platten und
    einer IDE Platte welche auch gleichzeitg die Bootpartition für WinXP & Fedora ist.

    meine zweite Festplatte war defekt und kam jetzt nach dem Austausch wieder zurück.

    Zwischenzeitlich bin ich auf Linux gewechselt und hatte die Platte noch garnicht drin.

    Nun wollte ich die Platte über die fstab automatisch mounten.

    Hab mir folgenden Thread schon angeschaut : http://www.unixboard.de/vb3/showthread.php?t=9567&highlight=mount

    Der brachte mich aber leider nicht weiter.

    Die Betreffende Festplattenpartition wird bei mir als sdb5 erkannt.

    fstab sieht wie folgt aus :

    Code:
    LABEL=/                 /                       ext3    defaults        1 1
    none                    /dev/pts                devpts  gid=5,mode=620  0 0
    none                    /dev/shm                tmpfs   defaults        0 0
    none                    /proc                   proc    defaults        0 0
    none                    /sys                    sysfs   defaults        0 0
    /dev/hda4               swap                    swap    defaults        0 0
    /dev/cdrom              /mnt/cdrom              udf,iso9660 noauto,owner,kudzu,ro 0 0
    /dev/cdrom1             /mnt/cdrom1             udf,iso9660 noauto,owner,kudzu,ro 0 0
    /dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu 0 0
    /dev/hdb5  /mnt/hdd1  vfat rw,user,uid=wojtek 0 0
    /dev/sda5  /mnt/hdd2  vfat rw,user,uid=wojtek 0 0
    /dev/sdb5  /mnt/hdd3  ext3 rw,user,uid=wojtek 0 0
    
    unter /mnt hab ich den Ordner "hdd3" erstellt und ihm CHMOD 777 gegeben.

    Jetzt beim versuch die Festplatte über "mount /mnt/hdd3" zu mounten,
    bekomm ich folgenden fehler :

    Code:
    mount: Falscher Dateisystemtyp, ungültige Optionen, der
           »Superblock« von /dev/sdb5 ist beschädigt oder es sind
           zu viele Dateisysteme eingehängt
    
    Also hab ich die Festplatte formatiert mittels : "./mkfs -t ext3 /dev/sdb5"

    Als Meldung bekam ich :

    Code:
    mke2fs 1.35 (28-Feb-2004)
    Dateisystem-Label=
    OS-Typ: Linux
    Blockgröße=4096 (log=2)
    Fragmentgröße=4096 (log=2)
    14663680 Inodes, 29308576 Blöcke
    1465428 Blöcke (5.00%) reserviert für den Superuser
    erster Datenblock=0
    895 Blockgruppen
    32768 Blöcke pro Gruppe, 32768 Fragmente pro Gruppe
    16384 Inodes pro Gruppe
    Superblock-Sicherungskopien gespeichert in den Blöcken:
            32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
            4096000, 7962624, 11239424, 20480000, 23887872
    
    Schreibe Inode-Tabellen: erledigt
    Erstelle Journal (8192 Blöcke): erledigt
    Schreibe Superblöcke und Dateisystem-Accountinginformationen: erledigt
    
    Das Dateisystem wird automatisch alle 32 Mounts bzw. alle 180 Tage überprüft,
    je nachdem, was zuerst eintritt. Veränderbar mit tune2fs -c oder -t .
    
    Der erneute Versuch die Festplatte zu mounten gibt wieder obige Fehlermeldung aus.

    Es ist eine 120GB S-ATA HDD von Samsung mit einer einzigen ext3 Partition drauf.

    Hab ich da irgendwo nen Denkfehler drin indem was ich da machen will ?

    :help:

    thx schonmal & Gruß Wojtek
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Was sagt fdisk zum partitionstyp ? (fdisk /dev/sdb - und schau dir mal an obs ne linuxpartition ist - ansonsten - t 83)
     
  4. Wojtek

    Wojtek Grünschnabel

    Dabei seit:
    11.08.2004
    Beiträge:
    7
    Zustimmungen:
    0
    Hallöle und Dank Dir schonmal für die Antwort.

    Direkt nach dem Aufruf kommt :
    Code:
    [root@host sbin]# ./fdisk /dev/sdb
    
    Die Anzahl der Zylinder für diese Platte ist auf 14596 gesetzt.
    Daran ist nichts verkehrt, aber das ist größer als 1024 und kann
    in bestimmten Konfigurationen Probleme hervorrufen mit:
    1) Software, die zum Bootzeitpunkt läuft (z. B. ältere LILO-Versionen)
    2) Boot- und Partitionierungssoftware anderer Betriebssysteme
       (z. B. DOS FDISK, OS/2 FDISK)
    
    Über die Option P bekomm ich :
    Code:
    Befehl (m für Hilfe): p
    
    Platte /dev/sdb: 120.0 GByte, 120060444672 Byte
    255 Köpfe, 63 Sektoren/Spuren, 14596 Zylinder
    Einheiten = Zylinder von 16065 * 512 = 8225280 Bytes
    
       Gerät Boot      Start         End      Blocks   Id  System
    /dev/sdb1               2       14596   117234337+   f  W95 Ext'd (LBA)
    /dev/sdb5               2       14596   117234306   83  Linux
    
    Also ist soweit mit der sdb5 alles O.K. ?

    Verlasse ich fdisk über die Option "w" kommt :

    Code:
    Befehl (m für Hilfe): w
    Die Partitionstabelle wurde verändert!
    
    Rufe ioctl() um Partitionstabelle neu einzulesen.
    Synchronisiere Platten.
    
    Formatiere ich die Platte anschliessend über "./mkfs -t ext3 /dev/sdb5"

    erhalte ich wieder :
    Code:
    mke2fs 1.35 (28-Feb-2004)
    Dateisystem-Label=
    OS-Typ: Linux
    Blockgröße=4096 (log=2)
    Fragmentgröße=4096 (log=2)
    14663680 Inodes, 29308576 Blöcke
    1465428 Blöcke (5.00%) reserviert für den Superuser
    erster Datenblock=0
    895 Blockgruppen
    32768 Blöcke pro Gruppe, 32768 Fragmente pro Gruppe
    16384 Inodes pro Gruppe
    Superblock-Sicherungskopien gespeichert in den Blöcken:
            32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
            4096000, 7962624, 11239424, 20480000, 23887872
    
    Schreibe Inode-Tabellen: erledigt
    Erstelle Journal (8192 Blöcke): erledigt
    Schreibe Superblöcke und Dateisystem-Accountinginformationen: erledigt
    
    Das Dateisystem wird automatisch alle 22 Mounts bzw. alle 180 Tage überprüft,
    je nachdem, was zuerst eintritt. Veränderbar mit tune2fs -c oder -t .
    
    Nach dem versuch zu mounten (mount /mnt/hdd3) kommt:

    Code:
    mount: Falscher Dateisystemtyp, ungültige Optionen, der
           »Superblock« von /dev/sdb5 ist beschädigt oder es sind
           zu viele Dateisysteme eingehängt
    
    thx & Gruß Wojtek
     
  5. #4 DennisM, 17.09.2004
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    mke2fs -j /dev/sdb5 ....

    GrEeTz

    Dennis
     
  6. #5 tomvomland, 20.09.2004
    tomvomland

    tomvomland Tripel-As

    Dabei seit:
    27.08.2002
    Beiträge:
    223
    Zustimmungen:
    0
    Ort:
    Korschenbroich (Kaff bei D-dorf)
    also,...

    mke2fs -j macht ja nix eigentlich nix anderes als mkfs -t exts3 oder mkfs.ext3, oder?

    Ich würde zunächst die Platte neu formatieren, wojtek. Es ist eigentlich nicht nötig, die Linux Partition als erweiterte Partitioin anzulegen. Deine Partitionierung müsste zwar eigentich funtionieren aber Du weisst ja wie das immer so geht....
    Also: sdb5 mit fdisk löschen, den Typ von sdb1 mit fdisk auf "linux" ändern, ähnlich wie von devilz vorgeschlagen, und dann noch einmal mit mkfs -t ext3 oder mke2fs -j oder wie auch immer ein ext3 auf sdb1 anlegen.

    Wenn das nicht geht, weiss ich auch nicht weiter....

    gruß
    tom
     
  7. Wojtek

    Wojtek Grünschnabel

    Dabei seit:
    11.08.2004
    Beiträge:
    7
    Zustimmungen:
    0
    Hallöle und danke für die Hilfe!

    Habs jetzt so gemacht :

    fdisk aufgerufen : ./fdisk /dev/sdb

    Anschliessend kam :

    Code:
    Die Anzahl der Zylinder für diese Platte ist auf 14596 gesetzt.
    Daran ist nichts verkehrt, aber das ist größer als 1024 und kann
    in bestimmten Konfigurationen Probleme hervorrufen mit:
    1) Software, die zum Bootzeitpunkt läuft (z. B. ältere LILO-Versionen)
    2) Boot- und Partitionierungssoftware anderer Betriebssysteme
       (z. B. DOS FDISK, OS/2 FDISK)
    
    
    Hab also die Partition mittels Option "d" gelöscht,

    Danach eine neue Angelegt.
    Diesmal als Primäre Partition.

    So dass es danach so aussah :

    Code:
    Platte /dev/sdb: 120.0 GByte, 120060444672 Byte
    255 Köpfe, 63 Sektoren/Spuren, 14596 Zylinder
    Einheiten = Zylinder von 16065 * 512 = 8225280 Bytes
    
       Gerät Boot      Start         End      Blocks   Id  System
    /dev/sdb1               1       14596   117242338+  83  Linux
    
    Soweit ja richtig, oder ?

    Hab fdisk dann beendet mittels Option "w"
    ( w Die Tabelle auf die Festplatte schreiben und das Programm beenden)

    Zum beenden kam :

    Code:
    Die Partitionstabelle wurde verändert!
    
    Rufe ioctl() um Partitionstabelle neu einzulesen.
    Synchronisiere Platten.
    
    Hab dann via "./mkfs -j ext3 /dev/sdb1" Formatiert.

    Allerdings hat er nicht Formatiert sondern folgendes ausgegeben :

    Code:
    [root@host sbin]# ./mkfs -j ext3 /dev/sdb1
    mkfs.ext2: Bad Blocks Anzahl - /dev/sdb1
    Über "./mkfs -t ext3 /dev/sdb1" hat er dann Formatiert.

    Code:
    mke2fs 1.35 (28-Feb-2004)
    Dateisystem-Label=
    OS-Typ: Linux
    Blockgröße=4096 (log=2)
    Fragmentgröße=4096 (log=2)
    14663680 Inodes, 29310584 Blöcke
    1465529 Blöcke (5.00%) reserviert für den Superuser
    erster Datenblock=0
    895 Blockgruppen
    32768 Blöcke pro Gruppe, 32768 Fragmente pro Gruppe
    16384 Inodes pro Gruppe
    Superblock-Sicherungskopien gespeichert in den Blöcken:
            32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
            4096000, 7962624, 11239424, 20480000, 23887872
    
    Schreibe Inode-Tabellen: erledigt
    Erstelle Journal (8192 Blöcke): erledigt
    Schreibe Superblöcke und Dateisystem-Accountinginformationen: erledigt
    
    Das Dateisystem wird automatisch alle 38 Mounts bzw. alle 180 Tage überprüft,
    je nachdem, was zuerst eintritt. Veränderbar mit tune2fs -c oder -t .
    
    Beim Versuch sie zu mounten via "mount /mnt/hdd3"

    bekomm ich wieder :

    Code:
    mount: Falscher Dateisystemtyp, ungültige Optionen, der
           »Superblock« von /dev/sdb1 ist beschädigt oder es sind
           zu viele Dateisysteme eingehängt
    
    Ich weiss wirklich nicht mehr weiter :(

    Grosses Dankeschön aber an euch die mir helfen wolltet,
    evtl. fällt euch oder jemand anderem noch was ein. *hoff*

    Gruß Wojtek
     
  8. oenone

    oenone Freier Programmierer[Mod]

    Dabei seit:
    22.08.2002
    Beiträge:
    599
    Zustimmungen:
    0
    Ort:
    Mannheim
    hast du schon mal versucht, nach fdisk erst mal neu zu booten?
    manchmal gibt es probleme, eine neu partitionierte platte sofort zu benutzen.

    auf bald
    oenone
     
  9. Wojtek

    Wojtek Grünschnabel

    Dabei seit:
    11.08.2004
    Beiträge:
    7
    Zustimmungen:
    0
    Hallöle,

    also FDISK -> Partition erstellen -> Neu starten -> Dann erst Formatieren & Mounten ?

    So hab ich es noch nicht probiert, werds aber mal versuchen, thx

    Gruß Wojtek
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 tomvomland, 20.09.2004
    tomvomland

    tomvomland Tripel-As

    Dabei seit:
    27.08.2002
    Beiträge:
    223
    Zustimmungen:
    0
    Ort:
    Korschenbroich (Kaff bei D-dorf)
    Hallo wojtek,

    ich glaube oenones Tip ist nicht schlecht, aber mir ist noch was anderes aufgefallen: Die Option uid=wojtek ist - glaube ich - für ext2 und ext3 nicht gültig.
    Versuchs mal mit ...
    Code:
    /dev/hdb5  /mnt/hdd1  vfat rw,user,uid=wojtek 0 0
    /dev/sda5  /mnt/hdd2  vfat rw,user,uid=wojtek 0 0
    /dev/sdb1  /mnt/hdd3  ext3 rw,user 0 0
    .... dann sollte es gehen.

    gruß
    tom
     
  12. Wojtek

    Wojtek Grünschnabel

    Dabei seit:
    11.08.2004
    Beiträge:
    7
    Zustimmungen:
    0
    @tomvomland

    Riesen dankeschön !

    Es lag wirklich daran dass ich uid=wojtek eingetragen hatte.

    Mit Deinem Vorschlag klappte es gleich auf anhieb :)

    Riesen dankeschön ! Super Forum !

    Gruß Wojtek :)
     
Thema:

ext3 mounten nicht möglich

Die Seite wird geladen...

ext3 mounten nicht möglich - Ähnliche Themen

  1. EXT3 USB Disk mounten

    EXT3 USB Disk mounten: Hallo, ich habe mir schon einige Threads zu diesem Thema durchgelesen aber nichts hat bei mir funktioniert. Ich muss dazu sagen dass es bei...
  2. NetBSD - ext3 mounten

    NetBSD - ext3 mounten: Moin, ich habe bei mir auf meinem Server NetBSD installiert. Da ich dort vorher Linux drauf hatte und eine Festplatte noch mit ext3 partitioniert...
  3. EXT3 unter windows mounten

    EXT3 unter windows mounten: Hi@all nunja dieser thread gehört zwischen beiden os aber da ihr ja hier etwas mehr kenne habt als leute im windows board , wollte ich mal...
  4. Verbleib des Ext3-Treibers im Kernel unklar

    Verbleib des Ext3-Treibers im Kernel unklar: Nachdem der aktuelle Betreuer von Ext3 vor knapp zwei Monaten vorgeschlagen hatte, das alte Dateisystem aus dem Kernel zu entfernen, meldet sich...
  5. ext3-Dateisystemtreiber soll aus Linux entfernt werden

    ext3-Dateisystemtreiber soll aus Linux entfernt werden: Da ext3-Dateisysteme schon lange vom ext4-Treiber verwaltet werden können, soll der ursprüngliche ext3-Treiber nun aus Linux entfernt werden. Die...