exim4 - interne E-Mails

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von gpi, 17.05.2012.

  1. gpi

    gpi Jungspund

    Dabei seit:
    05.11.2008
    Beiträge:
    22
    Zustimmungen:
    0
    Hallo zusammen :)

    Ich habe eine Problem mit exim4 und zwar ich kann keine interne E-Mails senden, nur nach außen. Exim4 hab ich wie auf der link steht installiert.

    Code:
    http://openbook.galileocomputing.de/ubuntu_904/ubuntu_20_server_006.htm
    in der Arbeit haben wir einen E-Mail Server im Betrieb. Das was ich machen will ist folgendes. Ich habe auf einen Rechner Debian installiert und will über Debian E-Mails senden intern und nach außen z.B. nach Hotmail oder Yahoo kann ich E-Mails von Debian ohne Probleme senden. Wenn ich aber eine E-Mail an eine interne E-Mailadresse schicken will kann ich nicht. In /var/log/exim4/mainlog steht zwar Completed aber ich bekomme die E-Mail nicht.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 tgruene, 17.05.2012
    Zuletzt bearbeitet: 17.05.2012
    tgruene

    tgruene Routinier

    Dabei seit:
    02.02.2012
    Beiträge:
    418
    Zustimmungen:
    0
    Existiert die Datei /var/mail/$USER? Und falls ja, was steht dort drin? Hast Du exim4 auf maildir konfiguriert (dann landen die Emails in $HOME/Mails oder aehnlich, nicht in /var/mail). Bist Du sicher, dass Du Emails nach Aussen auch tatsaechlich ueber Euren Server schickst, oder werden die ueber einen smtp-server verschickt?
    Steht in /var/spool/mail etwas drin?
     
  4. gpi

    gpi Jungspund

    Dabei seit:
    05.11.2008
    Beiträge:
    22
    Zustimmungen:
    0
    vielleicht habe ich es falls erzählt. Wir haben einen SMTP Server z.B. firma.de meine E-Mail Adresse lautet: meinename@firma.de

    in die passwd.client Datei von Exim habe ich die SMTP Zugangsdaten eingegeben wie folgt

    Code:
    firma.de:benutzername:Passwort
    auf die Konsole habe ich eine Test E-Mail geschickt

    echo "Test" | mail -s Betreff neinename@yahoo.de

    habe ich auch erhalten

    wenn ich aber eine Test an die meinename@firma.de schicke, dann kommt es auch nicht.
     
  5. #4 tgruene, 18.05.2012
    tgruene

    tgruene Routinier

    Dabei seit:
    02.02.2012
    Beiträge:
    418
    Zustimmungen:
    0
    Davon bin ich bei meiner Antwort auch ausgegangen, ausser dass ich zur Sicherheit zusaetzlich nachgefragt habe, ob der Server tatsaechlich auch als smtp-Server dient. Das hast Du ja jetzt beantwortet. Meine restlichen Hinweise koenntest Du dennoch ueberpruefen, um der Sache auf den Grund zu gehen, also z.B. das Verzeichnis /var/mail/$USER auf dem SMTP-Server zu ueberpruefen, bzwl $HOME/Mails, wenn exim4 mit maildir statt mit mbox konfiguriert wurde - wobei dann der Verzeichnisname 'Mails' variieren kann.

    Kommen denn Emails, die Du von neinename@yahoo.de an meinename@firma.de schickst, an?
     
  6. gpi

    gpi Jungspund

    Dabei seit:
    05.11.2008
    Beiträge:
    22
    Zustimmungen:
    0
    Der Debian Rechner dient nicht als SMTP Server. Wenn ich eine E-Mail von draussen nach meinename@firma.de schicke dann kriege ich es auch.

    Auf dem Debian Rechner in das Verzeichnis /var/mail/ leigt einer User

    Der Debian rechner gibt die E-Mails weiter an den SMTP Server und dann er verteilt Sie weiter. Oder denke ich falls??
     
  7. #6 tgruene, 20.05.2012
    tgruene

    tgruene Routinier

    Dabei seit:
    02.02.2012
    Beiträge:
    418
    Zustimmungen:
    0
    Das ist eine Textdatei. Hast Du mal geschaut, ob das Deine Nachrichten sind? Vielleicht hast Du exim4 so konfguriert, dass exim4 denkt, Dein Debian-Rechner sei der SMTP-server. Dann wuerden die Emails an @firma.de den Rechner nicht verlassen.
     
  8. gpi

    gpi Jungspund

    Dabei seit:
    05.11.2008
    Beiträge:
    22
    Zustimmungen:
    0
    Drin sind einige E-Mails. Weiß Du vielleicht wie ich exim am besten Konfigurieren kann, dass ich die E-Mail an name@firma.de auch kriegen kann?? Vielen Dank für deine Hilfe
     
  9. #8 tgruene, 21.05.2012
    tgruene

    tgruene Routinier

    Dabei seit:
    02.02.2012
    Beiträge:
    418
    Zustimmungen:
    0
    Ich habe exim4 noch nicht benutzt - die Konfiguration war mir im Vergleich zu postfix zu umstaendlich. Ich vermute allerdings, dass der Debiankomfort bei beiden der gleiche ist. Dann muesstest Du bei der Konfiguration von exim4 Deinen Debian-Rechner als 'Satellite-System' angeben. Die gleiche Option hat man laut diesem Treffer auch mit dem Befehl 'eximconfig'. Probier's mal aus.
     
  10. gpi

    gpi Jungspund

    Dabei seit:
    05.11.2008
    Beiträge:
    22
    Zustimmungen:
    0
    Ich teste gerade auch Postfix :) Danke für den Link.
     
  11. gpi

    gpi Jungspund

    Dabei seit:
    05.11.2008
    Beiträge:
    22
    Zustimmungen:
    0
    das gleich Problem habe ich mit Postfix auch. Obwohl in der Logdatei gesendet steht ich kriege das E-Mail nicht an meinem name@firma.de Account. Postfix habe ich als Satellitensystem installiert
     
  12. #11 tgruene, 24.05.2012
    tgruene

    tgruene Routinier

    Dabei seit:
    02.02.2012
    Beiträge:
    418
    Zustimmungen:
    0
    Was steht denn in /etc/postfix/main.cf unter 'myhostname', 'relayhost', 'mydestination' ? Du hast auch noch nicht gesagt, ob Deine Emails, die Du vermisst unter /var/mail/name liegen, sondern nur, DASS dort Emails drin sind.
     
  13. gpi

    gpi Jungspund

    Dabei seit:
    05.11.2008
    Beiträge:
    22
    Zustimmungen:
    0
    myhostname = debian.localdomain
    relayhost = firma.de
    mydestination = debian.localdoamin, localhost.localdomain, localhost

    unter /var/mail/name laden die E-Mail die ich vermisse. Vielen Dank für deine mühe :)
     
  14. #13 tgruene, 25.05.2012
    Zuletzt bearbeitet: 25.05.2012
    tgruene

    tgruene Routinier

    Dabei seit:
    02.02.2012
    Beiträge:
    418
    Zustimmungen:
    0
    postfix schreibt seine Logdatei in /var/log/mail.log (und /var/log/main.info, wobei die Dateien gleich sind). Was steht denn dort (auf dem Debian rechner) als letzter Eintrag, wenn Du eine Email an name@firma.de schickst? Es sollte der relayhost erwaehnt werden und auch der Sendestatus. Wenn nicht, kannst Du mal postfix stoppen (/etc/init.d/postfix stop) und dann von einer Kommandozeile mit 'postfix -vvv' starten. Dann sollten sehr viele Lognachrichten auf der Kommandozeile ausgegeben werden. Wenn Du dann eine Email schickst und diese Lognachrichten durchforst, steht da idealerweise, nach welchen Regeln aus der /etc/postfix/main.cf postfix die Email wie wohin verschickt - hoffe ich zumindest.
    Ach so: Danach kannst Du postfix in der Konsole mit Strg-C beenden und den normalen Service wieder mit /etc/init.d/postifx start aufnehmen.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. gpi

    gpi Jungspund

    Dabei seit:
    05.11.2008
    Beiträge:
    22
    Zustimmungen:
    0
    folgendes steht unter /var/log/mail.log

    Code:
    May 25 11:52:39 debian postfix/pickup[15174]: 98CC31A2613: uid=0 from=<root>
    May 25 11:52:39 debian postfix/cleanup[27554]: 98CC31A2613: message-id=<20120525095239.98CC31A2613@debian.localdomain>
    May 25 11:52:39 debian postfix/qmgr[15175]: 98CC31A2613: from=<root@debian.localdomain>, size=350, nrcpt=1 (queue active)
    May 25 11:52:40 debian postfix/smtp[27559]: 98CC31A2613: to=<name@firma.de>, relay=firma.de[ip-adresse]:25, delay=0.58, delays=0.1/0.01/0.3/0.17, dsn=2.0.0, status=sent (250 OK id=1SXrCC-0002DK-HW)
    May 25 11:52:40 debian postfix/qmgr[15175]: 98CC31A2613: removed
    ich habe gesucht gestern und habe etwas für eine Transport Datei gefunden. Ich habe was probiert aber ohne erfolg
     
  17. #15 tgruene, 25.05.2012
    tgruene

    tgruene Routinier

    Dabei seit:
    02.02.2012
    Beiträge:
    418
    Zustimmungen:
    0
    Und dann landet diese Datei/Mail direkt unter /var/mail??? hm. Schau doch mal mit 'less /var/mail/name' oder so den Header von dieser Email an. Dort steht, welchen Weg sie genommen hat ("Received:..."). Wird dort dann der relay-Rechner gar nicht erwaehnt?
    Stimmt die IP-Adresse (in den eckigen Klammern, wo Du 'ip-adresse' hingeschrieben hast) auch mit der IP-adresse von name.de ueberein? Oder hast Du zufaellig einen Eintrag in der /etc/hosts auf dem Debian-Rechner, in dem die IP-Adresse von name.de mit der IP-Adresse Deines Debian-Rechners ueberschrieben wird?

    Langsam gehen mir die Ideen aus, ohne direkt am Rechner zu sitzen, so leid mir das tut :-(
     
Thema:

exim4 - interne E-Mails

Die Seite wird geladen...

exim4 - interne E-Mails - Ähnliche Themen

  1. Exim4 - Faxmaster und andere Emailadressen im lokalen System eines Domänen-PCs

    Exim4 - Faxmaster und andere Emailadressen im lokalen System eines Domänen-PCs: Moin Gemeinde, ich habe viele Debian Systeme in mehreren Domains. Auf allen läuft Exim4 mit eigentlich immer derselben Konfig. Dem System wird...
  2. EXIM4 - Lokaler SMTP Server ohne Authentication

    EXIM4 - Lokaler SMTP Server ohne Authentication: Hallo Gemeinde, ich suche nach einem freien SMTP Server, der keine Authentifizierung verlangt - da dieses im WWW wohl nicht verfügbar sein wird -...
  3. Exim4: Absender nur mit Adresse

    Exim4: Absender nur mit Adresse: Hallo, ich benutze Exim 4.69 auf einem Debian Lenny. Auf einem älteren Debian Etch mit Exim 4.63 hatte ich die Absenderadresse von automatisch...
  4. exim4 für jedes empfangene Mail eine eigene Datei?

    exim4 für jedes empfangene Mail eine eigene Datei?: Hallo zusammen Habe eine kleine Frage zu exim4, welches ja die empfangenen Mails in eine Datei im Ordner /var/spool/mail anfügt. Leider sind...
  5. Kann exim4, Mails direkt in eine mySQL Datenbank speichern?

    Kann exim4, Mails direkt in eine mySQL Datenbank speichern?: Hallo zusammen Möchte meinen exim4 Mail-Server dazu bringen, dass er alle Mails die er entweder per POP3 abruft oder später auch per SMTP...