Error: Driver 'pcspkr' is already registered, aborting...

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von B-52, 30.09.2013.

  1. B-52

    B-52 Routinier

    Dabei seit:
    08.08.2011
    Beiträge:
    270
    Zustimmungen:
    0
    Ort:
    Bern (CH)
    Hallo Community,

    Wenn ich Debian 7 boote, erscheint nach ein paar Sekunden folgendes:

    Code:
    Loading, please wait...
    Init: version 2.88 booting
    Using makefile-style concurrent boot in run level S
    Starting the hotplug events dispatcher udevd
    Synthesizing the initial hotplug events... done
    Waiting for /dev/to be fully populated... [ 12.345678] Error: Driver 'pcspkr' is already registered, aborting...
    
    danach bricht der Bootvorgang ab (Blackscreen). Google bietet eine Menge Treffer zu dieser Fehlermeldung. Auch die Debian Bugs Plattform (1) äussert sich zu diesem bekannten Bug. Leider werde ich nicht schlau daraus.

    Ein weiterer Vorschlag besteht darin, das Modul unter /etc/modprobe.d/blacklist.conf auf die Blacklist zu setzten (2). Aber welches genau? Im Netz geistern dutzende von Vorschlägen herum.

    U wie in aller Welt bekomme ich Zugang zu /etc/modprobe.d/blacklist.conf, wenn der Bootvorgang einfach abbricht? Live-Systeme von Ubuntu, Knoppix und Fedora kann ich auch nicht booten.

    Ebenfalls der Bootparameter acpi=off brachte nichts. Jetzt bin ich mit meinem Latein am Ende. Im Bootmenü von GRUB kann ich zwar durch drücken von 'c' eine Shell öffnen. Es erscheint dann
    Code:
    grub>
    irgendwie bin ich hier überfordert. Versuchte mit dem Befehl configfile auf die blacklist.conf zuzugreifen. Klappt aber nicht. Irgendwas mache ich falsch...

    1) http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=495674
    2) http://debiandark.wordpress.com/2012/06/24/fix-debian-driver-pcspkr-is-already-registered-aborting/

    Gruss B-52
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 tgruene, 30.09.2013
    tgruene

    tgruene Routinier

    Dabei seit:
    02.02.2012
    Beiträge:
    418
    Zustimmungen:
    0
    Die ersten paar Treffer bei google sagen auch, dass deswegen der Bootprozess nicht abbricht - gibt es einen 'verbose' mode, mit dem Du mehr siehst als die wenigen Zeilen, die Du angibst, um rauszufinden, was wirklich der Fehler ist? Geben alle Live-Systeme, die Du auflistest, den gleichen Fehler? Wegen des Treibers fuer den Lautsprecher sollte eigentlich kein System lahmgelegt werden. Zur Not kannst Du es ja auch mal mit einem *BSD probieren.
     
  4. B-52

    B-52 Routinier

    Dabei seit:
    08.08.2011
    Beiträge:
    270
    Zustimmungen:
    0
    Ort:
    Bern (CH)
    Ja, der abgesicherte Modus plaudert zwar mehr, es ist aber unmöglich dies auch nur annähernd aufzulisten. Es geht einfach zu schnell, und danach herrsch Black Screen! Die Bootlog ist unter Debian ja Standartmässig deaktiviert, somit fällt diese Möglichkeit leider weg.
    ebenfalls Ja. Das DVD-Laufwerk gibt zwar die typischen Ladegeräusche von sich, der Bildschirm bleibt jedoch durchgehend schwarz.
    diese "Idee" wäre jedenfalls prüfenswert...

    Gruss B-52
     
  5. #4 tgruene, 30.09.2013
    tgruene

    tgruene Routinier

    Dabei seit:
    02.02.2012
    Beiträge:
    418
    Zustimmungen:
    0
    Ist der Rechner beim 'Black Screen' tot, oder koenntest Du mit einem Laptop per ssh an den Rechner kommen? Wobei Du das schon in Betracht gezogen haben koenntest.
     
  6. nighT

    nighT Guest

    Ist zwar eine ziemlich umständliche Lösung, aber:
    Kannst du die Festplatte ausbauen und per SATA/IDE-to-USB Adapter an einen anderen Linux-Rechner/Notebook anschließen, um so das Modul zu blacklisten?
     
  7. B-52

    B-52 Routinier

    Dabei seit:
    08.08.2011
    Beiträge:
    270
    Zustimmungen:
    0
    Ort:
    Bern (CH)
    der Rechner ist tot...

    Das ist eine Suggestivfrage... :-D

    Klar, das wäre durchaus machbar. Eine neue HDD oder SSD kostet aber weniger - in Relation von Aufwand und Ertrag gerechnet.

    PS: ich mache Backups auf eine externe HDD... das Wort "Datenverlust" kenne ich nicht *g*
     
  8. #7 HeadCrash, 30.09.2013
    HeadCrash

    HeadCrash Routinier

    Dabei seit:
    16.05.2009
    Beiträge:
    482
    Zustimmungen:
    1
    Ort:
    Bayern
    Wegen 'nem "vermurksten" OS 'ne neue Platte kaufen, irgendwas mach ich falsch. Wird dir aber nicht helfen, da du ja schreibst, dass du das Problem auch bei Live-Distris hast ;-)

    Ich bin der Meinung diese Meldung auch schon mal auf nem Debiansystem gesehen zu haben, allerdings hat die Kiste trotzdem gebootet.
    Mal dir restliche Hardware getestet memcheck und so?

    mfg
    HeadCrash
     
  9. #8 Goodspeed, 01.10.2013
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Man ... ich bin schon zu lange raus ... :D
    Gab es zumindest bei den Live-CDs nicht eine Möglichkeit beim Booten a) den Framebuffer für die Konsole und b) das starten des X-Servers zu unterbinden? Beides würde ich mal versuchen.
    Das während dem Booten ein Black Screen auftritt kann eigenlich nur beim Umschalten auf die graphische Konsole oder beim Starten des X-Servers passieren ...

    Und wenn das bei allen Live-CDs auftritt, scheint das auch kein Distributions-Problem zu sein. Welche Kernel-Versionen nutzen die Live-CDs? Ist das ein neuer Rechner oder lief da schon mal ein Linux?
     
  10. #9 tgruene, 01.10.2013
    tgruene

    tgruene Routinier

    Dabei seit:
    02.02.2012
    Beiträge:
    418
    Zustimmungen:
    0
    Die SystemRescue-CD startet X erst auf Verlangen und aus der Konsole heraus, so wie sich das gehoert fuer eine Rettungscd ;-)
     
  11. B-52

    B-52 Routinier

    Dabei seit:
    08.08.2011
    Beiträge:
    270
    Zustimmungen:
    0
    Ort:
    Bern (CH)
    der Rechner ist relativ neu und es lief bereits Debian 7 und Windows 8 mittels Dual Boot fehlerfrei auf der Platte. Der Fehler trat erst auf, als ich (aus reiner Neugierde) ein Debian Jessi auf eine kleine Partition installieren wollte. Erst danach bockten Debian 7 und auch die Live-Systeme.
    Das grösste Paradoxon: Windows 8 lässt sich weiterhin problemlos booten.
    alle Livesysteme sind von der neusten Generation. Das bringt mich ebenfalls auf die Idee, es mit einer älteren Distribution zu versuchen. Hach, desshalb liebe ich Linux. Jetzt ist der "Bastlerinstinkt" in mir wieder so richtig erwacht!
    hmm... interessanter Fakt! In diesem Falle versuche ich tgruene's Vorschlag mal aus:
    PS: so ganz ohne Linux bin ich ja noch nicht. Habe da noch meinen kleinen Raspberry Pi... *g*
     
  12. #11 ampromt, 01.10.2013
    ampromt

    ampromt Guest

    Also diese Meldung ist ganz sicher nicht der Grund dafür warum dein Rechner nicht will. Die Meldung gibt es schon seit Lenny - also gaaaanz schön lange. Editiere bitte deine blacklist.conf und trage dort ein > blacklist pcspkr... Du kannst dies natürlich erst machen wenn das System on ist. Die Frage ist hier, ob das System on ist, oder einfriert. Du machst auch keine Angaben welche Hardware du nutzt. Sag einmal woher hast du diese "kleine Partition"? Ich werde das Gefühl nicht los, das die Ursache hier ganz woanderrs liegt.
     
  13. B-52

    B-52 Routinier

    Dabei seit:
    08.08.2011
    Beiträge:
    270
    Zustimmungen:
    0
    Ort:
    Bern (CH)
    Das kann ich erklären! H i e r findest Du das Partitionsschema, wo alles noch in Butter war. Ich konnte Windows ab sda2 (Windowsloader) und/oder Debian und Windows 8 per GRUB ab sda5 problemlos booten.

    Dann kam die Idee, Debian Jessi zusätzlich zu installieren!

    a) die grosse Partition sda6 wurde um 100 GB verkleinert
    b) auf der soeben gewonnenen Partition "unallocated" wurde zusätzlich eine 200 MB grosse fat32 partition erstellt
    c) Debian Jessie wurde auf die freie Partition "unallocated" installiert.
    d) die fat32-Partition wurde während der Installation als EFI-Systempartition gewählt. Ohne EFI Systempartition konnte die Installation nicht fortgeführt werden.
    e) sda7 wurde automatisch als swap-Partition durch Debian gefunden.

    Die Installation lief fehlerfrei durch. Doch danach fing die Misere an. Debian lässt sich einfach nicht mehr booten. Windows 8 kann ich als einziges OS ab sda2 booten.

    Ich hoffe, den Vorgang einigermassen verständlich rekonstruiert zu haben.

    Gruss B-52
     
  14. #13 ampromt, 02.10.2013
    ampromt

    ampromt Guest

    Ich bin mir sicher das nach der Meldung mit dem "pcspkr" das Einbinden der Paritionen beginnt. Ich vermute ganz stark, dass deine Partitionen nicht gefunden werden. Das andere Live- Distributionen nicht laufen dürfte wahrscheinlich an UEFI liegen. Ich denke du solltest irgendwie versuchen ein Grub update durchlaufen zu lassen. Zum Beispiel statt Jessi würde ich Wheezy installieren, dann wird Grub ja neugeschrieben. Danach würde ich die /apt/source.list editieren und das System auf testing anheben. Vielleicht ist das ein Weg.. Frage du hast nicht zufällig Secureboot im Bios aktiviert?

    Gruß ampromt
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. B-52

    B-52 Routinier

    Dabei seit:
    08.08.2011
    Beiträge:
    270
    Zustimmungen:
    0
    Ort:
    Bern (CH)
    Nein, Secure Boot ist deaktiviert. Wheezy wurde zudem bereits neu installiert. Der Fehler bleibt jedoch bestehen... Das Partitionsschema sieht aktuell so aus, wie im Post oben verlinkt.

    Gruss B-52
     
  17. #15 Goodspeed, 02.10.2013
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Nur mal so ... wenn Du die Platte abklemmst und nur ein Live-System startest ... geht das?
     
Thema: Error: Driver 'pcspkr' is already registered, aborting...
Besucher kamen mit folgenden Suchen
  1. rmmode pcspkr for windows

Die Seite wird geladen...

Error: Driver 'pcspkr' is already registered, aborting... - Ähnliche Themen

  1. postfix - fputs-error

    postfix - fputs-error: Ich hoffe, dass sich wer von euch mit postfix bzw. der Fehlermeldung auskennt. Ich habe nach dem Youtube-Video postfix eingerichtet: [MEDIA] Nun...
  2. journal commit I/O error auf SSD

    journal commit I/O error auf SSD: Hallo zusammen Habe meiner "Sun Ultra 45" (SPARC System) eine 64GB-SSD eingebaut, und dort das OS (Debian 7) installiert. In unregelmässigen...
  3. Kein Sound im Spiel - OpenAL error

    Kein Sound im Spiel - OpenAL error: Ich hab in einem Spiel leider keinen Sound. In der Konsole kommt in einer Endlosschleife immer diese Meldung: OpenAL error: 40964 (Audio_Tick...
  4. syntax error near unexpected token `&'

    syntax error near unexpected token `&': Hallo Ich habe ein Scrip angepasst bzw. erweiter und habe nun an einer Stelle ein Problem. Vor der erweiterung ist es einwandfrei...
  5. Update error für OpenSuse 12.3 für "libsolv-tools-0.3.2-2.14.1"

    Update error für OpenSuse 12.3 für "libsolv-tools-0.3.2-2.14.1": Hallo, ich kann mein OpenSuse 12.3 nicht mehr richtig updaten. beim versuch bekomme ich folgende Meldung: ( 1/23) Installing:...