Epson DX4450 druckt nicht

Dieses Thema im Forum "Drucker / Scanner" wurde erstellt von tiefengrund, 20.06.2008.

  1. #1 tiefengrund, 20.06.2008
    tiefengrund

    tiefengrund an de wand schmiern

    Dabei seit:
    11.01.2006
    Beiträge:
    153
    Zustimmungen:
    0
    Ort:
    Wolkenstein / Erzgebirge
    Guten Tag liebe LinuxUser.

    Ich hab mir einen Epson gekauft, ein All-In-One printer, also der dx4450. Nun hab ich die Treiber installiert aber er geht nicht.

    Als Distribution hab ich sourcemage laufen, mit Kernel 2.6.24. Der Kernel spielt mit, der Drucker wird erkannt und ein device-file gibts auch.(/dev/usb/lp0). Meine CUPS Version ist die 1.3.7, als Treiber hab ich mir die Turboprint-treiber und die von avasys installiert, wobei letzteres nicht funktioniert. Beim ausführen des setups bekomme ich die Meldung "Document empty". Welches Dokument auch immer gemeint ist. Die Turboprint treiber konnte ich problemlos installieren. Der Drucker wird auch von CUPS erkannt und korrekt installiert. Er meldet auch das der Drucker bereit ist. Wenn ich einen Druckauftrag starte dann arbeitet er kurz und das wars dann auch. Hardwareseitig passiert gar nix. Softwareseitig sagt er mir :

    error.log
    Code:
    I [20/Jun/2008:13:41:28 +0200] [Job 32] Adding start banner page "none".
    I [20/Jun/2008:13:41:28 +0200] [Job 32] Adding job file of type application/postscript.
    I [20/Jun/2008:13:41:28 +0200] [Job 32] Adding end banner page "none".
    I [20/Jun/2008:13:41:28 +0200] [Job 32] Queued on "tp0" by "root".
    I [20/Jun/2008:13:41:28 +0200] [Job 32] Started filter /usr/lib/cups/filter/pstops (PID 28887)
    I [20/Jun/2008:13:41:28 +0200] [Job 32] Started filter /usr/lib/cups/filter/pstoturboprint (PID 28888)
    I [20/Jun/2008:13:41:28 +0200] [Job 32] Started backend /usr/lib/cups/backend/usb (PID 28889)
    I [20/Jun/2008:13:41:30 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=28917)
    I [20/Jun/2008:13:41:40 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=28968)
    I [20/Jun/2008:13:41:44 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=28981)
    
    
    Die LED am Drucker, die mir den Druckerstatus mitteilt leutet dauerhaft. Bekommt der Drucker was zu tun blinkt sie kurz und der Drucker geht danach aus. Das sagt mir das da irgendwas ankommt. Nur warum geht der schweigend aus ? Nun bin am ende mit meinem latein.

    Ich danke für alle Tipps...

    Mfg Hans
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 ralf_at_unixb, 20.06.2008
    ralf_at_unixb

    ralf_at_unixb Grünschnabel

    Dabei seit:
    06.06.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Mach mal ein chmod 700 auf /usr/lib/cups/backend/usb

    Hatte mal dasselbe Prob mit einem anderen Drucker. Das hat dann funktioniert.
     
  4. #3 tiefengrund, 20.06.2008
    Zuletzt bearbeitet: 20.06.2008
    tiefengrund

    tiefengrund an de wand schmiern

    Dabei seit:
    11.01.2006
    Beiträge:
    153
    Zustimmungen:
    0
    Ort:
    Wolkenstein / Erzgebirge
    chmod 700 bringt nix.

    chmod 707 bringt auch nix. Gleiches Fehlerbild

    ABER

    nach dem chmod 707 die error.log :

    Code:
    I [20/Jun/2008:14:16:57 +0200] [Job 36] Adding start banner page "none".
    I [20/Jun/2008:14:16:57 +0200] [Job 36] Adding job file of type application/postscript.
    I [20/Jun/2008:14:16:57 +0200] [Job 36] Adding end banner page "none".
    I [20/Jun/2008:14:16:57 +0200] [Job 36] Queued on "tp0" by "anonymous".
    I [20/Jun/2008:14:16:57 +0200] [Job 36] Started filter /usr/lib/cups/filter/pstops (PID 3310)
    I [20/Jun/2008:14:16:57 +0200] [Job 36] Started filter /usr/lib/cups/filter/pstoturboprint (PID 3311)
    I [20/Jun/2008:14:16:57 +0200] [Job 36] Started backend /usr/lib/cups/backend/usb (PID 3312)
    I [20/Jun/2008:14:16:59 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3333)
    I [20/Jun/2008:14:17:09 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3368)
    I [20/Jun/2008:14:17:19 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3401)
    I [20/Jun/2008:14:17:29 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3432)
    I [20/Jun/2008:14:17:40 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3466)
    I [20/Jun/2008:14:17:50 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3497)
    I [20/Jun/2008:14:18:00 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3528)
    I [20/Jun/2008:14:18:10 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3560)
    I [20/Jun/2008:14:18:20 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3592)
    I [20/Jun/2008:14:18:30 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3623)
    I [20/Jun/2008:14:18:41 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3659)
    I [20/Jun/2008:14:18:51 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3690)
    I [20/Jun/2008:14:19:01 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3722)
    I [20/Jun/2008:14:19:11 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3753)
    I [20/Jun/2008:14:19:21 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3786)
    I [20/Jun/2008:14:19:31 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3817)
    I [20/Jun/2008:14:19:42 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3848)
    I [20/Jun/2008:14:19:52 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3882)
    I [20/Jun/2008:14:20:02 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3913)
    
    

    WTF?????
     
  5. #4 ralf_at_unixb, 20.06.2008
    ralf_at_unixb

    ralf_at_unixb Grünschnabel

    Dabei seit:
    06.06.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Hast Du nach dem chmod Cups neu gestartet?
    Ansonsten interessiert ihn das nämlich nicht...
     
  6. #5 tiefengrund, 20.06.2008
    tiefengrund

    tiefengrund an de wand schmiern

    Dabei seit:
    11.01.2006
    Beiträge:
    153
    Zustimmungen:
    0
    Ort:
    Wolkenstein / Erzgebirge
    Ja hab ich. Der Drucker geht wieder aus und ich kann ihn erst nach entfernen und wiederanbringen des Netzsteckers wieder in Betrieb nehmen,
     
  7. #6 ralf_at_unixb, 20.06.2008
    ralf_at_unixb

    ralf_at_unixb Grünschnabel

    Dabei seit:
    06.06.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Dann schicke mal was an den Drucker und ruf' dann "http://localhost:631" auf.
    Zeigt er Dir dort im Bereich Drucker irgend etwas wie "Device is busy" ? Oder unter "Aufträge" nachkucken. Ist dort der Auftrag als abgearbeitet zu sehen?
     
  8. #7 tiefengrund, 20.06.2008
    tiefengrund

    tiefengrund an de wand schmiern

    Dabei seit:
    11.01.2006
    Beiträge:
    153
    Zustimmungen:
    0
    Ort:
    Wolkenstein / Erzgebirge
    tp0 (Default Printer) "Printer busy; will retry in 5 seconds..."
     
  9. #8 ralf_at_unixb, 20.06.2008
    ralf_at_unixb

    ralf_at_unixb Grünschnabel

    Dabei seit:
    06.06.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Zugriffsrechte....würde ich sagen...

    Da kann ich Dir leider nicht weiterhelfen...sorry...
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 tiefengrund, 20.06.2008
    tiefengrund

    tiefengrund an de wand schmiern

    Dabei seit:
    11.01.2006
    Beiträge:
    153
    Zustimmungen:
    0
    Ort:
    Wolkenstein / Erzgebirge
    Ich denk es sind nicht die Rechte. CUPS ist es egal ob der Drucker an ist oder nicht. Wenn er keinen Auftrag hat sagt er das er idle ist, sobald was in der Warteschlange ist geht der Drucker aus, CUPS sagt das der Drucker arbeitet, und wenn ich die Aufträge lösche meine er das er wieder bereit ist, obwohl der Drucker aus ist. Hmm. Zugriffsrecht sind das nicht, ich denk der Treiber ist schuld.

    Ich versuch ma ältere Treiber... :-(

    Aber danke dir
     
  12. #10 tiefengrund, 21.06.2008
    tiefengrund

    tiefengrund an de wand schmiern

    Dabei seit:
    11.01.2006
    Beiträge:
    153
    Zustimmungen:
    0
    Ort:
    Wolkenstein / Erzgebirge
    GELÖST

    Der Drucker druckt jetzt fleißig. Als Treiber fungiert der Gutenprint in der Version 1.96-4. Ich habe ghostscript mit cups und epson-support neu kompiliert und installiert. Der Fehler war beim backend. Als Device-URI war immer usb:/dev/usb/lp0 oder der Druckername eingetragen.

    Meine printers.conf
    Code:
    # Printer configuration file for CUPS v1.3.7
    # Written by cupsd on 2008-06-21 14:13
    <DefaultPrinter epson>
    Info EPSON Stylus DX4450
    Location hier
    DeviceURI epson:/dev/usb/lp0
    State Idle
    StateTime 1214050428
    Accepting Yes
    Shared Yes
    JobSheets none none
    QuotaPeriod 0
    PageLimit 0
    KLimit 0
    OpPolicy default
    ErrorPolicy stop-printer
    </Printer>
    
    In die Datei mime.convs ist folgende Zeile einzutragen :
    Code:
    application/postscript  application/vnd.cups-postscript 66      pstops
    
    Das wars auch schon.
     
Thema:

Epson DX4450 druckt nicht

Die Seite wird geladen...

Epson DX4450 druckt nicht - Ähnliche Themen

  1. Probleme mit Epson Stylus SX215 und Ubuntu 11.10

    Probleme mit Epson Stylus SX215 und Ubuntu 11.10: Hallo liebe Leute, unser Drucker, der Epson Stylus SX215, tut seit einem update nicht mehr das was er soll. Wenn er eine Internet-Seite ausm...
  2. Epson Stylus SX425W über WiFi einrichten

    Epson Stylus SX425W über WiFi einrichten: Hi, ich habe mich, wie amn an meiner langen Abstinenz hier merkt, gut in Linux (speziell OpenSuse 11.4) eingearbeitet und komm auch soweit klar....
  3. Epson vereinfacht Installation eigener Drucker unter Ubuntu

    Epson vereinfacht Installation eigener Drucker unter Ubuntu: Seiko Epson und die AVASYS Corporation haben ein neues Verfahren zur Installation von Epson Inkjet-Druckern unter Ubuntu vorgestellt. Das neue...
  4. Epson Stylus DX6050 Scanner tut, Drucker nicht.

    Epson Stylus DX6050 Scanner tut, Drucker nicht.: Hallo. Mal wieder ein Problem mit dem Drucker... Wie gesagt Scanner funktioniert... Drucker allerdings tot... regt sich gar nicht... keine...
  5. Epson Stylus Office BX300F: Welche Probleme sind bekannt unter Linux?

    Epson Stylus Office BX300F: Welche Probleme sind bekannt unter Linux?: Mein Vater und ich planen uns, einen 4 in 1 Multifunktionsgerät zu besorgen. Da man immer wieder munkelt von Problemen mit Drucker unter Linux,...