emerge world -> Nix geht mehr

Dieses Thema im Forum "Gentoo" wurde erstellt von schorsch312, 18.08.2006.

  1. #1 schorsch312, 18.08.2006
    Zuletzt bearbeitet: 18.08.2006
    schorsch312

    schorsch312 Routinier

    Dabei seit:
    18.07.2006
    Beiträge:
    372
    Zustimmungen:
    0
    Guten Morgen.
    Ich habe leider viele Probleme auf einmal, desshalb auch der aussagelose Titel.
    Ich habe gestern abend ein emerge world machen wollen. Es kam aber eine Fehlermeldung, dass ich zwei Packete (ich weiß leider nicht mehr welche) nicht gleichzeitig emergen könne. Ich habe also eins per --unmerge entfernt, um es nach erfolgreichem emerge world wieder zu instalieren.
    Leider hat er sich beim emerge world complett aufgehängt. Er hat auf keine Tasteneingabe irgendeiner Form reagiert, so dass ich reset drücken musste.
    Ich kann jetzt das Netzwerk nicht mehr erreichen. Ich habe das emerge world aus einer X-Konsole heraus durchgeführt. Ich finde jetzt leider die Befehle in der history nicht, ich kann also auch nicht rekonstruieren, welches Packet ich gelöscht habe.
    Falls Ihr noch weitere Informationen braucht poste ich die natürlich gerne.

    Danke für Eure Hilfe!!!
    Gruß, Georg

    Bei der nächsten Anmeldung kam folgende Fehlermeldung, sonst ist er ohne Fehlermeldung hochgefahren: Aug 18 09:30:05 Schorsch su[14051]: unknown configuration item `FAILLOG_ENAB' Aug 18 09:30:05 Schorsch su[14051]: unknown configuration item `LASTLOG_ENAB' Aug 18 09:30:05 Schorsch su[14051]: unknown configuration item `MOTD_FILE' Aug 18 09:30:05 Schorsch su[14051]: unknown configuration item `FTMP_FILE' Aug 18 09:30:05 Schorsch su[14051]: unknown configuration item `ENV_ROOTPATH' Aug 18 09:30:05 Schorsch su[14051]: unknown configuration item `PASS_MIN_LEN' Aug 18 09:30:05 Schorsch su[14051]: unknown configuration item `CHFN_AUTH' Aug 18 09:30:17 Schorsch su[14066]: unknown configuration item `FAILLOG_ENAB' Aug 18 09:30:17 Schorsch su[14066]: unknown configuration item `LASTLOG_ENAB' Aug 18 09:30:17 Schorsch su[14066]: unknown configuration item `MOTD_FILE' Aug 18 09:30:17 Schorsch su[14066]: unknown configuration item `FTMP_FILE' Aug 18 09:30:17 Schorsch su[14066]: unknown configuration item `ENV_ROOTPATH' Aug 18 09:30:17 Schorsch su[14066]: unknown configuration item `PASS_MIN_LEN' Aug 18 09:30:17 Schorsch su[14066]: unknown configuration item `CHFN_AUTH' Hier ein Ausschnitte der /var/log/emerge.log: 1155857182: === Unmerging... (sys-apps/findutils-4.1.20-r2) 1155857183: >>> unmerge success: sys-apps/findutils-4.1.20-r2 1155857183: === (50 of 50) Post-Build Cleaning (sys-apps/findutils-4.3.0::/usr/portage/s ys-apps/findutils/findutils-4.3.0.ebuild) 1155857183: ::: completed emerge (50 of 50) sys-apps/findutils-4.3.0 to / 1155857183: *** Finished. Cleaning up... 1155857184: *** exiting successfully. 1155857187: *** terminating. 1155886578: Started emerge on: Aug 18, 2006 09:36:18 1155886578: *** emerge ifdown 1155886580: *** terminating.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 DennisM, 18.08.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Kannst du mal das Ende von /var/log/emerge.log hier posten, vielleicht hast du was wichtiges gelöscht.

    MFG

    Dennis
     
  4. nikaya

    nikaya Guest

    Code:
    emerge --resume world
    könnte Dir weiterhelfen.Dann macht emerge da weiter wo er zuletzt abgebrochen hat.
     
  5. #4 schorsch312, 18.08.2006
    schorsch312

    schorsch312 Routinier

    Dabei seit:
    18.07.2006
    Beiträge:
    372
    Zustimmungen:
    0

    Das ist ja leider das Ende der emerge.log .

    ifconfig ist auch in Mitleidenschaft gezogen worden.
    Ich kriege keine IP mehr von meinem DHCP-Server, obwohl die config-Datei gut aussieht.

    ifconfig eth0 down
    +
    ifconfig eth0 up

    bringt genauso wenig wie

    ifconfig eth0 add 192.168.2.1 mask 255.255.255.1

    emerge --resume world wird dann wohl auch scheitern oder?

    Gruß, Georg
     
  6. nikaya

    nikaya Guest

    Versuch macht kluch.:)
    Für die Zukunft:In /etc/make.conf "FEATURES=parallel-fetch" eintragen.Dann werden bei Beginn eines Updates schon alle Pakete herunter geladen.
     
  7. #6 schorsch312, 20.08.2006
    schorsch312

    schorsch312 Routinier

    Dabei seit:
    18.07.2006
    Beiträge:
    372
    Zustimmungen:
    0
    Gleiche Sch.. wie vorher.
    Ich habe mich zu einer Neuinstalation entschieden, da ich bei meiner letzen eh per Genkernel gemogelt habe und jetzt ein wenig Zeit habe.
    Danke trotzem.
    Gruß, Georg
     
  8. Cyriz

    Cyriz Gehirnrentner

    Dabei seit:
    05.09.2006
    Beiträge:
    13
    Zustimmungen:
    0
    Ort:
    Berlin
    Iss zwar schon ne weile her, aber kann es sein das es "Pam" war, welches du gelöscht hast?. Denn das blockt ja immer..
     
  9. #8 wrath_of_god, 05.09.2006
    wrath_of_god

    wrath_of_god Foren As

    Dabei seit:
    06.02.2005
    Beiträge:
    93
    Zustimmungen:
    0
    ich hatte das gleiche Problem, die ToolChain ist da hinüber

    wenns Pam gewesen wäre könnte er sich ja nicht mehr einloggen ausserdem wurde pam ja durch ein anderes Packet ersetzt

    meiner Meinung nach wirds Zeit das Gentoo auch binaries anbietet, damit kann sowas nämlich nicht passieren ;)
     
  10. Cyriz

    Cyriz Gehirnrentner

    Dabei seit:
    05.09.2006
    Beiträge:
    13
    Zustimmungen:
    0
    Ort:
    Berlin
    Komplett ersetzt? Was denn da?
    Ich habs mal entfernt... weils es shadow blockte.
    "USE" mit "-pam" gesetzt, dann gleich "emerge -N shadow" und "emerge -NuD world" hinterher...
    su - und login funzte ja alles bestens... aber der Rest... man, man, man...
     
  11. #10 wrath_of_god, 05.09.2006
    wrath_of_god

    wrath_of_god Foren As

    Dabei seit:
    06.02.2005
    Beiträge:
    93
    Zustimmungen:
    0
    http://gentoo-wiki.com/HOWTO_Remove_PAM#Warnings

    wie gesagt, das einzige was da sein kann ist das du pam runtermachst und vergisst shadwo draufzutun dann kannste dich nichtmehr einloggen und musst dich rein'chroot'en ums zu fixen
     
  12. #11 DennisM, 05.09.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Naja wenn pam-login shadow blockt ist es doch klar, dass man pam-login löscht :/

    Damit ist das Problem doch schon behoben :)

    MFG

    Dennis
     
  13. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  14. #12 wrath_of_god, 06.09.2006
    wrath_of_god

    wrath_of_god Foren As

    Dabei seit:
    06.02.2005
    Beiträge:
    93
    Zustimmungen:
    0
    das Problem des Threadstarters war aber nicht pam ;)
     
  15. #13 DennisM, 06.09.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Ja aber in den vorherigen Posts ging es darum.

    MFG

    Dennis
     
Thema:

emerge world -> Nix geht mehr

Die Seite wird geladen...

emerge world -> Nix geht mehr - Ähnliche Themen

  1. emerge -vpuDN world will mehr als ich updaten

    emerge -vpuDN world will mehr als ich updaten: [GELÖST] emerge -vpuDN world will mehr als ich updaten Hallo zusammen, hatte noch aus früheren Zeiten das Packet "mozilla-firefox" als die...
  2. Probleme bei/nach emerge -avuDN world

    Probleme bei/nach emerge -avuDN world: Probleme bei/nach emerge -avuDN world[SOLVED] Hallo, ich hab in den letzten zwei Tagen Gentoo neu aufgesetzt, was auch soweit prima lief. Jetzt...
  3. xkeyboard-config Instalation schlägt fehl bei emerge world

    xkeyboard-config Instalation schlägt fehl bei emerge world: Für die Vorgeschichte möchte ich auf folgenden Thread verweisen. http://www.unixboard.de/vb3/showthread.php?t=23567 Ich habe ein emerge -uavDN...
  4. Fehlermeldung bei emerge --update --deep world

    Fehlermeldung bei emerge --update --deep world: Wenn ich updaten will passiert Folgendes: emerge --update --deep world und irgendwann kommt dann das: * Could not find a usable .config in...
  5. Probleme mit emerge -UD world bei installierten maskieren Packeten

    Probleme mit emerge -UD world bei installierten maskieren Packeten: root@server server # emerge -UDp world >>> --upgradeonly implies --update... adding --update to options. These are the packages that I would...