Einzelner Samba Benutzer kann kein Profile erzeugen

Dieses Thema im Forum "Samba" wurde erstellt von frust, 16.04.2008.

  1. frust

    frust Grünschnabel

    Dabei seit:
    16.04.2008
    Beiträge:
    3
    Zustimmungen:
    0
    Ich habe hier ein etwas seltsames Verhalten.
    Wenn ich einen neuen Benutzer im LDAP anlege und mich mit dem neuen Namen unter Vista an meiner Samba Domain anmelde, erzeugt er brav ein neues Profil-Verzeichnis und speichert dort die Einstellungen.
    Ich habe aber einen User, bei dem funktioniert das *nicht*. Wenn ich mich unter *dem* Namen anmelde mault er rum, er koennte das Profil nicht laden. Es wird auch keins erzeugt.

    Wie kann das kommen?

    Die profile stehen alle in /usr/lib/samba/profiles (drwxrwxrwx)
    und heissen username.V2 und sind (drwx------), ausser fuer den einen....

    Die home Verzeichnisse funktionieren normal. Die haben auch keine anderen Berechtigungen.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 16.04.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Was sagen denn die entsprechenden Log-files wenn du diesen user anlegst?
     
  4. frust

    frust Grünschnabel

    Dabei seit:
    16.04.2008
    Beiträge:
    3
    Zustimmungen:
    0
    Sinngemäß: open profile ... close profile
    (im Detail:
    [2008/04/16 12:01:54, 1] smbd/service.c:make_connection_snum(1033)
    lxt10 (134.169.39.131) connect to service profile initially as user frust (uid=1003, gid=10) (pid 22033)
    [2008/04/16 12:01:54, 1] smbd/service.c:make_connection_snum(1033)
    lxt10 (134.169.39.131) connect to service netlogon initially as user frust (uid=1003, gid=10) (pid 22033)
    [2008/04/16 12:01:55, 1] smbd/service.c:make_connection_snum(1033)
    lxt10 (134.169.39.131) connect to service frust initially as user frust (uid=1003, gid=10) (pid 22033)
    [2008/04/16 12:02:08, 1] smbd/service.c:close_cnum(1230)
    lxt10 (134.169.39.131) closed connection to service profile
    [2008/04/16 12:02:08, 1] smbd/service.c:close_cnum(1230)
    lxt10 (134.169.39.131) closed connection to service netlogon

    viel später:
    [2008/04/16 12:07:02, 1] smbd/service.c:close_cnum(1230)
    lxt10 (134.169.39.131) closed connection to service frust
    )
    Oben hat es nicht geklappt.

    und hier hats geklappt:
    [2008/04/16 13:37:03, 1] smbd/service.c:make_connection_snum(1033)
    lxt10 (134.169.39.131) connect to service profile initially as user lmueller (uid=12340, gid=10) (pid 23388)
    [2008/04/16 13:37:20, 1] smbd/service.c:make_connection_snum(1033)
    lxt10 (134.169.39.131) connect to service lmueller initially as user lmueller (uid=12340, gid=10) (pid 23388)
    [2008/04/16 13:37:31, 1] smbd/service.c:close_cnum(1230)
    lxt10 (134.169.39.131) closed connection to service profile
    [2008/04/16 13:37:41, 1] smbd/service.c:make_connection_snum(1033)
    lxt10 (134.169.39.131) connect to service profile initially as user lmueller (uid=12340, gid=10) (pid 23388)
    [2008/04/16 13:37:52, 1] smbd/service.c:close_cnum(1230)
    lxt10 (134.169.39.131) closed connection to service lmueller
    [2008/04/16 13:38:09, 1] smbd/service.c:close_cnum(1230)
    lxt10 (134.169.39.131) closed connection to service profile


    ich seh da nicht wirklich nen unterschied
     
  5. maxix

    maxix Eroberer

    Dabei seit:
    16.03.2006
    Beiträge:
    74
    Zustimmungen:
    0
    Klingt vielleicht blöd, die beiden User sind in den gleichen Gruppen?
     
  6. #5 frust, 17.04.2008
    Zuletzt bearbeitet: 17.04.2008
    frust

    frust Grünschnabel

    Dabei seit:
    16.04.2008
    Beiträge:
    3
    Zustimmungen:
    0
    Ja. Beide Gruppe staff + Domain-Users. Der einzige Unterschied zwischen den beiden Usern ist die UserID, die beim Funktionierenden deutlich hoeher ist. Aber das kann doch nicht die Ursache sein, oder? Ich probiere mal einen weiteren User mit niedriger UID anzulegen. Mal sehen, was passiert.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    ... also der neue User mit *noch* niedrigerer UID hat tadellos funktioniert. Ich werde mal den einen nicht funktionierenden User loeschen und neu anlegen.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Hat auch nichts gebracht. User geloescht, mit gleicher UID wieder angelegt --> geht nicht!

    Waere nicht so schlimm, wenns nicht mein eigener Account waere.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Problembehoben. Loesung:

    Es existierte mal ein user gleichen Namens lokal auf dem Windows Rechner.
    Den hatte ich geloescht und auch dessen Verzeichnis. Aaaaber:
    es existierte in der Registry noch ein Profile (SID...).bak. Nachdem ich das geloescht hatte konnte ich ueber die Samba Domain anmelden und ein Profil erzeugen. Den lokalen User mit gleichem Namen spaeter wieder anzulegen war unschaedlich. Es handelte sich also tatsaechlich um ein Windows Problem, nicht um ein Samba Problem!

    TIPP: Wenn ein Windows Rechner in eine Domain soll, sollte er vorher nur Benutzer kennen, die in der Domain garantiert nicht existieren (werden).
     
Thema:

Einzelner Samba Benutzer kann kein Profile erzeugen

Die Seite wird geladen...

Einzelner Samba Benutzer kann kein Profile erzeugen - Ähnliche Themen

  1. Implementieren eines Shell-Scripts zum Löschen einzelner Dateien

    Implementieren eines Shell-Scripts zum Löschen einzelner Dateien: Hallo , vielleicht kann mir ja hier jemand helfen. Hab ein kleines Problem mit einer Praktikumsaufgabe. Hab keine Ahnung wie ich das...
  2. Kein Sound bei einzelner Anwendung - funkt der Soundserver dazwischen?

    Kein Sound bei einzelner Anwendung - funkt der Soundserver dazwischen?: Hallo! Mein Problem ist folgendes: Ich habe das Programm TuxNES installiert, dass läuft soweit auch ganz gut nur der Sound funktioniert nicht....
  3. Systemanweisungen einzelner OS' ?

    Systemanweisungen einzelner OS' ?: Hallo! Das Topic mag vielleicht etwas verwirrend klingen, das ist es auch, da es mir schwer fällt meine Frage in worte zu fassen! Und zwar...
  4. Samba4 AD DC

    Samba4 AD DC: Hey Forum, das ist mein erster Post ich hoffe ich bin in der Richtigen section [IMG] Ich habe mit OpenSuSe 42.1 probiert einen Samba4 AD DC...
  5. Samba Active Directory SUBDOMAIN

    Samba Active Directory SUBDOMAIN: Hi, ich habe eine Samba Domäne ESC.LAN mit Samba 4.5 aufgebaut. Jetzt würde ich gern einen neuen Domänen AD im Tree MUNICH.ESC.LAN also eine...