DSL Connect via pppd scheitert - Falsche IP wird vergeben

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von sthiem, 13.02.2004.

  1. sthiem

    sthiem Grünschnabel

    Dabei seit:
    13.02.2004
    Beiträge:
    1
    Zustimmungen:
    0
    Hi,
    ich habe ein Problem mit meinem Debian-Router.
    Mir ist letztens die HDD abgeraucht und habe mich dann entschieden,
    von Suse auf Debian zu wechseln.

    Jetzt schaffe ich es aber nicht, eine funktionierende DSL-Verbindung herzustellen.
    Am Anfang war es noch möglich zu connecten, ich konnte mit
    "pppd call dsl-provider"
    eine Verbindung herstellen, ein ping auf heise.de war möglich.
    Nachdem ich dann allerdings versucht habe ppp_on_boot zu aktivieren (natürlich vorher noch das script angepasst), war es nicht mehr möglich eine Verbindung herzustellen.

    -------------------------------
    Using interface ppp0
    local IP address 10.64.64.64
    remote IP address 10.112.112.112
    -------------------------------

    Da es sich ja um eine nicht gültige IP (jedenfalls nicht von T-Online) handelt, kann auch kein ping funktionieren.

    Habe also die letzten Einstellungen rückgängig gemacht und versucht, ob es wieder wie am Anfang funktioniert. Leider ist der Fehler dann auch weiterhin vorhanden.

    Ich habe mich nach der anleitung auf adsl4linux.de gerichtet
    auch eine config mit pppoeconf ist fehlgeschlagen

    Hoffentlich könnt ihr mir sagen, was ich falsch gemacht habe, bzw. was ich ändern muss. Ich habe schon gegoogelt und auch hier im Forum gesucht, leider habe ich keine passende Antwort gefunden

    ---------------------------------------------------------------------------------------------------------
    Hier folgen noch einige relevante Ausgaben bzw. Configs:


    # /etc/ppp/pap-secrets
    #
    # This is a pap-secrets file to be used with the AUTO_PPP function of
    # mgetty. mgetty-0.99 is preconfigured to startup pppd with the login option
    # which will cause pppd to consult /etc/passwd (and /etc/shadow in turn)
    # after a user has passed this file. Don't be disturbed therfore by the fact
    # that this file defines logins with any password for users. /etc/passwd
    # (again, /etc/shadow, too) will catch passwd mismatches.
    #
    # This file should block ALL users that should not be able to do AUTO_PPP.
    # AUTO_PPP bypasses the usual login program so its necessary to list all
    # system userids with regular passwords here.
    #
    # ATTENTION: The definitions here can allow users to login without a
    # password if you don't use the login option of pppd! The mgetty Debian
    # package already provides this option; make sure you don't change that.

    # INBOUND connections

    # Every regular user can use PPP and has to use passwords from /etc/passwd
    * (none) "" *

    # UserIDs that cannot use PPP at all. Check your /etc/passwd and add any
    # other accounts that should not be able to use pppd!
    guest (none) "*" -
    master (none) "*" -
    root (none) "*" -
    support (none) "*" -
    stats (none) "*" -

    # OUTBOUND connections

    # Here you should add your userid password to connect to your providers via
    # PAP. The * means that the password is to be used for ANY host you connect
    # to. Thus you do not have to worry about the foreign machine name. Just
    # replace password with your password.
    # If you have different providers with different passwords then you better
    # remove the following line.

    "xxxxxxxxxxxxxxxxxxxxxxxxxx@t-online.de" * "xxxxxxx"

    -------------------------------------------------------------------------
    # /etc/ppp/peers/dsl-provider

    # Starten der PPPoE-Software - Das verwendete Device muss hier
    # angepasst werden!
    #pty "pppoe -I eth1"

    # Ist dieser Rechner ein Router (Masquerading), so ist folgende
    # Zeile zu verwenden!
    pty "pppoe -I eth1 -m 1452"

    # Funktioniert bei Masquerading obige Zeile nicht zufriedenstellend,
    # so sollte die folgende noch konservativere Einstellung versucht werden
    #pty "pppoe -I eth1 -m 1412"

    # Für Dial On Demand muss diese Zeile aktiviert werden
    #demand

    # Das Verbinden wird vom pppoe übernommen, ein Connect-Skript ist also
    # nicht nötig
    connect /bin/true

    # Lokale und Remote-IP-Nummer vom Server wird akzeptiert
    ipcp-accept-remote
    ipcp-accept-local

    # Der Server teilt uns den Nameserver mit
    usepeerdns

    # Nach 3 Minuten (180 s) Inaktivit\xe4t wird aufgelegt
    idle 180

    # Wir haben keine g\xfcltige Default-IP, also nehmen wir die vom
    # Provider zugewiesene
    noipdefault

    # Die Defaultroute wird auf diese Verbindung gesetzt
    defaultroute

    # Unser Login-Name beim Provider - muss exakt uebereinstimmen
    # mit /etc/ppp/pap-secrets
    user "xxxxxxxxxxxxxxx@t-online.de"
    hide-password

    # Kompression abschalten!
    noaccomp
    nopcomp
    novj
    novjccomp
    nobsdcomp
    nodeflate
    noccp

    # Wir haben kein Modem, ein Handshake ist nicht nötig
    nocrtscts

    local
    noauth

    # Wird mittlerweile direkt dem pppoe als Option übergeben, daher hier
    # deaktiviert
    # mru 1492
    # mtu 1492

    # Alle 10 s nachschauen, ob der Server noch da ist. Bei 3 "Fehlpaketen"
    # Verbindung beenden
    lcp-echo-interval 10
    lcp-echo-failure 3

    # Specifies that pppd should use a UUCP-style lock on the serial device
    # to ensure exclusive access to the device.
    lock

    # Nur zu Testzwecken sind die Meldungen im Syslog interessant
    #debug

    # Nicht in den Hintergrund "rutschen" - nur zu Testzwecken aktivieren!
    nodetach

    -----------------------------------------------------------------------------------------


    #/etc/ppp/ppp_on_boot
    #

    # The location of the ppp daemon itself (shouldn't need to be changed)
    PPPD=/usr/sbin/pppd

    # The Ethernet interface the DSL modem is connected to. If you change this,
    # you also need to edit the file /etc/ppp/peers/dsl-provider.
    INTERFACE=eth1

    # Bring the interface up
    ifconfig $INTERFACE up -arp

    $PPPD call dsl-provider

    ---------------------------------------------------------------
    sammy:/# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:50:22:40:00:84
    inet addr:192.168.0.6 Bcast:192.168.0.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:1397 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1814 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes:155356 (151.7 KiB) TX bytes:424417 (414.4 KiB)
    Interrupt:5 Base address:0xa000

    eth1 Link encap:Ethernet HWaddr 00:50:FC:A4:A9:44
    inet addr:192.168.0.66 Bcast:192.168.0.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:12 Base address:0xc000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:8 errors:0 dropped:0 overruns:0 frame:0
    TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:560 (560.0 b) TX bytes:560 (560.0 b)
    ---------------------------------------------------------------
    sammy:/# route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
    ---------------------------------------------------------------
    sammy:/# tail -f /var/log/messages
    Feb 12 17:03:59 sammy pppd[292]: Terminating on signal 2.
    Feb 12 17:03:59 sammy pppd[292]: Exit.
    Feb 12 17:05:19 sammy pppd[334]: pppd 2.4.1 started by root, uid 0
    Feb 12 17:05:19 sammy pppd[334]: Using interface ppp0
    Feb 12 17:05:19 sammy pppd[334]: local IP address 10.64.64.64
    Feb 12 17:05:19 sammy pppd[334]: remote IP address 10.112.112.112
    Feb 12 17:05:26 sammy pppd[334]: Terminating on signal 2.
    Feb 12 17:05:26 sammy pppd[334]: Exit.
    ---------------------------------------------------------------

    Sieht ganz danach aus, als ob die Routing Table "etwas" abgeändert wurde. Leider ist es mir auch nach mehrmaligem Nachlesen in diversen Howtos nicht gelungen, die Tabelle wiederherzustellen...

    Würde mich freuen, wenn wir jemand sagen könnte, wie ich die Tabelle wieder fixe bzw. welche Befehle ich dafür ausführen muss...

    Grüße
    Sebastian
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

DSL Connect via pppd scheitert - Falsche IP wird vergeben

Die Seite wird geladen...

DSL Connect via pppd scheitert - Falsche IP wird vergeben - Ähnliche Themen

  1. CIFS VFS: Server hsdesk has not responded in 120 seconds. Reconnecting...

    CIFS VFS: Server hsdesk has not responded in 120 seconds. Reconnecting...: Guten Morgen, Mein Laptop (Linux-Mint 17.1, KDE) ist über LAN und router mit meinem PC (Linux-Debian-Wheezy) verbunden. Letzterer ist als PDC...
  2. KDE Connect verbindet Android Smartphone und Linux Desktop

    KDE Connect verbindet Android Smartphone und Linux Desktop: KDE Connect ist ein Projekt des »Google Summer of Code 2013« und hat zum Ziel, verschiedene Benachrichtigungen von Android Smartphones auf den...
  3. Android connectbot und apf-firewall klappt nicht per Mobilfunknetz

    Android connectbot und apf-firewall klappt nicht per Mobilfunknetz: Hallo, ich möchte per connectbot auf meinen Debian Squeeze Server, der mit einer APF-Firewall ausgestattet ist, zugreifen. Wenn ich die...
  4. Debian Server mit Virtualbox hilfe kann nicht auf Putty Connecten :(

    Debian Server mit Virtualbox hilfe kann nicht auf Putty Connecten :(: Hallo liebe Unixboard Community :) , Ich hoffe ihr könnt mir vielleicht helfen, Ich hab auf meinem Win7 Laptop das Programm Virtualbox...
  5. curl: (7) couldn't connect to host

    curl: (7) couldn't connect to host: ---------- curl -I '<anyURL>' ---------- bringt bei mir die meldung ---------- curl: (7) couldn't connect to host ---------- hat irgendwer eine...