DSL 24h-disconnect

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von theton, 05.03.2005.

  1. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Wie kann ich beim 24h-disconnect dafür sorgen, dass sofort wieder eine neue Verbindung aufgebaut wird? 'persist' in der /etc/ppp/peers/dsl-provider scheint es irgendwie nicht zu bringen. Der pppd läuft zwar beim Disconnect weiter, baut aber keine neue Verbindung auf.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 MrFenix, 05.03.2005
    MrFenix

    MrFenix Executor

    Dabei seit:
    16.10.2004
    Beiträge:
    480
    Zustimmungen:
    0
    Ort:
    Siegen, NRW
    wie wärs mit nem crone job alle 5 minuten der irgendeine inet seite anpingt und wenn er keine response bekommt neueinwählt?
     
  4. #3 ricci007, 05.03.2005
    ricci007

    ricci007 # ~> : () { : & :; }; :

    Dabei seit:
    05.03.2005
    Beiträge:
    7
    Zustimmungen:
    0
    Vielleicht den Job einem Router uebergeben :D
     
  5. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Es geht bei dem Disconnect-Problem um einen Router.
    Wenn du was konstruktives zu sagen hast, dann mach das, ansonsten kann ich auf solche dummen Kommentare echt verzichten. Auch wenn es sich um einen Router handelt, löst sich das Problem nämlich nicht von allein. Hardware-Router/Firewall werd ich mir bestimmt nicht kaufen, solange diese Aufgabe auch ein alter PC übernehmen kann, falls du darauf anspielen wolltest.
     
  6. #5 nikster77, 06.03.2005
    nikster77

    nikster77 Routinier

    Dabei seit:
    15.03.2004
    Beiträge:
    307
    Zustimmungen:
    0
    Hmm... komisch das die persist-funktion nchts bringt... aber probier doch mal das ganze an ip-down zu binden.

    call dsl-provider (oder wie der befehl hiess) einfach in ipdown eintragen

    Niels
     
  7. #6 SethGecko, 06.03.2005
    SethGecko

    SethGecko Nich aussem Block!

    Dabei seit:
    21.09.2004
    Beiträge:
    168
    Zustimmungen:
    0
    Ort:
    Naehe FFM
    wie waere es einfach mit: ipdown und ipup... nutze rp-pppoe und das ist die einfachste loesung wie ich finde.

    muessten sich auch hier befinden... /etc/ppp/ kann imo nicht nachschauen, da ich auf der arbeit sitze.
     
  8. #7 marvin66, 06.03.2005
    Zuletzt bearbeitet: 06.03.2005
    marvin66

    marvin66 Jungspund

    Dabei seit:
    13.03.2004
    Beiträge:
    10
    Zustimmungen:
    0
    Hi theton,
    trag mal in Deine

    /etc/sysconfig/network/providers/xyz-dsl

    den Eintrag

    AUTO_RECONNECT='yes'

    ein. Der macht was er verspricht ;-)
    Bei mir sieht das ganze dann so aus

    ASKPASSWORD=
    AUTODNS=
    COUNTRY=
    DEMAND=
    DNS1=
    DNS2=
    DSLSUPPORTED=
    FIREWALL=
    HOMEPAGE=
    IDLETIME=
    AUTO_RECONNECT='yes'
    ISDNSUPPORTED=
    MODEMSUPPORTED=
    MODIFYDNS=
    PASSWORD=
    PHONE=
    PRODUCT=
    PROVIDER=
    UIMODE=
    USERNAME=

    Gruß
    marvin

    P.s. : Die Verbindung wird dadurch dann wiederhergestellt wenn eine unbeabsichtigte Trennung erfolgte. Zum Testen müßtest Du also eine unbeabsichtigte (!) Trenung simulieren.
    Es reicht also nicht aus auf KInternet zu klicken, das wäre eine beabsichtigte Trennung die nicht (!) wiederhergestellt wird.
    Stecker aus der Wand (g) entspricht dem schon eher ...
     
  9. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Nur leider benutze ich kein SuSE, sondern Ubuntu, und somit auch kein sysconfig, das weder bei Debian noch bei Ubuntu dabei ist. Die Idee mit dem Aufruf von 'pon dsl-provider' in der ip-down bringt es leider auch nicht, da das Interface ja nicht beendet wird, sondern ppp0 weiterhin als Interface existiert, selbst wenn die Verbindung vom Provider getrennt wird. :(
     
  10. #9 monarch, 06.03.2005
    monarch

    monarch Schattenparker

    Dabei seit:
    13.02.2005
    Beiträge:
    222
    Zustimmungen:
    0
    Probier mal die demand-Option vom pppd aus. Der wählt dann zwar nur wenn Daten übertragen werden sollen, verbindet sich aber neu, wenn du rausfliegst.
    Wenn er trotzdem immer eingewählt bleiben soll kannst du die idle-Option auf 2 Tage oder so etwas setzen.
     
  11. #10 StyleWarZ, 07.03.2005
    StyleWarZ

    StyleWarZ Profi Daten Verschieber

    Dabei seit:
    05.03.2004
    Beiträge:
    1.929
    Zustimmungen:
    0
    sicher nicht sie billig lösung wenn man die hardware austauscht. aber für einen 24h betrieb ist der router sicher besser geeignet. du hast je nach modell gleich noch ne firewall. ich persönlich habe meinen bei ebay gekauft (zyxel 652-r) und bin vollkommen zufrieden damit. RJ-45 rulez
     
  12. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  13. #11 Goodspeed, 07.03.2005
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Wenn ich das richtig sehe, sorgen die 3 Einträge in der dsl-provider für das reconnect:

    lcp-echo-interval 15
    lcp-echo-failure 2
    persist
     
  14. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Yo, lcp-echo-interval und lcp-echo-failure waren nicht drin, jetzt funktionierts. Thnx. :)
     
Thema:

DSL 24h-disconnect