Dreisatz configure-make-make install klappt nicht

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Tim_Tux, 07.06.2006.

  1. #1 Tim_Tux, 07.06.2006
    Zuletzt bearbeitet: 07.06.2006
    Tim_Tux

    Tim_Tux Mitglied

    Dabei seit:
    03.06.2006
    Beiträge:
    35
    Zustimmungen:
    0
    Ort:
    München
    Ich soll unter Open Suse 10.1 Apache 1.3 installieren. Da ich kein rpm gefunden habe, das ich installieren könnte, versuche ich es also aus den Quellen. Dafür habe ich mir Apache1.3 gedownloaded und will nun den klassischen Dreisatz aus ./configure --prefix=...&& make && make install durchführen.
    Schon beim ersten ./configure bekomme ich gemeldet:

    bash: configure : /bin/sh^M: bad interpreter: Datei oder Verzeichnis nicht gefunden.

    Da mir die Bedeutung von sh^M nicht klar ist und configure ja ein Shellskript ist, habe ich die Ausführung über
    /bin/sh "Pfad zu configure"
    versucht. Dabei bekomme ich aber haufenweise Meldungen der Marke "command not found" und "syntax error".

    Ratlosigkeit macht sich breit. Oder gibt es möglicherweise sogar ein rpm für Suse 10.1 welches ich downloaden kann?

    Grüße
    Tim

    Edit1: Das File wurde nicht editiert oder ähnliches und Ausführungsrechte sind freilich auch gesetzt. In der ersten Zeile des Skripts steht auch #!/bin/sh. Ich habe die Ausführung als user und root versucht und geprüft, dass der Link von /bin/sh zu /bin/bash vorhanden ist.
     
  2. Anzeige

    Schau dir mal diesen Ratgeber an. Viele Antworten inkl. passender Shell-Befehle!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 daedalus, 07.06.2006
    daedalus

    daedalus Doppel-As

    Dabei seit:
    10.07.2005
    Beiträge:
    113
    Zustimmungen:
    0
    Ort:
    Berlin
  4. #3 Tim_Tux, 07.06.2006
    Tim_Tux

    Tim_Tux Mitglied

    Dabei seit:
    03.06.2006
    Beiträge:
    35
    Zustimmungen:
    0
    Ort:
    München
    Danke für den Tip zu rpmseek, daedalus. Ich habe ein rpm für Suse 9.0 gefunden und installiert. Hat zwar noch nicht geklappt, aber ich versuche es weiter. Es gibt keine Fehlermeldung, jedoch werden die entsprechenden Dateien nicht in die vorgesehenen Verzeichnisse kopiert.
    Möglicherweise gibt es Probleme mit Suse 10.1 oder damit, dass Apache2.2.0 parallel installiert ist.

    Trotzdem interessiert mich weiterhin die Lösung für das ursprüngliche Problem. Schließlich kann die Geschichte beim nächsten Skript wieder vorfallen.
     
  5. ookami

    ookami Haudegen

    Dabei seit:
    06.07.2002
    Beiträge:
    543
    Zustimmungen:
    0
    Du mußt das fileformat von dos auf unix ändern, das kannst du z.B. mit dos2unix oder vim machen.
     
  6. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Emacs kann das auch. :) Aber is schon richtig. das ^M ist definitiv ein Windows-Zeilenumbruch. Schreib mal dem Programmierer von dem Ding und sag ihm, dass er Linux-Skripte auch unter Linux erstellen sollte. :) Allerdings kenne ich sowas von Apache eigentlich nicht. Evtl. selbst mal das configure-Skript unter Win bearbeitet?
     
  7. #6 Tim_Tux, 07.06.2006
    Zuletzt bearbeitet: 08.06.2006
    Tim_Tux

    Tim_Tux Mitglied

    Dabei seit:
    03.06.2006
    Beiträge:
    35
    Zustimmungen:
    0
    Ort:
    München
    Klasse, die Lösung scheint gefunden. Es lag tatsächlich am Dosformat. Ich habe das File komischerweise niemals unter Dos/Windows geöffnet. Windose nimmt nämlich keinen wertvollen Speicherplatz auf dem Rechner mehr weg :D
    Selbst unter Linux habe ich mir den Inhalt nur mit einem Pager (less) angesehen.

    Ich habe nochmal nachgeprüft, ob ich beim Download evtl. etwas falsch gemacht habe, doch es waren mit Sicherheit die Unix-Sources. Überrascht mich auch bei apache.org. Werde eine kurze Mail an die Kontaktadresse schreiben.

    Dos2Unix ist ein nettes Tool und war mir bislang noch gar nicht bekannt. Also vielen Dank an Euch.
    Bin froh, mich im Forum angemeldet zu haben und kann sicher auch einmal behilflich sein. :-)

    Grüße
    Tim

    Edit1: Lösung vollzogen:
    Da sämtliche Dateien in den Unterordern im Dos-Format waren habe ich natürlich eine rekursive funktion von Dos2Unix gesucht. Diese existiert so nicht. Das Skript
    for f in $(find -type f); do file $f | grep -q ASCII && dos2unix $f; done
    ändert nicht alle Dateien, ist aber sicher ausbaufähig.

    Jedenfalls hat zip/unzip mir bei der Lösung geholfen. Der Parameter -a wandelt in ASCII konformes Format um (genaue Erläuterung in man zip ;-)). Außerdem sollte man darauf achten, dass man beim Download nicht im binary, sonern im ascii Modus arbeitet.

    Ich habe das mal editiert, weil ich glaube, dass der Tip recht hilfreich sein kann.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Dreisatz configure-make-make install klappt nicht