[Debian]Waiting for root filesystem...

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von SiS, 01.07.2007.

  1. SiS

    SiS Routinier

    Dabei seit:
    12.02.2007
    Beiträge:
    318
    Zustimmungen:
    0
    Hallo,

    So hab heute mein Debian geupdated...letztes Update was schon etwas her und auch ein neuer Kernel wurde mit installiert!
    Beim einrichten kam dann eine Meldung, dass ein neuer Kernel installiert wurde, der aber nur Änderungen in der Modulkonfiguration hat (??) oder so ähnlich, und dass ich möglichst bald neustarten soll. Das hab ich dann auch gemacht, nachdem apt-get fertig war.

    Beim starten blieb er dann aber bei dieser Meldung hier hängen:
    Hab in einem anderen Forum gelesen, man solle mit Knoppix booten, die Root-Partition mounten, eine chroot umgebung erstellen und danach ein "aptitude install udev" ausführen! Das hat aber nur 3-4 libs rausgeworfen und nach einem Neustart kam nur wieder die oben genannte Meldung!

    Wie bekomm ich mein Debian wieder zum laufen?
    Am besten ohne neuinstall, da ich es nun soweit hatte, das alles soweit läuft wie ich es will.

    Danke im Vorraus,
    SiS
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 z-shell, 01.07.2007
    z-shell

    z-shell Debianator

    Dabei seit:
    30.05.2007
    Beiträge:
    434
    Zustimmungen:
    0
    Ort:
    /home/z-shell
    Live-CD rein, (welche ist egal) systemdevice mounten, und dann editiere deine /boot/grub/menu.list
    Suche nach den Eintägen:
    Code:
    title           
    root            
    kernel          
    initrd          
    
    Sollte dann ungefähr so aussehen:
    Code:
    title           Debian GNU/Linux, kernel 2.6.18-4-686
    root            (hd0,0)
    kernel          /boot/vmlinuz-2.6.18-4-686 root=/dev/hda1 ro vga=791
    initrd          /boot/initrd.img-2.6.18-4-686
    
    Musst du natürlich entsprechend anpassen.

    Oder du versuchst
    Code:
     update-grub
     
  4. SiS

    SiS Routinier

    Dabei seit:
    12.02.2007
    Beiträge:
    318
    Zustimmungen:
    0
    Ahh danke, der tipp mit der grub config war gut, hab da vorher garnich dadran gedacht!

    Jetzt weiß ich auch in etwa was beim Update passiert ist:
    Der Updater hat meine Grub-Config neugeschrieben, da ich aber einen zusätzlichen IDE-Controller in meinem Rechner habe, dachte der wohl ich hätte SCSI und hat die Platte deshalb wohl für /dev/sda1 gehalten!
    Ich hab das jetzt einfach auf den tatsächlichen Pfad zurück gestellt und jetzt rennt die Kiste wieder!

    Danke!
     
  5. #4 Bayernjoerg, 09.09.2007
    Bayernjoerg

    Bayernjoerg Tripel-As

    Dabei seit:
    24.03.2004
    Beiträge:
    184
    Zustimmungen:
    0
    Ort:
    Bayern
    Bei mir reichte das nicht. Der alte kernel 2.4.27 rennt, hat dieselben Einstellungen wie der 2.6.18 in der menu.lst. Den 2.6.22 hab ich mal aussen vor gelassen. Warten auf das root file system tut man dennoch ewig. Irgendwann rebootet man. Funktioniert nicht. Kein Hinweis drauf, was es sein könnte.

    Gibt´s denn nix, wo man sich halbwegs mal informieren kann, was sich da manche Programmierjungs so einfallen lassen ? Nach dem dist-upgrade kenn ich den Rechner nimmer wieder.
     
  6. #5 Goodspeed, 09.09.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Mal mit sowas wie "apci=off" oder "noapic" versucht?
    Sind das "normale" IDE-Platten?
     
  7. #6 Bayernjoerg, 09.09.2007
    Bayernjoerg

    Bayernjoerg Tripel-As

    Dabei seit:
    24.03.2004
    Beiträge:
    184
    Zustimmungen:
    0
    Ort:
    Bayern
    Hab´s jetzt mal durchlaufen lassen und bin spazieren gegangen.

    Danach kam diese Meldung: "Check root=bootarg cat /proc/cmdline or missing modules, devices:cat /proc/modules ls /dev ALERT! dev/hda3 does not exist. dropping to a shell /bin/sh: can´t access tty; job control turned off (initramfs)"

    Dev/hda3 war´s immer schon und alles funzt mit 2.4.27 (abgesehen von der hardware- Unterstützung von sound. Wenigstens hab ich unter 2.4.27 X11.

    "apci=off" "noapic" oh Gott, wo war das nochmal einzustellen?

    Hängt das mit diesem "udev" zusammen ?

    Irgendwie nicht mein Tag heute.
     
  8. #7 Goodspeed, 09.09.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Stichwort: Bootparameter

    udev sollte ja nun installiert sein ... hoffe ich für Dich.

    Das ist der 2.6.18-Debian-Standard-Kernel?

    Und nochmal: Das ist eine normale IDE- und keine SATA-Platte, oder?
     
  9. #8 Bayernjoerg, 09.09.2007
    Bayernjoerg

    Bayernjoerg Tripel-As

    Dabei seit:
    24.03.2004
    Beiträge:
    184
    Zustimmungen:
    0
    Ort:
    Bayern
    Stichwort ist gut, denke das müsste man irgendwo eingrenzen können.

    udev : ja, 0.105-4,

    00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA Storage Controller IDE (rev 02) liefert lspci. Also SATA.

    Der 2.6.18 war das, was ich per apt-get dist-upgrade auf die Platte gebeamt bekommen hab.

    Aufgrund Deiner Fragestellung vermute ich, daß hier das IDE/SATA- Thema relevant sein dürfte ?
     
  10. #9 Goodspeed, 09.09.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Versuch mal als Device /dev/sdaX statt /dev/hdaX ...
     
  11. #10 Bayernjoerg, 09.09.2007
    Bayernjoerg

    Bayernjoerg Tripel-As

    Dabei seit:
    24.03.2004
    Beiträge:
    184
    Zustimmungen:
    0
    Ort:
    Bayern
    Ich verneige mich

    dem großen Weisen !

    Schätze, das war´s, jetzt funzt zum ersten Mal auch hotplug mit USB- Sticks. Geil ! Lange danach gesucht.

    Jetzt nur noch wissen, wo man sie unpluggen kann. Oder ´a la mepis oder kanotix auf dem Desktop entfernen und neudarstellen kann.

    Gierig ich geworden bin: Solche Weisheiten gibt´s doch irgendwo auch als wiki o.ä. Schätze, mein debian.anwenderhandbuch.de ist etwas veraltet.
     
  12. #11 Goodspeed, 10.09.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    *feix* ... "jahrelange Erfahrung" oder "ständiges selbst auf die Nase fallen" nennt man sowas ;)

    Viele Sachen zum 2.6er hat man aus dem post-halloween Dokument ... und den Changes von kernel.org.
    Die SATA-Geschichte hat sich glaub ich seit dem ersten Pre-Release des 2.6ers schon 3mal geändert ... aber man gewöhnt sich dran ;)
    Zu den ganzen "automatisch und bunt" Geschichten darfste mich allerdings nicht fragen ...
     
  13. #12 Bayernjoerg, 10.09.2007
    Bayernjoerg

    Bayernjoerg Tripel-As

    Dabei seit:
    24.03.2004
    Beiträge:
    184
    Zustimmungen:
    0
    Ort:
    Bayern
    Also schlicht learning by doing ohne Handbuch.

    Ähnlich dem CAD- Sektor halt auch. Gut zu wissen.
     
  14. #13 Goodspeed, 10.09.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Nein ... eher "learning by doing" mit Handbuch ;)
    Denn das, was im Handbuh steht, kannste durch lesen schneller lernen als durch Fehler ...
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Bayernjoerg, 10.09.2007
    Bayernjoerg

    Bayernjoerg Tripel-As

    Dabei seit:
    24.03.2004
    Beiträge:
    184
    Zustimmungen:
    0
    Ort:
    Bayern
    darauf komme ich gerne zurück, wenn´s ans Audio- System geht, da hakelts auch noch.
     
  17. #15 ShadowDancer, 13.09.2007
    ShadowDancer

    ShadowDancer Grünschnabel

    Dabei seit:
    08.08.2007
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo,

    ich bekomme derzeit die gleiche Meldung.

    Code:
    Begin: Waiting fpr root file system ... ...
    Done.
    Check rppt= bootarg cat /proc/cmdline
    or missing modules, devices: cat /proc/modules ls /dev
    ALERT! /dev/sda1 does not exist. Dropping to a shell!
    
    BusyBox v1.1.3 (Debian 1:1.1.3-4) Build-in shell (ash)
    Enter 'hel' for a list of built-in commands.
    
    /bin/sh: can´t access tty: job control turned off
    (initramfs)
    Ich habe versucht ein Update vom 2.6.18. Kernel auf einen 2.6.21.7 Kernel vorzunehmen. Als .config hatte ich die Config vom 2.6.18-5 genommen, make menuconfig > make-kpkg kernel_image --initrd und schlussendlich den "neuen" Kernel mit "dpkg -i linux-kernel-2.6.21.17.deb" installiert.
    Lief auch alles ohne Probleme und Fehler durch.
    Der Eintrag in der "boot/grub/menu.lst" weist auch auf /dev/sda1 hin, die fstab sieht auch ok aus.
    Ich kann das System auch noch mit dem 2.6.18 Kernel starten.

    Hat jemand eine Idee und kann mir weiterhelfen ?
    Danke :)

    Tante Edit: Achso, ergänzend sei noch zu erwähnen. Ich habe das ganze derzeit zum Test auf einer VM-Ware laufen.
     
Thema:

[Debian]Waiting for root filesystem...

Die Seite wird geladen...

[Debian]Waiting for root filesystem... - Ähnliche Themen

  1. Logs von debsecan, tiger, chkrootkit richtig auswerten.

    Logs von debsecan, tiger, chkrootkit richtig auswerten.: Hallo! ich habe debsecan drüber laufen lassen und der zeigt mir einen Haufen an low/medium/high urgency an, mit oder ohne remotly exploitable....
  2. Root Login nach installation ohne Desktop Environment

    Root Login nach installation ohne Desktop Environment: Hey, Ich habe mir gerade Linux Debian 8 auf meinen alten PC gezogen und bei Desktop Environment das Sternchen rausgenommen, da das ja bei nem...
  3. Rootserver für Linux

    Rootserver für Linux: Hallo liebe Profis, ich arbeite nun schon seit Längerem mit Linux. Habe es privat als Betreibssystem. Nun will ich für ein Internetprojekt...
  4. openn SuSE 13.1 - 64-BIt erlaubt nicht mehr als 20GB für /root

    openn SuSE 13.1 - 64-BIt erlaubt nicht mehr als 20GB für /root: Aus früheren Versionen von SuSE-Linux kenne ich es noch so, dass es keine gesonderte /home-Partition gab, sondern diese sich auf derselben...
  5. Krusader, Root- bzw Administratorrecht

    Krusader, Root- bzw Administratorrecht: Moinsen, Unter Windows2000 habe ich den Totalcommander verwendet, unter Ubuntu habe ich Krusader installiert. Allerdings wird mir der Zugriff...