Debian Installer: "Kein partitionierbares Medium gefunden"

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von raz667, 12.10.2006.

  1. raz667

    raz667 Eroberer

    Dabei seit:
    16.05.2006
    Beiträge:
    73
    Zustimmungen:
    0
    Hallo zusammen,

    ich, als fortgeschrittener Linux-Anfänger, würde gerne auf Debian "Sarge" umsteigen, stoße jedoch bereits bei der Installation auf Probleme, welche eine Installation nicht zulassen.

    Das Problem äußert sich wie folgt:

    Zum einen wird mir gesagt, dass sich meine Netzwerkkarte (82801G (ICH7 Familiy) Lan Controller)) nicht finden lassen würde und wenn ich den Schritt in der Hardwareerkennung überspringe, folgt gleich die nächste Fehlermeldung, dass kein partitionierbares Medium gefunden werden könne.

    Habe diesbezüglich mal rumgegooglet und bin auf viele Forenbeiträge gestoßen, in welchen dasselbe Problem behandelt wird. Eine Lösung war dort aber leider nicht vorhanden.

    Immerhin konnte ich in Erfahrung bringen, dass es wohl mit einem veralteten Kernel zusammenhängt und dass man in die Installationsroutine einen anderen, neueren Kernel verbauen könne, mit dem es dann klappen soll.

    Jetzt meine Fragen:
    a) Geht das wirklich so oder muss ich auf Debian verzichten?
    und b) Wie geht das? Gibts dafür irgendwo ein ausführliches Tutorial?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Boote mal beim Installer den 2.6er-Kernel. Siehe dazu die erweiterten Boot-Parameter im Boot-Screen des Installers.
     
  4. raz667

    raz667 Eroberer

    Dabei seit:
    16.05.2006
    Beiträge:
    73
    Zustimmungen:
    0
    Bereits probiert. Brachte leider keine Abhilfe.
     
  5. #4 Goodspeed, 13.10.2006
    Zuletzt bearbeitet: 13.10.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Dann versuch mal den Etch-Installer ... da kannste auch wählen, welche Version installiert werden soll.
    Der Sarge Installer ist für die neuen Intel-Geschichten einfach zu alt ... bzw. der 2.6.8er Kernel ...

    Und da Etch zu Weihnachten eh stable werden soll ;)
     
  6. raz667

    raz667 Eroberer

    Dabei seit:
    16.05.2006
    Beiträge:
    73
    Zustimmungen:
    0
    Okay... mit dem Etch-Installer hat es dann wohl auch geklappt und das System konnte ohne weitere Komplikationen installiert werden.
    Nun tritt bei mir aber ein Problem auf, welches ich schon mit jeder anderen Distribution (ausser OpenSuse10.1) hatte. Bisher konnte ich es immer lösen, nur bei Debian komm ich noch nicht weiter.

    Und zwar ist das Problem, dass X nach der Installation nicht startet. Dieses Problem hängt vermutlich mit meiner Grafikkarte (ATI Radeon X600) und dem Treiber zusammen. Ich bekomme als Fehlermeldung immer "no screens found".

    Bei Ubuntu konnte ich das Problem mit "sudo dpkg-reconfigure xserver-xorg" lösen, indem ich dort den VESA-Treiber wählte.
    Bei Debian funzt leider selbst das nicht und ich erhalte weiterhin die Meldung, dass "no screens gefounded" werden. :/

    Wer kann mir da weiterhelfen?
     
  7. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Wichtig wäre mal deine XF86Config-4 zu sehen. Ich vermute aber mal, dass du erst den fglrx-Treiber installieren musst, damit deine Karte korrekt läuft. Allerdings weiss ich nicht, ob der XFree86 überhaupt noch unterstützt. Müsstest du mal auf der ATI-Homepage nachschauen.
    Im Notfall dürfte aber der Framebuffer-XServer weiterhelfen. Einfach den Kernel mit dem entsprechenden VGA-Parameter starten (z.B. vga=0x317 für eine Auflösung von 1024x768x16) und als XServer dann fbdev verwenden, welcher auf die gleiche Auflösung wie der Kernel gestellt werden sollte, damit es möglichst wenig Komplikationen gibt.
    Ubuntu nutzt im übrigen Xorg, das, meiner Meinung nach, nicht mehr viel mit XFree86 gemeinsam hat, da es weitaus bessere Unterstützung auch für neuere Grafikkarten bietet.
     
  8. raz667

    raz667 Eroberer

    Dabei seit:
    16.05.2006
    Beiträge:
    73
    Zustimmungen:
    0
    wird aber schwierig die zu posten, da ich ja ohne grafisches interface erstmal nicht online komm. ;) Zumindest nicht mit meinen Fähigkeiten. (bin grad im Windows on)

    Aber möglicherweise hilft es ja, wenn ich mir den Ati-Treiber auf die Platte saug und dann installiere, oder?
     
  9. #8 Goodspeed, 16.10.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Die nächste Frage wäre auch ... was haste denn nun installiert? (stable, testing, unstable)
     
  10. raz667

    raz667 Eroberer

    Dabei seit:
    16.05.2006
    Beiträge:
    73
    Zustimmungen:
    0
    testing :)
    stable führte zu probs in der hardwareerkennung, weg. des älteren kernels
     
  11. #10 Goodspeed, 16.10.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Hast Du auch die 2 Pakete installiert:
    Code:
    xserver-xorg-video-vesa
    xserver-xorg-video-ati
    
    Und die Ausgabe von
    Code:
    cat /var/log/Xorg.0.log | grep EE
    
    wäre auch noch interessant ...
     
  12. raz667

    raz667 Eroberer

    Dabei seit:
    16.05.2006
    Beiträge:
    73
    Zustimmungen:
    0
    Hi,

    also das Prob mit dem Grafiktreiber konnte ich mittlerweile lösen.
    Ich musste den Vesa-Treiber manuell in die xorg.conf schreiben, da es über dpkg-reconfigure aus irgendeinem Grunde nicht ging.
    Das Grafiksystem läuft jetzt also.

    Nun hab ich aber schon wieder ein Problem und hoffe auf Hilfe: :D
    Und zwar hab ich Debian Etch über die netinst-cd installiert. Als Standard-DM wurde Gnome installiert.
    Da ich aber lieber mit KDE arbeite, habe ich es nachträglich noch installiert.
    Blöderweise kommt es jetzt zu einem Mischmasch der Tools von beiden dms.
    Unter KDE hab ich neben den KDE-eigenen Programmen auch noch alle Programme aus Gnome und umgekehrt.

    Lässt sich das einstellen, dass unter jedem DM jwl. nur die DM-eigenen Programme angezeigt werden? Finde das sonst ein wenig unübersichtlich...

    Gruß,
    raz
     
  13. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  14. #12 Goodspeed, 16.10.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Nein ... aber für sowas gibts Menu-Editoren ...
     
  15. #13 kbdcalls, 16.10.2006
    kbdcalls

    kbdcalls Master of Universe

    Dabei seit:
    16.10.2006
    Beiträge:
    518
    Zustimmungen:
    0
    Schieb die Config auf mit Fat32 formatierten USB Stick, auch das Logfile des Xservers.

    Code:
    /var/log/Xorg.0.log
     
Thema:

Debian Installer: "Kein partitionierbares Medium gefunden"

Die Seite wird geladen...

Debian Installer: "Kein partitionierbares Medium gefunden" - Ähnliche Themen

  1. Debian Stretch: Installer erreicht erste Alpha

    Debian Stretch: Installer erreicht erste Alpha: Die erste Alphaversion des Debian-Installers 9.0 läutet eine neue Phase der Debian-Entwicklung ein. Trotzdem ist Debian 9 noch fast zwei Jahre...
  2. Zweite Betaversion des Installers für Debian 8 »Jessie«

    Zweite Betaversion des Installers für Debian 8 »Jessie«: Nachdem Mitte August die erste Fassung erschienen war, erfolgte nun die Fertigstellung der zweiten Betaversion des Installers für Debian 8...
  3. Die zweite Beta-Version des Installer für Debian 8 »Jessie« ist fertig

    Die zweite Beta-Version des Installer für Debian 8 »Jessie« ist fertig: Nachdem Mitte August die erste Fassung erschienen war, erfolgt nun die Fertigstellung der zweiten Version des Installers für Debian 8 »Jessie«. Er...
  4. Debian-Installer in Version 8.0 Beta1 erschienen

    Debian-Installer in Version 8.0 Beta1 erschienen: Die erste Betaversion des Debian-Installers 8.0 ist jetzt verfügbar und erlaubt einen Ausblick und Test der kommenden Debian-Version. Weiterlesen...
  5. Debian Jessie: Installer erreicht erste Alpha

    Debian Jessie: Installer erreicht erste Alpha: Die erste Alphaversion des Debian-Installers 8.0 läutet eine neue Phase der Debian-Entwicklung ein. Da der Feature-Freeze für November geplant...