Debian 5 - bash interpretiert ü als Steuerzeichen

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Gast123, 16.09.2014.

  1. #1 Gast123, 16.09.2014
    Zuletzt von einem Moderator bearbeitet: 17.09.2014
    Gast123

    Gast123 Guest

    [gelöst] Debian 5 - bash interpretiert ü als Steuerzeichen

    Vorab: Ich weis, Debian 5 ist out of Date.

    Ich wollte gerade mit grep nach einem String in einer Datei suchen und wurde davon überrrascht, dass mir die Shell beim einfügen des Strings aus meinem Client über SSH irgend ein Kommando aus der .bash_history ausgab, anstelle den String in die Eingabeaufforderung einzufügen.
    Ich konnte das Problem dahingehend eingrenzen, dass dies beim Eintippen des Buchstabens 'ü' passiert.
    Wie kann das sein und wie kann ich das Problem beheben?

    MfG,

    Schard

    PS:
    Hier führe ich ein cd und danach ein ls "normal" aus.
    Danach drücke ich abwechselnd [ü] und [Enter]:
    [video=youtube;4C45ktpqilM]https://www.youtube.com/watch?v=4C45ktpqilM[/video]
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 16.09.2014
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Das geschieht üblicherweise wenn die Lokalisierungs-Umgebungsvariablen auf 'C' oder gar nicht gesetzt sind. Was gibt dir 'printenv |grep LC' aus?
     
  4. #3 Gast123, 16.09.2014
    Gast123

    Gast123 Guest

    Nix... also wohl nicht gesetzt.
    Code:
    alt:~# printenv |grep LC
    alt:~# 
    
     
  5. #4 bitmuncher, 16.09.2014
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    In dem Fall wird LC_* auf C gesetzt. Das ist bei den meisten Linux-Distros der Fallback. Du kannst das Verhalten ändern, indem du folgende Settings in deine .bashrc einträgst und deine Shell neu startest:

    Code:
    export LC_ALL=de_DE.UTF-8
    export LANG=de_DE.UTF-8
    export LANGUAGE=de_DE.UTF-8
    
    Vorraussetzung ist natürlich, dass diese Locales in deinem System auch vorhanden sind. Unter Debian kannst du das mittels 'dpkg-reconfigure locales' sicherstellen.
     
  6. #5 Gast123, 17.09.2014
    Gast123

    Gast123 Guest

    Das
    Code:
    dpkg-reconfigure locales
    war das Zauberwort.
    Danke dir! :)
     
Thema:

Debian 5 - bash interpretiert ü als Steuerzeichen

Die Seite wird geladen...

Debian 5 - bash interpretiert ü als Steuerzeichen - Ähnliche Themen

  1. Bashscript aus Debian6 läuft nicht auf Debian7

    Bashscript aus Debian6 läuft nicht auf Debian7: Hallo an alle, nachdem ich ein Skript von squeeze auf wheezy kopiert habe und ausführte, erschienen gleich wilde Fehlermeldungen, nach denen ich...
  2. Debian: Bash-Skript darf nur (weiter)laufen, wenn Bildschirmschoner an

    Debian: Bash-Skript darf nur (weiter)laufen, wenn Bildschirmschoner an: Hallo zusammen, ich bräuchte mal einen Hinweis. Ziel ist es, dass das Bash-Skript nur läuft, wenn der PC gerade nicht benutzt wird. Ich dachte...
  3. Wiederherstellen von überschriebenen Dokumenten auf debian samba

    Wiederherstellen von überschriebenen Dokumenten auf debian samba: Ich habe ein Problem. Vor Kurzem hat der Trojaner cryptologer einen Schaden eingerichtet. Glücklicherweise gab es eine Sicherung auf...
  4. Debian Samba 4.2.10+dfsg-0+deb8u3 Password wrong -Windows DC

    Debian Samba 4.2.10+dfsg-0+deb8u3 Password wrong -Windows DC: Hallo, ich habe einen debian Samba-Server mit share´s ohne Domäne aufgesetzt, d.h. "standalone". Wenn ich von Windows-Clients mit...
  5. Debian VM Klonen und parallel betreiben? Systemanpassungen

    Debian VM Klonen und parallel betreiben? Systemanpassungen: Hallo, ich habe vor eine Debian Maschine als Prototyp aufzusetzen... (als vSphere VM).... Diese Maschine will ich dann x-mal klonen und in div....