Debian 5.0.6 hat Hänger bei Datenlast

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Gecko, 20.10.2010.

  1. #1 Gecko, 20.10.2010
    Zuletzt bearbeitet: 20.10.2010
    Gecko

    Gecko Jungspund

    Dabei seit:
    21.01.2006
    Beiträge:
    18
    Zustimmungen:
    0
    Hi Board,

    kurz zu meiner NAS: 2x Seagate 1,5TB im RAID1 mit mdadm, Debian 5.0.6 mit 2.6.32er Backports-Kernel auf 32Bit Basis.

    Meine NAS wirft in '/var/log/messages' folgende Fehler:
    Code:
    Oct 19 20:47:57 diskette kernel: [  279.856019] ata1: link is slow to respond, please be patient (ready=0)
    Oct 19 20:48:02 diskette kernel: [  284.840019] ata1: device not ready (errno=-16), forcing hardreset
    Oct 19 20:48:02 diskette kernel: [  284.840079] ata1: soft resetting link
    Oct 19 20:48:02 diskette kernel: [  285.167681] ata1.00: configured for UDMA/133
    Oct 19 20:48:02 diskette kernel: [  285.180556] ata1.01: configured for UDMA/133
    Oct 19 20:48:02 diskette kernel: [  285.180605] ata1.01: device reported invalid CHS sector 0
    Oct 19 20:48:02 diskette kernel: [  285.180662] ata1: EH complete
    
    Diese decken sich ganz gut mit dem Abspielen von HD-Inhalten übers Netzwerk (AFP und/oder SMB). Mit atop sehe ich beim Start des Abspielens eine erhöhte Last beider HDDs, klar... Dann hängt Video und Audio, die Last der HDDs verschwindet, atop läuft weiter, ansonsten ist die NAS nicht brauchbar. Das ist ungefähr 10-20 Sekunden der Fall, dann erscheinen obige Fehler im messages-Log.

    Nun habe ich schon für beide Platten den SMART long-Test und auch die Seagate Seatools laufen lassen. Bei beiden Malen hat es nichts gefunden.

    Ich habe zu dem Problem auch schon diesen Beitrag gelesen, allerdings ohne Erfolg. Auch die Temperaturen meiner NAS sind 'in Ordnung' (42/51°C).

    Mit den GRUB-Optionen acpi=off ahci=off habe ich auch schon experimentiert, die Probleme (siehe oben) ließen aber nicht lange auf sich warten.

    Die BIOS-Einstellungen habe ich derweil auch wieder auf die Default-Werte gesetzt, weil ich dachte, dass ich da iwas verstellt habe. Auch nix.

    Hat zu der Sache noch jemand eine Idee?


    Vielen Dank und beste Grüße,
    Daniel

    //edit 2010-10-20 19:10 Uhr:

    So sieht übrigens die Ausgabe mit dem 2.6.26er Kernel aus, also direkt aus den Distributions-Repositories:
    Code:
    Oct 20 19:02:53 diskette kernel: [  349.258563]          res 40/00:01:00:4f:c2/00:00:00:00:00/10 Emask 0x4 (timeout)
    Oct 20 19:02:58 diskette kernel: [  354.298475] ata1: link is slow to respond, please be patient (ready=0)
    Oct 20 19:03:03 diskette kernel: [  359.285953] ata1: device not ready (errno=-16), forcing hardreset
    Oct 20 19:03:03 diskette kernel: [  359.286010] ata1: soft resetting link
    Oct 20 19:03:03 diskette kernel: [  359.606967] ata1.00: configured for UDMA/133
    Oct 20 19:03:03 diskette kernel: [  359.626899] ata1.01: configured for UDMA/133
    Oct 20 19:03:03 diskette kernel: [  359.626899] ata1: EH complete
    Oct 20 19:03:03 diskette kernel: [  359.626899] sd 0:0:0:0: [sda] 2930277168 512-byte hardware sectors (1500302 MB)
    Oct 20 19:03:03 diskette kernel: [  359.654898] md: super_written gets error=-5, uptodate=0
    Oct 20 19:03:03 diskette kernel: [  359.654898] raid1: Operation continuing on 1 devices.
    Oct 20 19:03:03 diskette kernel: [  359.654898] sd 0:0:0:0: [sda] Write Protect is off
    Oct 20 19:03:03 diskette kernel: [  359.654898] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    Oct 20 19:03:03 diskette kernel: [  359.702898] sd 0:0:1:0: [sdb] 2930277168 512-byte hardware sectors (1500302 MB)
    Oct 20 19:03:03 diskette kernel: [  359.702898] sd 0:0:1:0: [sdb] Write Protect is off
    Oct 20 19:03:03 diskette kernel: [  359.726899] sd 0:0:1:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    Oct 20 19:03:03 diskette kernel: [  359.744214] sd 0:0:0:0: [sda] 2930277168 512-byte hardware sectors (1500302 MB)
    Oct 20 19:03:03 diskette kernel: [  359.746065] sd 0:0:0:0: [sda] Write Protect is off
    Oct 20 19:03:03 diskette kernel: [  359.770579] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    Oct 20 19:03:03 diskette kernel: [  359.770579] RAID1 conf printout:
    Oct 20 19:03:03 diskette kernel: [  359.770579]  --- wd:1 rd:2
    Oct 20 19:03:03 diskette kernel: [  359.770579]  disk 0, wo:0, o:1, dev:sda1
    Oct 20 19:03:03 diskette kernel: [  359.770579]  disk 1, wo:1, o:0, dev:sdb1
    Oct 20 19:03:03 diskette kernel: [  359.770975] sd 0:0:1:0: [sdb] 2930277168 512-byte hardware sectors (1500302 MB)
    Oct 20 19:03:03 diskette kernel: [  359.770975] sd 0:0:1:0: [sdb] Write Protect is off
    Oct 20 19:03:03 diskette kernel: [  359.770975] sd 0:0:1:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    Oct 20 19:03:03 diskette kernel: [  359.775938] RAID1 conf printout:
    Oct 20 19:03:03 diskette kernel: [  359.775938]  --- wd:1 rd:2
    Oct 20 19:03:03 diskette kernel: [  359.775938]  disk 0, wo:0, o:1, dev:sda1
    
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Gecko

    Gecko Jungspund

    Dabei seit:
    21.01.2006
    Beiträge:
    18
    Zustimmungen:
    0
    Hi!

    Ich habe noch ein paar andere Sachen ausprobiert, jedoch ohne Erfolg:
    - initrd neu gebaut und beim Erstellen mit angegeben, dass der Link-Speed auf 1.5Gbps begrenzt ist
    - im BIOS div. Einstellungen vorgenommen, um die Zugriffsmethode zu ändern, bzw. auch hier den Link-Speed zu droßeln
    - Betrieb nur mit Samba oder Netatalk/AFP

    Mir ist aber noch aufgefallen, dass beide Platten eine unterschiedliche Firmware verwenden:
    Code:
    diskette:~#  hdparm -I /dev/sd?|egrep '/dev/|Serial Number|Model Number|Firmware'
    /dev/sda:
            Model Number:       ST31500341AS
            Serial Number:      9VS3FLAM
            Firmware Revision:  CC1H
    /dev/sdb:
            Model Number:       ST31500341AS
            Serial Number:      9VS2C0P9
            Firmware Revision:  SD17
    
    Aktuell ist die Version SD1B. Rein von der Versions-Ähnlichkeit würde ich mal behaupten, dass die /dev/sdb somit den aktuelleren Stand hat. Nachdem ich die /dev/sda aus meinem Daten-Array (mdadm) entfernt habe, waren auch die Fehler/Hänger des Systems weg. Ich werde also mal die Firmware aktualisieren...

    Ich melde mich bei weiteren Vorkommnissen.


    Beste Grüße,
    Daniel
     
Thema:

Debian 5.0.6 hat Hänger bei Datenlast

Die Seite wird geladen...

Debian 5.0.6 hat Hänger bei Datenlast - Ähnliche Themen

  1. Wiederherstellen von überschriebenen Dokumenten auf debian samba

    Wiederherstellen von überschriebenen Dokumenten auf debian samba: Ich habe ein Problem. Vor Kurzem hat der Trojaner cryptologer einen Schaden eingerichtet. Glücklicherweise gab es eine Sicherung auf...
  2. Debian Samba 4.2.10+dfsg-0+deb8u3 Password wrong -Windows DC

    Debian Samba 4.2.10+dfsg-0+deb8u3 Password wrong -Windows DC: Hallo, ich habe einen debian Samba-Server mit share´s ohne Domäne aufgesetzt, d.h. "standalone". Wenn ich von Windows-Clients mit...
  3. Debian VM Klonen und parallel betreiben? Systemanpassungen

    Debian VM Klonen und parallel betreiben? Systemanpassungen: Hallo, ich habe vor eine Debian Maschine als Prototyp aufzusetzen... (als vSphere VM).... Diese Maschine will ich dann x-mal klonen und in div....
  4. LinuxDistribution: Bunsenlabs (Debian 8.2 mit Openbox)

    LinuxDistribution: Bunsenlabs (Debian 8.2 mit Openbox): Für alle die eine superschnelle minimalistische Distribution suchen, die auch auf schwachen Rechnern läuft, ich bin fündig geworden. Bin gestern...
  5. Update auf Apache >=2.4.12 unter Debian Jessie

    Update auf Apache >=2.4.12 unter Debian Jessie: Hi, aufgrund eines Bugs in Apache 2.4 benötige ich zum Deployment von Seafile unter Debian Jessie das Paket apache2 in der Version >= 2.4.12...