debian 3.1 Software-RAID (1) testen?

Dieses Thema im Forum "Installation & Basiskonfiguration" wurde erstellt von timothy, 30.07.2005.

  1. #1 timothy, 30.07.2005
    timothy

    timothy Grünschnabel

    Dabei seit:
    30.07.2005
    Beiträge:
    1
    Zustimmungen:
    0
    Hallo miteinander!

    Ich habe ein ASUS A8V Deluxe-Board mit aufgesetzen Promise PDC20378 RAID-Controller und will mit zwei identischen Platten ein RAID 1 machen, bzw. habe es schon getan und bin mir aber nicht sicher ob das alles so in Ordnung ist.
    Nach Recherche habe ich herausgefunden dass der Promise-Controller kein richtiger Hardware-Controller ist und nur Windows richtig unterstützt, hier sehe ich bei angelegtem RAID 1-Array durchaus nur eine Platte, bei debian 3.1 jedoch beide.
    Also habe ich erstmal Windows installiert, hier bei der installation zwei Partitionen angelegt, eine für's Betriebssystem und eine als "Datenaustausch-Zone" zwischen Windows und Linux (in FAT32).
    Dann habe ich debian 3.1 von DVD installiert und dabei "expert26" verwendet. Im Partitionierungs-Programm habe ich dann beide Platten gesehen und ordnungsgemäß war auf jeder schon zwei Partitionen angelegt (einmal für Windows und einmal für Datenaustausch.)
    Den restlichen Platz der beiden Platten habe ich dann identisch partitioniert und alle neuen Partitionen und die schon bestehende Datenaustausch-Partition für ein Software-Raid freigegeben. Dann habe ich entsprechende Software-Geräte erzeugt (1 aktive Platte, 1 Reserve-Platte) und da natürlich immer die entsprechenden identischen Partitionen als Aktive- und Reserveplatte eingestellt. Wohlgemerkt habe ich wirklich alle Partitionen als Soft-RAID eingestellt, selbst meine SWAP-Partition.
    Das hat auch alles wunderbar funktioniert und ich kann sowohl debian als auch Windows booten, auch die /proc/mdstat bei debian zeigt mir die Soft-RAIDs an.

    Jetzt dachte ich mir, dass ich zum Testen einfach mal mit Knoppix boote, wo ich dann ja wieder beide Platten sehe, und dann schaue ich mal nach ob auf den entsprechenden Partitionen jeweils genau das selbe drauf ist.
    Und hier kommt (endlich) meine Frage, denn das schlug dann fehl. Die Partitionen der aktiven Platte kann ich mit Knoppix sehr wohl einmounten und sehe dann auch die Daten, aber die Partitionen der passiven Platte kann ich nicht einmounten, sondern bekomme eine Fehlermeldung: "Der Dateisystemtyp konnte nicht festgestellt werden..."; wenn ich mit "mount -t ext3" versuche das ganze manuell einzuhängen, erhalte ich die Fehlermeldung: "Falscher Dateisystemtyp, ungültige Optionen, der Superblock von /dev/sdb7 ist beschädigt oder es sind zu viele Dateisysteme eingehängt."
    Ist das so normal, kann man die passiven Platten nicht einfach ganz normal einmounten weil sie unter Kontrolle des Soft-RAIDs sind? Ich hatte eigentlich angenommen dass das dann da auch einfach ext3-Partitionen sind wo ich eben genau das identische vorfinde. Oder muss dann bei mir eine Fehlkonfiguration vorliegen?
    Wenn das normal ist, wie kann ich dann testen, ob alles richtig funktioniert? Einfach mal die aktive Platte ausbauen? und schauen ob dann alles von der passiven läuft?
    Ich hab ein bisschen angst, etwas kaputt zu machen, deshalb hab ich das noch nicht getan.

    Danke für's lesen und ich würde mich sehr über eine Antwort freuen! :)

    Grüße,
    Timothy
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Mefju

    Mefju Grünschnabel

    Dabei seit:
    20.12.2005
    Beiträge:
    1
    Zustimmungen:
    0
    Hallo Timothy,

    nun ist Dein Beitrag ja schon ein wenig her, aber ich wüßte dennoch gerne, was denn nun aus Deinem RAID-System geworden ist. Ich stehe nämlich bald vor ähnlichen Fragen, allerdings bin ich mit Ubuntu noch nicht so weit gekommen, daß das RAID0/1 eingerichtet worden wäre. Auch Kanotix hat sich erstmal als wenig hilfreich erwiesen.

    Nun würde mich schon interessieren, ob Du eine Lösung gefunden hast, warum Knoppix Deinen Mirror nicht ordentlich als ext3 mounten konnte.

    Gruß,
    Mefju
     
Thema:

debian 3.1 Software-RAID (1) testen?

Die Seite wird geladen...

debian 3.1 Software-RAID (1) testen? - Ähnliche Themen

  1. Wiederherstellen von überschriebenen Dokumenten auf debian samba

    Wiederherstellen von überschriebenen Dokumenten auf debian samba: Ich habe ein Problem. Vor Kurzem hat der Trojaner cryptologer einen Schaden eingerichtet. Glücklicherweise gab es eine Sicherung auf...
  2. Debian Samba 4.2.10+dfsg-0+deb8u3 Password wrong -Windows DC

    Debian Samba 4.2.10+dfsg-0+deb8u3 Password wrong -Windows DC: Hallo, ich habe einen debian Samba-Server mit share´s ohne Domäne aufgesetzt, d.h. "standalone". Wenn ich von Windows-Clients mit...
  3. Debian VM Klonen und parallel betreiben? Systemanpassungen

    Debian VM Klonen und parallel betreiben? Systemanpassungen: Hallo, ich habe vor eine Debian Maschine als Prototyp aufzusetzen... (als vSphere VM).... Diese Maschine will ich dann x-mal klonen und in div....
  4. LinuxDistribution: Bunsenlabs (Debian 8.2 mit Openbox)

    LinuxDistribution: Bunsenlabs (Debian 8.2 mit Openbox): Für alle die eine superschnelle minimalistische Distribution suchen, die auch auf schwachen Rechnern läuft, ich bin fündig geworden. Bin gestern...
  5. Update auf Apache >=2.4.12 unter Debian Jessie

    Update auf Apache >=2.4.12 unter Debian Jessie: Hi, aufgrund eines Bugs in Apache 2.4 benötige ich zum Deployment von Seafile unter Debian Jessie das Paket apache2 in der Version >= 2.4.12...