datenbankmodule in php5 werden nicht mehr geladen

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von sono, 22.02.2006.

  1. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    Morgen.

    Ich hab gestern Abend mein Ubuntu Breezy upgedatet und heute morgen gingen plötzlich von PHP5 aus keine Datenbankzugriffe mehr.

    Sowohl bei mysql_connect wie auch pg_connect() kommen nur noch

    usw. Ich habe dann die Ubuntupackete aus den Dexterquellen installiert, da konnte dann keine Session geladen werden, und die Dotdep Packete von php5.1 habe gar nicht erst geparst.

    Teils Funktioniert php5 noch aber gerade die Datenbankmodule scheinen nicht geladen zu werden.

    Bescheiden ist mehr als nur geschmeichelt um das zu beschreiben.

    Weiß jemand was da passiert sein könnte und wie ich das wieder fixen kann?

    Gruß Sono
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 lordlamer, 22.02.2006
    lordlamer

    lordlamer Haudegen

    Dabei seit:
    15.05.2003
    Beiträge:
    703
    Zustimmungen:
    0
    Ort:
    hamburg
    sieht aus als seien die extensions in php nicht geladen. schau dir mal die php.ini an bzw php.conf

    mfg frank

    ps: was gibt dir den phpinfo() aus?
     
  4. hehejo

    hehejo blöder Purist

    Dabei seit:
    12.10.2003
    Beiträge:
    1.280
    Zustimmungen:
    0
    Ort:
    Stein (Mittelfranken)
    Ja, das sagte ich dir aber auch schon mal im Chat, dass ich glaube mal gelesen zu haben, dass bei PHP5 einige der Standardmodule nicht mehr automatisch geladen werden.
     
  5. #4 chrisnolde, 23.02.2006
    chrisnolde

    chrisnolde Mitglied

    Dabei seit:
    07.06.2004
    Beiträge:
    30
    Zustimmungen:
    0
    also bei meinem kubuntu war es so das standardmäßig keine dynamische bibliothek geladen wurde. auch wenn diese explizit installiert wurde.
     
  6. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    Sorry, das habe ich nicht mitbekommen. Das wäre es vermutlich auch nicht gewesen, denn bei mir läuft php5 schon bestimmt eine Halbes Jahr problemlos mit allen extentions die ich installiert habe.

    Abgesehen davon hatte ich auch php5 eigentlich nicht upgedatet also hätte sich das Verhalten von php nicht ändern dürfen.

    Mittlerweile läuft PHP wieder, aber ich verstehe nicht was passiert ist, bzw warum.

    Als erstes lief es nicht mehr. Ich bin sicher nichts gemacht zu haben was php beeinflusst hätte, eigentlich hab ich nur ein paar pdf libs upgedatet und die haben eigentlich nichts mit der Datenbank extentions zu tun denke ich mal.

    Dann ging nicht mehr, dann hab ich php aus 3 anderen Quellen installiert wobei jedesmal irgendwelche Module wie Sessions oder Datenbankzugriff nicht funktioniert hatten.
    In phpinfo() habe diese Module auch immer gefehlt obwohl in der php.ini am ende diese Module eigentlich geladen wurden.
    Das habe ich vorm posten schon alles geprüft.
    Ja, das sagte ich dir aber auch schon mal im Chat, dass ich glaube mal gelesen zu haben, dass bei PHP5 einige der Standardmodule nicht mehr automatisch geladen werden. Vom Rechner geschmissen und wieder das original Ubuntu php drauf gemacht.

    PHP lief wieder ohne extentions, trotz mehrmaliger apache reloads sowie sogar einem reboot.

    Kurz gestern Abend ging nichts.

    Heute morgen mache ich den Computer an, und alles geht wieder. Eigentlich habe ich nichts verändert im Gegensatz zu gestern Abend, aber es geht einfach wieder.

    Irgendwie verstehe ich nicht ganz was da passiert sein könnte.

    Gruß Sono
     
Thema:

datenbankmodule in php5 werden nicht mehr geladen

Die Seite wird geladen...

datenbankmodule in php5 werden nicht mehr geladen - Ähnliche Themen

  1. php3 nach php5

    php3 nach php5: Hallo zusammen, ich habe die Aufgabe eine in php3 gestrickte Anwendung nach php5 zu heben. Soweit ich das lese sollte auch alles...
  2. apache2-mod_php5 will nicht.

    apache2-mod_php5 will nicht.: Hi, ich habe hier einen apache2 mit installiertem PHP5 und Apache-Modul unter SuSE 10. PHP selbst funktioniert zwar, jedoch spuckt mir der...
  3. cacti killt meine php5-sockets für nginx

    cacti killt meine php5-sockets für nginx: hi, ich versuche gerade cacti per nginx zum laufen zubringen. nur jedesmal, wenn ich die auf die cacti seite zugreifen will sterben mir...
  4. PHP5.x + 5.3 parallel? (Apache, Debian)

    PHP5.x + 5.3 parallel? (Apache, Debian): Hi, ich wollte zum Testen auf meinen Webserver PHP5.3 installieren, damit ich die Seiten nach und nach umziehen kann, brauche aber für einige...
  5. Apache2 php5

    Apache2 php5: Ich habe ein suse 11.1 und über yast2 einen Apache2 mit PHP5 installiert. Die index.html öffnet er, eine index.php allerdings nicht. Bei der...