Courrier Imap

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von tiptel170, 31.07.2008.

  1. #1 tiptel170, 31.07.2008
    tiptel170

    tiptel170 Tripel-As

    Dabei seit:
    20.07.2008
    Beiträge:
    161
    Zustimmungen:
    0
    Guten Abend,

    ich setzte mir einen Courrier-Imap-Server auf. Habe eine LDAp-Datenbank laufen, der IMAP soll sich daran authenfizieren. Aber es funktioniert nicht.

    Anbei meine Konfigfiles und logs:

    /usr/local/etc/authlib/authldaprc

    Code:
    DAP_URI                ldap://127.0.0.1
    LDAP_PROTOCOL_VERSION   3
    LDAP_BASEDN             ou=Users,dc=casa,dc=red
    LDAP_BINDDN             cn=Administrator,dc=casa,dc=red
    LDAP_BINDPW             geheim
    LDAP_TIMEOUT            10
     LDAP_AUTHBIND          0
    LDAP_MAIL               mail
    LDAP_FILTER             (&(objectClass=shadowAccount)
    LDAP_DOMAIN            casa.red
    LDAP_GLOB_UID          vmail
     LDAP_GLOB_GID          vmail
    LDAP_HOMEDIR            homeDirectory
    LDAP_MAILDIR            mailbox
    LDAP_DEFAULTDELIVERY    defaultDelivery
    LDAP_FULLNAME           gecos
    LDAP_CRYPTPW            userPassword
    LDAP_UID               uidNumber
     LDAP_GID               gidNumber
    LDAP_DEREF              never
    LDAP_TLS                0
    
    /var/log/messages
    Code:
    Jul 31 22:46:12 Daten-Server slapd[3904]: conn=4157 fd=92 ACCEPT from IP=127.0.0.1:48416 (IP=0.0.0.0:389)
    Jul 31 22:46:12 Daten-Server slapd[3904]: conn=4157 op=0 BIND dn="cn=Administrator,dc=casa,dc=red" method=128
    Jul 31 22:46:12 Daten-Server slapd[3904]: conn=4157 op=0 BIND dn="cn=Administrator,dc=casa,dc=red" mech=SIMPLE ssf=0
    Jul 31 22:46:12 Daten-Server slapd[3904]: conn=4157 op=0 RESULT tag=97 err=0 text=
    Jul 31 22:46:12 Daten-Server slapd[3904]: conn=4158 fd=95 ACCEPT from IP=127.0.0.1:48417 (IP=0.0.0.0:389)
    Jul 31 22:46:12 Daten-Server slapd[3904]: conn=4157 op=1 UNBIND
    Jul 31 22:46:12 Daten-Server slapd[3904]: conn=4157 fd=92 closed
    Jul 31 22:46:12 Daten-Server slapd[3904]: conn=4158 op=0 BIND dn="cn=Administrator,dc=casa,dc=red" method=128
    Jul 31 22:46:12 Daten-Server slapd[3904]: conn=4158 op=0 BIND dn="cn=Administrator,dc=casa,dc=red" mech=SIMPLE ssf=0
    Jul 31 22:46:12 Daten-Server slapd[3904]: conn=4158 op=0 RESULT tag=97 err=0 text=
    Jul 31 22:46:12 Daten-Server slapd[3904]: conn=4158 op=1 UNBIND
    Jul 31 22:46:12 Daten-Server slapd[3904]: conn=4158 fd=95 closed
    
    /var/log/mail
    Code:
    Jul 31 22:46:12 Daten-Server authdaemond: received auth request, service=imap, authtype=login
    Jul 31 22:46:12 Daten-Server authdaemond: authldap: trying this module
    Jul 31 22:46:12 Daten-Server authdaemond: selected ldap protocol version 3
    Jul 31 22:46:12 Daten-Server authdaemond: binding to LDAP server as DN 'cn=Administrator,dc=casa,dc=red', password 'geheim'
    Jul 31 22:46:12 Daten-Server authdaemond: using search filter: (&(&(objectClass=shadowAccount)(mail=ms5))
    Jul 31 22:46:12 Daten-Server authdaemond: ldap_search_st() failed
    Jul 31 22:46:12 Daten-Server authdaemond: selected ldap protocol version 3
    Jul 31 22:46:12 Daten-Server authdaemond: binding to LDAP server as DN 'cn=Administrator,dc=casa,dc=red', password 'geheim'
    Jul 31 22:46:12 Daten-Server authdaemond: using search filter: (&(&(objectClass=shadowAccount)(mail=ms5))
    Jul 31 22:46:12 Daten-Server authdaemond: ldap_search_st() failed
    Jul 31 22:46:12 Daten-Server authdaemond: authldap: TEMPFAIL - no more modules will be tried
    
    Postfix, ftp und telnet können sich wunderbar am ldap authenfizieren. Das LDAP-Verzeichnis ist auf samba ausgelegt. Die samba-user und die authenfizieren der arbeitsstationen über ldap funktioniert auch.

    Was mache ich da falsch? Bin am verrückt werden.

    Gruss tiptel170
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 saeckereier, 31.07.2008
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Dein Filter ist nicht ok
     
  4. #3 tiptel170, 01.08.2008
    tiptel170

    tiptel170 Tripel-As

    Dabei seit:
    20.07.2008
    Beiträge:
    161
    Zustimmungen:
    0
    Danke mit, die aussage hilft mir nicht weiter. Wie wäre der filter richtig?
     
  5. #4 lordlamer, 01.08.2008
    lordlamer

    lordlamer Haudegen

    Dabei seit:
    15.05.2003
    Beiträge:
    703
    Zustimmungen:
    0
    Ort:
    hamburg
    perhaps:
    Klammersetzung bei LDAP_FILTER
     
  6. #5 saeckereier, 01.08.2008
    Zuletzt bearbeitet: 01.08.2008
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Sorry, du hast nen funktionierenden LDAP aufgsetzt der auch mit Postfix und allem möglichen anderen läuft und scheiterst dann an einem FILTER?! ;-)

    Ich bin davon ausgegangen, dass du dich damit auskennst und den Fehler einfach nur übersehen hattest.. Zähl einfach mal die Klammern, die aufgehen und schliessen, meiner Meinung nach ist da eine schliessende zuwenig
     
  7. #6 tiptel170, 28.08.2008
    tiptel170

    tiptel170 Tripel-As

    Dabei seit:
    20.07.2008
    Beiträge:
    161
    Zustimmungen:
    0
    Bin wieder da...

    so, ich habe heute auf einem zweitem server mal den courier installiert. Mit dem ergebnis, dass der sich auch nich anmelden kann.

    Hier der auszug der /var/log/mail

    Code:
    Aug 28 22:36:37 Daten-Server imapd: Connection, ip=[::ffff:192.168.0.3]
    Aug 28 22:36:37 Daten-Server authdaemond: received auth request, service=imap, authtype=login
    Aug 28 22:36:37 Daten-Server authdaemond: authldap: trying this module
    Aug 28 22:36:37 Daten-Server authdaemond: selected ldap protocol version 3
    Aug 28 22:36:37 Daten-Server authdaemond: binding to LDAP server as DN 'cn=Administrator, dc=casa, dc=red', password 'xxxx'
    Aug 28 22:36:37 Daten-Server authdaemond: using search filter: (uid=ms5)
    Aug 28 22:36:37 Daten-Server authdaemond: one entry returned, DN: uid=ms5,ou=Users,dc=casa,dc=red
    Aug 28 22:36:37 Daten-Server authdaemond: raw ldap entry returned:
    Aug 28 22:36:37 Daten-Server authdaemond: | uid: ms5
    Aug 28 22:36:37 Daten-Server authdaemond: | homeDirectory: /mnt/Sys/Win/Home/ms5
    Aug 28 22:36:37 Daten-Server authdaemond: | gecos: MS Werkstatt
    Aug 28 22:36:37 Daten-Server authdaemond: | userPassword: {SSHA}+3A41Ssiof0EYeWYrFNioIfv+qXZkCc1
    Aug 28 22:36:37 Daten-Server authdaemond: authldaplib: refuse to authenticate ms5: uid=0, gid=0 (zero uid or gid not permitted)
    Aug 28 22:36:37 Daten-Server authdaemond: authldaplib: sysusername=<null>, sysuserid=0, sysgroupid=0, homedir=/mnt/Sys/Win/Home/ms5, address=ms5, fullname=MS Werkstatt, maildir=<null>, quota=<null>, options=<null>
    Aug 28 22:36:37 Daten-Server authdaemond: authldaplib: clearpasswd=<null>, passwd={SSHA}+3A41Ssiof0EYeWYrFNioIfv+qXZkCc1
    Aug 28 22:36:37 Daten-Server authdaemond: supplied password 'mspc05' does not match encrypted password '{SSHA}+3A41Ssiof0EYeWYrFNioIfv+qXZkCc1'
    Aug 28 22:36:37 Daten-Server authdaemond: authldap: REJECT - try next module
    Aug 28 22:36:37 Daten-Server authdaemond: FAIL, all modules rejected
    Aug 28 22:36:37 Daten-Server imapd: LOGIN FAILED, user=ms5, ip=[::ffff:192.168.0.3]
    Aug 28 22:41:31 Daten-Server popper[11339]: (v4.0.8) Servicing request from "Medien-PC.red" at 192.168.0.3 [pop_init.c:1239]
    Aug 28 22:41:44 Daten-Server popper[11339]: Stats: ms 0 0 1138 246806116 Medien-PC.red 192.168.0.3 [pop_updt.c:301]
    
    
    Habe die geänderte datei auch auf meinen haupt-server übernommen, dort kommt auch die gleich fehlermeldung.
    Wenn ich umstelle auf

    LDAP_CLEARPW clearPassword
    #LDAP_CRYPTPW userPassword

    dann sieht es so aus:

    Code:
    Aug 28 22:33:34 Daten-Server authdaemond: selected ldap protocol version 3
    Aug 28 22:33:34 Daten-Server authdaemond: binding to LDAP server as DN 'cn=Administrator, dc=casa, dc=red', password 'xxxxx'
    Aug 28 22:33:34 Daten-Server authdaemond: using search filter: (uid=ms5)
    Aug 28 22:33:34 Daten-Server authdaemond: one entry returned, DN: uid=ms5,ou=Users,dc=casa,dc=red
    Aug 28 22:33:34 Daten-Server authdaemond: raw ldap entry returned:
    Aug 28 22:33:34 Daten-Server authdaemond: | uid: ms5
    Aug 28 22:33:34 Daten-Server authdaemond: | homeDirectory: /mnt/Sys/Win/Home/ms5
    Aug 28 22:33:34 Daten-Server authdaemond: | gecos: MS Werkstatt
    Aug 28 22:33:34 Daten-Server authdaemond: authldaplib: refuse to authenticate ms5: uid=0, gid=0 (zero uid or gid not permitted)
    Aug 28 22:33:34 Daten-Server authdaemond: authldaplib: sysusername=<null>, sysuserid=0, sysgroupid=0, homedir=/mnt/Sys/Win/Home/ms5, address=ms5, fullname=MS Werkstatt, maildir=<null>, quota=<null>, options=<null>
    Aug 28 22:33:34 Daten-Server authdaemond: authldaplib: clearpasswd=<null>, passwd=<null>
    Aug 28 22:33:34 Daten-Server authdaemond: no password to compare against!
    Aug 28 22:33:34 Daten-Server authdaemond: authldap: REJECT - try next module
    Aug 28 22:33:34 Daten-Server authdaemond: FAIL, all modules rejected
    
    
    Also er versucht das passwort abzufragen, aber wie bekomme ich dies hin, dass er mir mein verschlüsseltes pw aus der ldap-datenbank lesen kann.

    Gruss tiptel170
     
  8. #7 tiptel170, 29.08.2008
    Zuletzt bearbeitet: 29.08.2008
    tiptel170

    tiptel170 Tripel-As

    Dabei seit:
    20.07.2008
    Beiträge:
    161
    Zustimmungen:
    0
    Bin jetzt etwas weitergekommen,
    habe festgestellt, dass einige user nicht das SSHA-Passwort haben. Keine ahnung warum, bei einem user bekomme ich die fehlermeldung, wo aber auch drin steht, dass das passwort übereinstimmt.

    Code:
    Aug 29 14:24:04 Daten-Server authdaemond: password matches successfully
    Aug 29 14:24:04 Daten-Server authdaemond: using search filter: (&(objectClass=posixAccount)(uid=ms))
    Aug 29 14:24:04 Daten-Server authdaemond: one entry returned, DN: uid=ms,ou=Users,dc=casa,dc=red
    Aug 29 14:24:04 Daten-Server authdaemond: raw ldap entry returned:
    Aug 29 14:24:04 Daten-Server authdaemond: | uid: ms
    Aug 29 14:24:04 Daten-Server authdaemond: | homeDirectory: /mnt/Sys/Win/Home/ms
    Aug 29 14:24:04 Daten-Server authdaemond: | gecos: MS Medien-PC
    Aug 29 14:24:04 Daten-Server authdaemond: | userPassword: {SHA}ymJ6Zy/FueXWFCytSKauuHLQP8s=
    Aug 29 14:24:04 Daten-Server imapd: authentication error: Input/output error
    Aug 29 14:24:04 Daten-Server authdaemond: authldaplib: refuse to authenticate ms: uid=0, gid=0 (zero uid or gid not permitted)
    Aug 29 14:24:04 Daten-Server authdaemond: authldaplib: sysusername=<null>, sysuserid=0, sysgroupid=0, homedir=/mnt/Sys/Win/Home/ms, address=ms, fullname=MS Medien-PC, maildir=<null>, quota=<null>, options=<null>
    Aug 29 14:24:04 Daten-Server authdaemond: authldaplib: clearpasswd=<null>, passwd={SHA}ymJ6Zy/FueXWFCytSKauuHLQP8s=
    Aug 29 14:24:04 Daten-Server authdaemond: password matches successfully
    Aug 29 14:24:04 Daten-Server authdaemond: authldap: TEMPFAIL - no more modules will be tried
    
    

    Was noch komisch / merkwürdig ist, ist: Dass immer folgendes erscheint:

    Code:
    Aug 29 14:24:04 Daten-Server authdaemond: authldaplib: refuse to authenticate ms: uid=0, gid=0 (zero uid or gid not permitted)
    
    Es erscheint immer uid=0 und die gid=0 - bei jedem benutzer. Woran kann dies liegen? Wo kann ich es einstellen?

    Vielleicht hilft dies weiter ....

    Gruss tiptel170
     
  9. #8 saeckereier, 29.08.2008
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Exportier mal deinen User mit dem du es testest ins LDIF Format und poste das hier (in CODE Tags bitte) Du kannst statt der Kennwörter XXXXXXXXX reinschreiben, den Rest bitte nicht verfälschen.

    EDIT: Geht zum Beispiel mit JXPlorer
     
  10. #9 tiptel170, 29.08.2008
    tiptel170

    tiptel170 Tripel-As

    Dabei seit:
    20.07.2008
    Beiträge:
    161
    Zustimmungen:
    0
    Hier die ldif:
    user ms:
    Code:
    dn: uid=ms, ou=Users, dc=casa,dc=red
    sambaLMPassword: 3C13CC39ECE6FA33E6EDBA1A03E5C57D
    sambaPrimaryGroupSID: S-1-5-21-772460384-3307588627-3499720480-513
    displayName: ms
    givenName: ms
    sambaLogonScript: ms.cmd
    objectClass: top
    objectClass: person
    objectClass: organizationalPerson
    objectClass: inetOrgPerson
    objectClass: posixAccount
    objectClass: shadowAccount
    objectClass: sambaSamAccount
    shadowLastChange: 2804
    userPassword:: e1NIQX15bUo2WnkvRnVlWFdGQ3l0U0thdXVITFFQOHM9
    sambaHomeDrive: Z:
    sambaLogonTime: 0
    uidNumber: 500
    uid: ms
    cn: ms
    sambaLogoffTime: 2147483647
    sambaPwdLastSet: 1212605269
    sambaAcctFlags: [U]
    loginShell: /bin/bash
    sambaProfilePath: \\DATEN-SERVER\Profiles\ms.pds
    gidNumber: 513
    shadowMax: 999999
    sambaPwdMustChange: 2147483647
    sambaPwdCanChange: 1212605269
    gecos: MS Medien-PC
    sambaNTPassword: B6B1C1827F84A67C5A3287583D1BC58A
    sambaSID: S-1-5-21-772460384-3307588627-3499720480-3032
    homeDirectory: /mnt/Sys/Win/Home/ms
    sambaKickoffTime: 2147483647
    sn: ms
    sambaHomePath: \\DATEN-SERVER\homes\ms
    sambaPasswordHistory: 0000000000000000000000000000000000000000000000000000000
     000000000
    

    Was mir auffällt ist: dass die sysuserid=0, sysgroupid=0, auch immer null sind.
    Ich habe in der /etc/courier/authldaprc folgende werte eingestellt:

    Code:
    LDAP_URI                ldap://192.168.0.1
    LDAP_PROTOCOL_VERSION   3
    LDAP_BINDDN             cn=Administrator, dc=casa, dc=red
    LDAP_BINDPW             geheim
    LDAP_TIMEOUT            5
    LDAP_AUTHBIND          1
    LDAP_DEFAULTDELIVERY    defaultDelivery
    LDAP_MAIL       uid
    LDAP_FILTER             (objectClass=posixAccount)
    LDAP_DOMAIN           casa.red
    LDAP_HOMEDIR            /home
    LDAP_MAILROOT
    LDAP_MAILDIR    MAILROOT/$LDAP_HOMEDIR/$LDAP_MAILDIR
    LLDAP_CRYPTPW            userPassword
    LADAP_FULLNAME           gecos
    LDAP_UID
    LDAP_GID
    LDAP_DEREF              never
    LDAP_TLS                1
    
    Trage ich bei LDAP_UID uidNumber (oder gebe eine zahl an), passiert bei sysuserid nicht bleibt immer noch bei "0".
    Kann es sein, dass es an der authldap.schema liegt?

    Denn das home-verzeichnis wird gefunden und wenn ich bei LDAP_FULLNAME gecos gegen cn ersetzte, wird das auch in der log-datei angezeigt.

    tiptel170
     
  11. #10 saeckereier, 29.08.2008
    Zuletzt bearbeitet: 29.08.2008
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    So muss das aussehen:
    Code:
    LDAP_UID                uidNumber
    LDAP_GID                gidNumber
    
    Das ist auch ziemlich sicher der Fehler, da er sich im Log ja immer beschwert und den User dann für root hält (uid=0). Mit der o.g. Änderung sollte das eigentlich klappen. Sicher, dass du auch den authdaemon neugestartet hattest?

    EDIT: Ich hab keine Zeit mir deine Datei durchzulesen, eigentlich will ich im Moment gar nicht posten, aber hier ist meine authldaprc:
    Code:
    LDAP_URI                ldaps://ldap.homenet.de
    LDAP_PROTOCOL_VERSION   3
    LDAP_BASEDN             dc=homenet, dc=de
    LDAP_TIMEOUT            5
    LDAP_AUTHBIND           1
    LDAP_MAIL               mail
    LDAP_FILTER           (objectClass=shadowAccount)
    LDAP_HOMEDIR            homeDirectory
    LDAP_FULLNAME           cn
    LDAP_CLEARPW            clearPassword
    LDAP_CRYPTPW            userPassword
    LDAP_UID                uidNumber
    LDAP_GID                gidNumber
    LDAP_DEREF              never
    LDAP_TLS                0
    
    EDIT: casa.red? eres español?
     
  12. #11 tiptel170, 29.08.2008
    Zuletzt bearbeitet: 29.08.2008
    tiptel170

    tiptel170 Tripel-As

    Dabei seit:
    20.07.2008
    Beiträge:
    161
    Zustimmungen:
    0
    Habe es gerad eingetragen. Habe auch meine authdaemon neu gestartet ;) Es kommt immernoch die gleiche fehlermeldung - werd bald verrückt .... :(

    Ich spreche etwas spanisch, mir fiel damals nichts anderes ein - wie war das: "die erste idee, ist meist die beste!"

    Vielleicht ist da ein bug dirn? Hmmmmmmmmmmmmmm

    Weis nicht mehr weiter

    Danke für deine Hilfe
     
  13. #12 saeckereier, 29.08.2008
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Code:
    alias nocomment="sed -e '/^#.*$/d' -e '/^\s*$/d'"
    
    Poste bitte einmal nocomment authdaemonrc und nocomment authldaprc.
    Das LDIF von weiter oben wurde auch mit dem Adminuser aus der authldaprc erstellt? Kannst du den Server zur Sicherheit einmal neustarten?

    P.S.: Das alias Kommando einmal ausführen, danach gibt nocomment nur die nicht auskommentierten Zeilen einer Datei zurück (Danke @TBlue!!) Denk dran etwaige Passwörter aus den Dateien zu killen
     
  14. #13 tiptel170, 29.08.2008
    Zuletzt bearbeitet: 29.08.2008
    tiptel170

    tiptel170 Tripel-As

    Dabei seit:
    20.07.2008
    Beiträge:
    161
    Zustimmungen:
    0
    Das LDIF wurde über samba erstellt, da samba als erstes installiert wurde. Danach habe ich den courier-imap installiert.

    Hier meine authdaemonrc
    Code:
    authmodulelist="authldap"
    authmodulelistorig="authldap"
    daemons=5
    authdaemonvar=/usr/local/var/spool/authdaemon
    DEBUG_LOGIN=2
    DEFAULTOPTIONS="disableimap=0"
    LOGGEROPTS=""
    version="authdaemond.ldap"
    
    Ich habe auch den server neu gestartet und auch die dementsprechende dienste von hand neugestartet, rcldap restart ....
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Wenn ich bei

    Code:
    LDAP_GLOB_UID         vmail
    LDAP_GLOB_GID         vmail
    
    Bekomme ich eine rückmeldung mit den gruppen- und userid, aber die falschen!

    Code:
    authldaplib: sysusername=<null>, sysuserid=117, sysgroupid=1002
    
    117 = uid vmail
    1002 = gid vmail

    Es wird besser solangsam ......
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 saeckereier, 29.08.2008
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    [quote authldaprc.dist]
    ##NAME: LDAP_GLOB_IDS:0
    # The following two variables can be used to set everybody's uid and gid.
    # This is convenient if your LDAP specifies a bunch of virtual mail accounts
    # The values can be usernames or userids:
    #
    # LDAP_GLOB_UID vmail
    # LDAP_GLOB_GID vmail
    [...]
    ##NAME: LDAP_IDS:0
    #
    # Uncomment the following, and modify as appropriate, if your LDAP database
    # stores individual userids and groupids. Otherwise, you must uncomment
    # LDAP_GLOB_UID and LDAP_GLOB_GID above. LDAP_GLOB_UID and LDAP_GLOB_GID
    # specify a uid/gid for everyone. Otherwise, LDAP_UID and LDAP_GID must
    # be defined as attributes for everyone.
    #
    # LDAP_UID uidNumber
    # LDAP_GID gidNumber
    [/quote]

    Also die GLOB Optionen rausschmeissen und nur die LDAP_UID Optionen reinsetzen. Idealerweise könntest du's auch mit meiner Konfig testen (s. weiter oben) und so lange auf dein System abändern bis die Fehlermeldungen verschwinden. Wie gesagt, meine Config läuft. (Courier-authlib 0.60.6)

    Alternative: Nimm dovecot. Das ist meiner Meinung nach unkomplizierter. Ich bin vor kurzem umgestiegen und hab's in Rekordzeit geschafft.

    In deinem Post fehlt die authldaprc im momentanen Stand..
     
  17. #15 tiptel170, 29.08.2008
    tiptel170

    tiptel170 Tripel-As

    Dabei seit:
    20.07.2008
    Beiträge:
    161
    Zustimmungen:
    0
    Trage ich folgendes ein:

    LDAP_GLOB_UID ms
    LDAP_GLOB_GID Domain Users

    dann geht es, kann mich nur mit ms authenfizieren.

    Meine aktuelle authldaprc

    Code:
    LDAP_URI                ldap://192.168.0.1
    LDAP_PROTOCOL_VERSION   3
    LDAP_BASEDN             dc=casa, dc=red
    LDAP_BINDDN             cn=Administrator, dc=casa, dc=red
    LDAP_BINDPW             MarkusS000
    LDAP_TIMEOUT            5
     LDAP_AUTHBIND          1
    LDAP_MAIL       uid
    LDAP_FILTER             (objectClass=posixAccount)
      LDAP_DOMAIN           casa.red
    LDAP_GLOB_UID        ms
    LDAP_GLOB_GID       Domain Users
    LDAP_HOMEDIR            homeDirectory
      LDAP_MAILROOT
       #  /var/mail
    LDAP_MAILDIR            ./Maildir
    LDAP_DEFAULTDELIVERY    defaultDelivery
    LDAP_FULLNAME           gecos
    LDAP_CRYPTPW            userPassword
     LDAP_UID               uidNumber
     LDAP_GID               gidNumber
    LDAP_DEREF              never
    LDAP_TLS                0
    
    
    Was ist da faul? Nehme ich die LDAP_GLOB_ ... raus (trage keine user und gruppen ein) - dann rückmeldung usersysid=0 ...

    Der parameter LDAP_UID und GID hat keine Funktion. Habe gerade nach geschaut es ist die courier-authlib-0.60.4. Kann es sein, dass diese version ziemlich buggy ist? Anders kann ich mir es bald nicht erklären, wenn du die 0.60.6 hast und es bei dir funktioniert. Dann probiere ich es mal mit der version. Oder ich bin zu blöde um den courier an hand eines buches und unzähligen anleitungen an den ldap zum laufen zubekommen.

    Danke für deine hilfe - vielleicht habe ich was übersehen?
     
Thema:

Courrier Imap

Die Seite wird geladen...

Courrier Imap - Ähnliche Themen

  1. IMAP/POP3 durchsuchen und an beliebige App. übergeben

    IMAP/POP3 durchsuchen und an beliebige App. übergeben: Hallo zusammen, ich möchte gerne ein E-Mail Postfach (IMAP/POP3) mit regulären Ausdrücken durchsuchen und dann ein beliebiges Programm aufrufen...
  2. Automatischen Eintrag in courierimapsubscribe vornehmen

    Automatischen Eintrag in courierimapsubscribe vornehmen: Guten Tag und Hallo alle zusammen, wollte mich heute mal daran geben einen Spamfilter auf meinem vServer zu installieren. Klappte auch alles...
  3. Backup (IMAP-) Mailverzeichnis

    Backup (IMAP-) Mailverzeichnis: [gelöst] Backup (IMAP-) Mailverzeichnis Hallo zusammen, ich möchte meinen Server neu aufsetzen. Jetzt sind in einem meiner Mailboxen aber noch...
  4. horde3 + dovecot = IMAP wont work

    horde3 + dovecot = IMAP wont work: Hallo, ich habe folgendes Problem: ich habe im horde3 die autentifizierung auf imap gestellt. Als IMAP Server verwende ich dovecot....
  5. Thunderbird Backup, IMAP Server involved

    Thunderbird Backup, IMAP Server involved: Hi, ich hab da mal ne Frage. Wenn ich einfach den /Library/Thunderbird Folder kopiere, habe ich ja die Config sowie die Mails, zumindest...