Conceptronic C54RU Wlan USB treiber für Suse 10.3

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von fightx, 27.06.2008.

  1. fightx

    fightx Jungspund

    Dabei seit:
    07.06.2008
    Beiträge:
    18
    Zustimmungen:
    0
    Hallo zusammen,

    ich habe ein Conceptronic C54RU Wlan USB Adapter und suche die Treiber für SuSE 10.3. Der Hersteller bietet keine an, kann mir einer sagen was für ein Chip in dem Adapter verbaut ist und wo ich dir Treiber herbekomme?

    danke im voraus
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Yogibaer, 28.06.2008
    Yogibaer

    Yogibaer Routinier

    Dabei seit:
    01.11.2006
    Beiträge:
    330
    Zustimmungen:
    0
    wie wäre es dann mit einem lsusb als root in einem terminal bei eingestecktem USB-WLAN-stick und dann die USB-ID bei Tante Google eingeben?
     
  4. fightx

    fightx Jungspund

    Dabei seit:
    07.06.2008
    Beiträge:
    18
    Zustimmungen:
    0
    danke für deine hilfe, es ist ein Rt2500 Chip woll verbaut, ich habe auch im internet eine erklärumg gefunden wie ich den treiber einfügen kann, http://wiki.linux-club.de/opensuse/Rt2500_HowTo aber bei dem schritt mit "sudo cp rt2570.ko" bringt er mir immer eine fehler das er die datei nicht finden konnte. ich hab auch in dem ornder geschaut aber die datei ist nicht vorhanden :think:

    Ich habe suse linux 10.3 mit dem Kernel 2.6.22.18-0.2 installiert.
    hoffe ihr könnt mir da weiter helfen
     
  5. #4 Yogibaer, 28.06.2008
    Yogibaer

    Yogibaer Routinier

    Dabei seit:
    01.11.2006
    Beiträge:
    330
    Zustimmungen:
    0
    Schreib doch mal den Befehl als post in code-tags hier rein. Bitte benutze copy und paste eventuell in ein Textdokument und aus diesem heraus hierher. Vermeidung von Tippfehlern. Du bist doch schon 2 Schritte vor ende, dann sollte das doch gehen. Und in welchem directory hast Du gesucht?
     
  6. #5 fightx, 28.06.2008
    Zuletzt bearbeitet: 28.06.2008
    fightx

    fightx Jungspund

    Dabei seit:
    07.06.2008
    Beiträge:
    18
    Zustimmungen:
    0
    der fehler tritt vorher auf hab ich gerade beim nochmaligen ausprobieren gemerkt, man sollte sich die ausgaben immer genau anschauen ;) es kommen fehler beim make siehe unten
    Code:
    Notebook:/home/marcel/Documents/programme/RT25USB-SRC-V2.0.8.0 # make
    make -C /lib/modules/2.6.22.18-0.2-default/build SUBDIRS=/home/marcel/Documents/
    programme/RT25USB-SRC-V2.0.8.0 modules
    make[1]: Entering directory `/usr/src/linux-2.6.22.18-0.2-obj/i386/default'
    make -C ../../../linux-2.6.22.18-0.2 O=../linux-2.6.22.18-0.2-obj/i386/default m
    odules
      CC [M]  /home/marcel/Documents/programme/RT25USB-SRC-V2.0.8.0/rtusb_main.o
    /home/marcel/Documents/programme/RT25USB-SRC-V2.0.8.0/rtusb_main.c: In function
    ‘CMDHandler’:
    /home/marcel/Documents/programme/RT25USB-SRC-V2.0.8.0/rtusb_main.c:1079: warning
    : unused variable ‘pkey’
    /home/marcel/Documents/programme/RT25USB-SRC-V2.0.8.0/rtusb_main.c:1078: warning                              : unused variable ‘i’
    /home/marcel/Documents/programme/RT25USB-SRC-V2.0.8.0/rtusb_main.c: In function                               ‘usb_rtusb_probe’:
    /home/marcel/Documents/programme/RT25USB-SRC-V2.0.8.0/rtusb_main.c:1779: error:                               ‘struct net_device’ has no member named ‘get_wireless_stats’
    /home/marcel/Documents/programme/RT25USB-SRC-V2.0.8.0/rtusb_main.c:1807: error:                               ‘dev_base’ undeclared (first use in this function)
    /home/marcel/Documents/programme/RT25USB-SRC-V2.0.8.0/rtusb_main.c:1807: error:                               (Each undeclared identifier is reported only once
    /home/marcel/Documents/programme/RT25USB-SRC-V2.0.8.0/rtusb_main.c:1807: error:                               for each function it appears in.)
    /home/marcel/Documents/programme/RT25USB-SRC-V2.0.8.0/rtusb_main.c:1807: error:                               ‘struct net_device’ has no member named ‘next’
    make[4]: *** [/home/marcel/Documents/programme/RT25USB-SRC-V2.0.8.0/rtusb_main.o                              ] Fehler 1
    make[3]: *** [_module_/home/marcel/Documents/programme/RT25USB-SRC-V2.0.8.0] Feh                              ler 2
    make[2]: *** [modules] Fehler 2
    make[1]: *** [modules] Fehler 2
    make[1]: Leaving directory `/usr/src/linux-2.6.22.18-0.2-obj/i386/default'
    make: *** [all] Fehler 2
    



    ich gebe es so ein
    Code:
    sudo cp rt2570.ko /lib/modules/`uname -r`/extra/
    
    danach bestätige ich mit enter, und die fehlermeldung kommt. ich habe in dem ordner gesucht in dem die daten entpackt werden am anfang.
     
  7. fightx

    fightx Jungspund

    Dabei seit:
    07.06.2008
    Beiträge:
    18
    Zustimmungen:
    0
    so hab jetzt mal den treiber von Serialmonkey installiert und siehe da unter der konsole wird meine karte erkannt, mit ifconfig bekomme ich folgende ausgabe
    Code:
    noname:/home/marcel # ifconfig
    eth0      Protokoll:Ethernet  Hardware Adresse 00:40:45:07:D5:10
              inet Adresse:192.168.2.100  Bcast:192.168.2.255  Maske:255.255.255.0
              inet6 Adresse: fe80::240:45ff:fe07:d510/64 Gültigkeitsbereich:Verbindung
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:179859 errors:0 dropped:0 overruns:0 frame:0
              TX packets:136078 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 Sendewarteschlangenlänge:1000
              RX bytes:256611218 (244.7 Mb)  TX bytes:10899909 (10.3 Mb)
              Interrupt:10 Basisadresse:0xd000
    
    lo        Protokoll:Lokale Schleife
              inet Adresse:127.0.0.1  Maske:255.0.0.0
              inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:278 errors:0 dropped:0 overruns:0 frame:0
              TX packets:278 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 Sendewarteschlangenlänge:0
              RX bytes:16868 (16.4 Kb)  TX bytes:16868 (16.4 Kb)
    
    wlan0     Protokoll:Ethernet  Hardware Adresse 00:80:5A:38:FC:AA
              inet6 Adresse: fe80::280:5aff:fe38:fcaa/64 Gültigkeitsbereich:Verbindung
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:7391 errors:0 dropped:0 overruns:0 frame:0
              TX packets:16677 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 Sendewarteschlangenlänge:1000
              RX bytes:989414 (966.2 Kb)  TX bytes:1102698 (1.0 Mb)
    mit iwconfig bekomme ich folgendes

    Code:
    noname:/home/marcel # iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wlan0     RT73 WLAN  ESSID:""
              Mode:Managed  Frequency=2.412 GHz  Bit Rate=54 Mb/s
              RTS thr:off   Fragment thr:off
              Encryption key:off
              Link Quality=0/100  Signal level:-121 dBm  Noise level:-115 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    mit
    Code:
    iwlist wlan0 scan
    bekomme ich auch wlan netzwerke angezeigt.

    unter KNetworkManger wird mir der USB Stick auch angezeigt aber wenn ich mich mit meinem Netzwerk verbinden will kommt immer ein fehler das die verbindung fehlgesschlagen ist.

    Unter Yast Netzwerkkarten steht der USB Stick nicht drinn, ist das normal?
    Mein Wlan SSID ist unsichtbar und mit WPA Verschlüsselt, woran kann es liegen das ich nicht rein komme?

    Danke im vorraus
     
  8. #7 Yogibaer, 06.07.2008
    Yogibaer

    Yogibaer Routinier

    Dabei seit:
    01.11.2006
    Beiträge:
    330
    Zustimmungen:
    0
    um erst einmal zu sehen, ob die Hardware tut, unverschlüsselt ausprobieren. Also sichtbar machen und wpa weg. Dann sind Tippfehler im Schlüssel vermieden. Außerdem muß klar sein, ob im Schlüssel nicht erlaubte Zeichen sind, oder hex-Übergabe oder so etwas. Wenn Du Dich dann verbinden kannst, ist es ein Schlüsselproblem.
     
  9. Gast1

    Gast1 Guest

    Daran, daß

    a) Du einen Legacy-Treiber (rt73 statt rt73usb) verwendest

    b) die Legacy-Treiber nicht mit dem NetworkManager zurecht kommen und der NWM auch ab und zu (je nach Treiber) Probleme mit "versteckten" ESSID hat (schalt den Unsinn übrigens ab, das ist Kosmetik und keine wirkliche Sicherheit)

    c) die Legacy-Treiber nicht mit der wpa_supplicant-Extension "wext" zurecht kommen

    d) der "normale" wpa_supplicant die Extension "ralink" nicht beherrscht.
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. fightx

    fightx Jungspund

    Dabei seit:
    07.06.2008
    Beiträge:
    18
    Zustimmungen:
    0
    woher bekomme ich den denn rt73usb Treiber? bei ralink find ich nichts und der Serialmonkey wird als rt73-USB deklariert
     
  12. Gast1

    Gast1 Guest

    1. Weg mit dem selbsgefrickelten Kram.

    Code:
    su
    
    Passwort
    
    find /lib/modules/$(uname -r)/ -name rt73.ko -exec rm -i {} \;
    
    modprobe -r rt73
    
    modprobe -r rt73usb
    2. Das hier lesen:

    http://www.pc-forum24.de/linux-howt...-legacy-treibern-rt73-rt61-opensuse-10-x.html

    und Schritt für Schritt vorgehen wie dort beschrieben, sprich als _letztes_ auf die Legacy umsteigen, wenn sonst gar nichts geht.

    3. Statt unnützer Handarbeit immer RPM-Pakete zwecks einfacher Installation/Deinstallation und im Normalfall auch "überlebt ein Kernelupdate" (Ausnahme wird erklärt) verwenden (dazu baue ich die Dinger schliesslich).

    4. Der hier hat es auch hinbekommen

    http://www.pc-forum24.de/suse-inter...-10-3-wpa2-legacy-treiber-wpa_supplicant.html

    (ob rt61 oder rt73 spielt hier keine entscheidende Rolle, der rt61 ist sogar noch "zickiger" als der rt73), wahrscheinlich funktioniert das mittlerweile auch mit den compat-wireless Paketen

    http://www.linuxforen.de/forums/showthread.php?t=252823

    Die vorgestellte(n) Lösung(en) funktioniert/en nachweislich, also arbeite die Anleitung genau so ab und lies sie genau, Fragen, die im HowTo schon er/geklärt werden, werde ich nicht beantworten.

    Viel Erfolg.
     
Thema:

Conceptronic C54RU Wlan USB treiber für Suse 10.3

Die Seite wird geladen...

Conceptronic C54RU Wlan USB treiber für Suse 10.3 - Ähnliche Themen

  1. Conceptronic C54Ri mit Ralink RT2561/RT61 läuft unter openSuse 10.3 nicht

    Conceptronic C54Ri mit Ralink RT2561/RT61 läuft unter openSuse 10.3 nicht: Hallo Zusammen, bin umgezogen und möchte nun ein WLAN einrichten. Ich habe es auch schon zum laufen gebracht - und zwar sowohl mit Kubuntu 7.10...
  2. Problem mit Conceptronic C54Ri und ralink-rt61

    Problem mit Conceptronic C54Ri und ralink-rt61: Hi Ich habe folgendes: vor einiger Zeit legte ich mir die Conceptronic C54Ri zu. Damals nutze ich noch mehrheitlich Windows, Ich hatte aber...