Centos 5.5: Qmail lauscht nicht auf Port 25

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von Just Matt, 16.01.2011.

  1. #1 Just Matt, 16.01.2011
    Just Matt

    Just Matt Eroberer

    Dabei seit:
    16.09.2007
    Beiträge:
    64
    Zustimmungen:
    0
    Ort:
    München
    Hallo zusammen,

    ich habe einen frisch installierten Server mit Centos 5.5 und Parallels als Oberfläche. Der Versand von Emails funktioniert, nur der Empfang externer Emails funktioniert nicht. Habe darauf hin mal mit "telnet example.com 25" probiert ob der SMTP-Port offen ist und wurde mit "connection refused" abgebügelt. Daraufhin hab ich mir das nochmal mit nmap angeguckt und folgende Aufstellung bekommen:

    Starting Nmap 5.00 ( http://nmap.org ) at 2011-01-16 13:34 CET
    Interesting ports on example.com (123.456.789.123):
    Not shown: 988 closed ports
    PORT STATE SERVICE
    21/tcp open ftp
    53/tcp open domain
    80/tcp open http
    106/tcp open pop3pw
    110/tcp open pop3
    143/tcp open imap
    443/tcp open https
    993/tcp open imaps
    995/tcp open pop3s
    1720/tcp filtered H.323/Q.931
    2006/tcp open invokator
    8443/tcp open https-alt

    In der /etc/services stehen beide Einträge drin:

    smtp 25/tcp mail
    smtp 25/udp mail

    Wo kann ich denn Qmail dazu bringen auf Port 25 zu lauschen?

    Viele Grüße

    Matthias
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    ist qmail eingerichtet mit inetd zu laufen; läuft inetd; ist inetd für qmail konfiguriert;

    nur sone idee habe weder wirklich ahnung von qmail noch von inetd
     
  4. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Was sagt den
    Code:
    netstat -tulpen
    ?
     
  5. #4 Just Matt, 16.01.2011
    Zuletzt von einem Moderator bearbeitet: 16.01.2011
    Just Matt

    Just Matt Eroberer

    Dabei seit:
    16.09.2007
    Beiträge:
    64
    Zustimmungen:
    0
    Ort:
    München
    Code:
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       User       Inode      PID/Program name
    tcp        0      0 0.0.0.0:993                 0.0.0.0:*                   LISTEN      0          5706       2491/couriertcpd
    tcp        0      0 0.0.0.0:995                 0.0.0.0:*                   LISTEN      0          5738       2508/couriertcpd
    tcp        0      0 127.0.0.1:10025             0.0.0.0:*                   LISTEN      0          6021       2563/master
    tcp        0      0 127.0.0.1:3306              0.0.0.0:*                   LISTEN      27         6393       2754/mysqld
    tcp        0      0 127.0.0.1:10026             0.0.0.0:*                   LISTEN      0          6025       2563/master
    tcp        0      0 0.0.0.0:106                 0.0.0.0:*                   LISTEN      0          5683       2466/xinetd
    tcp        0      0 127.0.0.1:10027             0.0.0.0:*                   LISTEN      0          6029       2563/master
    tcp        0      0 0.0.0.0:110                 0.0.0.0:*                   LISTEN      0          5722       2499/couriertcpd
    tcp        0      0 0.0.0.0:143                 0.0.0.0:*                   LISTEN      0          5690       2481/couriertcpd
    tcp        0      0 0.0.0.0:8880                0.0.0.0:*                   LISTEN      0          5599       2444/sw-cp-serverd
    tcp        0      0 127.0.0.1:10001             0.0.0.0:*                   LISTEN      0          5597       2444/sw-cp-serverd
    tcp        0      0 123.456.789.123:53           0.0.0.0:*                   LISTEN      25         6263       2614/named
    tcp        0      0 127.0.0.1:53                0.0.0.0:*                   LISTEN      25         6261       2614/named
    tcp        0      0 0.0.0.0:21                  0.0.0.0:*                   LISTEN      0          5682       2466/xinetd
    tcp        0      0 0.0.0.0:2006                0.0.0.0:*                   LISTEN      0          5600       2444/sw-cp-serverd
    tcp        0      0 127.0.0.1:5432              0.0.0.0:*                   LISTEN      26         6475       2802/postmaster
    tcp        0      0 127.0.0.1:953               0.0.0.0:*                   LISTEN      25         6264       2614/named
    tcp        0      0 0.0.0.0:8443                0.0.0.0:*                   LISTEN      0          5598       2444/sw-cp-serverd
    tcp        0      0 :::80                       :::*                        LISTEN      0          6658       2859/httpd
    tcp        0      0 :::2256                     :::*                        LISTEN      0          5621       2454/sshd
    tcp        0      0 :::443                      :::*                        LISTEN      0          6663       2859/httpd
    udp        0      0 123.456.789.123:53           0.0.0.0:*                               25         6262       2614/named
    udp        0      0 127.0.0.1:53                0.0.0.0:*                               25         6260       2614/named
    udp        0      0 0.0.0.0:68                  0.0.0.0:*                               0          5289       2306/dhclient
    Ich hoffe das kann man einigermaßen so lesen - die Leerzeichen werden offensichtlich ignoriert :(

    Auf alle Fälle taucht da auch nirgendwo der Port 25 auf. Bei einem anderen Server mit Qmail und Plesk erscheint dort eine Zeile mit der lokalen Adresse 0.0.0.0:25 xinetd und das müsste doch hier dann auch sein :think:
     
  6. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    ok also ist es für inetd konfiguriert, und der inetd läuft auch ? und in der config findet sich auch ne zeile für smtp ?
     
  7. #6 Just Matt, 16.01.2011
    Just Matt

    Just Matt Eroberer

    Dabei seit:
    16.09.2007
    Beiträge:
    64
    Zustimmungen:
    0
    Ort:
    München
    Ich habe xinetd eben mal gestoppt und dann wieder gestartet - also läuft.

    In der xinetd.conf direkt steht kein Hinweis auf SMTP, sondern nur eine Zeile in der ein Verzeichnis inkludet wird: includedir /etc/xinetd.d

    in diesem Verzeichnis sind mehrere Dateien, z.B. ftp_psa, rsync, usw.

    Die ftp_psa - Datei ist wie folgt aufgebaut:

    Code:
    service ftp
    {
            disable         = no
            socket_type     = stream
            protocol        = tcp
            wait            = no
            user            = root
            instances       = UNLIMITED
            server          = /usr/sbin/in.proftpd
            server_args     = -c /etc/proftpd.conf
    }
    Da sollten wohl auch zwei Dateien sein, namens smtp_psa und smtps_psa - sind sie aber nicht. Also hab ich die beiden Dateien mal angelegt und erhalte prompt im messages-log eine Fehlermeldung: xinetd[7889]: Server /var/qmail/bin/tcp-env is not execut\
    able [file=/etc/xinetd.d/smtp_psa] [line=9]

    Kann auch gar nicht, denn es gibt unter Centos gar kein Verzeichnis /var/qmail/bin.

    Ich bin mit meinem Latein im Moment am Ende, weil unter Centos alles irgendwie anders abgelegt zu sein scheint (als unter Suse, woran ich mich jetzt schon etwas gewöhnt habe). Bin natürlich wissbegierig, aber im Moment läuft's gerade sehr zäh mit den Fortschritten.

    Auf alle Fälle sind im qmail-Verzeichnis (/var/qmail/) dann direkt 2 Ordner namens popuser und mailnames (wo dann auch das Verzeichnis der 1. Emailadresse angelegt wurde, was für mich ein Indiz ist, dass Plesk auf diesem Server mit Qmail arbeitet und nicht mit Postfix).
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Centos 5.5: Qmail lauscht nicht auf Port 25

Die Seite wird geladen...

Centos 5.5: Qmail lauscht nicht auf Port 25 - Ähnliche Themen

  1. Centos 7.2.15.11 - yum install ecryptfs-utils-gui

    Centos 7.2.15.11 - yum install ecryptfs-utils-gui: Hallo ich habe hier eine alte Informationseite >>> https://www.centos.org/docs/5/html/5.4/technical-notes/ecryptfs-utils.html dort wird so die...
  2. Centosbefehle

    Centosbefehle: Hallo ich habe ein Centos 7.2.15.11 image (mit Hdclone von Miray gemacht) Ich möchte das Image auf eine existierende Ubuntu installation...
  3. Welche Paketquellen sind empfohlen? -CentOS 7.2.15.11

    Welche Paketquellen sind empfohlen? -CentOS 7.2.15.11: Hallo liebes Forum. Es scheint mir wie eine plumpe Anfängerfrage, jedoch habe ich zu dem Thema nichts sinnvolles gefunden. Ich habe CentOS...
  4. linux-firmware-nonfree in Centos 15.11 (64 Bit)

    linux-firmware-nonfree in Centos 15.11 (64 Bit): Hallo wie kann man linux-firmware-nonfree in Centos 15.11 (64 Bit) installieren?
  5. Centos 15.11 und grub anpassen

    Centos 15.11 und grub anpassen: Hallo ich habe Centos 15.11 (64 bit) Ich möchte grub anpassen und zwar so das ich nicht im Grubmenü an Stelle 0 stehe , sondern an Stelle 4 Wie...