bind wird nicht zum primary

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von sono, 23.08.2005.

  1. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    Also ich hab ein kleines Konfigurationsproblem mit Bind.
    Vermutlich ist es nur eine Kleinigkeit aber nach 5 Tutorials die alle eine andere Bindsyntax haben blicke ich so langsam nicht mehr durch.

    Ich hab eine dyndns domain und ein kleines netzwerk . Jetzt will ich das bind innerhalb meines netzwerkes der Primary für meine dyndns domain wird .

    ich hab debian sarge mit bind9
    meine conf sieht so aus :

    die named.conf.local
    Code:
    //
    // Do any local configuration here
    //
    
    // Consider adding the 1918 zones here, if they are not used in your
    // organization
    //include "/etc/bind/zones.rfc1918";
    
    // Bertec Zone
    zone "test.selfip.biz" {
       type master;
       file "/etc/bind/db.test.selfip.biz";
    };
    
    // Die Reverse Zone der test Adresse
    zone "100.168.192.in-addr.arpa" {
       type master;
       file "/etc/bind/db.test.selfip.rev";
    };
    
    Die Zonendatei
    Code:
    ; Konfiguration der test Zone
    $TTL 86400
    @ 	IN SOA	ns.test.selfip.biz. hostmaster.test.selfip.biz. (
    		2005082300 	; Serien Nummer
    		10800			; Refresh
    		3600			; Retry
    		604800		; Expire after one Week
    		86400	)		; Minimum TTL ein Tag
    		
    ; Name und Mailserver der Domain
    @	IN NS 	ns.test.selfip.biz.
    @	IN MX 5	mail.test.selfip.biz.
    
    ; Die Hosts
    
    mail.test.selfip.biz.		IN	A	192.168.100.150
    www.test.selfip.biz.		IN	A	192.168.100.150
    ns.test.selfip.biz.		IN	A	192.168.100.150
    solap.test.selfip.biz.	IN A	192.168.100.154
    
    Die Reverse Zone
    Code:
    ; Reverse Lookup datei der test.selfip.biz zone
    $TTL 86400
    100.168.192.in-addr.arpa. IN SOA ns.test.selfip.biz. sono.test.selfip.biz. (
                                   2005082300 ; serial
                                   3H         ; refresh
                                   1H         ; retry
                                   1W         ; expiry
                                   1D )       ; minimum
    
    150.100.168.192.in-addr.arpa. 	IN	NS 	ns.test.selfip.biz.
    
    
    150.100.168.192.in-addr.arpa.		IN	PTR	www.test.selfip.biz.
    150.100.168.192.in-addr.arpa.		IN	PTR 	mail.test.selfip.biz.
    150.100.168.192.in-addr.arpa.		IN	PTR 	ns.test.selfip.biz.
    154.100.168.192.in-addr.arpa.		IN	PTR 	solap.test.selfip.biz.
    
    Sieht jemand zufällig einen Fehler ?

    Gruß SOno
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Ich verwalte hier einen Debian-DNS für diverse Domains. Hier mal ein Domain-Eintrag aus der named.conf und die zugehörige zone-Datei. Ich vermute, dass dein Fehler bei den DNS-Einträgen in der zone-Datei liegen.

    Code:
    # named.conf
    
    options {
            directory "/var/named";
            pid-file "/var/run/named/named.pid";
            datasize default;
            stacksize default;
            coresize default;
            files unlimited;
            recursion yes;
            multiple-cnames no;
            forwarders {
                    123.123.123.250; // Adresse des "globalen Routers"
            };
    };
    
    zone "." IN {
            type hint;
            file "root.zone";
    };
    
    zone "localhost" IN {
            type master;
            file "localhost.zone";
            check-names fail;
            allow-update { none; };
    };
    
    zone "0.0.127.in-addr.arpa" IN {
            type master;
            file "127.0.0.zone";
            check-names fail;
            allow-update { none; };
    };
    
    zone "1.168.192.in-addr.arpa" IN {
            type master;
            file "192.168.1.zone";
            check-names fail;
            allow-update { none; };
    };
    
    zone "123.123.123.in-addr.arpa" IN {
            type master;
            file "123.123.123.zone";
            check-names fail;
            allow-update { none;};
    };
    
    zone "mydomain.de" IN {
            type master;
            file "mydomain.de.zone";
            notify yes;
    };
    
    ... weitere Zonen
    
    Und hier die zu mydomain.de gehörende zone-Datei:

    Code:
    # mydomain.de.zone
    
    @               IN      SOA     kolibri.mydomain.de. root.kolibri.mydomain.de. (
                                    2005082200      ; Serial
                                    8H              ; refresh
                                    2H              ; retry
                                    1W              ; expire
                                    1D )            ; minimum
                            NS      ns1.mydomain.de.
                            NS      ns2.mydomain.de.
                            MX      10 mail.mydomain.de.
                            MX      20 albatros.mydomain.de.
                            TXT     "Name meiner Firma"
    
    localhost               A       127.0.0.1
    albatros                A       123.123.123.123
    albatrosintern       A       192.168.1.2
    columba                A       123.123.123.124
    ...
    mydomain.de.             A       123.123.123.123
    www                     CNAME   mydomain.de.
    
    Ich hoffe, dass dir dieser Vergleich ein wenig weiter hilft. Habe den DNS so übernommen wie er ist und er läuft problemlos. Muss mal schaun, wann ich die Zeit finde mich in die Bind-Doku einzulesen.
     
  4. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    Habs zum laufen bekommen.

    Habs nach einem Tutorial alles neu geschrieben und plötzlich lief alles .
    Leider weiß ich echt nicht was ich anderst gemacht haben soll denn eigentlich müssten die neue conf zur alten fast identisch sein.

    Es geht zumindest und das ist die Hauptsache.
     
Thema:

bind wird nicht zum primary

Die Seite wird geladen...

bind wird nicht zum primary - Ähnliche Themen

  1. Aus BIND 10 wird Bundy

    Aus BIND 10 wird Bundy: Das Internet Systems Consortium (ISC) hat die Entwicklung des DNS-Servers BIND 10 eingestellt. Eine Gemeinschaft von Interessierten soll die...
  2. Internet-Verbindung wird getrennt - KInternet-Problem?

    Internet-Verbindung wird getrennt - KInternet-Problem?: Hallo, nachdem ich in den letzten Wochen - durchaus mit eurer tatkräftigen Hilfe - meine SuSE soweit zum Laufen gebracht habe, dass ich jetzt...
  3. Netzwerk bzw. Internetverbindung wird nicht ordentlich gestartet

    Netzwerk bzw. Internetverbindung wird nicht ordentlich gestartet: Hi, Ich habe meine Netwerk bzw. Internet verbindung so eingerichtet, dass sie automatisch startet, wenn das System hochfährt. Das hat auch...
  4. Keine WLAN Verbindung wenn kein SSID gesendet wird

    Keine WLAN Verbindung wenn kein SSID gesendet wird: Hallo zusammen, habe opensuse 10.2 auf einem Acer-Notebook und als Wlan AP ein Netgear WG602. Soweit funtzt auch alles ganz prima. Um nun...
  5. Arch Linux via Hamachi zu bestehendem VPN verbinden

    Arch Linux via Hamachi zu bestehendem VPN verbinden: Guten Tag zusammen! Ich betreibe zu Hause einen kleinen Server für Minecraft und samba file sharing und möchte diesen nun zu meinem bestehenden...