Beryl und Desktopeffekte laufen nicht.

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Skilfinger, 12.08.2007.

  1. #1 Skilfinger, 12.08.2007
    Skilfinger

    Skilfinger Grünschnabel

    Dabei seit:
    12.08.2007
    Beiträge:
    3
    Zustimmungen:
    0
    Ich habe meine Ati x850 nach ubuntuusers wiki installiert und wollte mir danach XGL einrichten um Beryl voll und ganz nutzen zu können. Nur leider bekomme ich wenn ich XGL solch ein ähnliches Bild: http://www.hauke-online.de/xgl.png
    Und wenn ich unter einer normalen Gnome Sitzung Die Desktopeffekte starten will bekomme ich das:
    Code:
    :~$ compiz --indirect-rendering --strict-binding --replace gconf &
    [1] 14156
    :~$ /usr/bin/compiz.real: GLX_SGIX_fbconfig is missing
    /usr/bin/compiz.real: Failed to manage screen: 0
    /usr/bin/compiz.real: No manageable screens found on display :0.0
    Mein X11 config:
    Code:
    Section "Files"
    	FontPath	"/usr/share/fonts/X11/misc"
    	FontPath	"/usr/share/fonts/X11/cyrillic"
    	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
    	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
    	FontPath	"/usr/share/fonts/X11/Type1"
    	FontPath	"/usr/share/fonts/X11/100dpi"
    	FontPath	"/usr/share/fonts/X11/75dpi"
    	# path to defoma fonts
    	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection
    
    Section "Module"
    	Load	"i2c"
    	Load	"bitmap"
    	Load	"ddc"
    	Load	"dri"
    	Load	"extmod"
    	Load	"freetype"
    	Load	"glx"
    	Load	"int10"
    	Load	"vbe"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"de"
    	Option		"XkbVariant"	"nodeadkeys"
    	Option		"XkbOptions"	"lv3:ralt_switch"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"		"/dev/input/mice"
    	Option		"Protocol"		"ImPS/2"
    	Option		"ZAxisMapping"		"4 5"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"stylus"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"stylus"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"eraser"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"eraser"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"cursor"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"cursor"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "Device"
    	Identifier	"ATI Technologies Inc R423 UK [Radeon X800SE (PCIE)]"
    	Driver		"fglrx"
    	BusID		"PCI:5:0:0"
    	Option		"TripleBuffer" "true"
    	Option		"AddARGBGLXVisuals" "true"
    EndSection
    
    Section "Monitor"
    	Identifier	"AOC"
    	Option		"DPMS"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"ATI Technologies Inc R423 UK [Radeon X800SE (PCIE)]"
    	Monitor		"AOC"
    	DefaultDepth	24
    	SubSection "Display"
    		Depth		1
    		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		4
    		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		8
    		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		15
    		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		16
    		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		24
    		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Generic Keyboard"
    	InputDevice	"Configured Mouse"
    	InputDevice     "stylus"	"SendCoreEvents"
    	InputDevice     "cursor"	"SendCoreEvents"
    	InputDevice     "eraser"	"SendCoreEvents"
    EndSection
    
    Section "DRI"
    	Mode	0666
    EndSection
    Vielen Dank schonmal
    Skilfinger
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 ThE-FiSH, 13.08.2007
    ThE-FiSH

    ThE-FiSH Mitglied

    Dabei seit:
    17.03.2007
    Beiträge:
    43
    Zustimmungen:
    0
    hi,

    ich denke du musst an deine xorg.conf noch anhängen

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection

    ansonsten hier mal meine xorg.conf (nutze Kubuntu und eine Nvidia grafikkarte)

    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (buildmeister@builder3)  Mon Feb 26 23:39:38 PST 2007
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
        RgbPath         "/usr/X11R6/lib/X11/rgb"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
        Option         "Xinerama" "0"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Acer AL1916W"
        HorizSync       30.0 - 82.0
        VertRefresh     56.0 - 76.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Videocard0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 6600 GT"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Videocard0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "metamodes" "1440x900_60_0 +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0"
        SubSection     "Display"
            Depth       24
            Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    
    EndSubSection
    Option "TripleBuffer" "True"
    Option "AddARGBGLXVisuals" "True"
        EndSection
    
    Section "Extensions"
       Option "Composite" "Enable"
    EndSection
    
     
  4. #3 Skilfinger, 13.08.2007
    Zuletzt bearbeitet: 14.08.2007
    Skilfinger

    Skilfinger Grünschnabel

    Dabei seit:
    12.08.2007
    Beiträge:
    3
    Zustimmungen:
    0
    Ich habs mal angehängt und neu gestartet. Leider nichts :(

    Edit:

    Also ich musste was im XGL Startscript ändern:
    Aber Beryl gibt noch den Fehler aus:
    Code:
    **************************************************************
    * Beryl system compatiblity check                            *
    **************************************************************
    
    Detected xserver                                : XGL
    
    Checking Display :1.0 ...
    
    Checking for XComposite extension               : passed (v0.3)
    Checking for XDamage extension                  : passed
    Checking for RandR extension                    : passed
    Checking for XSync extension                    : passed
    
    beryl: GLX_EXT_texture_from_pixmap is missing
    beryl: Using non-tfp mode
    beryl: GLX_SGIX_fbconfig is missing
    beryl: Failed to manage screen: 0
    beryl: No manageable screens found on display :1.
     
  5. #4 Armin056, 16.08.2007
    Zuletzt von einem Moderator bearbeitet: 16.08.2007
    Armin056

    Armin056 Mitglied

    Dabei seit:
    08.02.2007
    Beiträge:
    41
    Zustimmungen:
    0
    Ort:
    Berlin
    Hi meiner Meinung nach kannst mit der x850 auch den radion treiber benutzen starte mal den Xserver wieder und nicht XGL und mit der angepassten Xorg.conf von mir.

    Code:
    Section "Files"
    	FontPath	"/usr/share/fonts/X11/misc"
    	FontPath	"/usr/share/fonts/X11/cyrillic"
    	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
    	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
    	FontPath	"/usr/share/fonts/X11/Type1"
    	FontPath	"/usr/share/fonts/X11/100dpi"
    	FontPath	"/usr/share/fonts/X11/75dpi"
    	# path to defoma fonts
    	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection
    
    Section "Module"
    	Load	"i2c"
    	Load	"bitmap"
    	Load	"ddc"
    	Load	"dri"
    	Load	"extmod"
    	Load	"freetype"
    	Load	"glx"
    	Load	"int10"
    	Load	"vbe"
            Load "dbe"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"de"
    	Option		"XkbVariant"	"nodeadkeys"
    	Option		"XkbOptions"	"lv3:ralt_switch"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"		"/dev/input/mice"
    	Option		"Protocol"		"ImPS/2"
    	Option		"ZAxisMapping"		"4 5"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"stylus"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"stylus"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"eraser"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"eraser"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"cursor"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"cursor"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "Device"
    	Identifier	"ATI Technologies Inc R423 UK [Radeon X800SE (PCIE)]"
    	Driver		"radeon"
    	BusID		"PCI:5:0:0"
    #	Option		"TripleBuffer" "true"
    #	Option		"AddARGBGLXVisuals" "true"
            Option  "AddARGBGLXVisuals" "True"
            Option  "XAANoOffscreenPixmaps"
    EndSection
    
    Section "Monitor"
    	Identifier	"AOC"
    	Option		"DPMS"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"ATI Technologies Inc R423 UK [Radeon X800SE (PCIE)]"
    	Monitor		"AOC"
    	DefaultDepth	24
    	SubSection "Display"
    		Depth		1
    		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		4
    		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		8
    		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		15
    		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		16
    		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		24
    		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Generic Keyboard"
    	InputDevice	"Configured Mouse"
    	InputDevice     "stylus"	"SendCoreEvents"
    	InputDevice     "cursor"	"SendCoreEvents"
    	InputDevice     "eraser"	"SendCoreEvents"
    EndSection
    
    Section "DRI"
    	Mode	0666
    EndSection
    
    Section "Extensions"
            Option "Composite" "Enable"
    EndSection
    
    Section "ServerLayout" 
             Option "AIGLX" "true" 
    EndSection
    
    Hoff Radeon läuft ansonsten halt weiter XGL und auf XEGL hoffen :-)

    gruß Armin056
     
  6. #5 darkfritz2, 18.08.2007
    Zuletzt bearbeitet: 18.08.2007
    darkfritz2

    darkfritz2 Jungspund

    Dabei seit:
    16.07.2007
    Beiträge:
    12
    Zustimmungen:
    0
    die x850 geht auf keinster weise auf linux nicht... ich hab genau die gleiche und funzt weder unter suse noch unter ubuntu! das heist du hast nur probleme... zwar war der driver installiert... und hast du dann die einstellungen machen wollen d.h. die auflösung ändern und 3d beschleunigung aktivieren wird nach dem neustart alles schwarz :) d.h. er startet den x-server nimma.. sollte alles doch gehen.. wird deine graka trotzdem nich erkannt.. entweder spuckt er bei dem befehl fglrxinfo eine ati 800GTO oda die mesa driver ;) von daher.. du hast keine chance :) in 2-3 monaten kauf ich mir auch ne nvidia 7800 :D weil die hammergeil is ^^
     
  7. #6 Goodspeed, 19.08.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Es ist zwar richtig, dass die ATI-Treiber immer mal wieder Probleme machen, aber ein generelles "geht nicht" ist definitiv falsch ...
     
  8. #7 darkfritz2, 19.08.2007
    darkfritz2

    darkfritz2 Jungspund

    Dabei seit:
    16.07.2007
    Beiträge:
    12
    Zustimmungen:
    0
    das was du sagst kann irgendwie nich so ganz stimmen bzw du hast beweise das es tatsächlich läuft... weil bei mir is es überhaupt nich der fall!

    http://wiki.ubuntuusers.de/ATI-Grafikkarten <- hier heist es das die grafikkarten bis x800 ünterstützt werden und selbst da teilweise unstabil..

    http://wiki.ubuntuusers.de/ATI-Grafikkarten/fglrx <-- auf dieser liste wo die fglrx unterstützung gefragt wird läuft auch nur die x800 und die x700 und angeblich auch alle R4xx chipsätze aber das kann nich ganz stimmen da ausdrücklich die x700 und die x800 erwähnt wird und bei MIR es überhaupt nich gefunzt hat..

    also ich weis nich was du dir darunter vostellst das es laufen kann das wenn ich nach einer angeblichen "erfolgreichen" driver installation die ausgabe erhalte das ich eine x800GTO habe was aber überhaupt nicht stimmt! (und das ich jetzt nich die auflösung geändert und die 3d besch. aktiviert habe)
    sobald ich aber die auflösung ändere (3d besch. immernoch deaktiviert) bekomm ich als ausgabe das ich ne mesa hab..
    ändere ich auflösung UND aktiviere ich 3d besch. startet er den x-server nimma! (und das gleiche auch wenn ich NICHT die auflösung ändere)

    und glaub mir! ich habe jedes tutorial benutzt was ich im internet gefunden hab! absolut jedes und es hat kein einziges gefunzt!

    mfg
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. #8 Goodspeed, 19.08.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    "Beweis":
    https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/linux_8.40.4.html

    Wenn ATI selbst der Meinung ist, dass der fglrx-Treiber die 850er-Serie unterstützt, dann sollte das wohl so sein ...

    Dein erster Link bezieht sich nur auf den Xorg-eigenen radeon-Treiber.

    Und bei Aussagen wie "ich hab jedes Tut benutzt, was ich finden konnte", kräuseln sich mir immer die Nackenhaare, denn das klingt immer nach "ich weiß nicht, was ich gemacht hab, aber davon ne Menge ..."

    Wenn Du Dich hier im Forum schon ein bisschen umgeschaut hast, wirst Du sicher festgestellt haben, dass bei Treiber/X-Server Problemen mindestens die aktuelle xorg.conf und das zugehörige Xorg.0.log gepostet werden sollte, denn mit einem "geht nicht" allein, kann man schlecht helfen. Und das hab ich irgendwie von Dir noch nicht gesehen ...
     
  11. #9 Ferdinant, 19.08.2007
    Ferdinant

    Ferdinant Doppel-As

    Dabei seit:
    24.12.2006
    Beiträge:
    103
    Zustimmungen:
    0
    Ort:
    Unterm Dach
    Ich erdreiste mich jetzt mal zum eigenlichen Topic zurückzukommen, ok?
    Als erstes wundert es mich, das im ersten Post von Beryl und Compiz die Rede ist :D

    Mein Tip wäre hier, ersteinmal nur Compiz (-Fusion) benutzen da ich mit Beryl auch die "lustigsten" Erfahrungen gemacht habe

    Aber egal, ich hab selbiges Problem, aber mit einer X1600, mit folgendem Befehl umgangen:
    Code:
    LD_PRELOAD=/usr/lib/fglrx/libGL.so.1.2.xlibmesa compiz --replace
    
     
Thema:

Beryl und Desktopeffekte laufen nicht.

Die Seite wird geladen...

Beryl und Desktopeffekte laufen nicht. - Ähnliche Themen

  1. Beryl & Emerald installieren unter Ubuntu

    Beryl & Emerald installieren unter Ubuntu: Hi, ich würde gern Beryl & Emerald installieren (gehört ja zusammen?). Hab mir das auch schonmal im Wiki von ubuntuusers durchgelesen. Da steht...
  2. Debian etch und beryl

    Debian etch und beryl: Nach vielen Versuchen, endlich den beryl auf meine etch zu kriegen, hab ich sie, aber: Ausgabe von compiz-check: Checking if it's possible to...
  3. Beryl

    Beryl: Hallo,... kurze Frage da wieder länger weg vom PC war,..wer hat Beryl auf Slack laufen. Was brauche ich dazu und gibt es diverse dependc...
  4. Benutzt ihr Programme wie Compiz-Fusion oder Beryl?

    Benutzt ihr Programme wie Compiz-Fusion oder Beryl?: Hallo, Aufgrund dieses Threads und dieser Umfrage habe ich mich gefragt ob und warum ihr Programme wie Compiz-Fusion oder Beryl benutzt. Ich...
  5. Beryl Hintergrund Verändern

    Beryl Hintergrund Verändern: Hi Hab grad bei Youtube Folgendes Movie gesehen: http://youtube.com/watch?v=ZD7QraljRfM Dort wenn er Den Würfel Dreht kommt son geiler...