Autostart mit rc.local oder init.d

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Das Kamel, 14.03.2012.

  1. #1 Das Kamel, 14.03.2012
    Das Kamel

    Das Kamel Mitglied

    Dabei seit:
    19.09.2007
    Beiträge:
    44
    Zustimmungen:
    0
    Ort:
    Erfurt
    Moin,

    als erstes mal meine Ausgangssituation:
    FSC RX100S3 mit Debian Squeeze AMD64, ohne grafische Oberfläche.

    Ich möchte ein (ggf. auch mehrere Programme) automatisch starten lassen.

    Im Moment habe ich das Ganze über einen Eintrag in rc.local realisiert.

    Code:
    cd /home/ts3
    su ts3 ./home/ts3/ts3server_startscript.sh start
    Nun habe ich mich noch ein bisschen belesen und bin darauf gestoßen dass der Inhalt von rc.local prinzipiell als root ausgeführt wird. Ich bin mir nicht ganz sicher ob das mit dem su funktioniert.

    Deshalb nun meine Frage:
    Ist das bezüglich der Sicherheit des Servers so in Ordnung oder sollte man das lieber über ein Script in init.d machen?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Remidemi, 15.03.2012
    Remidemi

    Remidemi Routinier

    Dabei seit:
    17.03.2008
    Beiträge:
    352
    Zustimmungen:
    0
    Ort:
    Südpfalz
    Hi

    Wieso muss ts3 den Server starten?

    Grundsätzlich finde ich rc.local den richtigen Ort.
     
  4. #3 tgruene, 15.03.2012
    tgruene

    tgruene Routinier

    Dabei seit:
    02.02.2012
    Beiträge:
    418
    Zustimmungen:
    0
    Wenn Du ueber su erreichst, dass das Programm als 'ts3' tatsaechlich ausgefuehrt wird, ist das ja kein Problem. Ob der Start nun ueber rc.local oder ein Skript in init.d ausgefuehrt wird, aendert daran ja nichts.
    Andere Frage: Funktioniert Dein Skript? Laut 'man su' muesste der Befehl doch mit der Option '-c' erfolgen. Ausserdem ist dafuer eher 'sudo' das eigentlich Programm, denke ich.
     
  5. #4 Remidemi, 15.03.2012
    Remidemi

    Remidemi Routinier

    Dabei seit:
    17.03.2008
    Beiträge:
    352
    Zustimmungen:
    0
    Ort:
    Südpfalz
    su ts3 reicht, die Bash ist so schlau...
     
  6. #5 HeadCrash, 15.03.2012
    Zuletzt bearbeitet: 15.03.2012
    HeadCrash

    HeadCrash Routinier

    Dabei seit:
    16.05.2009
    Beiträge:
    482
    Zustimmungen:
    1
    Ort:
    Bayern
    Komisch, meine Bash scheinbar nicht (ist btw auch Debian Squeeze ;) )
    Code:
    root@atlantis:~# which whoami
    /usr/bin/whoami
    root@atlantis:~# ls -l /usr/bin/whoami
    -rwxr-xr-x 1 root root 27472 28. Apr 2010  /usr/bin/whoami
    root@atlantis:~# su headcrash /usr/bin/whoami
    /usr/bin/whoami: /usr/bin/whoami: Kann die Datei nicht ausführen.
    root@atlantis:~# su headcrash -c /usr/bin/whoami
    headcrash
    
    man sollte sich nicht auf "das funktioniert so" verlassen.

    Über "su" oder "sudo" kann man an dieser Stelle streiten, ich bevorzuge an dieser Stelle "su".

    Ob /etc/rc.local oder ein Skript in init.d das auch nichts anderes macht ist gemschack Sache, die Skripte in /etc/init.d werden auch als root gestartet.
    Ein sauberes Start/Stop-Skript im in init.d finde ich für Server Dienste besser. Einfach weil es eine zentrale Anlaufstelle ist.

    @Kamel
    Einfach als root das ganze Stück für Stück ausführen ;)
    Ob der Prozess mit dem richtigen User läuft findust du mittels "ps aux | grep ts3" heruas.
    Dann solltest du eine Zeile in der Ausgabe finden, die so ähnlich aussieht:
    Code:
    ts3       1668  0.2  0.9 143268  4932 ?        Sl   Jan31 187:03 ./ts3server_linux_amd64 inifile=ts3server.ini
    
    @Remidemi
    Teamspeak gibt die root-Rechte die er beim starten erhält nicht wieder ab und liefert an dieser Stelle lieber eine deutliche Warnung,
    dass man den Dienst bitte nicht als root starten und laufne lassen sollte.

    mfg
    HeadCrash
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. #6 Das Kamel, 15.03.2012
    Das Kamel

    Das Kamel Mitglied

    Dabei seit:
    19.09.2007
    Beiträge:
    44
    Zustimmungen:
    0
    Ort:
    Erfurt
    @HeadCrash

    der ts3 Server läuft unter dem entsprechendem user.

    Den Parameter -c habe ich noch eingefügt.

    Vielleicht erstelle ich bei Gelegenheit noch ein Script für init.d.
    Vorerst werde ich es aber so lassen, das es ja offensichtlich kein Sicherheitsrisiko darstellt.

    Besten Dank ;)
     
  9. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Alternativ mit 'update-rc.d' entsprechenden Runleveln zuweisen.
     
Thema:

Autostart mit rc.local oder init.d

Die Seite wird geladen...

Autostart mit rc.local oder init.d - Ähnliche Themen

  1. Wo befindet sich der Autostartordner?

    Wo befindet sich der Autostartordner?: Hallo ich habe CentOS 7.2.15.11 und Desktopumgebung mate , wo befindet sich der Autostartordner?
  2. centos & Gnome autostart

    centos & Gnome autostart: Hi zusammen, ich würde gerne nach dem Start von CentOS + Gnome ein von mir geschriebenes Script ausführen (lassen). im Idealfall würde ich gerne...
  3. sh Script zum Autostart

    sh Script zum Autostart: hallo liebe Mitglieder, wenn ich unter Linux eins meiner Shell Skripte im Autostart haben will nutze ich immer die @reboot Funktion im crontab....
  4. Autostart auf raspbmc

    Autostart auf raspbmc: Abend, auf meinem Raspberry Pi hatte ich bisher Raspbian installiert und dort XBMC in einer älteren Version installiert. Leider wird diese von...
  5. Autostart-Skript für TightVNC löschen

    Autostart-Skript für TightVNC löschen: Hallo, ich habe auf meinem Raspberry Pi nach diesem HowTo (http://jankarres.de/2012/08/raspberry-pi-vnc-server-installieren/) TightVNC-Server...