Audiokonverter pacpl: There was an error loading: MP4::Info.

Dieses Thema im Forum "Anwendungen" wurde erstellt von supersucker, 14.04.2007.

  1. #1 supersucker, 14.04.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Hi,

    ich kriege den perl audio konverter ums Verrecken nicht zum Laufen:

    Ein
    Code:
    smart install pacpl
    
    läuft erfolgreich durch.

    Ein erster Aufruf gibt mir:

    Code:
    pacpl --help
    
    Perl Audio Converter - v3.3.1
    
    There was an error loading: MP4::Info.
    Install the module or set USETAGS to 0 in conf file.
    
    No such file or directory
    
    Es gibt neben "pacpl" noch "pacpl-install". Im INSTALL-doc steht folgendes:

    Code:
    ------------------
    Required Libraries
    ------------------
    
    libogg    => v1.1.3
    libvorbis => v1.1.2
    flac      => v1.1.2
    
    ---------------------
    Required Perl Modules
    ---------------------
    
    Parse::RecDescent
    Carp
    Inline
    Inline::C
    Audio::Musepack
    Audio::WMA
    Audio::FLAC::Header
    MP3::Tag
    Ogg::Vorbis::Header
    MP4::Info
    Audio::APETags
    CDDB_get
    
    ----------------------------------------------------------------
    Perl modules above can be installed using the following command:
    
    pacpl-install --install all
    ---------------------------------------------------------------
    ----------------------------
    Konqueror & Amarok Extension
    ----------------------------
    
    kdialog - Located in kde-base package.
    
    The default path for kdialog is /opt/kde/bin/kdialog (Slackware Default).
    You may need to adjust this in your /etc/pacpl/pacpl.conf file.
    
    pacpl-install --install kde
    
    -------------------------------------------------------------------------
    
    
    Das wars, mehr steht nicht drin.

    Die am Anfang des Dokumentes erwähnten Bibliotheken sind installiert:

    Code:
    smart query libogg libvorbis flac --installed
    Loading cache...
    Updating cache...                                             ####################################################################################### [100%]
    
    flac-1.1.2-34@i586
    libogg-1.1.3-31@i586
    libvorbis-1.1.2-31@i586
    
    Saving cache...
    
    Ok, also mal

    Code:
    pacpl-install --install=all
    
    ausgeführt, Ausgabe:

    Code:
    PACPL - v3.3.1: Installing Parse::RecDescent via CPAN
    CPAN: Storable loaded ok
    Going to read /root/.cpan/Metadata
      Database was generated on Tue, 10 Apr 2007 14:11:48 GMT
    CPAN: LWP::UserAgent loaded ok
    Fetching with LWP:
      ftp://cpan.mirror.iphh.net/pub/CPAN/authors/01mailrc.txt.gz
    Going to read /root/.cpan/sources/authors/01mailrc.txt.gz
    CPAN: Compress::Zlib loaded ok
    Fetching with LWP:
      ftp://cpan.mirror.iphh.net/pub/CPAN/modules/02packages.details.txt.gz
    Going to read /root/.cpan/sources/modules/02packages.details.txt.gz
      Database was generated on Fri, 13 Apr 2007 21:09:30 GMT
    
      There's a new CPAN.pm version (v1.90) available!
      [Current version is v1.7602]
      You might want to try
        install Bundle::CPAN
        reload cpan
      without quitting the current session. It should be a seamless upgrade
      while we are running...
    
    Fetching with LWP:
      ftp://cpan.mirror.iphh.net/pub/CPAN/modules/03modlist.data.gz
    Going to read /root/.cpan/sources/modules/03modlist.data.gz
    Going to write /root/.cpan/Metadata
    Parse::RecDescent is up to date.
    PACPL - v3.3.1: Installing Carp via CPAN
    Carp is up to date.
    PACPL - v3.3.1: Installing Inline via CPAN
    Inline is up to date.
    PACPL - v3.3.1: Installing Inline::C via CPAN
    Inline::C is up to date.
    PACPL - v3.3.1: Installing Devel::Symdump via CPAN
    Devel::Symdump is up to date.
    PACPL - v3.3.1: Installing Pod::Coverage via CPAN
    Pod::Coverage is up to date.
    PACPL - v3.3.1: Installing Test::Pod::Coverage via CPAN
    Test::Pod::Coverage is up to date.
    PACPL - v3.3.1: Installing MP3::Info via CPAN
    MP3::Info is up to date.
    PACPL - v3.3.1: Installing Audio::Musepack via CPAN
    Audio::Musepack is up to date.
    PACPL - v3.3.1: Installing Audio::WMA via CPAN
    Audio::WMA is up to date.
    PACPL - v3.3.1: Installing Audio::FLAC::Header via CPAN
    Audio::FLAC::Header is up to date.
    PACPL - v3.3.1: Installing MP3::Tag via CPAN
    MP3::Tag is up to date.
    PACPL - v3.3.1: Installing Ogg::Vorbis::Header via CPAN
    Ogg::Vorbis::Header is up to date.
    Ogg::Vorbis::Header is up to date.
    PACPL - v3.3.1: Installing MP4::Info via CPAN
    MP4::Info is up to date.
    PACPL - v3.3.1: Installing Audio::APETags via CPAN
    Audio::APETags is up to date.
    PACPL - v3.3.1: Installing CDDB_get via CPAN
    CDDB_get is up to date.
    
    PACPL - v3.3.1 - Installed Apps/Tagging Modules
    
    App           Conversion Type           Installed
    -------------------------------------------------
    bonk          BONK                         Yes
    cdparanoia    CD Ripping                   Yes
    faac          FAAC (MP4/M4A/AAC)           Yes
    faad          FAAD (MP4/M4A/AAC)           Yes
    ffmpeg        AC3/MP2                      Yes
    flac          FLAC (FLA/FLAC)              Yes
    kdialog       Konqueror/Amarok Extensions  Yes
    kexis         Kexis (KXS)                  Yes
    la            Lossless Audio (LA)          No
    lame          MP3                          Yes
    lpac          LPAC (PAC/LPAC)              No
    mac           Monkey Audio (APE)           Yes
    mplayer       RealAudio (RA/RAM) & WMA     Yes
    mppdec        Musepack (MPC)               Yes
    mppenc        Musepack (MPC)               No
    ofr           OptimFrog (OFR)              No
    ofs           OptimFrog (OFS)              No
    oggdec        Ogg Vorbis                   Yes
    oggenc        Ogg Vorbis                   Yes
    shorten       Shorten (SHN)                Yes
    sox           AU/SND/AIFF/RAW/SMP/VOC      Yes
    ttaenc        TTA                          Yes
    wavpack       Wavpack (WV)                 Yes
    wvunpack      Wavpack (WV)                 Yes
    
    See /usr/local/doc/pacpl-v3.3.1/README for application URLs
    
    Press enter to continue
    
    PACPL - v3.3.1: Audio Tagging Modules
    
    MP3::Tag -> Not Installed
    Ogg::Vorbis::Header -> Not Installed
    Audio::FLAC::Header -> Not Installed
    MP4::Info -> Not Installed
    Audio::Musepack -> Not Installed
    Audio::WMA -> Not Installed
    CDDB_get -> Not Installed
    
    Sieht ja eigentlich gut aus, bis auf das Ende. Die ganzen Module die als "not installed" angemahnt werden sind nämlich installiert.

    Code:
     perl -MCPAN -e 'install Audio::WMA'
    CPAN: Storable loaded ok
    Going to read /root/.cpan/Metadata
      Database was generated on Fri, 13 Apr 2007 21:09:30 GMT
    Audio::WMA is up to date.
    
    Code:
     perl -MCPAN -e 'install MP3::Tag'
    CPAN: Storable loaded ok
    Going to read /root/.cpan/Metadata
      Database was generated on Fri, 13 Apr 2007 21:09:30 GMT
    MP3::Tag is up to date.
    
    Code:
     perl -MCPAN -e 'install MP4::Info'
    CPAN: Storable loaded ok
    Going to read /root/.cpan/Metadata
      Database was generated on Fri, 13 Apr 2007 21:09:30 GMT
    MP4::Info is up to date.
    
    Ein erneuter Aufruf bringt mir wieder:

    Code:
    pacpl --help
    
    Perl Audio Converter - v3.3.1
    
    There was an error loading: MP4::Info.
    Install the module or set USETAGS to 0 in conf file.
    
    No such file or directory
    
    Ok, habs also in der /etc/pacpl/pacpl.conf auf 0 gesetzt:

    Code:
    
    # (AAC/MP4/M4A) Encoder
    ###########################
    FAAC = 0
    
    
    # (AAC/MP4/M4A) Decoder
    ###########################
    FAAD = 0
    
    Ein erneuter Aufruf bringt mir aber schon wieder:

    Code:
    pacpl --help
    
    Perl Audio Converter - v3.3.1
    
    There was an error loading: MP4::Info.
    Install the module or set USETAGS to 0 in conf file.
    
    No such file or directory
    
    Habs dann wieder über smart deinstalliert, mir die sourcen gezogen und wieder "pacpl-install" ausgeführt.

    Ergebnis: Die gleichen Fehlermeldungen wie oben.

    Google sagt nichts zu der Fehlermeldung, auch in den FAQ von pacpl find ich nichts dazu....

    Jemand ne Idee?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Audiokonverter pacpl: There was an error loading: MP4::Info.

Die Seite wird geladen...

Audiokonverter pacpl: There was an error loading: MP4::Info. - Ähnliche Themen

  1. pacpl installiert... wie konvertiere ich

    pacpl installiert... wie konvertiere ich: Hallo, wie in der Überschrift schon erwähnt habe ich die neuste Version von pacpl (4.0.1) auf meinem Debian Rechner installiert. Das Programm an...