ATI und XGL in Suse 10.3

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Marlowe1967, 01.01.2008.

  1. #1 Marlowe1967, 01.01.2008
    Marlowe1967

    Marlowe1967 Grünschnabel

    Dabei seit:
    01.01.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo

    Ich weiss, das Thema ist alt und ich habe auch schon viele Posts gefunden, aber leider konnte ich das Problem noch nicht lösen.

    Ich habe eine ATI Mobile X1600 und habe den Treiber installiert und alles klappt toll in meinem Suse10.3 64bit, auch 3D. Dann habe ich das neuste bezüglich xgl und Compiz-Fusion installiert. Alles kein Problem. Ich kann auch alles Starten und der Cube von Compiz funktioniert tadellos, nur reagieren die Fenster und Knöpfe in der Startleiste nicht auf die Mausbefehle.

    Beispiel:Ich habe Compiz als Fenstermanager gestartet und klicke dann auf den Knopf Firefox - nichts geschiet. Wenn ich dann den Cube vor und zurück rotiere, ist der Browser offen, nur kann ich ihn dann wieder nicht schliessen. Ich muss auf x drücken und dann Cube vor und zurück und Firefox ist geschlossen.

    Hat irgendwer eine Ahnung woran das liegen könnte?

    Danke für die Hilfe.

    Marlowe1967
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Marlowe1967, 07.01.2008
    Marlowe1967

    Marlowe1967 Grünschnabel

    Dabei seit:
    01.01.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Xgl

    Hallo

    Scheint ja nicht so einfach zu sein. Habe festgestellt, dass beim Umschalten auf Xgl mit fglrxinfo nicht mehr der ATI-Treiber angezeigt wird, sonder der Vesa-Treiber. Könnte das Problem da liegen und wenn ja, was kann ich machen? :think:

    danke
     
  4. #3 devolo01, 07.01.2008
    devolo01

    devolo01 Tripel-As

    Dabei seit:
    04.09.2007
    Beiträge:
    150
    Zustimmungen:
    0
    Scheint erstmal Aktuell das Problem zu sein, mal versucht deinen ATI neu zu Installieren unter XGL?
     
  5. #4 Marlowe1967, 08.01.2008
    Marlowe1967

    Marlowe1967 Grünschnabel

    Dabei seit:
    01.01.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Danke für den Tipp
    Habe ich ausprobiert. Umgestellt auf XGL, Compiz nicht aktiviert und dann Treiber komplett deinstalliert und neu installiert. Unter XGL immer noch VESA, unter Xorg ATI!
     
  6. #5 devolo01, 09.01.2008
    Zuletzt bearbeitet: 09.01.2008
    devolo01

    devolo01 Tripel-As

    Dabei seit:
    04.09.2007
    Beiträge:
    150
    Zustimmungen:
    0
    so habe jetzt mal bei mir getestet und auch mal auf XGL umgeschalten. Komischerweise Identischer Fehler:
    Code:
    devolo01@localhost:~> fglrxinfo
    libGL error: open DRM failed (Operation not permitted)
    libGL error: reverting to (slow) indirect rendering
    display: :0.0  screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.4 (2.1 Mesa 7.0.1)
    
    devolo01@localhost:~>
    
    Was ich jetzt nicht verstehe warum das so ist ? Hat evt jemand eine Idea ob die Treiber evt nicht auf XGL Kompatible sind oder ob in der Xorg was geändert werden muss ? Ich verstehe jetzt leider auch nicht was der Lib error genau Aussagt.

    Ist es Richtig das

    Code:
    libGL error: open DRM failed (Operation not permitted)
    
    bedeutet das open DRM fehlt ?

    und die 2. meldung sagt für mich aus das das System zulangsam ist oder übersetze ich da was Falsch ?
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. #6 gropiuskalle, 09.01.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    failed = fehlgeschlagen.

    Bedeutet, dass aufgrund der fehlgeschlagenen Aktivierung keine 3D-Beschleunigung erreicht wurde.
     
  9. #7 devolo01, 09.01.2008
    Zuletzt bearbeitet: 09.01.2008
    devolo01

    devolo01 Tripel-As

    Dabei seit:
    04.09.2007
    Beiträge:
    150
    Zustimmungen:
    0
    @ Kalla danke dir

    Habe es gelöst bekommen :)

    bin jetzt über konsole

    mit aticonfig vorgegangen.

    und siehe da

    Code:
    localhost:/home/devolo01 # fglrxinfo
    display: :0.0  screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Mobility Radeon X1400
    OpenGL version string: 2.1.7170 Release
    
    Werde nachher noch testen ob compiz funks und 3 D gebe dann Feedback :)

    Gruß

    ---------------

    Edit:

    So als 3D Funks allerdings Tut Compiz-Fusion nichts.

    Solbald ich es Aktiviere hängt sich mein Ganzer Desktop auf reagiert auf nix mehr :(

    Sobald ich dann in dir Konsole wechsle und versuche kde Neu zu starten oder auch einach versuche den Rechner in ein Anderes Runlevel zu fahren reagiert diese auch nicht mehr.

    Habe jetzt erstmal wieder auf Xorg umgeschalten.

    Meine Frage jemand evt ne Idea woran das Liegen könnt. Bzw wo kann ich genau nach schauen was da passiert ist ? Sollte doch nen Log oder Protokoll geben oder? Da ich nich relativ Frisch bin weiß ich jetzt leider nicht genau wie ich mit der Fehler beseitigung btw. wo genau ich die entsprechenden Logs oder Protokolle finde.

    Danke euch
     
Thema:

ATI und XGL in Suse 10.3

Die Seite wird geladen...

ATI und XGL in Suse 10.3 - Ähnliche Themen

  1. SUSE 13.2 Bumblebee dual monitor

    SUSE 13.2 Bumblebee dual monitor: Folgendes Problem: weder am VGA noch HDMI-Ausgang ist ein Signal für den Beamer vorhanden. Rechner: Lenovo Z70 SUSE 13.2 Kernel...
  2. Suse: Tomas Di Giacomo wird neuer CTO

    Suse: Tomas Di Giacomo wird neuer CTO: Suse hat seinen Vorstand um Dr. Tomas Di Giacomo erweitert, der als Chief Technology Officer ab sofort dem Unternehmen angehört. In der neu...
  3. OpenSuse Conference vom 22. bis 26. Juni in Nürnberg

    OpenSuse Conference vom 22. bis 26. Juni in Nürnberg: Zum mittlerweile achten Mal findet die OpenSuse Conference statt. In diesem Jahr wird sie vom 22. bis 26. Juni in Nürnberg abgehalten. Der Call...
  4. OpenSuse Conference vom 22. bis 26. Juni in Nürnberg

    OpenSuse Conference vom 22. bis 26. Juni in Nürnberg: Zum mittlerweile achten Mal findet die OpenSuse Conference statt. In diesem Jahr wird sie vom 22. bis 26. Juni in Nürnberg abgehalten. Der Call...
  5. Suse veröffentlicht OpenStack Cloud 6

    Suse veröffentlicht OpenStack Cloud 6: Mit Suse OpenStack Cloud 6 können Unternehmen private Clouds mit geringem Aufwand aufsetzen. Die Distribution beruht auf Suse Enterprise Linux und...