ATI-Grafiktreiber?

Dieses Thema im Forum "NetBSD" wurde erstellt von kasumi, 16.07.2011.

  1. kasumi

    kasumi Eroberer

    Dabei seit:
    14.07.2011
    Beiträge:
    59
    Zustimmungen:
    0
    Ort:
    Südlich von Böhmen.
    Hallo.

    Es existiert zwar ein Port, der sich jedoch nicht installieren lässt. Während der Installation von libXext, einer Dependency, benötigt er zwei neuere Versionen von Programmen (xproto und xextproto)

    Ich hab der Einfachheit halber einen Screenshot gemacht, copy&paste ausm Xterm ist ja nicht so einfach möglich ...

    http://www.abload.de/img/2011-07-16-171332_1280tnbp.png

    Hoffe, ihr könnt mir helfen. :)

    Danke.

    Kasumi.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 gropiuskalle, 16.07.2011
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Text markieren, paste mit Mausmittelklick. ;)

    Dir fehlen offenbar einige compiler.
     
  4. kasumi

    kasumi Eroberer

    Dabei seit:
    14.07.2011
    Beiträge:
    59
    Zustimmungen:
    0
    Ort:
    Südlich von Böhmen.
    Mir fehlen Compiler ... und das beheb ich wie?

    Bzw, welche denn? Das mit den USE_LANGUAGES sind ja nur Warnings, keine Errors, oder?
     
  5. #4 gropiuskalle, 16.07.2011
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Nee sorry, hab nicht genau hingelesen, vergiss meinen Kommentar.

    Stelle die Ausgabe doch mal als Reintext hier rein, sonst liest sich das kein Mensch durch.
     
  6. kasumi

    kasumi Eroberer

    Dabei seit:
    14.07.2011
    Beiträge:
    59
    Zustimmungen:
    0
    Ort:
    Südlich von Böhmen.
    Code:
     checking for cc option to accept ISO C89... (cached) none needed
    checking dependency style of cc... (cached) gcc3
    checking for cc option to accept ISO C99... -std=gnu99
    checking pkg-config is at least version 0.9.0... yes
    checking for XEXT... configure: error: Package requirements (xproto >= 7.0.13 x11 >= 1.1.99.1 xextproto >= 7.0.99.2) were not met:
    
    Requested 'xextproto >= 7.0.99.2' but version of XExtProto is 7.0.5
    
    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.
    
    Alternatively, you may set the environment variables XEXT_CFLAGS
    and XEXT_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.
    
    *** Error code 1
    
    Stop.
    make: stopped in /usr/pkgsrc/x11/libXext
    WARNING: *** Please consider adding c++ to USE_LANGUAGES in the package Makefile.
    WARNING: *** Please consider adding fortran to USE_LANGUAGES in the package Makefile.
    *** Error code 1
    
    Stop.
    make: stopped in /usr/pkgsrc/x11/libXext
    *** Error code 1
    
    Stop.
    make: stopped in /usr/pkgsrc/x11/modular-xorg-server
    *** Error code 1
    
    Stop.
    make: stopped in /usr/pkgsrc/x11/xf86-video-ati
    # 
    So.
     
  7. #6 xbeduine, 16.07.2011
    xbeduine

    xbeduine ausgesperrt

    Dabei seit:
    09.09.2007
    Beiträge:
    142
    Zustimmungen:
    0
    Da hast du eine zu alte lib installiert.
     
  8. kasumi

    kasumi Eroberer

    Dabei seit:
    14.07.2011
    Beiträge:
    59
    Zustimmungen:
    0
    Ort:
    Südlich von Böhmen.
    Scheint so, aber nicht absichtlich.

    Wie beheb ich das dann? :)
     
  9. #8 gropiuskalle, 17.07.2011
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Die Frage beantwortet sich doch von selbst.

    Recherchiere, wo Du eine >= 7.0.99.2-Version von xextproto (und ggf. dessen devels) bekommst.
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. kasumi

    kasumi Eroberer

    Dabei seit:
    14.07.2011
    Beiträge:
    59
    Zustimmungen:
    0
    Ort:
    Südlich von Böhmen.
    Gut. Die hab ich in Form eines .tgz-Archivs. Und ... wie installier ich die? Google spuckt nix aus ...
     
  12. #10 xbeduine, 17.07.2011
    xbeduine

    xbeduine ausgesperrt

    Dabei seit:
    09.09.2007
    Beiträge:
    142
    Zustimmungen:
    0
    Archiv schon mal entpackt? Darin gibts event. ein Readme.
     
Thema:

ATI-Grafiktreiber?