ASF/WMV TV Streams kommen nur ruckelig mit mPlayer

Dieses Thema im Forum "Grafik / Video" wurde erstellt von Y-Tux, 08.08.2006.

  1. Y-Tux

    Y-Tux Tripel-As

    Dabei seit:
    23.05.2006
    Beiträge:
    212
    Zustimmungen:
    0
    wie gesagt kommen bei mir die ASF/WMV TV/Video streams nur ruckelig der ton ist gut aber das video ruckelt vor sich hin..

    ist das bei euch auch so?
    wie kann man es fluessig machen?

    beim mplayer plugin ruckelts und beim direkten abspielen im mplayer ruckelts auch..

    beim VLC player kommt nur der sound aber hab kein bild...

    in der konsole so eingeben und enter drucken
    gmplayer http://streamers.at.sara.crossmediaventures.com/tmf_video?MSWMExt=.asf

    in den browser kopieren und schauen wen man das mplayer-plugin hat
    http://streamers.at.sara.crossmediaventures.com/tmf_video?MSWMExt=.asf
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Nein, huckelt nicht. Muss ich garnicht erst ausprobieren. Ich hab mit asf und wmv keinerlei Probleme. Was sagt bekommst du denn fuer Meldungen auf der Konsole, wenn du 'mplayer <stream>' im Terminal startest?
     
  4. #3 Y-Tux, 08.08.2006
    Zuletzt bearbeitet: 08.08.2006
    Y-Tux

    Y-Tux Tripel-As

    Dabei seit:
    23.05.2006
    Beiträge:
    212
    Zustimmungen:
    0
    was fuer ne version vom mplayer nutzt du den und auf welcher distri?

    probiers doch mal aus.. besonders diese links die ich oben angegeben hab.
    bei wmv/asf dateien auf der festplatte hab ich auch keine probleme.

    in der konsole gibt er das aus

    linux:~ # gmplayer -dumpstream http://streamers.at.sara.crossmediaventures.com/tmf_video?MSWMExt=.asf
    MPlayer SuSE Linux 10.0 (i686)-Packman-4.0.2 (C) 2000-2005 MPlayer Team
    CPU: Advanced Micro Devices Athlon 4 /Athlon MP/XP Palomino (Family: 6, Stepping: 2)
    Detected cache-line size is 64 bytes
    CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
    Compiled with runtime CPU detection - WARNING - this is not optimal!
    To get best performance, recompile MPlayer with --disable-runtime-cpudetection.



    vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.2" => local display)
    xscreensaver_disable: Could not find xscreensaver window.
    Opening joystick device /dev/input/js0
    Can't open joystick device /dev/input/js0 : No such file or directory
    Can't init input joystick
    Setting up LIRC support...
    mplayer: could not connect to socket
    mplayer: Connection refused
    Failed to open LIRC support.
    You will not be able to use your remote control.
    Playing http://streaming.newmedia.lu//telehighres.
    Resolving streaming.newmedia.lu for AF_INET6...
    Couldn't resolve name for AF_INET6: streaming.newmedia.lu
    Resolving streaming.newmedia.lu for AF_INET...
    Connecting to server streaming.newmedia.lu[81.92.238.8]:80 ...
    Resolving streaming.newmedia.lu for AF_INET6...
    Couldn't resolve name for AF_INET6: streaming.newmedia.lu
    Resolving streaming.newmedia.lu for AF_INET...
    Connecting to server streaming.newmedia.lu[81.92.238.8]:80 ...
    Resolving streaming.newmedia.lu for AF_INET6...
    Couldn't resolve name for AF_INET6: streaming.newmedia.lu
    Resolving streaming.newmedia.lu for AF_INET...
    Connecting to server streaming.newmedia.lu[81.92.238.8]:80 ...
    Cache size set to 1790 KBytes
    Connected to server: streaming.newmedia.lu
    Cache fill: 18.32% (335872 bytes) ASF file format detected.
    VIDEO: [WMV3] 384x288 24bpp 1000.000 fps 0.0 kbps ( 0.0 kbyte/s)
    Clip info:
    name: T��Live
    author: RTL T��L�zebuerg
    copyright: RTL T��L�zebuerg
    ==========================================================================
    Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
    AUDIO: 32000 Hz, 2 ch, s16le, 48.0 kbit/4.69% (ratio: 6000->128000)
    Selected audio codec: [ffwmav2] afm:ffmpeg (DivX audio v2 (FFmpeg))
    ==========================================================================
    xscreensaver_disable: Could not find xscreensaver window.
    ==========================================================================
    Trying to force video codec driver family vfw...
    Opening video decoder: [dmo] DMO video codecs
    DMO dll supports VO Optimizations 0 1
    DMO dll might use previous sample when requested
    GetOutput r=0x0 size:331776 align:1
    StreamCount r=0x0 1 1
    Decoder supports the following YUV formats: YV12 YUY2 UYVY YVYU ▒
    Decoder is capable of YUV output (flags 0x1b)
    VDec: vo config request - 384 x 288 (preferred csp: Packed YUY2)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is undefined - no prescaling applied.
    VO: [xv] 384x288 => 384x288 Planar YV12
    Selected video codec: [wmv9dmo] vfm:dmo (Windows Media Video 9 DMO)
    ==========================================================================
    Checking audio filter chain for 32000Hz/2ch/s16le -> 32000Hz/2ch/s16le...
    AF_pre: 32000Hz/2ch/s16le
    AO: [oss] 32000Hz 2ch s16le (2 bps)
    Building audio filter chain for 32000Hz/2ch/s16le -> 32000Hz/2ch/s16le...
    Starting playback...
    A:1776814.1 V:1776813.8 A-V: 0.373 ct: -0.713 610/610 5% 4% 16.7% 55 0 0%

    ************************************************
    **** Your system is too SLOW to play this! ****
    ************************************************

    Possible reasons, problems, workarounds:
    - Most common: broken/buggy _audio_ driver
    - Try -ao sdl or use the OSS emulation of ALSA.
    - Experiment with different values for -autosync, 30 is a good start.
    - Slow video output
    - Try a different -vo driver (-vo help for a list) or try -framedrop!
    - Slow CPU
    - Don't try to play a big DVD/DivX on a slow CPU! Try -hardframedrop.
    - Broken file
    - Try various combinations of -nobps -ni -forceidx -mc 0.
    - Slow media (NFS/SMB mounts, DVD, VCD etc)
    - Try -cache 8192.
    - Are you using -cache to play a non-interleaved AVI file?
    - Try -nocache.
    Read DOCS/HTML/en/video.html for tuning/speedup tips.
    If none of this helps you, read DOCS/HTML/en/bugreports.html.
     
  5. #4 DennisM, 08.08.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Versuch doch mal die Optionen, die MPlayer dir vorschlägt.

    MFG

    Dennis
     
  6. Y-Tux

    Y-Tux Tripel-As

    Dabei seit:
    23.05.2006
    Beiträge:
    212
    Zustimmungen:
    0
    das meise wo mplayer vorschlaegt hab ich schon versucht -isty immer gleich und bringt kaum verbesserungen...

    muss da wohl ne andere mplayer version installieren...
     
  7. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Also ich habe sie aus dem Source von mplayerhq.com installiert und damit keinerlei Probleme. Versuch's doch mal damit, wenn du derzeit die Version deiner Distro nutzt.
     
  8. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Bei mir ruckelt das Bild auch. Allerdings wundert es mich wenig, da ich einen langsamen Rechner ohne besondere Grafikkarte habe (700MHz Athlon k6, ATI Rage). Auf welchem der angegebenen Rechner hast Du es denn probiert? Sind die proprietaeren Grafiktreiber installiert?
     
  9. Y-Tux

    Y-Tux Tripel-As

    Dabei seit:
    23.05.2006
    Beiträge:
    212
    Zustimmungen:
    0
    ich habs auf dem AMD 1800+ mit suse 10.0 und die graka is die sis xabre 400.. bei mpg/avi/dvd und so gehts fluessig mit dem mplayer und vlc...

    ich hab noch nie ein programm aus der source compiliert und isntalliert -immer nur die rpm vom packman.
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. Xanti

    Xanti Mouse Organist

    Dabei seit:
    05.09.2004
    Beiträge:
    1.855
    Zustimmungen:
    0
    Steht doch alles da :D

    Code:
    Compiled with runtime CPU detection - WARNING - this is not optimal!
    To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
    
    Aus eigener Erfahrung bringt dies wirklich was.
     
  12. #10 Y-Tux, 09.08.2006
    Zuletzt bearbeitet: 09.08.2006
    Y-Tux

    Y-Tux Tripel-As

    Dabei seit:
    23.05.2006
    Beiträge:
    212
    Zustimmungen:
    0
    der mplayer war bei jeder linux distri noch nie zu 100% optimal bei mir aber ging immer gut..

    der TMF musik sender geht wieder fluessig bei mir aber der sound ist mit dem bild nicht mehr synchrom -das video is um 1-2 sekunden dem sound hintendrin... hab einige optionen ausprobiert beim mplayer bringen aber nichts.
    gmplayer http://streamers.at.sara.crossmediaventures.com/tmf_video?MSWMExt=.asf

    dafuer ruckelt der RTL Luxenburg -oder wie ist es bei euch?
    gmplayer http://streaming.newmedia.lu//telehighres
     
Thema:

ASF/WMV TV Streams kommen nur ruckelig mit mPlayer

Die Seite wird geladen...

ASF/WMV TV Streams kommen nur ruckelig mit mPlayer - Ähnliche Themen

  1. Webcam freeBSD für Streamserver

    Webcam freeBSD für Streamserver: Hi Forum Ich würde gerne eine Webcam an meinem freeBSD Server anschliessen, mit der ich dann über das Internet einen Stream ansehen kann. Im...
  2. Real Player Streams - Kein Fullscreen möglich

    Real Player Streams - Kein Fullscreen möglich: Hallo zusammen, Ich möchte mir gerne Videos auf CBS.com unter Ubuntu 7.04 ansehen und habe dafür auch schon alle notwendigen Vorkehrungen...
  3. streams die 2.

    streams die 2.: Kann ir jemand sagen ob (undwenn ja wie) man die Buffergrösse von BinaryReader/Writer ändern kann? Das Problem: Ich füttere einen externen...
  4. mplayer und (g)xine installiert - dennoch keine webstreams möglich

    mplayer und (g)xine installiert - dennoch keine webstreams möglich: Hallo - ich versuche im Moment Video-Streams auf meinem 64 Bit Suse 10.2 System zum Laufen zu bringen (ein spezielles Interesse besteht am...
  5. Amarok speilt keine ogg files/streams

    Amarok speilt keine ogg files/streams: Wie gesagt AmaroK spielt keine ogg streams und files, ich habe aber die libogg installiert, auch die libvorbis und die vorbis tools. Es sagt...