ArchLinux + Xorg 6.8.2 + ATi-Treiber gehen ned

Dieses Thema: "ArchLinux + Xorg 6.8.2 + ATi-Treiber gehen ned" im Forum "Sonstige Linux Distributionen" wurde erstellt von fabifri, 22.02.2005.

  1. #1 fabifri, 22.02.2005
    Zuletzt bearbeitet: 22.02.2005
    fabifri

    fabifri Kopf hörer

    Dabei seit:
    02.09.2004
    Beiträge:
    116
    Zustimmungen:
    0
    Ort:
    AUT
    ArchLinux + Xorg 6.8.2 + ATi-Treiber gehen ned ++ irgend ein AGP fehler ++ hilfe ++

    hallo leute
    habe heir massive probleme mit dem ATi-treiber obwohl ich die für Xorg habe(soweit ich weiss) und diese mit pacman(packetsystem) installiert habe...

    also

    ati-drivers-module-kernel26 8.8.25-1 January 20 2005 00:13:15
    ati-drivers 8.8.25-1 January 20 2005 00:19:34

    ^^ diese heir..

    hab die installiert, das modul von /lib/modules/2.6.10-ARCH/video/fglrx.ko nach /lib/modules/2.6.10-ARCH/drivers/media/video verschoben und als root mit modprobe geladen,... (lsmod | grep fglrx zeigt fglrx-modul mal an...)

    jetzt hab ich einfach meine bestehende xorg-config genommen, als driver "fglrx" eingetragen und der X-Server startetet...., aber wenn ich fgl_glxgears mache, dann kommt:

    Code:
    Xlib:  extension "XFree86-DRI" missing on display ":0.0".
    X Error of failed request:  BadMatch (invalid parameter attributes)
      Major opcode of failed request:  142 (GLX)
      Minor opcode of failed request:  5 (X_GLXMakeCurrent)
      Serial number of failed request:  30
      Current serial number in output stream:  30
    ok gut, fglrxconfig ausgeführt, alles eingestellt und XF86config erstellen lassen und die dann in xorg.conf umbenannt, Xserver startet nicht mehr, ich schreib euch gleich die ausgabe hin:

    die zeilen in denen "(EE)" vorkommt:
    Code:
    (EE) Failed to load module "Keyboard" (module does not exist, 0)
    (EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENOMEM"
    (EE) fglrx(0): cannot init AGP
    (EE) No Input driver matching `Keyboard'
    die zeilen mit (WW):
    Code:
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (WW) Open APM failed (/dev/apm_bios) (No such file or directory)
    (WW) Warning, couldn't open module Keyboard
    (WW) fglrx: No matching Device section for instance (BusID PCI:3:0:1) found
    (WW) fglrx(0): board is an unknown third party board, chipset is supported
    (WW) fglrx(0): Cannot read colourmap from VGA.  Will restore with default
    (WW) fglrx(0): could not detect XFree86 version (query_status=-3)
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed!                  *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO)             *
    (WW) fglrx(0): * no 3D acceleration available                *
    (WW) fglrx(0): ********************************************* *
    fast vergessen: mein sytem:

    2800+
    radeon 9600
    1gb ram
    xorg 2.8.2

    ARCH LINUX

    -- ich bin mit meinem latein einfach am ende, ich versuch jetzt mal "keyboard" zu schreiben, in die config, vielleicht gehts dann...aber ich glaube da iss was am AGP-modul...
     
  2. Anzeige

    schau mal hier --> (hier klicken). Viele Antworten inkl. passender Shell-Befehle!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Moritz

    Moritz Life is hard and so am I

    Dabei seit:
    06.08.2003
    Beiträge:
    367
    Zustimmungen:
    0
    Ort:
    Köln
    Ich bin nicht ganz sicher, ob der ATi-Treiber überhaupt xorg 6.8.2 unterstützt. Geschrieben wurde er nämlich noch für 6.8.1. Hab leider selber ne nVidia.

    Also folgendes würde ich mal überprüfen:
    1. steht in der xorg.conf in der Modules-Sektion
    Code:
        Load        "glx"
    2. hat sich die conf von xfree nach xorg n bissl geändert deswegen der "keyboard"-fehler. Guck die mal InputDevice-Sektion an. Meine sieht folgendermaßen aus:
    Code:
    Section "InputDevice"
        Identifier  "Keyboard1"
        Driver      "kbd"
        Option      "Protocol"      "Standard"
        Option      "AutoRepeat"    "500 30"
        Option      "XkbModel"      "pc105"
        Option      "XkbLayout"     "de"
        Option      "XkbVariant"    "nodeadkeys"
        Option      "XkbRules"      "xorg"
        Option      "XkbOptions"    "altwin:menu"
    EndSection
    
    Pass auf den Identifier auf. Der muss in der ServerLayout-Sektion passen (d.h. gleicher Name).

    So. Vielleicht hilft das ja schonmal.

    Grüße,
    Moritz
     
  4. Riebl

    Riebl Foren As

    Dabei seit:
    15.03.2004
    Beiträge:
    79
    Zustimmungen:
    0
    also ich verwende selber arch linux, auch mit xorg 6.8.2 zusammen mit den fglrx treibern und ich hab keine probleme. ich hab auch keine module irgendwo verschoben oO einfach mit pacman aus dem tur von "link" die pakete installiert - fertig. vielleicht musst du noch agpgart laden?
     
  5. #4 DennisM, 22.02.2005
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    den keyboard treiber von "Keyboard" nach "kbd" ändern , und dri laden lassen...

    MFG

    Dennis
     
  6. #5 fabifri, 22.02.2005
    fabifri

    fabifri Kopf hörer

    Dabei seit:
    02.09.2004
    Beiträge:
    116
    Zustimmungen:
    0
    Ort:
    AUT

    jo das ist es: (dri is geladen, glx ist geladen, keyboard-fehler behoben)

    hab das vorher im IRC mit devilz durchgecheckt, module geladen und installiert, nur beim laden bringt er den fehler das der Interne AGP ned geht und man AGPGART verwenden soll. modprobe agpgart geht nee, kannste mir das bitte sagen :) *nettschau*

    die xorg.conf ist vorbereitet ich weiss nur ned wie das geht mit dem agp laden...

    xcompmgr müsste eh ned gehen mit ATi, das hat mir zumindest devilz gesagt, aber 3D is auch schon was :)

    danke und mfg fabifri
     
  7. Riebl

    Riebl Foren As

    Dabei seit:
    15.03.2004
    Beiträge:
    79
    Zustimmungen:
    0
    ich schwing mich jetzt in die falle, aber morgen werde ich dich mal per icq oder so kontaktieren, wäre doch gelacht, wenn mir das problem nicht in den griff bekommen würden ;)
    persönlich hab ich einen eigenen kernel unter arch gebaut und auch das fglrx kernel modul habe ich selber compiliert, mal gucken welche einstellungen da arch standardmäßig verwendet, aber wie gesagt, das alles morgen wenn ich wieder fit bin :P
     
  8. #7 fabifri, 22.02.2005
    Zuletzt bearbeitet: 22.02.2005
    fabifri

    fabifri Kopf hörer

    Dabei seit:
    02.09.2004
    Beiträge:
    116
    Zustimmungen:
    0
    Ort:
    AUT
    von mir aus kannst du mir ja helfen, auch ein eigenes modul zu bauen, aber beim kernel bleib ich beim arch kernel, also ich hab das rpm runtergeladen vun ATi aber da weiss ich schon nimmer weiter, weil keinerlei RPM tools bei arch dabei sind, und vom TUR die RPM tools bringen mich ned weiter beim installieren des treibers, kommen file conflicts........

    aber ich bin mir sicher dass das mit dem agp-gart zusammenhängt
    danke noch,

    mfg fabifri (ICQ# 169103555)

    EDIT1: ich vervolge gerade eine e-bay auktion von einer GeForce2 MX 400 64MB
    dann kann ich wenigstens 3ddesktop und xcompmgr nutzen, um das gehts mir ja, um den xcompmgr, der müsste mit einer beschleunigten GF2 auch ganz recht gut laufen....
    kostet ja auch ned viel, max. 5€.... für xcompmgr is mir das recht... :)
     
  9. Riebl

    Riebl Foren As

    Dabei seit:
    15.03.2004
    Beiträge:
    79
    Zustimmungen:
    0
    hmm... irgendwas stimmt mit meinem icq heute nicht oO
    naja, rpm pakete kannst du mit folgender befehlskette entpacken unter arch:
    Code:
    rpmunpack < fglrx-paket-name.rpm | gzip -d | cpio -idmuv
    damit wird das paket im aktuellen verzeichnis entpackt, am besten kopierst du nur die daten aus dem unterordner lib nach /lib. für den kernel 2.6.10 brauchst du noch einen patch, den du hier finden kannst:
    http://www.stanford.edu/~fenn/linux/fglrx-kernel2.6.10.patch (mit anleitung: http://www.stanford.edu/~fenn/linux/radeon.shtml )
    dann sollte das compilieren des kernel-modules kein problem mehr sein. wenn du willst, kann ich dir auch noch meine xorg.conf schicken :)
    was mir gerade noch einfällt, was sagt eigentlich dmesg | grep agpgart?

    mfg, raphael
     
  10. #9 fabifri, 24.02.2005
    fabifri

    fabifri Kopf hörer

    Dabei seit:
    02.09.2004
    Beiträge:
    116
    Zustimmungen:
    0
    Ort:
    AUT
Thema:

ArchLinux + Xorg 6.8.2 + ATi-Treiber gehen ned

Die Seite wird geladen...

ArchLinux + Xorg 6.8.2 + ATi-Treiber gehen ned - Ähnliche Themen

  1. vbox - archlinux und IP

    vbox - archlinux und IP: Hallo Habe archlinux per architect (besserer Installer als dieser dumfug via chroot), funktioniert soweit fast alles. Das fast ist, wie bekomme...
  2. xdm-archlinux Frage

    xdm-archlinux Frage: Hallo Archlinux für amd64, incl. xdm-archlinux. Jetzt hab ich in der /etc/X11/xdm/archlinux/Xresources den Text fürs userlogin geändert....
  3. fehlerhaftes Grub nach ArchLinux-Installation

    fehlerhaftes Grub nach ArchLinux-Installation: Hey. Erstmal 'schuldigung, wenn dieses Thread hier falsch platziert sein sollte. Bin ganz neu in diesem Forum, und suche eine freundliche...
  4. ArchLinux Basic [Quick&Dirty]

    ArchLinux Basic [Quick&Dirty]: Inhaltsverzeichnis 1. Installation
  5. ArchLinux + TS154USB (ndiswrapper)

    ArchLinux + TS154USB (ndiswrapper): Morgen^^, oder ist es abend?!:D Also hier meine Frage: Ich will auf Arch umsteigen! Jetzt ein paar Fragen: 1) Unterstützt es dual cores 2)...