Apt würde gern wichtige Pakete lösche.

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Emess, 24.02.2008.

  1. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Wollte gerade per Apt ein Programm deinstallieren, da bekomm ich den Vorschlag per apt-get autoremove einige hundert MB zu deinstallieren.

    Code:
    michael@lennynb:~$ su
    Passwort:
    lennynb:/home/michael# apt-get remove kandy
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Reading state information... Fertig
    The following packages were automatically installed and are no longer required:
      knetwalk kpat kpdf ksokoban kolf php-fpdf blinken kscreensaver-xsavers libconvert-binhex-perl krdc
      korn libdb4.6++ krfb kppp kshisen kmoon kmahjongg klaptopdaemon ksig ksim kwifimanager kcharselect
      kjumpingcube kdeartwork-style knewsticker-scripts kdeartwork-misc kcoloredit texlive-base-bin-doc
      kdessh kanagram ktip knode katomic kleopatra kdegames-card-data kscreensaver kruler ktux klettres
      texlive-base kgoldrunner kbackgammon libxine1-x kpoker dirmngr kdepim-kfile-plugins ncompress
      libkiten1 texlive-fonts-recommended kgeography libcrypt-ssleay-perl ksnapshot kpackage liblockdev1
      kenolaba xscreensaver-gl kblackbox kdebase atlantikdesigner konsolekalendar klatin lmodern kfloppy
      kdegraphics-kfile-plugins kstars ttf-dustin ksame libxine1-misc-plugins kbruch kpager libxcb-xv0
      libsmokeqt1 libkdegames1 kde-core kcalc texlive-common libpcap0.8 xscreensaver libpisock9 dosfstools
      keduca libfinance-quote-perl kdeedu-data kdemultimedia-kappfinder-data kontact
      kdeadmin-kfile-plugins kdeartwork-theme-icon kweather kmplot kalzium pinentry-curses klinkstatus
      libxine1-bin klickety postgresql-client-8.2 postgresql-client-8.3 ksayit kde-icons-mono php5-gd
      kmouth kalarm noatun-plugins talk libmime-tools-perl libqt-perl kworldclock kalzium-data kdewebdev
      texlive-base-bin kdegames toshset kicker-applets ttf-kochi-gothic festlex-cmu amor ktouch
      lilo-config kgeography-data ktnef khexedit kdeaccessibility kedit dvipdfmx kbounce kvoctrain kdetoys
      kdenetwork-kfile-plugins libfile-temp-perl kimagemapeditor atlantik kbstate akregator ytalk tidy
      libtidy-0.99-0 finger libxcb1 arts php-pear ark tipa docbook-defguide kwordquiz kcron ktalkd
      adept-common ktron libxine1-ffmpeg libgmp3c2 ttf-sjfonts libkpathsea4 nvclock kdenetwork
      libtiff-tools perl-suid kttsd libept0 kdeartwork-emoticons dcoprss ksysv kwin4 kdewallpapers kuser
      libhtml-tableextract-perl klettres-data kdeaddons libxcb-shape0 kreversi kdf libksba8 kspaceduel
      libgle3 kig festlex-poslex gnupg-agent kpf libopensync0 juk kdnssd klines
      kdemultimedia-kfile-plugins fifteenapplet libxapian15 kdemultimedia kfaxview kstars-data edict lskat
      kdenetwork-filesharing knotes kaddressbook-plugins festvox-kallpc16k kgamma kfilereplace kommander
      debtags php5-pgsql ppp networkstatus php-log kdeutils kdegraphics kaboodle khangman kmailcvt
      postgresql-client libindex0 libmime-perl kanjidic knetworkconf kdeartwork-theme-window
      texlive-latex-base ksmiletris konq-plugins xli postgresql-client-common zip libarts1-audiofile
      kxsldbg zoo quanta kbattleship libpoppler-qt2 kiconedit kdeadmin kpilot kasteroids php5-ldap
      festival kfouleggs perl-tk libkdeedu3 libkgantt0 kwalletmanager knewsticker ksnake kdelibs kiten
      kappfinder eyesapplet kdat karm indi php5-cli kdeedu kdelirc kpercentage superkaramba kjots kfax
      ksirtet kmines libxcb-shm0 kdvi kget pinentry-qt texlive-doc-base kgpg libestools1.2 konquest
      kate-plugins php5-common tex-common kolourpaint libnss3-0d libboost-python1.34.1 gpgsm gnupg2
      kmousetool kitchensync kdeaddons-kfile-plugins libarts1-xine kmag kdepim-wizards kmilo ktuberling
      kturtle kaudiocreator ktimer quanta-data kteatime kverbos kdepasswd libxine1-console
      libnews-nntpclient-perl kdeartwork kodo libxine1
    Use 'apt-get autoremove' to remove them.
    Die folgenden Pakete werden ENTFERNT:
      kandy
    0 aktualisiert, 0 neu installiert, 1 zu entfernen und 0 nicht aktualisiert.
    After this operation, 365kB disk space will be freed.
    Möchten Sie fortfahren [J/n]? 
    Ich hatte das problem schon einmal, kann mich aber nur noch erinnern, das es einen Apt-Befehl "keep all" geben muss.
    Wie schon erwähnt habe ich die genaue Syntax vergessen.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Gast1

    Gast1 Guest

    Meldung überhaupt gelesen?

    Code:
    Die folgenden Pakete werden ENTFERNT:
      kandy
    0 aktualisiert, 0 neu installiert, 1 zu entfernen und 0 nicht aktualisiert.
    After this operation, 365kB disk space will be freed.
    Möchten Sie fortfahren [J/n]?
    Wo sollen da denn mehrere 100 MB deinstalliert werden?
     
  4. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    die Pakete werden nur nach dem Ausführen von
    Code:
    apt-get autoremove
    entfernt
     
  5. Shorti

    Shorti Routinier

    Dabei seit:
    08.04.2007
    Beiträge:
    271
    Zustimmungen:
    0

    apt sagt nur welche Pakete du deinstallieren koenntest, da sie jetzt nicht mehr benoetigt werden, dh sie wurden als abhaengigkeit installiert, die nun aber erlischt.
     
  6. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Habt ihr euch überhaupt mal angesehen was das alles auf einmal überflüssig sein soll. Einige der Pakete hab ich ja zum Gebrauch installiert.

    Da ist doch was faul.
     
  7. Gast1

    Gast1 Guest

    Ja, wir haben die Meldung gelesen.

    Code:
    The following packages were [B]automatically installed [/B]and are no longer required:
    Die Pakete hat sich apt als "habe ich als Abhängigkeit damals zu nem anderen Paket installiert" gemerkt.

    Und ohne apt-get autoremove fliegt da auch KEIN Bit von runter.
     
  8. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Wenn du die behalten möchtest, musst du sie auf manuell installiert setzen, das geht soweit ich weis in dem du sie noch mal explizit installierst.
     
  9. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Das ist schon klar. Nur jedesmal wenn ich jetzt ein Programm installiere oder auch deinstalliere kommt diese Meldung. Das ist schon nervig.
     
  10. #9 Wolfgang, 24.02.2008
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Dann hast du wahrscheinlich ein nettes Mischsystem erzeugt, oder mit verschiedenen Paketmanagern experimentiert.

    Gruß Wolfgang
     
  11. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Hab hin und wieder Aptitude verwendet
     
  12. Dvergr

    Dvergr Tripel-As

    Dabei seit:
    10.10.2006
    Beiträge:
    180
    Zustimmungen:
    0
    Da liegt der Fehler: Man verwendet entweder apt-get ODER aptitude. Jedoch niemals beides zusammen. Wahrscheinlich wurden diese Pakete über aptitude installiert und nun denkt apt-get, dass diese lediglich automatisch hinzugefügt und nicht mehr verwendet werden.
     
  13. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Da gab es doch diesen Befehl um Apt mitzuteilen, dass man diese Pakete behalten will. Irgendwas mit "keep all". Ich kenn leider die genaue Syntax nicht mehr.
     
  14. Dvergr

    Dvergr Tripel-As

    Dabei seit:
    10.10.2006
    Beiträge:
    180
    Zustimmungen:
    0
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    scheint so, man apt-get kennt diesen Befehl jedenfalls auch nicht...
     
  17. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Ich hab auch parallel gegoogelt.

    Also der Befehl "Aptitude keep-all" syncronisiert Apt und Aptitude und somit ist das Problem gelöst.:D:D

    Danke an alle!
     
Thema:

Apt würde gern wichtige Pakete lösche.

Die Seite wird geladen...

Apt würde gern wichtige Pakete lösche. - Ähnliche Themen

  1. "Busy" SD-Karte, die eigentlich gern FAT32 formatiert werden würde

    "Busy" SD-Karte, die eigentlich gern FAT32 formatiert werden würde: [gelöst] :-/ "Busy" SD-Karte, die eigentlich gern FAT32 formatiert werden würde Ein warmes Hallihallo erstmal, ist meine erste kleine Frage hier...
  2. FreeNAS 9.2 wurde schneller und benutzerfreundlicher

    FreeNAS 9.2 wurde schneller und benutzerfreundlicher: Die auf FreeBSD basierende Distribution für Network Attached Storage-Systeme (NAS) ist in der Version 9.2 erschienen. Weiterlesen...
  3. Die Graphendatenbank Neo4j wurde aktualisiert

    Die Graphendatenbank Neo4j wurde aktualisiert: Neo4j ist eine in Java geschriebene NoSQL-Datenbank, die Daten in Graphen anstatt in Tabellen speichert. Die bereits seit zwölf Jahren entwickelte...
  4. Nach Variable fragen wenn die nicht als Parameter eingegeben wurde

    Nach Variable fragen wenn die nicht als Parameter eingegeben wurde: Hallo, wie man aus dem Titel entnehmen kann, möchte ich dass man nach Argument gefragt wird, wenn man keinen eingetippt hat. zB ----------...
  5. Der Netzwerkpfad wurde nicht gefunden

    Der Netzwerkpfad wurde nicht gefunden: Wenn ich mich mit WinXP an meinem PDC anmelden will kommt immer diese Fehlermeldung: Die Serverkopie des servergespeicherte Profils wurde nicht...