apt Problem nach backport installation

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von buli, 25.05.2007.

  1. #1 buli, 25.05.2007
    Zuletzt bearbeitet: 25.05.2007
    buli

    buli Debianator

    Dabei seit:
    16.09.2006
    Beiträge:
    789
    Zustimmungen:
    0
    Ort:
    Essen/Ruhrgebiet
    Hallo!
    Ich habe mir mittels
    Code:
     apt-get build-dep
     apt-get -b source 
    ein backport aus den unstable repos gebaut.Und zwar tor, weil es in stable nicht mehr vorhanden ist.
    Das .deb habe ich ein mein deb Verzeichnis verschoben, und mit apt installiert. Seitdem hab ich bei einem update immer folgende Meldungen:
    (Auszug)
    Code:
    Konnte http://ftp.de.debian.org/debian/dists/etch/contrib/source/Sources.gz nicht holen  Konnte »tor« nicht auflösen
    Konnte http://security.debian.org/dists/etch/updates/non-free/source/Sources.gz nicht holen  Konnte »tor« nicht auflösen
    Konnte http://ftp.de.debian.org/debian/dists/etch/non-free/source/Sources.gz nicht holen Konnte »tor« nicht auflösen
    Paketlisten werden gelesen... Fertig
    E: Einige Indexdateien konnten nicht heruntergeladen werden, sie wurden ignoriert oder alte an ihrer Stelle benutzt.
    
    In der Stausanzeige steht immer "Verbinde mit tor". Anscheinend will er sich mit einem Rechner namens "tor" verbinden. ?(

    Was kann da schief gelaufen sein?


    Ich habe tor auch mal wieder deinstalliert (purge), aber dasselbe Ergebnis.

    Ach, ja:
    Ich hab auch mal
    Code:
    echo tor hold | dpkg --set-selections
    probiert. Ohne Erfolg.

    Der Vollständigkeit halber, hier mal meine sources.list:
    Code:
    # deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST Binary-1 20070407-11:29]/ etch contrib main
    
    # deb file:/home/buli/debs ./
    
    ##
    # stable 1st server
     deb http://ftp.de.debian.org/debian/ etch main contrib non-free
     deb-src http://ftp.de.debian.org/debian/ etch main contrib non-free
    
    ##
    # oldstable
    # deb http://ftp.de.debian.org/debian/ sarge main contrib non-free
    # deb-src http://ftp.de.debian.org/debian/ sarge main contrib non-free
    
    ##
    # testing
    # deb http://ftp.de.debian.org/debian/ lenny main contrib non-free
    # deb-src http://ftp.de.debian.org/debian/ lenny main contrib non-free
    
    ##
    # unstable
    # deb http://ftp.de.debian.org/debian/ unstable main contrib non-free
    # deb-src http://ftp.de.debian.org/debian/ unstable main contrib non-free
    
    ##
    # stable 2nd server
    # deb http://ftp2.de.debian.org/debian/ etch main contrib non-free
    # deb-src http://ftp2.de.debian.org/debian/ etch main contrib non-free
    
    ##
    # security
     deb http://security.debian.org/ etch/updates main contrib non-free
     deb-src http://security.debian.org/ etch/updates main contrib non-free
    
    #deb http://www.debian-multimedia.org/ etch main
    
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    /edit:
    Also, ich hab jetzt rausgefunden, dass es mit zsh zu tun haben muss.
    Mit der bash kann ich problemlos updaten.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    /edit:
    Ich habs gelöst. Und zwar mit der Holzhammermethode ;)
    Code:
    rm /var/lib/apt/lists/* -vf  
    apt-get update
     
    Passt!
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Nemesis, 25.05.2007
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    was sollte das bringen?
    du weisst schon was die zeile macht?
    damit kannst du packete, die nicht geupdatet werden sollen zurückhalten.
     
  4. buli

    buli Debianator

    Dabei seit:
    16.09.2006
    Beiträge:
    789
    Zustimmungen:
    0
    Ort:
    Essen/Ruhrgebiet
    Eben!
    Ich dachte, da könnte das Problem liegen.
    (obwohl mein deb Verzeichnis auskommentiert war)
     
  5. #4 Nemesis, 25.05.2007
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    ich versteh deine logik nicht, aber egal ...
     
  6. buli

    buli Debianator

    Dabei seit:
    16.09.2006
    Beiträge:
    789
    Zustimmungen:
    0
    Ort:
    Essen/Ruhrgebiet
    Erwarte ich auch garnicht von dir.
     
Thema:

apt Problem nach backport installation

Die Seite wird geladen...

apt Problem nach backport installation - Ähnliche Themen

  1. Internet Problem mit Router nach PPPoe konfiguration

    Internet Problem mit Router nach PPPoe konfiguration: Hallo zusammen, ich habe mir heute irgendwie den Internetzugang zerschossen. Normalerweise lasse ich die Verbindung über einen Router laufen,...
  2. Nach IP Umstellung: SSL Problem: ssl_error_rx_record_too_long

    Nach IP Umstellung: SSL Problem: ssl_error_rx_record_too_long: Ich musste auf meinem ubuntu server die Server-IP ändern. Jetzt komme ich nicht mehr auf die https Seite, welche unter /var/www mit Zertifikat...
  3. rsync: Problem - Verzeichnisse mit Suffix umbenennen - nach 2.6.9

    rsync: Problem - Verzeichnisse mit Suffix umbenennen - nach 2.6.9: Hallo unixboard-Mitglieder, Mit rsync version 2.6.9 hat es noch funktioniert: root/lmarkus$ rsync --version...
  4. Probleme nach Update auf Suse 12.1

    Probleme nach Update auf Suse 12.1: Hallo Leute, Ich habe heute per Netzwerk-CD mein Sytem von 11.4 auf 12.1 upgegradet. Die Installtion ging ohne Fehlermeldungen von statten....
  5. apt-get problem - nach "Lese Changelogs... Fertig" geht's nicht mehr weiter...??!

    apt-get problem - nach "Lese Changelogs... Fertig" geht's nicht mehr weiter...??!: hallo zusammen, versuchte gerade gnome per apt-get install gnome zu installieren. der download klappt, aber nach der meldung "Lese...