apt-get Problem mit nichterfüllten Abhängigkeiten ...

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von sir_rage, 26.09.2005.

  1. #1 sir_rage, 26.09.2005
    sir_rage

    sir_rage Mitglied

    Dabei seit:
    17.10.2004
    Beiträge:
    49
    Zustimmungen:
    0
    hallo,

    habe ein Problem mit apt-get hier ein Beispiel, das wohl selbsterklärend ist...

    Code:
    debian:/home/userx# apt-get install ripperx
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Sie möchten wahrscheinlich »apt-get -f install« aufrufen, um dies zu korrigieren:
    Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
      proftpd: Hängt ab: proftpd-common (= 1.2.10-15) aber 1.2.10-15sarge1.0.1 soll installiert werden
    E: Nichterfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne jeglich Pakete (oder geben Sie eine Lösung an).
    
    Die angebotene Lösung 'apt-get -f install' bringt mich auch nicht weiter:
    Code:
    debian:/home/userx# apt-get -f install
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Abhängigkeit werden korrigiert... Fertig
    Die folgenden zusätzlichen Pakete werden installiert:
      proftpd
    Vorgeschlagene Pakete:
      proftpd-doc
    Die folgenden Pakete werden aktualisiert:
      proftpd
    1 aktualisiert, 0 neu installiert, 0 zu entfernen und 14 nicht aktualisiert.
    52 nicht vollständig installiert oder entfernt.
    Es müssen noch 0B von 372kB Archiven geholt werden.
    Nach dem Auspacken werden 80,9kB Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren? [J/n] j
    Vorkonfigurieren der Pakete ...
    (Lese Datenbank ... 113275 Dateien und Verzeichnisse sind derzeit installiert.)
    Vorbereiten zum Ersetzen von proftpd 1.2.10-15 (durch .../proftpd_1.2.10-15sarge
    1.0.1_i386.deb) ...
    invoke-rc.d: unknown initscript, /etc/init.d/proftpd not found.
    dpkg: Warnung - altes pre-removal-Skript wurde beendet mit Fehler-Status 100
    dpkg - probiere stattdessen Skript aus dem neuen Paket ...
    invoke-rc.d: unknown initscript, /etc/init.d/proftpd not found.
    dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/proftpd_1.2.10-15sarge1
    .0.1_i386.deb (--unpack):
     Unterprozess neues pre-removal Skript gab den Fehlerwert 100 zurück
    Fehler traten auf beim Bearbeiten von:
     /var/cache/apt/archives/proftpd_1.2.10-15sarge1.0.1_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    Ich habe proftpd vor einer Weile aus inetd rausgenommen. Ist es möglich das Problem zu lösen, ohne proftpd wieder einzutragen (wenn es überhaupt der Grund des Probs ist...) ?

    mfg

    sir_rage
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    Probiers mal mit Synaptic.

    Ich hatte ein ähnliches Problem mit eclipse , dass nicht deinstallieren wollte weil angeblich eine datei nicht existieren sollte . ( ich meine ich wollte es so oder so löschen , wo liegt dann da das problem wenn deine datei die ich löschen will schon weg ist X( )

    Wie gesagt Synaptic hat das dann ohne zu murren erledigt .

    Gruß SOno
     
  4. #3 sir_rage, 26.09.2005
    Zuletzt bearbeitet: 26.09.2005
    sir_rage

    sir_rage Mitglied

    Dabei seit:
    17.10.2004
    Beiträge:
    49
    Zustimmungen:
    0
    Hi,

    habe Synaptic leider nicht installiert *g
    gibts davon irgendwo die sources oder rpms ?
    hab nichts dazu gefunden und apt-get geht ja ned :/
     
  5. #4 monarch, 26.09.2005
    monarch

    monarch Schattenparker

    Dabei seit:
    13.02.2005
    Beiträge:
    222
    Zustimmungen:
    0
    Wenn du synaptik runterlädtst und mit dpkg -i synaptic-blabla-789.deb reinknallst?

    Andere Möglichkeit wäre noch dselect. Der motzt dann auch wegen Abhängigkeiten rum, aber du kannst `x' drücken und die Probleme umgehen. dselect istn bißchen archaisch, kriegt aber oft wieder nen konsistenten Zustand hin.
     
  6. #5 sir_rage, 27.09.2005
    sir_rage

    sir_rage Mitglied

    Dabei seit:
    17.10.2004
    Beiträge:
    49
    Zustimmungen:
    0
    thx ;)
    alles geklappt, kriegte beim starten von synaptic auch gleich die meldung, das ein packet defekt sei. es lag nun wirklich daran, dass ich proftpd aus der init und inetd ausgetragen haben, beim enfernen bekam ich auch die nachricht '/etc/init.d/proftpd' nicht vorhanden -> abbruch. das problem löste ich mit 'touch /etc/init.d/proftpd' und schon gings ;) (hoffe, dass der thread irgendwann mal einem verzweifeltem/einer verzweifelten weiterhelfen wird )


    mfg sir_rage
     
Thema:

apt-get Problem mit nichterfüllten Abhängigkeiten ...

Die Seite wird geladen...

apt-get Problem mit nichterfüllten Abhängigkeiten ... - Ähnliche Themen

  1. Problem bei apt-get upgrade (Kali 2.0)

    Problem bei apt-get upgrade (Kali 2.0): Hi, seit paar Tagen habe ich einige Probs. Dachte es sei mal an der Zeit für ein Update und nun tauchen da einige Fehler auf: Es müssen noch 0 B...
  2. apt-get problem - nach "Lese Changelogs... Fertig" geht's nicht mehr weiter...??!

    apt-get problem - nach "Lese Changelogs... Fertig" geht's nicht mehr weiter...??!: hallo zusammen, versuchte gerade gnome per apt-get install gnome zu installieren. der download klappt, aber nach der meldung "Lese...
  3. apt-get problem

    apt-get problem: Hi Leude, ich habe mal vor einem halben jahr pakete installiert wo die installation nicht 100%tig durchlief. wenn ich jetzt etwas installiere...
  4. Problem mit apt-get

    Problem mit apt-get: Seit kurzen erscheint bei allen Paketinstallationen und -updates folgende Fehlermeldung. Auch wenn ich versuche das besagte Paket zu...
  5. Noch ein kleines Problem mit apt-get update

    Noch ein kleines Problem mit apt-get update: Kann mir jemand die Fehler erklären und wie man das abstellt. OK http://ftp.de.debian.org etch/non-free Packages 99% [8 Packages bzip2 0]...